Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 46 messages ]  Aller à la page 1, 2  Suivante
Auteur Message
MessagePosté: 13 Fév 2012 13:05 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
Bonjour, j'ai installé code blocks pour une petite appli en c, mais il etait impossible de compiler, erreur:
Code:
------------- Build: Debug in test2 ---------------

Linking console executable: bin/Debug/test2
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings


apres recherches sur crt1.o, j'ai essayé les diverses solution proposées a gauche a droite, cad installer build-essential ou libc6-dev, mais c'etait deja installé... J'ai fini par essayer de désinstaller , et la impossible de réinstaller a cause de dependance... Je suis completement nul la dedans, pouvez vous m'aider???

l'histoire de ma co***rie:
Code:
sudo apt-get remove libc-dev-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  build-essential g++ g++-4.4 libc-dev-bin libc6-dev libncurses5-dev
  libstdc++6-4.4-dev


Code:
sudo apt-get install libc-dev-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libc-dev-bin : Dépend: libc6 (< 2.12) mais 2.13-7 devra être installé
E: Paquets défectueux
cedric@lix:~$ sudo apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 build-essential : Dépend: libc6-dev mais ne sera pas installé ou
                            libc-dev
                   Dépend: g++ (>= 4:4.4.3) mais ne sera pas installé
E: Paquets défectueux


apres j'ai essayé par aptitude, mais rien de fort rassurant...

mes sources (qui viennent d'ici normalement)

Code:
################################################
## squeeze
deb http://ftp.be.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.be.debian.org/debian/ squeeze main contrib non-free

## squeeze multimedia
deb http://www.debian-multimedia.org squeeze main non-free
deb-src http://mirror.home-dn.net/debian-multimedia squeeze main

# squeeze security

# squeeze update
deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free

################################################
## wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

## wheezy multimedia
deb http://www.debian-multimedia.org wheezy main non-free
deb-src http://www.debian-multimedia.org/ wheezy main

## wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

################################################
## sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

## sid multimedia
deb http://www.debian-multimedia.org/ sid main
deb-src http://www.debian-multimedia.org/ sid main

################################################
## experimental
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free

# experimental multimedia (uniquement 64 bits, décommentez les lignes dans ce cas)
# deb http://www.debian-multimedia.org/ experimental main
# deb-src http://www.debian-multimedia.org/ experimental main

#################################################"
#mozilla
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release
deb http://security.debian.org/ squeeze/updates contrib non-free main
deb-src http://security.debian.org/ squeeze/updates contrib non-free main

#################################################
#pour code block
deb http://apt.wxwidgets.org/ lenny-wx main


je remarque que la derniere ligne est problematique, peut etre la responsable? j'ai installé libwxgtk2.8-0 par cela...


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 13:19 
Hors ligne
Contributeur

Inscription: 08 Sep 2009 12:03
Messages: 3279
Localisation: saint julien le montagnier Haut Var
mélange de différents versions debian =micmac à la sortie,choisis une version et garde la et tu verras que tes pbs disparaitront.

_________________
wheezy 32 bits nvidia Geforce GT610 pilote 304.121 lxde

Le système financier n’a plus besoin des pauvres pour faire tourner la machine, les robots seront là pour les remplacer, l’ère de la destruction massive des pauvres est en marche.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 15:00 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
c'est le sources.lis conseillé sur ce forum dans truc et astuces "sources.list au carré" qui ne m'a jamais créé de problemes...

Si je repasse entierement en stable, plus rien ne va fonctionner...


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 15:29 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Salut,

Tu est à deux doigts de casser ta Debian en jouant avec libc6, pour l'heure évites tout arrêt machine avant d'avoir solder la réinstallation. Pas de panique ... :083

J'ai un sources.list similaire, sans problème!

Bien sur tu as des sauvegardes ... :033 Voir le wiki.

Dans un premier temps.

As tu un fichier "preferences" en conséquence ???

Voir le wiki L'etiquetage de paquets via le fichier /etc/apt/preferences

Deuxième temps.

Supprimes ceci de ton sources.list, c'est d'autant plus couillon que code block est disponible dans les dépôts depuis le 28 Février 2011.

codeblocks (10.05-2) http://packages.debian.org/unstable/main/codeblocks

Citation:
#pour code block
deb http://apt.wxwidgets.org/ lenny-wx main


Troisième temps.

Est ce que la mise à jour pose problème ???

Uniquement avec aptitude !

Notes : Avec un fichier preferences!!!!

Code:
# aptitude update


option -s pour simulation.

Code:
# aptitude -s upgrade


Si tout ce passe bien, lances la MAJ.

On verra la suite après ... :083

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 16:40 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
le fichier de preference:

Code:
Package: backup-manager
Pin: release o=Debian,a=experimental
Pin-Priority: 999

Package: *
Pin: release o=apt-build
Pin-Priority: 995

Package: *
Pin: release o=Debian,a=stable-updates,l=Debian
Pin-Priority: 990

Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 990

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable,l=Unofficial Multimedia Packages
Pin-Priority: 980

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 990

Package: *
Pin: release o=Debian,a=testing,l=Debian-Security
Pin-Priority: 90

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing,l=Unofficial Multimedia Packages
Pin-Priority: 90

Package: *
Pin: release o=Debian,a=testing,l=Debian
Pin-Priority: 90

Package: *
Pin: release o=Unofficial Multimedia Packages,a=unstable,l=Unofficial Multimedia Packages
Pin-Priority: 50

Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 50

Package: *
Pin: release o=Unofficial Multimedia Packages,a=experimental,l=Unofficial Multimedia Packages
Pin-Priority: 10

Package: *
Pin: release o=Debian,a=experimental,l=Debian
Pin-Priority: 10


j'ai des sauvegardes de mes datas, mais pas du systeme...

j'ai deja supprimé de mon source la derniere ligne, grosse erreur de distraction...

aptitude upgrade n'a rien a mettre a jour, tout est a zero,

merci pour ton aide...

ced


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 16:54 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Parfait, on continu ... :033

Crées un fichier /etc/apt/apt.conf avec ceci en contenu.

Code:
:~$ cat /etc/apt/apt.conf

APT::Install-Suggests "false";
APT::Install-Recommends "false";
Aptitude::Recommends-Important "false";
Aptitude::Suggests-Important "false";
APT::Default-Release "stable";


apt-listbugs est il installé ??? :083


Lances une mise à jour du cache.

aptitude update suivit d'un aptitude -s upgrade, si cette dernière ne relève aucun message d'alerte, alors vires le -s et lances l'upgrade.

Quels sont les fichiers de configurations orphelins ???

Code:
:~$ aptitude search ~c


Si tout c'est bien passé ... nous passeront à la suite ... ;)

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 17:06 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
fichier créé... meme si je sais pas ce que je fais: mais c'est pas le plus important...

j'ai installé apt-listbug

aptitude update pas de soucis

upgrade -s:
Code:
aptitude -s upgrade
Aucun paquet ne va être installé, mis à jour ou enlevé.


les orphelins:

Code:
c   alsa-oss               - encapsuleur ALSA pour applicati
c   browser-plugin-gnash   - GNU Shockwave Flash (SWF) playe
c   bsd-mailx              - agent de courriel utilisateur s
c   exim4                  - Meta-paquet pour faciliter l'in
c   exim4-base             - fichiers complémentaires pour t
c   exim4-config           - configuration de l'agent de tra
c   exim4-daemon-light     - version légère du démon de tran
c   festival               - General multi-lingual speech sy
c   gnash                  - GNU Shockwave Flash (SWF) playe
c   gnash-common           - GNU Shockwave Flash (SWF) playe
c   iceweasel              - Web browser based on Firefox   
c   libboost-date-time1.42 - set of date-time libraries base
c   libboost-thread1.42.0  - portable C++ multi-threading   
c   libcddb2               - library to access CDDB data - r
c   libdvbpsi6             - library for MPEG TS and DVB PSI
c   libebml0               - access library for the EBML for
c   libestools2.0          - Edinburgh Speech Tools Library
c   libgammu7              - mobile phone management library
c   libgd2-noxpm           - bibliothèque graphique GD versi
c   libgsf-1-114           - bibliothèque de fichiers struct
c   libgsmme1c2a           - GSM mobile phone access library
c   libgsmsd7              - SMS daemon helper library     
c   liblzo2-2              - Bibliothèque de compression de
c   libmatroska0           - extensible open standard audio/
c   libmozjs3d             - The Mozilla SpiderMonkey JavaSc
c   libtar                 - C library for manipulating tar
c   libupnp3               - Portable SDK for UPnP Devices,
c   libvlc5                - multimedia player and streamer
c   libvlccore4            - base library for VLC and its mo
c   libvncserver0          - API to write one's own vnc serv
c   libx264-104            - x264 video coding library     
c   libxcb-keysyms1        - utility libraries for X C Bindi
c   libxcb-randr0          - X C Binding, randr extension   
c   libxcb-render-util0    - Bibliothèque d'utilitaires pour
c   localepurge            - Reclaim disk space removing unn
c   mozilla-acroread       - Adobe Acrobat(R) Reader plugin
c   timidity               - Software sound renderer (MIDI s
c   timidity-daemon        - runs TiMidity++ as a system-wid
c   virtualbox-4.0         - Oracle VM VirtualBox           
c   virtualbox-ose-qt      - transitional package for virtua
c   vlc                    - lecteur de fichiers et flux mul
c   vlc-data               - données communes pour VLC     
c   xulrunner-1.9.1        - XUL + XPCOM application runner
c   xulrunner-1.9.2        - XUL + XPCOM application runner
c   zonecheck              - DNS configuration checker 


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 17:14 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Allons y ...

Commentes tous des dépôts de ton sources.list, hormis squeeze.

Code:
################################################
## squeeze
deb http://ftp.be.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.be.debian.org/debian/ squeeze main contrib non-free

## squeeze multimedia
deb http://www.debian-multimedia.org squeeze main non-free
deb-src http://mirror.home-dn.net/debian-multimedia squeeze main

# squeeze security

# squeeze update
deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free


Relances un update et upgrade.

En simulation : -s

Relances l'installation de libc-dev-bin. Et donnes le retour de cette dernière.

Citation:
# aptitude -s install libc-dev-bin

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 17:52 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
cedge a écrit:
grosse erreur de distraction...


Une autre ... :mrgreen: ... :whistle:

Citation:
##############################
## squeeze
deb http://ftp.be.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.be.debian.org/debian/ squeeze main contrib non-free

## squeeze multimedia
deb http://www.debian-multimedia.org squeeze main non-free
deb-src http://mirror.home-dn.net/debian-multimedia squeeze main

# squeeze security

# squeeze update
deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free

#########################


Profites en pour rajouter le dépôt indispensable : security. :075

Code:
# squeeze security
deb http://security.debian.org/ squeeze/updates main contrib non-free
#deb-src http://security.debian.org/ squeeze/updates main contrib non-free

Code:
# aptitude update

-s pour simulation!
Code:
# aptitude -s upgrade

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 17:57 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
j'ai commenté updaté et upgradé(rien a changer)

Code:
root@lix:/home/cedric# aptitude -s install libc-dev-bin
Les NOUVEAUX paquets suivants vont être installés :
  libc-dev-bin{b}
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 202 ko d'archives. Après dépaquetage, 356 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libc-dev-bin: Dépend: libc6 (< 2.12) mais 2.13-7 est installé.
Les actions suivantes permettront de résoudre ces
dépendances :

     Conserver les paquets suivants dans leur version actuel
1)     libc-dev-bin [Non installé]     


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:12 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Non! tu n'as pas upgradé, tu as lancé une simulation. L'option : -s

Avant toute chose, lances tes mises à jours de sécurité.

Code:
aptitude update


Sans la simulation (-s)

Code:
aptitude  upgrade

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:23 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
non, l'install je l'ai simulé l'upgrade pas:
Code:
root@lix:/home/cedric# aptitude  upgrade
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:27 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
j'ai peut etre mal compris le dernier message, j'ai donc rajouter les "security" dans mon sources, puisque c'etait celui de weezy avant.
j'ai re-updaté et gradé toujours zero changements


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:35 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Ok, nous sommes d'accord pour la simulation.

Bien, quel est alors ta version actuel ? :083

Code:
:~$ lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 6.0.4 (squeeze)
Release:        6.0.4
Codename:       squeeze
:~$

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:42 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
voici:
Code:
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 6.0.4 (squeeze)
Release:   6.0.4
Codename:   squeeze


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:45 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
À présent, pour en avoir le cœur net ... :033


Code:
:~$ apt-cache policy libc6

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:50 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
Désolé pour le delai mais c'est un peu chaud...

Code:
root@lix:/home/cedric# lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 6.0.4 (squeeze)
Release:   6.0.4
Codename:   squeeze
root@lix:/home/cedric# apt-cache policy libc6
libc6:
  Installé : 2.13-7
  Candidat : 2.13-7
 Table de version :
 *** 2.13-7 0
        100 /var/lib/dpkg/status
     2.11.3-2 0
        990 http://ftp.be.debian.org/debian/ squeeze/main i386 Packages


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:53 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Pas de souci, et surtout soit Zen ... ;)

Réinstallation en simulation!

Code:
# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev


Et ...

Code:
aptitude -s reinstall libc6-dev libncurses5-dev libstdc++6-4.4-dev


Donnes le retour complet.

On verra après pour libc-dev-bin ...

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 18:57 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
Code:
root@lix:/home/cedric# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev
Les NOUVEAUX paquets suivants vont être installés :
  g++-4.4{a} libc-dev-bin{ab} libc6-dev{b} libncurses5-dev libstdc++6-4.4-dev
0 paquets mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 13,3 Mo d'archives. Après dépaquetage, 47,2 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libc-dev-bin: Dépend: libc6 (< 2.12) mais 2.13-7 est installé.
  libc6-dev: Dépend: libc6 (= 2.11.3-2) mais 2.13-7 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     g++-4.4 [Non installé]                                   
2)     libc-dev-bin [Non installé]                             
3)     libc6-dev [Non installé]                                 
4)     libncurses5-dev [Non installé]                           
5)     libstdc++6-4.4-dev [Non installé]                       



Accepter cette solution ? [Y/n/q/?]


Et
Code:
root@lix:/home/cedric# aptitude -s reinstall libc6-dev libncurses5-dev libstdc++6-4.4-dev
libc6-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
libncurses5-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
libstdc++6-4.4-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
libc6-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
libncurses5-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
libstdc++6-4.4-dev n'est pas actuellement installé, il ne sera donc pas réinstallé.
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:12 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Ok!

cedge a écrit:
Code:
root@lix:/home/cedric# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev
Les NOUVEAUX paquets suivants vont être installés :
 g++-4.4{a} libc-dev-bin{ab} libc6-dev{b} libncurses5-dev libstdc++6-4.4-dev
0 paquets mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 13,3 Mo d'archives. Après dépaquetage, 47,2 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libc-dev-bin: Dépend: libc6 (< 2.12) mais 2.13-7 est installé.
 libc6-dev: Dépend: libc6 (= 2.11.3-2) mais 2.13-7 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

 Conserver les paquets suivants dans leur version actuelle :
1) g++-4.4 [Non installé]
2) libc-dev-bin [Non installé]
3) libc6-dev [Non installé]
4) libncurses5-dev [Non installé]
5) libstdc++6-4.4-dev [Non installé]



Accepter cette solution ? [Y/n/q/?]


Il te faut à présent utiliser les ressources d'aptitude.

Citation:
Accepter cette solution ? [Y/n/q/?]


Il t'invite à le questionner, et ainsi te proposer des solutions.


Code:
Accepter cette solution ? [Y/n/q/?] ?
Les commandes suivantes sont disponibles :
  y: accepter les modifications proposées
  n: rejeter les modifications proposées et rechercher une autre solution
  q: abandonner et quitter le programme
  ,: aller à la solution suivante
  .: aller à la solution précédente
  o: basculer entre le contenu de la solution et une explication de la solution
  e: examiner la solution dans l'interface utilisateur visuelle
  x: abandon de la résolution automatique des dépendances ; il est nécessaire de résoudre les dépendances manuellement
  r (ID|pkg ver) ...: reject the given package versions; don't display any solutions in which they occur.  Enter UNINST instead of a version to reject removing the package.  ID is
                 the integer printed to the left of the action.
 
  a (ID|pkg ver) ...: accept the given package versions; display only solutions in which they occur.  Enter UNINST instead of a version to accept removing the package.  ID is the
                 integer printed to the left of the action.
 
  <ID>: display information about the action labeled ID from the solution.  The label is the integer printed to the left of the action.
 
  <ACTION> pkg... : ajuster l'état des paquets affichés, où ACTION est l'une des suivantes :
 
  « + » pour installer des paquets
  « +M » pour installer des paquets et les marquer aussitôt comme ayant été installés automatiquement.
  « - » pour supprimer des paquets
  « _ » pour purger des paquets
  « = » pour conserver des paquets
  « : » pour conserver les paquets dans leur état actuel sans les mettre dans l'état conservé (« hold »)
  « &M » pour marquer des paquets comme ayant été installés automatiquement
  « &m » pour marquer des paquets comme ayant été installés manuellement
Accepter cette solution ? [Y/n/q/?]


Relances la simulation ...

Réponds lui simplement par non (n)


Citation:
# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev

...

Accepter cette solution ? [Y/n/q/?] n


Et voyons ce qu'il propose, tu peux refuser la première soluce, il t'en proposera une autre, ainsi de suite, jusqu'au résultat désirer.

Retour complet please ... :083

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:21 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
PAs mal le deuxieme resultat pour moi, avant il voulait tjrs upgradé vers testing...
J'ai repondu 2X non pour voir...

Code:
root@lix:/home/cedric# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev
Les NOUVEAUX paquets suivants vont être installés :
  g++-4.4{a} libc-dev-bin{ab} libc6-dev{b} libncurses5-dev libstdc++6-4.4-dev
0 paquets mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 13,3 Mo d'archives. Après dépaquetage, 47,2 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libc-dev-bin: Dépend: libc6 (< 2.12) mais 2.13-7 est installé.
  libc6-dev: Dépend: libc6 (= 2.11.3-2) mais 2.13-7 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     g++-4.4 [Non installé]                                   
2)     libc-dev-bin [Non installé]                             
3)     libc6-dev [Non installé]                                 
4)     libncurses5-dev [Non installé]                           
5)     libstdc++6-4.4-dev [Non installé]                       



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                           
1)      at-spi                                                   
2)      dasher                                                   
3)      gnome-accessibility                                       
4)      gnome-orca                                               
5)      gok                                                       
6)      k3b                                                       
7)      kdebase-runtime                                           
8)      libgail-common                                           
9)      libgail-gnome-module                                     
10)     libgdk-pixbuf2.0-0                                       
11)     libk3b6                                                   
12)     libk3b6-extracodecs                                       
13)     libkcddb4                                                 
14)     libxcb-shm0                                               
15)     libxine1                                                 
16)     libxine1-x                                               
17)     multiarch-support                                         
18)     phonon                                                   
19)     phonon-backend-xine                                       
20)     python-pyatspi                                           

      Installer les paquets suivants :                           
21)     libgsf-1-114 [1.14.18-1 (now, stable)]                   
22)     libgsf-1-common [1.14.18-1 (stable)]                     
23)     libxcb-render-util0 [0.3.6-1 (now, stable)]               

      Réinstaller à une version antérieure les paquets suivants :
24)     gtk2-engines-pixbuf [2.24.5-1 (now) -> 2.20.1-2 (stable)]
25)     libc-bin [2.13-7 (now) -> 2.11.3-2 (stable)]             
26)     libc6 [2.13-7 (now) -> 2.11.3-2 (stable)]                 
27)     libc6-i686 [2.13-7 (now) -> 2.11.3-2 (stable)]           
28)     libcairo2 [1.10.2-6 (now) -> 1.8.10-6 (stable)]           
29)     libgail18 [2.24.5-1 (now) -> 2.20.1-2 (stable)]           
30)     libgcrypt11 [1.5.0-1 (now) -> 1.4.5-2 (stable)]           
31)     libgnutls26 [2.12.7-2 (now) -> 2.8.6-1+squeeze1 (stable)]
32)     libgtk2.0-0 [2.24.5-1 (now) -> 2.20.1-2 (stable)]         
33)     libgtk2.0-bin [2.24.5-1 (now) -> 2.20.1-2 (stable)]       
34)     libnss3-1d [3.12.10-2 (now) -> 3.12.8-1+squeeze4 (stable)]
35)     libpixman-1-0 [0.23.2-1 (now) -> 0.16.4-1 (stable)]       
36)     librsvg2-2 [2.34.0-1 (now) -> 2.26.3-1 (stable)]         
37)     librsvg2-common [2.34.0-1 (now) -> 2.26.3-1 (stable)]     
38)     libstdc++6 [4.6.1-3 (now) -> 4.4.5-8 (stable)]           
39)     libwmf0.2-7 [0.2.8.4-8 (now) -> 0.2.8.4-6.1+b1 (stable)] 
40)     locales [2.13-10 (now) -> 2.11.3-2 (stable)]             



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                           
1)      at-spi                                                   
2)      dasher                                                   
3)      gnome-accessibility                                       
4)      gnome-orca                                               
5)      gok                                                       
6)      libgail-common                                           
7)      libgail-gnome-module                                     
8)      libgdk-pixbuf2.0-0                                       
9)      libxcb-shm0                                               
10)     libxine1                                                 
11)     libxine1-x                                               
12)     multiarch-support                                         
13)     phonon-backend-xine                                       
14)     python-pyatspi                                           

      Installer les paquets suivants :                           
15)     libgsf-1-114 [1.14.18-1 (now, stable)]                   
16)     libgsf-1-common [1.14.18-1 (stable)]                     
17)     libxcb-render-util0 [0.3.6-1 (now, stable)]               
18)     phonon-backend-null [4:4.6.0really4.4.2-1 (stable)]       

      Réinstaller à une version antérieure les paquets suivants :
19)     gtk2-engines-pixbuf [2.24.5-1 (now) -> 2.20.1-2 (stable)]
20)     libc-bin [2.13-7 (now) -> 2.11.3-2 (stable)]             
21)     libc6 [2.13-7 (now) -> 2.11.3-2 (stable)]                 
22)     libc6-i686 [2.13-7 (now) -> 2.11.3-2 (stable)]           
23)     libcairo2 [1.10.2-6 (now) -> 1.8.10-6 (stable)]           
24)     libgail18 [2.24.5-1 (now) -> 2.20.1-2 (stable)]           
25)     libgcrypt11 [1.5.0-1 (now) -> 1.4.5-2 (stable)]           
26)     libgnutls26 [2.12.7-2 (now) -> 2.8.6-1+squeeze1 (stable)]
27)     libgtk2.0-0 [2.24.5-1 (now) -> 2.20.1-2 (stable)]         
28)     libgtk2.0-bin [2.24.5-1 (now) -> 2.20.1-2 (stable)]       
29)     libnss3-1d [3.12.10-2 (now) -> 3.12.8-1+squeeze4 (stable)]
30)     libpixman-1-0 [0.23.2-1 (now) -> 0.16.4-1 (stable)]       
31)     librsvg2-2 [2.34.0-1 (now) -> 2.26.3-1 (stable)]         
32)     librsvg2-common [2.34.0-1 (now) -> 2.26.3-1 (stable)]     
33)     libstdc++6 [4.6.1-3 (now) -> 4.4.5-8 (stable)]           
34)     libwmf0.2-7 [0.2.8.4-8 (now) -> 0.2.8.4-6.1+b1 (stable)] 
35)     locales [2.13-10 (now) -> 2.11.3-2 (stable)]   


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:38 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
cedge a écrit:
PAs mal le deuxieme resultat pour moi, avant il voulait tjrs upgradé vers testing...
J'ai repondu 2X non pour voir...



C'est dû au fichier /etc/apt/apt.conf, je te donnerai le lien pour explication après ... ;)

Effectivement, la deuxième solution proposé par aptitude semble convenir.

Relances à nouveau la simulation, après le deuxième non, soit positif :083 Y

Citation:
# aptitude -s install libc6-dev libncurses5-dev libstdc++6-4.4-dev
...
Accepter cette solution ? [Y/n/q/?] n
...
Accepter cette solution ? [Y/n/q/?] n

Accepter cette solution ? [Y/n/q/?] y



Que dit il ?

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:45 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Mai 2010 16:32
Messages: 2751
Localisation: . . . . . . Ch'timi
Question!

Ton sources.list est il toujours commenté ? comme dit plus haut. Si oui, laisses le tel que ! Uniquement squeeze.

Tu y reviendras une fois ceci régler ... :033

_________________
Debianneux-Autodidacte . ^¿^ . sur les chemins de la connaissance et du libre ...
La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance
Que la pique du peuple brise le sceptre des rois.


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:46 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
c'est la troisieme solution alors:
Code:
Accepter cette solution ? [Y/n/q/?] y
Les paquets suivants vont être RÉINSTALLÉS à une VERSION ANTÉRIEURE :
  gtk2-engines-pixbuf libc-bin libc6 libc6-i686 libcairo2 libgail18 libgcrypt11 libgnutls26 libgtk2.0-0 libgtk2.0-bin libnss3-1d libpixman-1-0 librsvg2-2 librsvg2-common
  libstdc++6 libwmf0.2-7 locales
Les NOUVEAUX paquets suivants vont être installés :
  g++-4.4{a} libc-dev-bin{a} libc6-dev libgsf-1-114{a} libgsf-1-common{a} libncurses5-dev libstdc++6-4.4-dev libxcb-render-util0{a} phonon-backend-null{a}
Les paquets suivants seront ENLEVÉS :
  at-spi{a} dasher{a} gnome-accessibility{a} gnome-orca{a} gok{a} libgail-common{a} libgail-gnome-module{a} libgdk-pixbuf2.0-0{a} libxcb-shm0{a} libxine1{a} libxine1-x{a}
  multiarch-support{a} phonon-backend-xine{a} python-pyatspi{a}
0 paquets mis à jour, 9 nouvellement installés, 17 remis à une version antérieure, 14 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 31,2 Mo d'archives. Après dépaquetage, 11,2 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?]


je dois encore accepter? (je sais pas si la simulation continue plus loin)
par contre gnome-accessibility semble utile quand meme??? et le reste?


Haut
 Profil  
 
MessagePosté: 13 Fév 2012 19:47 
Hors ligne
Grand posteur

Inscription: 09 Nov 2010 15:12
Messages: 122
oui, j'ai plus touché au source, sauf rajouté les security de stable


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 46 messages ]  Aller à la page 1, 2  Suivante

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: webby et 5 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.428s | 13 Queries | GZIP : Off ]