Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 33 messages ]  Aller à la page 1, 2  Suivante
Auteur Message
MessagePosté: 04 Juil 2013 07:21 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
Bonjour,
J'ai vainement tenté, hier, d'installer mon imprimante Samsung ML-1670 sur Debian wheezy. Craignant d'avoir modifié des éléments importants du système, j'ai tout réinstallé (Debian et les logiciels fournis avec lui).

Mais quand je veux installer l'imprimante via l'outil "imprimantes", l'installation semble se dérouler "normalement". L'outil a repéré mon imprimante mais installe un pilote qui ne semble pas correspondre à ma machine. Je continue tout de même l'installation mais impossible d'imprimer la page test. L'instruction d'impression est envoyée (je reçois l'information via un popup), puis un nouveau popup me signale que l'impression est terminée mais ... rien ne sort de la machine.

Je supprime l'imprimante que je viens d'installer et me tourne vers le pilote unifié Samsung qui contient le pilote nécessaire à ma machine - et qui a très bien fonctionné quand j'étais sur Ubuntu ;) ). Je lance l'application dans un terminal.
L'installation commence mais je reçois un message indiquant que SANE doit être installé or il est installé.

Dans le terminal, j'ai le message suisvant
Code:
sudo sh autorun
libstdc++.so.5 (gcc 3.0.x .. 3.3.x) not found, install ... done
libtiff.so.3 not found, install ... done
****  It seems Qt library is not installed, or X display is not accessible.
****  Custom Qt library will be configured for use with this package.

et là ... je coince.

Mon imprimante est bien vue sur ma machine Bus 005 Device 002
Code:
~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)
Bus 001 Device 003: ID 058f:6364 Alcor Micro Corp. AU6477 Card Reader Controller
Bus 002 Device 003: ID 045e:0023 Microsoft Corp. Trackball Optical
Bus 005 Device 002: ID 04e8:3313 Samsung Electronics Co., Ltd

Que faire pour pouvoir installer correctement mon imprimante USB ?

Merci

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Dernière édition par Papy Octet le 06 Juil 2013 07:11, édité 2 fois.

Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:23 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 20 Avr 2007 17:34
Messages: 5493
Localisation: sud ouest
Bonjour Papy,
tu parles d'imprimante, puis de SANE qui est un outils de gestion de scanner.
Je supose donc que l'appareil fait imprimante et scanner.
Qu'est ce qui ne fonctionne pas.
La partie imprimante ou la partie scanner ?

_________________
ubuntu est un mot africain signifiant "je n'ai pas réussi à configurer ma debian" (je n'aime pas ubuntu, ça se voit non ?)


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:25 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 03 Mai 2008 05:16
Messages: 4219
Localisation: Nantes
Bonjour!
Ah, ça, c'est une imprimante écologique! :grin:

Pourrais-tu nous indiquer comment tu installes le "pilote unifié SAMSUNG"? C'est un script? Car d'après le message d'erreur, il semble qu'il n'y ait pas de serveur X (graphique) qui tourne. Tu le lances peut-être dans un tty?
Sinon, il semble avoir besoin des bibliothèques Qt.

Sinon, ce tutoriel détaille les étapes à réaliser directement avec l'interface CUPS : http://www.osside.net/?p=11307 . Ça semble être en espagnol, donc si la lecture pose souci on te fera un résumé :)

_________________
Adhérent april 8505
Et toi, tu boinc? - Auto-hébergez vous avec Host@home
Debian wheezy, dwm ou fluxbox, suckless-tools

Pensez à correctement formater vos titres dans la catégorie SUPPORT


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:29 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
piratebab a écrit:
Bonjour Papy,
tu parles d'imprimante, puis de SANE qui est un outils de gestion de scanner.
Je supose donc que l'appareil fait imprimante et scanner.
Qu'est ce qui ne fonctionne pas.
La partie imprimante ou la partie scanner ?


Pas du tout, mais Samsung n'a prévu qu'un seul driver pour les deux types.
Si on lance install.sh sous root les questions sont posées en semi-graphique et permettent de lui sire d'ignorer.

PS. Mais de ce moment stable ou sid ne permettent pas d'installer (chez moi)

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:35 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 20 Avr 2007 17:34
Messages: 5493
Localisation: sud ouest
Ils sont tordus chez SAMSUNG :shock:

_________________
ubuntu est un mot africain signifiant "je n'ai pas réussi à configurer ma debian" (je n'aime pas ubuntu, ça se voit non ?)


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:38 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 10 Fév 2009 21:57
Messages: 1100
Localisation: Bretagne
Le paquet printer-driver-splix est-il installé ? Il contient peut-être le bon pilote.

_________________
Cordialement,
François
http://www.flegad.infini.fr


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:43 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Re,

printer-driver-splix est installé :smile:

Mais cups est en grand remue-ménage depuis un moment. Et comme elle a fonctionné, j'attends des jours meilleurs :smile:

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 08:52 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
Bonjour à vous,

J'ai installé Wheezy stable comme conseillé si on est "nouveau" sous Debian :lol:

Mon imprimante est une laser Nb toute simple.

Lorsque j'installais ce pilote sous Ubuntu :P l'installation se déroulait exclusivement en mode console et je n'avais pas la fenêtre qui s'ouvre et m'impose d'installer une machine combinée.
Dans cette fenêtre graphique, lorsque je demande l'installation sans tenir compte de la présence de SANE, il m'est proposé de choisir une connexion /dev/mfp4 à 11. Or ces connexions mfp.. correspondent à des imprimantes combinées et donc pas à la mienne.

Je me demande aussi s'il ne serait pas possible de "forcer" l'utilisation exclusive de la console (terminal) pour exécuter l'installation du pilote comme sous Ubuntu.

@thuban : Ça, pour être écologique ... on économise du papier comme pas possible 8)
L'installation du pilote unifié se fait via le terminal en ROOT puis
Code:
sudo sh autorun

Là, une fenêtre d'installation s'ouvre et la galère commence. Sous Ubuntu, on restait en mode console et donc pas de fenêtre graphique et également pas de problème d'installation :mrgreen:
C'est bien un script .sh qui lance l'installation.

Pour ce qui est de l'interface CUPS, lorsque j'y arrive (http://about:631) je ne peux rien modifier, tout est interdit. Mais je vais aller jeter un oeil sur le lien que tu donnes.

Euh ... c'est quoi un tty ? :oops:

@François_29 : Oui, printer-driver-splix est bien installé.

Eh les amis ... vous allez plus vite pour poster que moi pour vous répondre :023

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:13 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Salut Papy,

Je sais pas lequel de nous deux à le droit au titre de Papy :smile:

Code:
Lorsque j'installais ce pilote sous Ubuntu :P l'installation se déroulait exclusivement en mode console et je n'avais pas la fenêtre qui s'ouvre et m'impose d'installer une machine combinée.


Je peux au moins te donner la raison de ce changement : le compte root est désactivé sous Ubuntu, de façon à ressembler au plus près à Windows où tout est permis à l'utilisateur principal :smile:

Si au lieu d'être dans /Samsung tu vas dans /Samsung/Linux tu trouveras un install. sh et uninstall.sh mais malheureusement on a le même résultat.

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:18 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
@ ggoodluck47

Citation:
Je sais pas lequel de nous deux à le droit au titre de Papy

J'ai 64 piges :dance: et suis un heureux pré-retraité :041

Citation:
Je peux au moins te donner la raison de ce changement : ...

Mais quand j'essaie d'installer soit en mode admin soit en mode user ... j'ai toujours la même fenêtre graphique et les mêmes problèmes :013

Citation:
Si au lieu d'être dans /Samsung tu vas dans /Samsung/Linux tu trouveras un install. sh et uninstall.sh mais malheureusement on a le même résultat.

En effet, j'ai essayé cela aussi et toujours la même sanction :013

Il serait étonnant que sous Debian il ne soit pas possible de "forcer" un script à se dérouler complètement en mode console, non ?!

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:36 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Re,

Bien sûr, mais çà n'apporte rien de plus. Et Samsung va beaucoup plus loin dans ses recommandations puisqu'il demande une installation root en mode graphique.
Je sais faire (en trichant) mais çà n'apporte rien de plus !

PS. je suis né l'année des premiers congés payés et du front populaire :lol:

En attendant j'ai installé une Windows sous VisualBasic et mis en commun le dossier /home/gerard/Documents.

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:46 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
ggoodluck47 a écrit:
...
PS. je suis né l'année des premiers congés payés et du front populaire :lol:
...

Respect alors :violin:

Quans on regarde dans le script, on voit qu'il peut travailler en mode texte uniquement :
Code:
...
# Text mode procedures

ask_any_key_or_q() {
#   read -p '****  Press any key to continue or q to quit: ' -n 1 KEY_PRESSED
   read -p '****  Press Enter to continue or q and then Enter to quit: ' KEY_PRESSED
   echo ""
   if test "$KEY_PRESSED" = "q" || test "$KEY_PRESSED" = "Q" ; then
      echo "****  $RUN_MODE terminated by user"
      exit 0
   fi
}


select_model_in_textmode() {
   MODEL=
   while test -z "$MODEL" ; do   
      if test -n "$MODEL_LIST" ; then
         echo "****  Print drivers for the following device models available:"
         echo $MODEL_LIST
         read -p "****  Please enter model to install and press Enter: " KEY_PRESSED
         if test -z "$KEY_PRESSED" ; then
            MODEL=`echo $MODEL_LIST | awk '{print $1}'`
         elif echo "$MODEL_LIST" | grep -qw "$KEY_PRESSED" ; then
            MODEL=$KEY_PRESSED
         else
            echo "****"
            echo "ERROR Invalid model entered. Please enter model from the list,"
            echo "ERROR or press Enter to select the first one."
            echo "****"
         fi
      fi
   done
}

run_textmode_dialog() {

   test "`id -u`" = "0" || abort_execution "Root priviliges required"

   test -n "$VENDOR" || abort_execution "VENDOR undefined"
   IN_TEXTMODE=1

   if [ "$RUN_MODE" = "$RUN_MODE_UNINSTALL" ]; then
      echo "****  Running text mode uninstall"
      ask_any_key_or_q
      do_uninstall
      echo "****  Text mode uninstall finished"
   else
      echo "****  Running text mode install"
      ask_any_key_or_q
      create_file_smfp_users_to_add
      if test -s /tmp/smfp_users_to_add ; then
         echo "**** Non-priviliged users found:"
         echo `cat /tmp/smfp_users_to_add`
         echo "****  Are you going to use USB-connected devices ?"
         echo "****  If yes, users allowed to scan or manage printers should be added to $PRINTER_GROUP"
         echo "****  group. The list of non-privileged users proposed for addition is shown above."
         read -p "****  Press y and then Enter to add users or Enter to leave $PRINTER_GROUP group intact: " KEY_PRESSED
         echo ""
         if test "$KEY_PRESSED" != "y" && test "$KEY_PRESSED" != "Y" ; then
            rm -f /tmp/smfp_users_to_add
         fi
      fi
      select_model_in_textmode
      do_install
      echo "****  Text mode install finished"
   fi
}
...

C'est un extrait du script, bien entendu. Celui-ci fait plus de 1800 lignes.

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:47 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 20 Avr 2007 17:34
Messages: 5493
Localisation: sud ouest
as tu essayé de le lancer avec l'option help ?

_________________
ubuntu est un mot africain signifiant "je n'ai pas réussi à configurer ma debian" (je n'aime pas ubuntu, ça se voit non ?)


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 09:54 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
piratebab a écrit:
as tu essayé de le lancer avec l'option help ?

Je ne comprends pas :oops:

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 11:54 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Re,

Je suis arrivé à faire fonctionner ma ML-2160 :041

Mais la méthode n'est pas recommandable.

1 - Déconnexion
2 - Menu ==> Console
3 - Login root
4 - startx ==> oui je sais !
5 - exécuter dans dolphin l'installation qui s'active en mode graphique
6 - Dans iceweasel installer l'imprimante (http://localhost:631)
7 -Ne pas tenter de vérifier en lançant un test d'imprimante mais une impression réelle. On imprime :041

Mais n'espérez pas qu'en revenant à un autre user çà fonctionne. J'en déduis que c'est une question de droits, mais lesquels ?

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 12:09 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 20 Avr 2007 17:34
Messages: 5493
Localisation: sud ouest
papy: tu lances le script en ajoutant --help juste aprés
Citation:
./script.sh --help


Pour vos problèmes de droits, essayez un chmod sur le /dev/xxx correspondant à la connexion de l'imprimante.

_________________
ubuntu est un mot africain signifiant "je n'ai pas réussi à configurer ma debian" (je n'aime pas ubuntu, ça se voit non ?)


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 12:45 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
@ piratebab :
Quand je fais ça, j'ai une erreur :
Code:
/home/guy/cdroot/Linux# ./install.sh --help
Invalid argument <--help>

/home/guy/cdroot/Linux# sh install.sh --help
Invalid argument <--help>

pourtant le script se trouve bien dans ce dossier :
Code:
/home/guy/cdroot/Linux# dir
check_installation.sh  i386  Installer.htm  install.sh   noarch   OEM.ini  uninstall.sh  x86_64

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 13:02 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 20 Avr 2007 17:34
Messages: 5493
Localisation: sud ouest
c'est que l'auteur du script n'a pas jugé utile de faire une aide!
essai avec -h

_________________
ubuntu est un mot africain signifiant "je n'ai pas réussi à configurer ma debian" (je n'aime pas ubuntu, ça se voit non ?)


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 16:44 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
Non, c'est pareil. Il n'y a pas d'aide pour ce script :12

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 04 Juil 2013 19:57 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Re,

Confirmation, seul Samsung confond Ubuntu & Debian.
En lançant une session graphique root leur driver fonctionne parfaitement.
Il ne leur reste plus qu'à apprendre la différence entre les deux optiques de sécurité.
Dans leur mode d'emploi ils conseillent de cliquer sur install.sh ce qui prouve bien que ce n'est pas clair dans leur tête. Ils en sont à ignorer que root ne fait pas de graphique.
Qu'ils comptent sur moi pour leur faire de la publicité :lol:

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 05 Juil 2013 07:58 
Hors ligne
Très bavard(e)!

Inscription: 28 Mai 2013 16:11
Messages: 303
Localisation: Liège - Belgique
ggoodluck47 a écrit:
...
Confirmation, seul Samsung confond Ubuntu & Debian...

Moi ... pas encore ... quoi que :017

ggoodluck47 a écrit:
...
En lançant une session graphique root leur driver fonctionne parfaitement.


Ah. Bien.
Mais comment fait-on alors pour lancer leur programme pour que l'installation se fasse correctement ?
Je suis un gros débutant avec Debian et ... :oops: je viens justement de ... Ubuntu :oops: qui est, sans aucune flagornerie, un point d'entrée à Linux intéressant pour ceux qui n'y ont jamais touché :083 à Linux.

ggoodluck47 a écrit:
...
Il ne leur reste plus qu'à apprendre la différence entre les deux optiques de sécurité.


et à moi aussi :12
Je veux bien tenter d'apprendre quelque chose, moi :P

ggoodluck47 a écrit:
...
Dans leur mode d'emploi ils conseillent de cliquer sur install.sh ce qui prouve bien que ce n'est pas clair dans leur tête.

Je suis d'accord. Mais dès qu'on a appris qu'il "suffit" de passer en "console", oups, pardon, en "terminal" (et pas en "terminale" comme je l'ai déjà vu sur des sites), et taper sauvagement - et savamment aussi :

Code:
sh install.sh


pour que ça se lance, c'est qu'on a déjà un peu appris sur Linux :lol:

ggoodluck47 a écrit:
...
Qu'ils comptent sur moi pour leur faire de la publicité :lol:


Je ne fais pas de bub non plus mais je voudrais simplement pouvoir utiliser mon imprimante sous Debian sans quoi ... je devrai retourner sous Ubuntu :-? car je dois souvent imprimer des documents et je ne vais tout de même pas jeter une machine à la poubelle parce que son installation ne fonctionne pas bien sous Debian.

Help :078 SVP.

_________________
La connaissance est une richesse qu'il faut pas hésiter à partager. - Debian 7.x - Gnome 3.x - Matos : Asus P8Z77-M Pro - Intel pentium G860 LGA-1155 3GHz - HDD 1TO WD Green + WD 1TO Caviar Black - Asus GeForce 210 Silent 1GB ddr3 - 8GiO


Haut
 Profil  
 
MessagePosté: 05 Juil 2013 08:31 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Salut,

Je confirme que même après avoir éteint cette nuit l'imprimante est restée configurée pour root.

Il n'y a plus qu'a trouver quel droit doit avoir l'user pour être en droit d'imprimer !

1 - Comme j'ai rebooté ce n'est pas /dev/ppp qui est revenu à root seul

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 05 Juil 2013 08:55 
Hors ligne
Contributeur

Inscription: 22 Oct 2008 17:08
Messages: 2630
Le tuto fourni par thuban propose une autre voie.
http://www.osside.net/?p=11307
thuban : non è spagnolo , è italiano. C'est de l'italien, pas de l'espagnol.

Ça ne me semble pas particulièrement compliqué à réaliser. En résumé :
installer printer-driver-splix e printer-driver-foo2zjs (foo2qpdl), sélectionner
le pilote Samsung CLP-310 Foomatic/foo2qpdl.

Quelle que soit la méthode, étape très importante pour pouvoir accéder à l'administration de CUPS

Citation:

Aggiungiamo il nostro utente a quelli autorizzati:

Code:
 # usermod -aG lpadmin


C'est-à-dire ajouter l'utilisateur au groupe lpadmin, groupe ayant l'autorisation d'administrer les imprimantes.
Quitter la session en cours, se connecter à nouveau, se placer en
http://localhost:631/admin
Ajouter l'imprimante en sélectionnant le pilote.


Haut
 Profil  
 
MessagePosté: 05 Juil 2013 09:00 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Salut,

J'essaierai cette méthode sur une autre machine un peu plus tard.
En attendant il suffit de modifier le .profile du "user" pour lui ajouter /bin:/sbin:/usr/bin:/usr/sbin:

Je n'ai pas de groupe lpadmin, c'est grave docteur ?


c'est faux je viens de le trouver, mes excuses :smile:

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
MessagePosté: 05 Juil 2013 09:04 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14767
Localisation: Le domaine de Henri IV
Re,

Seulement je faisait déjà partie de ce groupe !

Donc je persiste et signe. Il semblerait qu'une partie du système est installée sur le chemin accessible à root exclusivement !

_________________
Debian 3.17-1.slh.3-aptosid (3.17-5) GT520 Nvidia 343.22 Intel (I5) ~3GHz

Pensez à correctement formater vos titres dans SD :

https://www.debian-fr.org/important-mod ... 49679.html


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 33 messages ]  Aller à la page 1, 2  Suivante

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.454s | 14 Queries | GZIP : Off ]