Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 56 messages ]  Aller à la page Précédente  1, 2, 3  Suivante
Auteur Message
MessagePosté: 25 Mar 2011 11:36 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14688
Localisation: Le domaine de Henri IV
Re,

Après relecture du post :

Citation:
Benl03, je n'ai qu'une carte ION sur ma machine. Je n'installe d'ailleurs pas de drivers spécifiques ce qui fait que je n'utilise pas son potentiel.


Ce qui fait que tu laisses au processeur le boulot que la carte graphique pourrait faire. Bien sûr cela ne resoudra pas ton problème, mais comme le chiffrage, c'est encore un plus :smile:

_________________
Debian 3.16-1.slh.1-aptosid (3.16-3) GT520 Nvidia 343.13 Intel (I5) ~3GHz

http://aptosid-fr.org/forum


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 11:43 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Juin 2009 20:16
Messages: 2152
ggoodluck47 a écrit:
Re,

Après relecture du post :

Citation:
Benl03, je n'ai qu'une carte ION sur ma machine. Je n'installe d'ailleurs pas de drivers spécifiques ce qui fait que je n'utilise pas son potentiel.


Ce qui fait que tu laisses au processeur le boulot que la carte graphique pourrait faire. Bien sûr cela ne resoudra pas ton problème, mais comme le chiffrage, c'est encore un plus :smile:

+1 !

A noter qu'il me semble que seul Compiz gère intégralement les interfaces graphiques via l'accélération 3D, les autres gestionnaires de fenêtres délèguent ça au CPU. Et sur une config un peu light on sent vraiment la différence au niveau de l'utilisation du CPU ! fran.b pourra confirmer je pense ;)
Au-delà de ça, déléguer l'affichage des vidéos à la carte graphique allège infiniment le CPU. Donc si tu regardes des vidéos tu as tout intérêt à configurer ta carte graphique correctement.

On notera que les animations en Flash consomment énormément de ressources CPU...


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 11:43 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 24 Aoû 2007 08:34
Messages: 1016
Localisation: Perpignan
Le module à charger est spécifié dans /etc/modules.
Certains bios sont capable via acpi de charger le bon module. Sinon c'est pas bien grave il suffit de connaitre le nom du module correspondant à son cpu et de charger les gouverneurs dont on a besoin (et qui sont supportés par le hardware -en général : on demand, conservative, performance, powersave et userspace.
La doc explique bien tout ça.

Sysfs peut être rajouté à la main dans le fstab car c'est OBLIGATOIRE pour que cpufreq fonctionne.

_________________
« Le manuel disait “Nécessite Windows huit ou supérieur”. J’ai donc installé Debian Gnu/Linux. »

°°°
thinkpad sl510 wheezy xfce


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 11:50 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Nov 2008 19:25
Messages: 257
Localisation: Bordeaux, FRANCE / Dakar, SENEGAL
Hello.
Cluxter a écrit:
Donc si l'on souhaite être sûr que "cpufreq" puisse être lancé, il faut d'abord s'assurer que la fonction est bien active dans le kernel.


Ce serait p'tet bien de dire quelle option non?
Code:
iman@debian:~$ cat /boot/config-2.6.38-1-686 | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m
iman@debian:~$ cat /boot/config-2.6.37-2-686 | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m
iman@debian:~$ cat /boot/config-2.6.32-5-686 | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m

A priori ça n'a pas évolué depuis un moment de ce côté dans les kernels Debian.

@+...

_________________
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 12:35 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 24 Aoû 2007 08:34
Messages: 1016
Localisation: Perpignan
Le kernel standard supporte en natif cpufreq.
S'il est recompilé ça semble judicieux d'activer ces modules :roll:

_________________
« Le manuel disait “Nécessite Windows huit ou supérieur”. J’ai donc installé Debian Gnu/Linux. »

°°°
thinkpad sl510 wheezy xfce


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 21:52 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
Bonsoir tout le monde,

J'essaie d'apporter autant d'éléments que possible et de répondre (dans le désordre) à tout ce que j'ai relevé dans vos commentaires.

Code:
laptop-ph:~$ lsmod | grep cpu
cpufreq_userspace       1992  0
cpufreq_conservative     5162  0
cpufreq_stats           2659  0
cpufreq_powersave        902  0


Pour ce qui est de sysfs dans mon /etc/fstab : je ne vois rien de tel et je ne sais pas du tout de quoi il s'agit :/ J'essaie de me documenter.

Pour ce qui est des vidéos, de l'accélération graphique, etc., je répondrais que je n'ai pas installé de drivers spécifiquement destinés à exploiter pleinement ma carte ION mais je ne suis pas sûr que cela ait un lien car je n'ai besoin de rien faire pour que cela chauffe très fort ! Je n'ai pas d'environnement de bureau mais simplement Openbox et un firefox de deux onglets (sans flash ou autre cochonnerie), un gvim, un gajim et deux terminaux suffisent à faire monter la température. Je crois même que je n'ai pas besoin de faire un startx pour que ça s'envole... D'ailleurs je teste dès que j'ai posté ce message !

Comment tester si l'option est présente dans mon kernel Cluxter ? J'avoue que vous me perdez un peu. Triangle : mon fichier /etc/modules ne comporte que "loop".

Ma todolist :
- faire un retour sur mes tests sysfs
- tester un liveusb pour voir si j'ai le problème
- tester sans démarrer X
- installer drivers 3D ? En dernier recours car je crois que les drivers ne sont pas libres et en plus, ça me gonfle :)


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 22:12 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Juin 2009 20:16
Messages: 2152
Citation:
Comment tester si l'option est présente dans mon kernel Cluxter ?

i M@N a donné ci-dessus la commande qui va bien, à savoir :
Code:
$ cat /boot/config-2.6.38-1-686 | grep CONFIG_CPU_FREQ

et c'est le paramètre en face de "CONFIG_CPU_FREQ=" qui définit si l'option est active dans le kernel (bien sûr tu dois adapter la commande à la version de ton kernel).


Haut
 Profil  
 
MessagePosté: 25 Mar 2011 22:54 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
Alors, voici mon grand bilan ;)

Sans activer X

Aucun changement, je plafonne à 88°C juste avec un vim et un mutt de lancés...

Sysfs

J'ai ajouté une ligne qui m'a parue adaptée dans /etc/fstab (je ne comprends pas trop l'intérêt mais je pars du principe que vous savez, je ferai les recherches quand on aura trouvé ^^) :
Code:
laptop-ph:~$ grep sysfs /etc/fstab
sysfs          /sys         sysfs  defaults        0     0
laptop-ph:~$ mount | grep sysfs
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)


Aucun changement... J'ai laissé le point de montage et cpufreq-info retourne toujours la même chose.

Code:
laptop-ph:~$ cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 1 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 2 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 3 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.


Le module est-il activé ?

Code:
laptop-ph:~$ cat /boot/config-2.6.32-5-amd64 | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m


Test en liveUSB

Aucun changement... J'ai fait à peu près les mêmes contrôles que pour ma debian installée. J'ai regardé si /sys était monté en sysfs et c'est le cas. Je n'ai pas observé le rendu de la commande cpufreq-info mais l'option dont vous me parlez est réglée comme suit :

Code:
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m


Haut
 Profil  
 
MessagePosté: 26 Mar 2011 13:23 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Nov 2008 19:25
Messages: 257
Localisation: Bordeaux, FRANCE / Dakar, SENEGAL
Hello.

Phi a écrit:
Le module est-il activé ?

Code:
laptop-ph:~$ cat /boot/config-2.6.32-5-amd64 | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m


Code:
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y <- le gouverneur par defaut est ondemand
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y <- le gouverneur performance est compilé en dur dans le kernel (y)
CONFIG_CPU_FREQ_GOV_POWERSAVE=m <- le gouverneur powersave est un module (m)
CONFIG_CPU_FREQ_GOV_USERSPACE=m <- le gouverneur userspace est un module (m)
CONFIG_CPU_FREQ_GOV_ONDEMAND=y <- le gouverneur ondemand est compilé en dur dans le kernel (y)
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m <- le gouverneur conservative est un module (m)


Ensuite il faut que tu charges le pilote cpufreq pour ton CPU. A priori je dirais p4-clockmod :
Code:
sudo modprobe p4-clockmod
sudo modprobe cpufreq_conservative
sudo modprobe cpufreq_powersave
sudo modprobe cpufreq_stats
sudo modprobe cpufreq_userspace

Maintenant tu dois avoir des infos :
Code:
cpufreq-info

et les fréquences disponibles :
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies

et les gouverneurs disponibles :
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

ça devrait t'afficher :
Citation:
userspace powersave conservative ondemand performance


ensuite tu dois ajouter les modules à charger au démarrage (ceux qui ne sont pas compilés en dur dans le kernel) :
Code:
sudo nano /etc/modules

et tu ajoutes :
Citation:
p4-clockmod
cpufreq_stats
cpufreq_powersave
cpufreq_userspace
cpufreq_conservative

CRTL + o et ENTER pour enregistrer
CTRL + x pour quitter nano

Pour modifier le gouverneur :
Code:
su (tape le pass root)
echo conservative > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
exit


Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

doit te renvoyer :
Citation:
conservative


Pour conserver le gouverneur conservative au reboot il faut éditer /etc/sysfs.conf :
Code:
sudo nano /etc/sysfs.conf

et tu ajoutes à la fin :
Citation:
devices/system/cpu/cpu0/cpufreq/scaling_governor=conservative

CRTL + o et ENTER pour enregistrer
CTRL + x pour quitter nano

Enfin il semblerait que le module eeepc_laptop soit utile pour ton processeur.
Code:
sudo aptitude install laptop-mode-tools

Code:
sudo modprobe eeepc_laptop

Code:
sudo nano /etc/modules

et tu ajoutes :
Citation:
eeepc_laptop

CRTL + o et ENTER pour enregistrer
CTRL + x pour quitter nano

http://evanhanson.com/2011/01/14/cpufre ... -atom-330/

@+...

_________________
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org


Haut
 Profil  
 
MessagePosté: 26 Mar 2011 19:03 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
Je reviens avec de mauvaises nouvelles :(

Code:
root@laptop-ph:/home/phil# modprobe p4-clockmod
FATAL: Module p4_clockmod not found.
root@laptop-ph:/home/phil# modprobe cpufreq_conservative
root@laptop-ph:/home/phil# modprobe cpufreq_powersave
root@laptop-ph:/home/phil# modprobe cpufreq_stats
root@laptop-ph:/home/phil# modprobe cpufreq_userspace
root@laptop-ph:/home/phil# cpufreq-info


J'ai quand même testé coufreq-info :

Code:
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 1 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 2 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 3 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.


Aucun changement. D'ailleurs, les fichiers n'existent toujours pas :

Code:
root@laptop-ph:/home/phil# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies: Aucun fichier ou dossier de ce type
root@laptop-ph:/home/phil# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors: Aucun fichier ou dossier de ce type


Et après installation du paquet laptop-mode-tools :

Code:
root@laptop-ph:/home/phil# modprobe eeepc_laptop
FATAL: Error inserting eeepc_laptop (/lib/modules/2.6.32-5-amd64/kernel/drivers/platform/x86/eeepc-laptop.ko): No such device


L'installation de laptop-mode-tools a exigé que je retire des paquets en rapport avec acpi : je reviens sur ça ou ça change plus trop rien dans mon cas ? :)

Code:
3 paquets vont être installés, et 5 retirés.
594 ko d'espace disque vont être libérés
===============================================================================
[SUPPRIMÉ, NON UTILISÉ] radeontool
[SUPPRIMÉ, NON UTILISÉ] rfkill
[INSTALLÉ, DÉPENDANCES] ethtool
[INSTALLÉ, DÉPENDANCES] sdparm
[RETIRÉ, DÉPENDANCES] acpi-support
[RETIRÉ, DÉPENDANCES] eeepc-acpi-scripts
[RETIRÉ, DÉPENDANCES] pm-utils
[INSTALLÉ] laptop-mode-tools
===============================================================================


Haut
 Profil  
 
MessagePosté: 26 Mar 2011 20:35 
Hors ligne
Très bavard(e)!

Inscription: 21 Déc 2010 16:26
Messages: 401
Peux-tu poster cat /proc/cpuinfo
et
cat /boot/config-2.6.32-5-amd64 egrep | 'CONFIG_X86_PCC_CPUFREQ|CONFIG_X86_ACPI_CPUFREQ|CONFIG_X86_POWERNOW_K8|CONFIG_X86_SPEEDSTEP_CENTRINO|CONFIG_X86_P4_CLOCKMOD'


Haut
 Profil  
 
MessagePosté: 26 Mar 2011 21:01 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Nov 2008 19:25
Messages: 257
Localisation: Bordeaux, FRANCE / Dakar, SENEGAL
re ...
Phi a écrit:
Code:
root@laptop-ph:/home/phil# modprobe p4-clockmod
FATAL: Module p4_clockmod not found.


FAiL! :018
Phi a écrit:
Code:
root@laptop-ph:/home/phil# modprobe cpufreq_conservative
root@laptop-ph:/home/phil# modprobe cpufreq_powersave
root@laptop-ph:/home/phil# modprobe cpufreq_stats
root@laptop-ph:/home/phil# modprobe cpufreq_userspace


WiN! :023

Phi a écrit:
J'ai quand même testé coufreq-info :
Code:
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 1 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 2 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 3 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.

Aucun changement. D'ailleurs, les fichiers n'existent toujours pas :

Code:
root@laptop-ph:/home/phil# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies: Aucun fichier ou dossier de ce type
root@laptop-ph:/home/phil# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors: Aucun fichier ou dossier de ce type


Normal puisque t'as pas pu charger le pilote p4-clockmod

Phi a écrit:
Et après installation du paquet laptop-mode-tools :
Code:
root@laptop-ph:/home/phil# modprobe eeepc_laptop
FATAL: Error inserting eeepc_laptop (/lib/modules/2.6.32-5-amd64/kernel/drivers/platform/x86/eeepc-laptop.ko): No such device

L'installation de laptop-mode-tools a exigé que je retire des paquets en rapport avec acpi : je reviens sur ça ou ça change plus trop rien dans mon cas ? :)
Code:
3 paquets vont être installés, et 5 retirés.
594 ko d'espace disque vont être libérés
===============================================================================
[SUPPRIMÉ, NON UTILISÉ] radeontool
[SUPPRIMÉ, NON UTILISÉ] rfkill
[INSTALLÉ, DÉPENDANCES] ethtool
[INSTALLÉ, DÉPENDANCES] sdparm
[RETIRÉ, DÉPENDANCES] acpi-support
[RETIRÉ, DÉPENDANCES] eeepc-acpi-scripts
[RETIRÉ, DÉPENDANCES] pm-utils
[INSTALLÉ] laptop-mode-tools
===============================================================================

L'histoire de laptop-mode-tools c'était en plus, oublie ça ... enlève laptop-mode-tools pour le moment puis remets les paquets radeontool, rfkill, acpi-support, eeepc-acpi-scripts et pm-utils.

Le souci apparemment d'après ce que j'ai pu lire sur la toile c'est que p4-clockmod a été viré du kernel Debian : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=609638
et
https://groups.google.com/group/linux.d ... 9764?hl=fr
et
https://linuxfr.org/forums/linuxg%C3%A9 ... nt-1077860
Donc pour avoir p4-clockmod il te faudrait recompiler ton kernel.
Y'a parfois des trucs qui m'échappe chez Debian ...

il reste la solution acpi-cpufreq qui est compilé en module dans le kernel normalement (mais ça n'a pas l'air de fonctionner super avec tous les processeurs) ... essaye voir :
Code:
iman@debian:~$ cat /boot/config-2.6.32-5-686 | grep ACPI_CPUFREQ
CONFIG_X86_ACPI_CPUFREQ=m


Code:
sudo modprobe acpi-cpufreq

et donne ce que te renvoient :
Code:
cpufreq-info
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors


Si tu as "conservative" dans la liste tu peux faire :
Code:
sudo cpufreq-set -g conservative


Si ça fonctionne remplace p4-clockmod par acpi-cpufreq dans /etc/modules

@+...

_________________
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 09:52 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
sebB a écrit:
Peux-tu poster cat /proc/cpuinfo
et
cat /boot/config-2.6.32-5-amd64 egrep |
'CONFIG_X86_PCC_CPUFREQ|CONFIG_X86_ACPI_CPUFREQ|CONFIG_X86_POWERNOW_K8|CONFIG_X86_SPEEDSTEP_CENTRINO|CONFIG_X86_P4_CLOCKMOD'


Code:
laptop-ph:~$ cat /proc/cpuinfo
processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU  330   @ 1.60GHz
stepping    : 2
cpu MHz     : 1599.929
cache size  : 512 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3199.85
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU  330   @ 1.60GHz
stepping    : 2
cpu MHz     : 1599.929
cache size  : 512 KB
physical id : 0
siblings    : 4
core id     : 1
cpu cores   : 2
apicid      : 2
initial apicid  : 2
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3199.96
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:

processor   : 2
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU  330   @ 1.60GHz
stepping    : 2
cpu MHz     : 1599.929
cache size  : 512 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 1
initial apicid  : 1
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3199.95
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:

processor   : 3
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU  330   @ 1.60GHz
stepping    : 2
cpu MHz     : 1599.929
cache size  : 512 KB
physical id : 0
siblings    : 4
core id     : 1
cpu cores   : 2
apicid      : 3
initial apicid  : 3
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3199.97
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:


Code:
laptop-ph:~$ cat /boot/config-2.6.32-5-amd64 | grep "CONFIG_X86_PCC_CPUFREQ\|CONFIG_X86_ACPI_CPUFREQ\|CONFIG_X86_POWERNOW_K8\|CONFIG_X86_SPEEDSTEP_CENTRINO\|CONFIG_X86_P4_CLOCKMOD"
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_POWERNOW_K8=m
CONFIG_X86_SPEEDSTEP_CENTRINO=m
# CONFIG_X86_P4_CLOCKMOD is not set


i M@N a écrit:
L'histoire de laptop-mode-tools c'était en plus, oublie ça ... enlève laptop-mode-tools pour le moment puis remets les paquets radeontool, rfkill, acpi-support, eeepc-acpi-scripts et pm-utils.


C'est fait !

i M@N a écrit:
il reste la solution acpi-cpufreq qui est compilé en module dans le kernel normalement (mais ça n'a pas l'air de fonctionner super avec tous les processeurs) ... essaye voir :
Code:
iman@debian:~$ cat /boot/config-2.6.32-5-686 | grep ACPI_CPUFREQ
CONFIG_X86_ACPI_CPUFREQ=m



Code:
laptop-ph:~$ cat /boot/config-2.6.32-5-amd64 | grep ACPI_CPUFREQ
CONFIG_X86_ACPI_CPUFREQ=m


i M@N a écrit:
Code:
sudo modprobe acpi-cpufreq

et donne ce que te renvoient :
Code:
cpufreq-info
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors


Si tu as "conservative" dans la liste tu peux faire :
Code:
sudo cpufreq-set -g conservative


Si ça fonctionne remplace p4-clockmod par acpi-cpufreq dans /etc/modules


Code:
root@laptop-ph:~# modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.32-5-amd64/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device


:(

Et donc, pas de surprise :

Code:
root@laptop-ph:~# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors: Aucun fichier ou dossier de ce type


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 10:19 
Hors ligne
Très bavard(e)!

Inscription: 21 Déc 2010 16:26
Messages: 401
http://ark.intel.com/Product.aspx?id=35641
Ton cpu ne supporte pas les changements de frequence
Une solution sans grande conviction, recompiler ton kernel et inclure les support pour p4-clockmod.


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 10:28 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14688
Localisation: Le domaine de Henri IV
Salut,

Il te reste à trouver un radiateur avec ventilo incorporé. Chez moi cela à été spectaculaire mais il est énorme !

_________________
Debian 3.16-1.slh.1-aptosid (3.16-3) GT520 Nvidia 343.13 Intel (I5) ~3GHz

http://aptosid-fr.org/forum


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 12:46 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Nov 2008 19:25
Messages: 257
Localisation: Bordeaux, FRANCE / Dakar, SENEGAL
Hello.

@Phi : avant de compiler un kernel essaye en installant une image 2.6.32-5-686 et refais les manips pour voir.

@+...

_________________
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 14:57 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
Je ne peux rien changer dedans (comme un ventilo) car c'est un ordinateur portable :(

Pourquoi mon CPU ne gérerait pas le changement de fréquence alors qu'avant il ne chauffait pas du tout ? C'est depuis que j'ai réinstallé squeeze après sa sortie.


Haut
 Profil  
 
MessagePosté: 27 Mar 2011 15:09 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14688
Localisation: Le domaine de Henri IV
Phi a écrit:
Je ne peux rien changer dedans (comme un ventilo) car c'est un ordinateur portable :(

Pourquoi mon CPU ne gérerait pas le changement de fréquence alors qu'avant il ne chauffait pas du tout ? C'est depuis que j'ai réinstallé squeeze après sa sortie.


Je confirme avoir un AMD64 2600+ qui ne gère pas !

Parce que dans ce que tu as installé il y a sans doute quelque chose de nouveau. Mais tu as déjà cherché de ce côté avec htop !

Même sur un portable il y a un radiateur sur la cpu. Et sur certains on peut le dévisser pour en mettre un avec ventilo incorporé. Ils ont creusé le radiateur de la profondeur d'un ventilo :038 Bonjour la bricole :smile:

_________________
Debian 3.16-1.slh.1-aptosid (3.16-3) GT520 Nvidia 343.13 Intel (I5) ~3GHz

http://aptosid-fr.org/forum


Haut
 Profil  
 
MessagePosté: 29 Mar 2011 22:10 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
Salut tout le monde,

Je me permets de remettre le sujet sur le tapis pour cette dernière question : ça ne vous choque pas qu'il ne chauffait pas du tout auparavant ?? J'ai juste changé de version de "squeeze testing" à "squeeze stable" (réinstallation après repartitionnement).

Deuxième point similaire : j'ai le même processeur sur mon serveur je crois (ATOM 330) et il tourne sous debian squeeze :

Code:
server-bl:/srv# sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +47.0°C  (crit = +90.0°C)                 

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +49.0°C  (crit = +90.0°C)                 

it8718-isa-0290
Adapter: ISA adapter
in0:         +1.14 V  (min =  +0.00 V, max =  +4.08 V)   
in1:         +1.84 V  (min =  +0.00 V, max =  +4.08 V)   
in2:         +3.34 V  (min =  +0.00 V, max =  +4.08 V)   
in3:         +4.08 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
in4:         +3.17 V  (min =  +0.00 V, max =  +4.08 V)   
in5:         +0.08 V  (min =  +0.00 V, max =  +4.08 V)   
in6:         +0.02 V  (min =  +0.00 V, max =  +4.08 V)   
in7:         +4.08 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
Vbat:        +3.23 V
fan1:          0 RPM  (min =    0 RPM)
fan2:          0 RPM  (min =    0 RPM)
fan3:          0 RPM  (min =    0 RPM)
temp1:       -55.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp2:        -2.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp3:       +48.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermal diode
cpu0_vid:   +1.850 V


Pourtant, j'ai voulu installer cpufrequtils pour tester et déjà à l'extraction du paquet :
Code:
CPUFreq Utilities: Setting ondemand CPUFreq governor...disabled, governor not available...done


Et ensuite :
Code:
server-bl:/srv# cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 1 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 2 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 3 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.


Donc rien à voir avec le cpufrequtils non ?


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 07:19 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14688
Localisation: Le domaine de Henri IV
Re,

Et s'il était entrain de rendre l'âme ?

_________________
Debian 3.16-1.slh.1-aptosid (3.16-3) GT520 Nvidia 343.13 Intel (I5) ~3GHz

http://aptosid-fr.org/forum


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 07:29 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 24 Aoû 2007 08:34
Messages: 1016
Localisation: Perpignan
Ca ne concerne pas directement l'atom 330 mais ça peut aider à mieux comprendre le fonctionnement.

http://www.thinkwiki.org/wiki/How_to_ma ... cy_Scaling

_________________
« Le manuel disait “Nécessite Windows huit ou supérieur”. J’ai donc installé Debian Gnu/Linux. »

°°°
thinkpad sl510 wheezy xfce


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 10:44 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 30 Nov 2008 19:25
Messages: 257
Localisation: Bordeaux, FRANCE / Dakar, SENEGAL
Hello.

Phi a écrit:
Pourtant, j'ai voulu installer cpufrequtils pour tester et déjà à l'extraction du paquet :
Code:
CPUFreq Utilities: Setting ondemand CPUFreq governor...disabled, governor not available...done


Mais est-ce qu'avant tu as chargé les modules comme je t'ai expliqué plus haut?
Code:
#modprobe p4-clockmod cpufreq_conservative cpufreq_powersave cpufreq_stats cpufreq_userspace


@+...

_________________
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 10:49 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 29 Juil 2009 01:51
Messages: 626
il s'agit d'une installation infructueuse...reinstallation requise...

_________________
pc Slitaz_Custom_squeeze_stable--gnome2.30.2--kernel2.6.32-5-486


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 18:00 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
burty : je ne l'ai pas indiqué pour ne pas brouiller la conversation mais j'ai réinstallé tout mon système il y a 2 jours sans aucun changement.

iM@N : non mais je viens de m'y reprendre, voici ce que j'obtiens (sur mon serveur donc...) :

Code:
server-bl:~# modprobe p4-clockmod cpufreq_conservative cpufreq_powersave cpufreq_stats cpufreq_userspace
FATAL: Module p4_clockmod not found.
server-bl:~# /etc/init.d/cpufrequtils restart
CPUFreq Utilities: Setting ondemand CPUFreq governor...disabled, governor not available...done.
server-bl:~# cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à cpufreq@vger.kernel.org, s'il vous plait.
analyse du CPU 0 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 1 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 2 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.
analyse du CPU 3 :
  pas de pilotes cpufreq reconnu pour ce CPU
  maximum transition latency: 4294.55 ms.


Trangle : Je vais parcourir ta doc merci (je ne sais pas bien comment tout ça fonctionne effectivement). Sai-ton jamais...

ggoodluck47 : Je ne sais pas s'il rend l'âme... ça m'embêterait car je l'ai acheté sur internet alors niveau SAV... Surtout s'ils le gardent 27 ans. C'est peut-être bête mais c'est arrivé dans un contexte tel (après réinstall) que j'ai quand même l'impression que c'est le système... J'ai envie d'installer autre chose que Debian, pour voir... et pour revenir sur Debian :D

Bref, si vous avez encore des idées : je prends. Je vous tiens au courant de mes différentes découvertes. Merci encore une fois pour tout.


Haut
 Profil  
 
MessagePosté: 30 Mar 2011 20:43 
Hors ligne
Très bavard(e)!

Inscription: 19 Juil 2009 08:57
Messages: 271
J'ai testé avec un live USB Xubuntu et le processeur chauffe toujours énormément.

J'ai l'impression que c'était mon dernier recours... Vous me conseiller d'installer carrément la Xubuntu pour que le test soit valable ou vous pensez que mon processeur a un problème matériel ?


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 56 messages ]  Aller à la page Précédente  1, 2, 3  Suivante

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: flavien et 4 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.507s | 15 Queries | GZIP : Off ]