Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 6 messages ] 
Auteur Message
MessagePosté: 10 Mai 2013 23:50 
Hors ligne
Nouvel utilisateur

Inscription: 10 Mai 2013 23:30
Messages: 52
Localisation: ::1 ou ailleurs, ça dépend
Bonjour à tous,

J'ai mis à Debian squeeze vers wheezy et depuis je ne peux plus envoyer de mail (mais je peux en recevoir) à cause d'une erreur de SASL.

/var/log/mail.info :
Citation:
May 10 22:53:09 ks28476 postfix/smtpd[16865]: warning: abo-13-131-68.bdx.modulonet.fr[85.68.131.13]: SASL PLAIN authentication failed: no mechanism available
May 10 22:53:09 ks28476 postfix/smtpd[16865]: warning: abo-13-131-68.bdx.modulonet.fr[85.68.131.13]: SASL LOGIN authentication failed: no mechanism available


/etc/default/saslauthd
Code:
START=yes
DESC="SASL Authentication Daemon"
NAME="saslauthd"
MECHANISMS="rimap"
MECH_OPTIONS="localhost"
THREADS=5
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"


/etc/postfix/sasl/smtpd.conf
Citation:
pwcheck_method: saslauthd
mech_list: PLAIN LOGIN
auxprop_plugin: rimap


Je ne vois pas trop ce qui coince compte tenu que ça fonctionnait très bien avant.

Merci de votre aide


Haut
 Profil  
 
MessagePosté: 11 Mai 2013 10:31 
Hors ligne
Nouvel utilisateur

Inscription: 10 Mai 2013 23:30
Messages: 52
Localisation: ::1 ou ailleurs, ça dépend
Après pas mal de recherches, il s'est avéré qu'il suffit de commenter la ligne
Code:
auxprop_plugin: rimap
dans /etc/postfix/sasl/smtpd.conf

http://microbits.info/index.php/2012/06/setting-up-postfix-and-saslauthd-with-rimap


Haut
 Profil  
 
MessagePosté: 13 Mai 2013 17:58 
Hors ligne
Nouvel utilisateur
Avatar de l’utilisateur

Inscription: 18 Nov 2009 17:26
Messages: 48
Localisation: Ile De France
Merciii :041 :041

_________________
Etudiant éternel en Informatique
Darkasal @ Absylonia - Draks @ Absylonia - Taraknor @ Absylonia - Stormfire @ Absylonia - Dreshindral @ Absylonia - Slykus @ Absylonia


Haut
 Profil  
 
MessagePosté: 15 Mai 2013 13:46 
Hors ligne
Très bavard(e)!

Inscription: 10 Déc 2007 10:31
Messages: 354
Je joins ma voix à celle de Thald'.
Merci beaucoup. Cependant juste une précision qui pourra servir à d'autres, cela fonctionne également quand on utilise Mysql en backend ce qui est mon cas. Le passage vers Wheezy avait cassé l'authentification SASL et j'ai du commenter cette ligne :

Code:
#auxprop_plugin: mysql


dans /etc/postfix/sasl/smtpd.conf

Ce qui a rétabli le fonctionnement.


Haut
 Profil  
 
MessagePosté: 27 Juin 2013 15:19 
Hors ligne

Inscription: 27 Juin 2013 15:15
Messages: 1
Cette discussion sur Howtoforge apporte la précision suivante:
Dans /etc/postfix/sasl/smtpd.conf

Remplacer
Code:
auxprop_plugin: mysql

Par:
Code:
auxprop_plugin: sql
sql_engine: mysql


Et remplacer %u par %u@%r


Haut
 Profil  
 
MessagePosté: 08 Juil 2013 20:19 
Hors ligne
Nouvel utilisateur

Inscription: 12 Fév 2013 21:06
Messages: 19
Localisation: Gironde
Nickel, merci pour la solution ! :041


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 6 messages ] 

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.134s | 14 Queries | GZIP : Off ]