Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 7 messages ] 
Auteur Message
MessagePosté: 01 Avr 2010 08:16 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12682
Localisation: Madagascar - Isalo
Bonjour,
Je n'ai pas l'habitude de poster pour des cartes graphiques, je n'ai que des nvidia :mrgreen:
Mais là... J'essaye d'installer une machine pour mes enfants (Lenny + junior) et j'ai un problème de carte :

Code:
lspci -v
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome]
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
        Memory at f0000000 (32-bit, prefetchable) [size=64M]
        Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at f5000000 [disabled] [size=64K]
        Capabilities: <access denied>

C'est une carte intégrée...
J'ai un beau "out of range" lorsque le serveur X démarre. Je suppose que c'est un problème de fréquence qui ne colle pas avec l'écran (plat)
Mais je ne sais pas comment régler ce problème..

J'avais un problème que j'ai réglé ce matin (genre "no screen") à coup de "Xorg -configure"
Pas de EE dans les logs de xorg...

Le xorg.conf si ça peut servir...
Code:
$ cat /etc/X11/xorg.conf
Section "ServerLayout"                 
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0     
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection                                       

Section "Files"
        RgbPath      "/etc/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"           
        FontPath     "/usr/share/fonts/X11/100dpi"         
        FontPath     "/usr/share/fonts/X11/75dpi"           
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection                                                             

Section "Module"
        Load  "glx"
        Load  "xtrap"
        Load  "record"
        Load  "GLcore"
        Load  "dri"   
        Load  "extmod"
        Load  "dbe"   
EndSection           

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"     
EndSection                     

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7" 
EndSection                                   

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection                           

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"             
        ### [arg]: arg optional                                     
        #Option     "PrintVGARegs"              # [<bool>]           
        #Option     "PrintTVRegs"               # [<bool>]           
        #Option     "I2CScan"                   # [<bool>]           
        #Option     "VBEModes"                  # [<bool>]           
        #Option     "NoAccel"                   # [<bool>]           
        #Option     "AccelMethod"               # <str>             
        #Option     "ExaNoComposite"            # [<bool>]           
        #Option     "ExaScratchSize"            # <i>               
        #Option     "SWCursor"                  # [<bool>]           
        #Option     "ShadowFB"                  # [<bool>]           
        #Option     "Rotate"                    # [<str>]           
        #Option     "VideoRAM"                  # <i>               
        #Option     "ActiveDevice"              # [<str>]           
        #Option     "BusWidth"                  # [<str>]           
        #Option     "Center"                    # [<bool>]           
        #Option     "PanelSize"                 # [<str>]           
        #Option     "ForcePanel"                # [<bool>]           
        #Option     "TVDotCrawl"                # [<bool>]           
        #Option     "TVDeflicker"               # <i>               
        #Option     "TVType"                    # [<str>]           
        #Option     "TVOutput"                  # [<str>]           
        #Option     "DisableVQ"                 # [<bool>]           
        #Option     "DisableIRQ"                # [<bool>]           
        #Option     "EnableAGPDMA"              # [<bool>]           
        #Option     "NoAGPFor2D"                # [<bool>]           
        #Option     "NoXVDMA"                   # [<bool>]           
        #Option     "VbeSaveRestore"            # [<bool>]
        #Option     "DisableXvBWCheck"          # [<bool>]
        #Option     "MaxDRIMem"                 # <i>
        #Option     "AGPMem"                    # <i>
        Identifier  "Card0"
        Driver      "openchrome"
        VendorName  "Unknown Vendor"
        BoardName   "Unknown Board"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


Merci d'avance pour vos suggestions.

PS : Je n'ai pour l'instant qu'un accès SSH à la machine...

_________________
GO Compréhensif...
SID 3.x-etc...-amd64 && Xfce 4.x
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 01 Avr 2010 08:19 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14639
Localisation: Le domaine de Henri IV
Salut,

Pour trouver les capacités d'un moniteur je ne connais rien de mieux que la Knoppix qui l'affiche pendant le démarrage. Puis un coup de pince Dymo pour le fixer une fois pout toute sur le pied du moniteur :D

_________________
Debian 3.15-6.slh.3-aptosid (3.15-22) GT520 Nvidia 340.24 Intel (I5) ~3GHz


Haut
 Profil  
 
MessagePosté: 01 Avr 2010 08:25 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12682
Localisation: Madagascar - Isalo
ggoodluck47 a écrit:
Salut,

Pour trouver les capacités d'un moniteur je ne connais rien de mieux que la Knoppix qui l'affiche pendant le démarrage. Puis un coup de pince Dymo pour le fixer une fois pout toute sur le pied du moniteur :D


Salut,

Oui j'y avais pensé... Et démarrer sur le live CD et copier le xorg.conf ?
J'essaye ça dés je suis devant la machine.
Merci !

_________________
GO Compréhensif...
SID 3.x-etc...-amd64 && Xfce 4.x
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 01 Avr 2010 12:32 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12682
Localisation: Madagascar - Isalo
Bon, cette histoire de out-of-range est réglée, merci !

Knoppix, puis cp /etc/X11/xorg.conf /media/hdb3/etc/X11/xorg.conf

il faut maintenant que je fasse des réglages...
Car il m'offre généreusement ces résolutions :

832x624 (je ne sais pas d'ou il sort un truc pareil :mrgreen: )
800x600
640x480

...et en 75Hz (l'écran n'aime pas trop...)

_________________
GO Compréhensif...
SID 3.x-etc...-amd64 && Xfce 4.x
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 01 Avr 2010 12:55 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12682
Localisation: Madagascar - Isalo
Re,

Un truc m'étonne tout de même...

Code:
laurent@girls:~$ xrandr
Screen 0: minimum 320 x 240, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050      50.0*    51.0
   1440x900       52.0
   1400x1050      53.0     54.0     55.0     56.0
   1360x768       57.0     58.0
   1280x1024      59.0     60.0
   1280x960       61.0
   1152x864       62.0     63.0     64.0     65.0
   1024x768       66.0     67.0     68.0
   960x600        69.0
   960x540        70.0
   840x525        71.0     72.0     73.0     74.0
   832x624        75.0
   800x600        76.0     77.0     78.0     79.0
   720x450        80.0
   700x525        81.0     82.0
   680x384        83.0     84.0
   640x480        85.0     86.0     87.0     88.0     89.0
   512x384        90.0     91.0
   400x300        92.0
   320x240        93.0     94.0


Il me dit que je suis en 1680x1050 50Hz... Alors que dans gnome, je suis en 832x624 75.0 !

Qu'est-ce que ça signifie ?

_________________
GO Compréhensif...
SID 3.x-etc...-amd64 && Xfce 4.x
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 01 Avr 2010 14:09 
Hors ligne
Contributeur
Avatar de l’utilisateur

Inscription: 28 Aoû 2003 13:01
Messages: 14639
Localisation: Le domaine de Henri IV
Re,

J'ai déjà constaté ces réglages et surtout ces taux de rafraîchissement qui devraient provoquer des scintillements, mais je n'ai pas trouvé d'explications ?

Pendant le démarrage la Knoppix donne les taux verticaux et Horizontaux mini-maxi ce qui peut éviter des désagréments (jamais arrivé chez moi)

_________________
Debian 3.15-6.slh.3-aptosid (3.15-22) GT520 Nvidia 340.24 Intel (I5) ~3GHz


Haut
 Profil  
 
MessagePosté: 02 Avr 2010 06:36 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12682
Localisation: Madagascar - Isalo
Bien, bien...
J'ai trouvé une carte à base de nvidia dans une carcasse qui trainait au fond de mon bureau...
Enquillée dans l'agp, câble branché, démarrage impec, rien à faire... :D
Un p'tit coup de sgfxi par dessus, et "roule ma poule" :mrgreen:

Pourquoi se prendre la tête avec des puces qui grattent ? :smt006

_________________
GO Compréhensif...
SID 3.x-etc...-amd64 && Xfce 4.x
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 7 messages ] 

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.264s | 15 Queries | GZIP : Off ]