Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 18 messages ] 
Auteur Message
 Sujet du message: glibc_2.14 amd64 recherchée
MessagePosté: 12 Déc 2012 14:36 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
Bonjour,

J'utilise debian mint amd64 sur un portable toshiba satellite 64 bits.

J'ai installé opencpn version debian/ubuntu en 64 bits. Tout s'est bien déroulé, merci gdebi.
Lancé en console, opencpn émet une protestation:

/lib/x86_64-linux-gnu/libc.so.6 version GLIBC_2.14 not found.

J'ai téléchargé cette librairie sur ftp.gnu.org/gnu/glibc ,
lors de la compilation, dès le ./configure ,nouvelle protestation: impossible avec amd64.

question:
comment est-il possible de récupérer et installer cette GLIBC "modèle 64"

Merci.

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 12 Déc 2012 16:22 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
La libc6 est présente en version 2.16 dans les dépôts experimental de Debian.
Pense à simuler l'installation avant de la réaliser vraiment, il se peut que certains de tes paquets doivent être supprimés pour l'installer.

Après simulation et test, la commande suivant suffit pour l'installer sur ma Sid :
Code:
apt-get install libc6/experimental libc6:i386/experimental locales/experimental

Si tu n'utilises pas de paquets 32-bit, tu peux oublier le paquet libc6:i386.

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 12 Déc 2012 17:27 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 18 Mai 2009 15:49
Messages: 4764
De manière générale, quand tu cherches une version spécifique d'un paquet il y a deux endroits où regarder :

_________________
testing/unstable (amd64) sous KDE4
github/syam44 - De la bonne manière de poser les questions - Wiki debian-fr
That's the thing about people who think they hate computers. What they really hate is lousy programmers. -- Larry Niven


Haut
 Profil  
 
MessagePosté: 13 Déc 2012 10:43 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
Bonjour

et merci pour ces deux réponses.

1-) les deux adresses données par syam recensent :

sur "snapshot" pour libc6 les versions 2.13 et 2.16 !! et glibc 2.9-10 au plus
sur "packages" 2.13-17 en testing .

2-) j'ai suivi les indications de vv222, là les versions "experimental" de libc6 et locales sont introuvables.
Je remplace par testing, retour: libc6 est déjà la plus recente version disponible qui est la 2.13-33

Je vais tenter la compilation de opencp en suivant les indications données sur son site et voir ce qui en sort.

Merci et à suivre.

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 13 Déc 2012 14:28 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
Voici la suite:

Les sources d'opencpn sont chargées, le tour des fichiers nécessaires est fait. Architecture amd64 reconnue.

Compilation réussie.. :041

opencpn lancé, pas de réclamation de glibc_2.14_amd64.

Quand même, GTK2 not found, j'ai libgtk-3-dev à la place.
Il me reste les cartes à installer, et le gps...

nb:
dois-je mettre résolu alors que rien n'est trouvé ?? :think:

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 13 Déc 2012 17:57 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
pancrace a écrit:
2-) j'ai suivi les indications de vv222, là les versions "experimental" de libc6 et locales sont introuvables.

Il faut pour ça que les dépôts experimental soient déclarés dans ton sources.list.

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 14 Déc 2012 08:06 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
vv222 a écrit:
Il faut pour ça que les dépôts experimental soient déclarés dans ton sources.list.


Bigre,
J'utilise régulièrement, Squeeze en architecture 32 bits. Lors de l'installation j'ai modifié le sources.list de squeeze pour y mette une branche vers testing, suivant pas à pas un tuto trouvé sur debian-facile.
Cela n'a franchement pas été un succès. J'ai tenté de reprendre le dessus, jusqu'à réinstaller complètement.

Ta proposition de placer une voie vers expérimental, je la comprends très bien, mais je ne suis pas assez assuré de tout maîtriser. J'y viendrais un de ces jours.

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 14 Déc 2012 12:09 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
On a un tuto sur le Wiki à ce sujet :
https://www.isalo.org/wiki.debian-fr/in ... _les_bases

Les dépôts experimental ne nécessitent pas de fichier preferences, ils ont déjà une priorité de 1 par défaut.

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 14 Déc 2012 15:46 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
vv222 a écrit:
On a un tuto sur le Wiki à ce sujet :
https://www.isalo.org/wiki.debian-fr/in ... _les_bases


Je viens de parcourir le topo, je suppose que unstable = experimental = sid.
dans ce cas, j'ajoute la ligne
http://ftp.fr.debian.org/debian/ unstable main
dans le sources.list de LMDE (mint debian edition)

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 14 Déc 2012 16:59 
Hors ligne
Modérateur du forum
Avatar de l’utilisateur

Inscription: 18 Mai 2009 15:49
Messages: 4764
Non !
unstable = sid effectivement, mais c'est différent d'experimental.
Code:
http://ftp.fr.debian.org/debian/ experimental main

unstable (ce que tu voulais faire) c'est dangereux : à la première mise à jour toute ta machine va passer en unstable, ce n'est sûrement pas ce que tu veux !

_________________
testing/unstable (amd64) sous KDE4
github/syam44 - De la bonne manière de poser les questions - Wiki debian-fr
That's the thing about people who think they hate computers. What they really hate is lousy programmers. -- Larry Niven


Haut
 Profil  
 
MessagePosté: 14 Déc 2012 17:35 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
Non non, unstable = sid OK, mais experimental est une sorte de quatrième branche avec des versions encore plus récentes des paquets.

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 15 Déc 2012 08:01 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
syam a écrit:
Code:
http://ftp.fr.debian.org/debian/ experimental main

unstable (ce que tu voulais faire) c'est dangereux : à la première mise à jour toute ta machine va passer en unstable, ce n'est sûrement pas ce que tu veux !


Effectivement, j'ai déjà eu à faire face à ce distribil dans la tour avec non pas unstable, mais testing , j'attendrais que Wheezy soit devenue stable.

Pour expérimental, je ne connaissais pas. J'ai modifié le sources.list, puis aptitude update.
Résultat, 439 m-a-j restantes et 38 293 nouveaux paquets.. Que du bonheur.

Fin de console, retour au menu et je clique sur le gestionnaire de mise à jour. Beaucoup de patience m'est demandé, d'autant plus qu'il y a un plantage: alors que les locales sont en cours d'installation, il m'est demandé de relancer xscreensaver.. En console, rien n'y fait.
Relance, ce matin je vais avoir à réinstaller mate. C'est bon, le week-end sera pluvieux..

Merci de vos conseils, je reviens lorsque glib_2.14 sera là..

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 15 Déc 2012 11:10 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
vv222 a écrit:
Code:
apt-get install libc6/experimental libc6:i386/experimental locales/experimental

Si tu n'utilises pas de paquets 32-bit, tu peux oublier le paquet libc6:i386.


l'interface graphique est remise en place, plus rapidement que je le pensais.
je lance la comande apt comme ci-dessus
Réponse:
libc6 est déjà la plus récente version disponible.
... 2.16-0experimental1 amd64 est là.

Je reste sur l'idée que qui peut le plus peut le moins .. dans 2.16 se trouve 2.14 (sans aucune assurance), opencpn compilé avant hier fonctionne. OK pour les futures navigations..

Pourtant glibc_2.14 existe, le source est dans http://fp.gnu.org/gnu/glibc/

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 15 Déc 2012 12:10 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
pancrace a écrit:
Pour expérimental, je ne connaissais pas. J'ai modifié le sources.list, puis aptitude update.
Résultat, 439 m-a-j restantes et 38 293 nouveaux paquets.. Que du bonheur..

???
Si tu n'as ajouté que les dépôts experimental, aptitude ne devrait voir aucune mise-à-jour de proposée…

Tu n'aurais pas un fichier preferences assignant une priorité particulière à l'ensemble des dépôts Debian, priorité qui dans ce cas prend le pas sur celle par défaut des dépôts experimental ?

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 15 Déc 2012 14:24 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
vv222 a écrit:
Tu n'aurais pas un fichier preferences assignant une priorité particulière à l'ensemble des dépôts Debian, priorité qui dans ce cas prend le pas sur celle par défaut des dépôts experimental ?


Je te joins les deux fichiers, celui avec la "branche" expérimental et le second, le fichier préferences installé le 17-9bre, donc, pas encore modifié.

Pancrace


Fichiers joints:
preferences.txt [172 Octets]
Téléchargé 36 fois
sources.txt [375 Octets]
Téléchargé 54 fois

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC
Haut
 Profil  
 
MessagePosté: 15 Déc 2012 16:58 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
En effet, ton fichier preferences assigne une priorité de 500 à tous les paquets étiquetés Debian, y compris la branche experimental (qui a une priorité de 1 par défaut).
Il faut simplement que tu supprimes les lignes concernant Debian, la priorité de 500 étant de toutes façons celle par défaut de tout dépôt non-déclaré (sauf experimental et quelques exceptions).

Mais si tu as déjà fait les mises-à-jour, une partie de ton système a migré en experimental !
Tu peux te vanter d'avoir le système avec les versions de paquets les plus récentes de tous les utilisateurs du forum… :mrgreen: Et surtout les plus instables !

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
MessagePosté: 16 Déc 2012 08:27 
Hors ligne
Nouvel utilisateur

Inscription: 06 Oct 2011 10:21
Messages: 23
Localisation: Manche 50
vv222 a écrit:
Tu peux te vanter d'avoir le système avec les versions de paquets les plus récentes de tous les utilisateurs du forum… :mrgreen: Et surtout les plus instables !


Bonne mauvaise nouvelle pour ce dimanche matin . Je croise virtuellement les doigts pour que ne se manifeste pas l'instabilité "expérimentale".

J'arrête là. :006

Pancrace

_________________
celui qui ne sait rien, en sait toujours autant que celui qui n'en sait pas plus.
Pierre DAC


Haut
 Profil  
 
MessagePosté: 16 Déc 2012 15:08 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 27 Mar 2009 16:47
Messages: 2671
Localisation: Bretagne (Rennes)
Le processus est réversible !

Commence par utiliser ce fichier preferences :
Code:
Package: *
Pin: release o=linuxmint
Pin-Priority: 1002

Package: *
Pin: release o=Debian,a=experimental
Pin-Priority: 1

Package: *
Pin: release o=Debian
Pin-Priority: 1001


Puis mets à jour ton système de façon classique :
Code:
apt-get update
apt-get upgrade
apt-get dist-upgrade


Remets en place un preferences adapté à ton système (il s'agit bien ici d'un fichier preferences complet) :
Code:
Package: *
Pin: release o=linuxmint
Pin-Priority: 700


Et maintenant tu peux sans risque réinstaller des paquets depuis experimental !
(en commençant par ta libc6 qui est revenue à sa version linuxmint)

_________________
À chacun selon ses besoins,
de chacun selon ses capacités.


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 18 messages ] 

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.665s | 17 Queries | GZIP : Off ]