# Affichage retour commande ipv6

**URL:** <https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672>\
**Category:** Support Debian\
**Tags:** trixie\
**Created:** [Octobre 24, 2025, 4:18 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672 "2025-10-24T04:18:51Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 24, 2025, 4:18 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/1 "2025-10-24T04:18:51Z")

</div>

Je viens d’installer [Debian](https://www.debian.org) 13 ;

Je voulais configurer un réseau IPv6 ULA/SLA/GUA pour ma nouvelle machine avec des LinuX Containers avec des services etc.. (la suite)

Pour configurer la machine sur ce réseau : [🔑 How to configure strongSwan v6 Post-Quantum Cryptography NIST compliant #2731](https://github.com/strongswan/strongswan/discussions/2731) comme exemple.

> _Si vous voulez participer en ajoutant votre configuration de «&nbsp;serveurs de dev&nbsp;» et vos «&nbsp;meilleurs&nbsp;» applications et vos appréciations ; cela serait très intéressant._

Je prendrait seulement les meilleurs idées et les meilleurs configurations d’applications que vous nous proposerez sur la communauté ; pour les installer aussi 😉

Pour le clin d’œil, ce n’est pas un **[Linux From Scratch](https://fr.wikipedia.org/wiki/Linux_From_Scratch)** (_Linux à partir de rien_ , souvent abrégé en **LFS** ) mais bon ; pour faire, me faire un debugging sur les commandes que j’utilise.

* * *

Donc et ; Par contre le retour de la commande «&nbsp;`ip -6 route show`&nbsp;» c’est abusé !

 ![Capture d'écran 2025-10-24 060814](https://www.debian-fr.org/uploads/default/original/2X/4/437a790a136d2b14e9395adeb94db56dc673e13e.png)  
Cf : [PuTTY](https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html) - Release 0.83

Comment puis-je changer la couleur des adresses IPv6 comme celle des IPv4 ?

Parce que là c’est abusé ; on ne voit rien.

Déjà que les utilisateurs ont du mal avec l’IPv6 mais là ; c’est vraiment flippant - çà donne pas envie.

Sinon, j’avoue c’est une bonne idée ; Bel affichage de la commande «&nbsp;`ip route -4`&nbsp;»

[https://unix.stackexchange.com/questions/391607/pretty-display-of-ip-route](https://unix.stackexchange.com/questions/391607/pretty-display-of-ip-route)

```auto
alias ip='ip -c=never'

```

* * *

Sinon,

Infos du serveur «&nbsp;`hst-fr`&nbsp;» → [ip-config-20251024](http://147.79.115.130/infos/ip-config-20251024.txt)

«&nbsp;`hst-fr`&nbsp;» → [iperf3-20251024](http://147.79.115.130/infos/iperf3-20251024.txt)

@+

Moi, je commence une installation.

```auto
apt install iptables iputils-ping dnsutils net-tools whois ipv6toolkit thc-ipv6 ipv6pref iptraf-ng iperf3 tcpdump nmap

```

* * *

[🇫🇷🇨🇦 Vous êtes sympat dans Debian ; mais là c’est de trop!](https://www.debian-fr.org/t/vous-etes-sympat-dans-debian-mais-la-c-est-de-trop/91672)  
[🇬🇧 🇦🇺 You’re being nice in Debian; but this is too much!](https://www.debian-fr.org/t/youre-being-nice-in-debian-but-this-is-too-much/91672)  
[🇪🇸 Eres agradable en Debian; ¡pero esto es demasiado!](https://www.debian-fr.org/t/eres-agradable-en-debian-pero-esto-es-demasiado/91672)  
[🇩🇪 Du bist nett in Debian, aber das ist zu viel!](https://www.debian-fr.org/t/du-bist-nett-in-debian-aber-das-ist-zu-viel/91672)

Romain.

---

<div class="post-metadata">

**Author:** ![artlog](https://www.debian-fr.org/user_avatar/www.debian-fr.org/artlog/32/15049_2.png) [@artlog](https://www.debian-fr.org/u/artlog)\
**Post date:** [Octobre 24, 2025, 7:12 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/2 "2025-10-24T07:12:49Z")

</div>

Bonjour @anon36725218

ici le problème vient donc de l’affichage en dark blue au lieu de violet ou d’une couleur plus visible sur un fond sombre

La vérité est dans le code, remontons à la source.

`apt info iproute2 | grep Homepage`

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Homepage: [networking:iproute2 [Wiki]](https://wiki.linuxfoundation.org/networking/iproute2)

Sur cette page le contact du mainteneur Stephen Hemminger est fourni, il est m^eme possible de le contacter directement.

mais je préfère voir le code …

git clone git://git.kernel.org/pub/scm/network/iproute2/iproute2.git

cd iproute2

et par exemple regarder ce qui a été fait autours des couleurs :

git log --grep color

Le sujet est intéressant car la correspondance entre le code qui défini les champs colorés et celui qui défini les couleurs est indirect.  
Les champs colorés sont dans include/color.h et leur couleur respective dans lib/color.c  
COLOR\_INET et COLOR\_INET6 sont différents et donc les adresses ipv4 et les adresses ipv6 ont des couleurs différentes dépendant du fond ( dark ou light ) C\_MAGENTA, C\_BLUE ; C\_BOLD\_MAGENTA C\_BOLD\_LIGHT\_BLUE

pour le dark blue il y a eu un commit

```
commit 46a4659313c2610427a088d8f03b731819f2b87a
Author: Ben Hutchings <benh@debian.org>
Date: Wed Mar 26 15:08:56 2025 +0100

    color: Do not use dark blue in dark-background palette

```

en 6.15 qui doit être déjà dans la derniere trixie

```
dpkg -l | grep iproute2
ii iproute2 6.15.0-1 amd64 networking and traffic control tools

```

Pour aujourd’hui ce sera tout pour mon activité de support bénévole…

A+

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 24, 2025, 2:44 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/3 "2025-10-24T14:44:27Z")

</div>

Génial ton explication @artlog !

Grand merci.

Par contre les développeurs n’ont pas du lire :

```auto
color: Do not use dark blue in dark-background palette

```

Cette couleur de «&nbsp;blue&nbsp;» est jolie :

 ![Capture d'écran 2025-10-24 163412](https://www.debian-fr.org/uploads/default/original/2X/9/901b7385c2edfaea8805b6342c71db48a70a67f9.png)

Sinon ; une critique sur la commande «&nbsp;`networkctl status`&nbsp;» il manque la «&nbsp;length&nbsp;» sur les adresses.

* * *

J’ai la version «&nbsp;Version: 6.15.0-1&nbsp;», oui.

```auto
root@hst-fr:~ # apt show iproute2
Package: iproute2
Version: 6.15.0-1

```

> [@artlog](#):
>
> il est m^eme possible de le contacter directement.

Et, oui pas bête je vais contacter toutes les teams et développeurs Open Source ; c’est une superbe idée. Je n’ose pas.

> [@artlog](#):
>
> mais je préfère voir le code …

😃

J’ai appelé [@gospo](https://github.com/gospo) 😇 😉 à l’instant, après avoir lu ton commentaire, sur [GitHub](https://github.com) ; merci.

> [@artlog](#):
>
> Pour aujourd’hui ce sera tout pour mon activite de support bénévole…
> 
> A+

Ciao. Merci.

* * *

Infos du serveur « `hst-fr` » → [infos](http://147.79.115.130/infos/)

Dans ce répertoire [/infos/](http://147.79.115.130/infos/), donc :

Je crée un fichier :

```auto
root@hst-fr:/var/www/html # vim infos/ip-config-20251024.txt

```

je l’édite et je le modifie plusieurs fois dans la journée :

```auto
root@hst-fr:/var/www/html # stat infos/ip-config-20251024.txt
  File: infos/ip-config-20251024.txt
  Size: 12200 Blocks: 24 IO Block: 4096 regular file
Device: 8,1 Inode: 282906 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2025-10-24 19:10:08.122209777 +0200
Modify: 2025-10-24 19:10:08.122209777 +0200
Change: 2025-10-24 19:10:08.122209777 +0200
 Birth: 2025-10-24 19:10:08.122209777 +0200

```

At 20h21 Timezone Europe/Paris

```auto
root@hst-fr:/var/www/html # stat infos/ip-config-20251024.txt
  File: infos/ip-config-20251024.txt
  Size: 12198 Blocks: 24 IO Block: 4096 regular file
Device: 8,1 Inode: 282904 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2025-10-24 20:21:38.633555724 +0200
Modify: 2025-10-24 20:21:38.633555724 +0200
Change: 2025-10-24 20:21:38.633555724 +0200
 Birth: 2025-10-24 20:21:38.633555724 +0200

```

Et puis je crée celui-ci :

```auto
root@hst-fr:/var/www/html # vim infos/ip-test-20251024.txt

```

Et je ne le réédite pas :

```auto
root@hst-fr:/var/www/html # stat infos/ip-test-20251024.txt
  File: infos/ip-test-20251024.txt
  Size: 0 Blocks: 0 IO Block: 4096 regular empty file
Device: 8,1 Inode: 282905 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2025-10-24 19:11:25.885403805 +0200
Modify: 2025-10-24 19:11:25.885403805 +0200
Change: 2025-10-24 19:11:25.885403805 +0200
 Birth: 2025-10-24 19:11:25.885403805 +0200

```

Pour l’instant…

 ![Capture d'écran 2025-10-24 201648](https://www.debian-fr.org/uploads/default/original/2X/f/fbe7c26651c1a10f58cd9b778a57ee8777966bd8.png)

Cf : sur le répertoire Web.

* * *

La commande «&nbsp;`stat`&nbsp;» est bugguée ou non, mais je cherche une commande pour pouvoir trouver la date de création.

* * *

### Installation du Web Server Apache2

```auto
root@hst-fr:~ # apt install apache2

root@hst-fr:~ # cd /var/www/html/

```

#### Fichier «&nbsp;`.well-known/security.txt`&nbsp;»

```auto
root@hst-fr:/var/www/html # mkdir .well-known/

root@hst-fr:/var/www/html # vim .well-known/security.txt

# Our security address
Contact: mailto:security@ipv10.net
Expires: 2033-12-12T00:00:00z
Preferred-Languages: fr, en

```

Un minimum…

* * *

Je configure les IPs sur un nom pour la machine dans mon DNS :

```auto
; IDN : ◕‿◕.st

$ORIGIN xn--hwgz2tba.st.

; Hostinger

hst.fr 3600 IN A 147.79.115.130
hst.xn--j77hya 3600 IN A 147.79.115.130

hst.fr 3600 IN AAAA 2a02:4780:28:5295::1
hst.xn--j77hya 3600 IN AAAA 2a02:4780:28:5295::1

```

Pour le drapeau, l’Emoji dans le DNS il faut écrire en [PunyCode](https://www.punycoder.com/).

Mon Kernel-based Virtual Machine [Hostinger](https://www.hostinger.com/) (France Paris) :

```auto
root@hst:~ # host hst.🇫🇷.◕‿◕.st
hst.xn--j77hya.xn--hwgz2tba.st has address 147.79.115.130
hst.xn--j77hya.xn--hwgz2tba.st has IPv6 address 2a02:4780:28:5295::1

```

Et sur l’interface d’admin de mon hébergeur pour le rDNS des IPv4 et IPv6 ; et le nom d’hôte.

Je ne sais pas combien d’adresses `IPv6::/128` GUA (Global-Unicast Addresses) je dispose (je crois qu’une seule, ce qui semble improbable).

Je vois que sur le KVM dans leur configuration network IPv6 par default le block GUA `IPv6::/48` mais j’ai une IPv6 de type GUA `IPv6::/64`.

À voir ; faire des tests ; pour l’instant çà m’a l’air mort ; 1 seule IPv6 GUA (Global-Unicast Address) sur le KVM [Hostinger](https://www.hostinger.com/).

* * *

### On doit installer «&nbsp;Incus&nbsp;»

Qui m’a l’air d’être un outil offrant une approche unifiée pour gérer ces environnements de manière efficace pour pouvoir gérer des **conteneurs** et des **machines virtuelles**.

Une documentation «&nbsp;[Incus, un moteur de conteneurs et de VM par Stéphane Robert](https://blog.stephane-robert.info/docs/conteneurs/moteurs-conteneurs/incus/)&nbsp;»

### Installation de LinuX Containers (LXC)

Une documentation «&nbsp;[Le moteur de conteneurs LXC par Stéphane Robert](https://blog.stephane-robert.info/docs/conteneurs/moteurs-conteneurs/lxc/)&nbsp;»

```auto
root@hst-fr:~ # apt install apt install debootstrap lxc lxc-templates busybox wget bridge-utils

```

```auto
root@hst-fr:~ # ip -6 address add fc00:4780:28:5295::1/64 dev lxcbr0

```

J’installe le premier container «&nbsp;`dc1`&nbsp;» (pour [Samba](https://fr.wikipedia.org/wiki/Samba_(informatique)) : Domain\_Controller\_1).

```auto
root@hst-fr:~ # lxc-create -n dc1 -t debian -- -r trixie -a amd64

```

```auto
root@hst-fr:~ # lxc-start dc1

```

```auto
root@hst-fr:~ # lxc-attach dc1

```

…

---

<div class="post-metadata">

**Author:** ![PengouinPdt](https://www.debian-fr.org/user_avatar/www.debian-fr.org/pengouinpdt/32/3978_2.png) [@PengouinPdt](https://www.debian-fr.org/u/PengouinPdt)\
**Post date:** [Octobre 25, 2025, 10:46 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/4 "2025-10-25T10:46:03Z")

</div>

> [@anon36725218](#):
>
> `color: Do not use dark blue in dark-background palette`

Sous Sid, nous avons la version 6.17.0-1.

```auto
$ apt show iproute2
Package: iproute2
Version: 6.17.0-1
(…)

```

Cela donne ça :

 ![Capture d’écran du 2025-10-25 12-42-14](https://www.debian-fr.org/uploads/default/original/2X/0/0f819fd7422382b6073c437de9cbecf1811cbd71.png)

C’est un peu mieux… mais ce n’est pas encore ça. Pas assez visible (pour moi, vu ma déficience visuelle). 😛

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 25, 2025, 1:47 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/5 "2025-10-25T13:47:48Z")

</div>

> [@PengouinPdt](#):
>
> Cela donne ça :
> 
> ![Capture d’écran du 2025-10-25 12-42-14](https://www.debian-fr.org/uploads/default/original/2X/0/0f819fd7422382b6073c437de9cbecf1811cbd71.png)
> 
> C’est un peu mieux…

Ouais, c’est vrai, c’est ce que je pensais, c’est jolie - Ils doivent entendre des voix tous… ces développeurs.

Merci à elles et eux…

Mais, encore si le retour serait de la commande «&nbsp;`ip address`&nbsp;» ; je comprendrait mais là les 2 couleurs différentes sur «&nbsp;`ip route`&nbsp;», je ne comprend plus.

C’est le même dev ?!

🤣

> [@anon36725218](#):
>
> Cette couleur de « blue » est jolie :
> 
> ![Capture d'écran 2025-10-24 163412](https://www.debian-fr.org/uploads/default/original/2X/9/901b7385c2edfaea8805b6342c71db48a70a67f9.png)

@PengouinPdt ok, merci ; et de quand date-t’elle la _Version: 6.17.0-1_ d’`iproute2`.

Je plaisante..

C’est quoi ce titre, mince… @Clochette ; j’avais 20 bugs à remonter… Pourri ce titre !

▼ Affichage retour qui bug…

Non mais, parce que je n’ai pas envie de créer 20 sujets.

- Affichage retour commande «&nbsp;`networkctl`&nbsp;» – déjà la commande ipv6 n’existe pas les gars.
- Affichage retour commande «&nbsp;`traceroute6`&nbsp;» ;
- Affichage retour commande «&nbsp;`host`&nbsp;» ;
- Demande et Affichage retour commande «&nbsp;`ping`&nbsp;» ;
- Affichage commande «&nbsp;`tcpdump`&nbsp;»…
- Affichage **bug sur les «&nbsp;emojis&nbsp;» sur le forum** …

Cà va faire débile dans le forum.

Je suis repassé en mode Kss_BonBon ou Kss_Couilles Kss\*Perle, Olive… comme tu veut 😉

Tu ne m’avez pas reconnu depuis le temps ; Moi c’est Kss\*OS ; bonjour au gens opérationnels du système, des business, des réseaux et de la communication humaine.

OS : comme Operating Sytem !

Et,

IDNA : A comme dans ton Application ; toi le développeur de la dite application.

Aidez-moi, s’il te plaît.

* * *

Et c’est quoi `sid` ? je ne connais pas (je plaisante)… ou est-ce ?! Moi, j’ai fais que installer la dernière version officielle de Debian, Debian 13 😃

😛 🤩

PS : Inquiétez-vous ; je fais pareil sur le forum de Windows ; Windows 11, Hub de Commentaires…

@+

🚀 Operations Sytem Solar !!!

> PS : Je vais re-changer le titre mais par contre cette fois ce sera «&nbsp;Debian-FR&nbsp;» à la place de «&nbsp;Debian&nbsp;» - çà référence quand même pas de problème 😉

---

<div class="post-metadata">

**Author:** ![Clochette](https://www.debian-fr.org/user_avatar/www.debian-fr.org/clochette/32/8757_2.png) [@Clochette](https://www.debian-fr.org/u/Clochette)\
**Post date:** [Octobre 25, 2025, 4:09 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/7 "2025-10-25T16:09:07Z")

</div>

> [@anon36725218](#):
>
> Comment puis-je changer la couleur des adresses IPv6 comme celle des IPv4 ?

le fichier lu pour la coloration est :

```auto
/etc/iproute2/color.conf

```

A la limite créer toi un fichier dans ton /home et gère ensuite la coloration dans ton bashrc :

```auto
~/.config/iproute2/color.conf

```

Pour ajouter l’alias dans ton bashrc :

```auto
echo "alias ip='ip -c'" >> ~/.bashrc
source ~/.bashrc

```

Franchement configurer le prompt de ces machines c’est tout de même une chose simple à gérer 😉

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 25, 2025, 4:10 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/8 "2025-10-25T16:10:51Z")

</div>

Merci @Clochette

> [@Clochette](#):
>
> Franchement configurer le prompt de ces machines c’est tout de même une chose simple à gérer 😉

J’avoue n’avoir jamais configuré de prompt de ma Vie !

> [@Internationalized Domain Name - Comment puis-je configurer mon système Linux pour qu’il s’adapte à la norme IDNA?](https://www.debian-fr.org/t/internationalized-domain-name-comment-puis-je-configurer-mon-systeme-linux-pour-qu-il-s-adapte-a-la-norme-idna/91572/5):
>
> Si tu arrives à me faire clignoter ⛔- je t’aimemerai jusqu’à ma mort ; même si c’n’était pas sur mon coeur ❤ pour me le faire battre. Je t’aimerais toute ma vie.

Ici, je cherche à faire clignoter le «&nbsp;coeur&nbsp;» ou le «&nbsp;no entry&nbsp;» dans mes logs (encore faut-il que les retours des commandes m’affichent les «&nbsp;emojis&nbsp;» à la place du code Punny.

Tu, vous ne sauriez-pas comment-faire @Clochette ?

Moi, non.

🤪

Clignoter comme le … truc à l’endroit où j’écris.

---

<div class="post-metadata">

**Author:** ![Clochette](https://www.debian-fr.org/user_avatar/www.debian-fr.org/clochette/32/8757_2.png) [@Clochette](https://www.debian-fr.org/u/Clochette)\
**Post date:** [Octobre 25, 2025, 4:25 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/9 "2025-10-25T16:25:27Z")

</div>

mes prompt sont des prompts pro (partager dans la boîte) qu’on utilise en entreprise … pas de clignotement et pas d’emojis … on bosse on n’a pas le temps pour les distractions et on va au plus simple et le plus direct.

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 25, 2025, 5:16 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/10 "2025-10-25T17:16:26Z")

</div>

Au plus simple comme en Unicode ?

Mon nouveau serveur «&nbsp;[hoooost.fr](http://hoooost.fr)&nbsp;» nom de domaine :

> hst.%F0%9F%87%AB%F0%9F%87%B7.%E2%97%95%E2%80%BF%E2%97%95.st

😉

▼ Sinon…

```auto
$ dig -x 2a02:4780:28:5295::1 @dns.google +short
hst.🇫🇷.◕‿◕.st.

```

```auto
$ dig -x 147.79.115.130 @dns.google +short +noidnout
hst.xn--j77hya.xn--hwgz2tba.st.

```

Est-ce assez pro @Clochette ; pour tes clients ?

🤑

Du Street Art l’eXtension de domaine ( ◕‿◕)

😝

il faut que je me créais un mail «&nbsp;xn–wq8h@&nbsp;»

Pour mes contacts pour «&nbsp;`.well-known/security.txt`&nbsp;» en plus du contact des «&nbsp;DNS SOA (hostmaster)&nbsp;».

```auto
$ dig SOA ◕‿◕.st @dns.google +short
ns1.ip❤10.ws. 👮.ip❤10.ws. 2025102502 300 60 420 60

```

En tout cas, çà fait classe, moi j’aime beaucoup.

😉

Pour ajouter mon professionnalisme et ma bonne attitude.

```auto
$ dig AAAA ns1.ip❤10.ws @dns.google +short
2607:5300:60:9389:15:1:a:1000

```

```auto
$ dig -x 2607:5300:60:9389:15:1:a:1000 @dns.google +short
⛅.🇨🇦.ip❤10.ws.

```

ou host «&nbsp;ns1.ca.ip​❤10.ws&nbsp;» ou «&nbsp;[ns1.ca.ipv10.net](http://ns1.ca.ipv10.net)&nbsp;» ou «&nbsp;[ns1.🇨🇦.ipv10.net](http://ns1.xn--e77hd.ipv10.net)&nbsp;» ou «&nbsp;[⛅.🇨🇦.ipv10.net](http://xn--68h.xn--e77hd.ipv10.net)&nbsp;» 😉

🤠

Bientôt en verra çà dans nos barres d’adresses des navigateurs Web !

- [https://fr.domain.tld/dossier/pageweb](https://fr.domain.tld/dossier/pageweb)
- https:// 🇫🇷.domain.tld/dossier/pageweb
- https:// 🇬🇧.domain.tld/folder/webpage

Pour le moment on voit dans nos navigateurs ( **je ne sais pas trop ce qu’ils attendent** , c’est assez vieux le [PunyCode](https://www.punycoder.com/)) :

- https:// xn–j77hya.domain.tld/dossier/pageweb
- https:// xn–f77hja.domain.tld/folder/webpage

D’où l’intérêt de mettre normalement.

* * *

C’est assez vieux le PunyCode 😉

- [RFC 3492: Punycode: A Bootstring encoding of Unicode for Internationalized…](https://datatracker.ietf.org/doc/html/rfc3492) (March 2003)
- [RFC 5280: Internet X.509 Public Key Infrastructure Certificate and…](https://datatracker.ietf.org/doc/html/rfc5280) (May 2008)
- [RFC 5890: Internationalized Domain Names for Applications (IDNA): Definitions…](https://datatracker.ietf.org/doc/html/rfc5890) (August 2010)
- [RFC 5891: Internationalized Domain Names in Applications (IDNA): Protocol](https://datatracker.ietf.org/doc/html/rfc5891) (August 2010)
- [RFC 8399: Internationalization Updates to RFC 5280](https://datatracker.ietf.org/doc/html/rfc8399) (May 2018)
- [RFC 9549: Internationalization Updates to RFC 5280](https://datatracker.ietf.org/doc/html/rfc9549) (March 2024)

@+

* * *

Bon, je dois installer « [Incus](https://linuxcontainers.org/fr/incus/introduction/) » … j’n’ai jamais fais çà moi ; avant mes bons travailleurs ; mes dockers.

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Octobre 25, 2025, 10:07 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/13 "2025-10-25T22:07:26Z")

</div>

oui, et les retours de commandes - ok

---

<div class="post-metadata">

**Author:** ![PengouinPdt](https://www.debian-fr.org/user_avatar/www.debian-fr.org/pengouinpdt/32/3978_2.png) [@PengouinPdt](https://www.debian-fr.org/u/PengouinPdt)\
**Post date:** [Octobre 26, 2025, 9:08 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/20 "2025-10-26T09:08:04Z")

</div>

Salut @Clochette .

Déjà merci pour ce retour.  
Sur Sid, sur ma station, iproute2 est bien installé :

```auto
$ apt policy iproute2
iproute2:
  Installé : 6.17.0-1
(…)

```

Par contre, il semble que je n’ai pas de fichier `color.conf` !  
Une idée ?

* * *

Par contre le manpage indique [ceci](https://manpages.debian.org/unstable/manpages-fr/ip.8.fr.html#c) et [ceci](https://manpages.debian.org/unstable/manpages-fr/ip.8.fr.html#COLORFGBG) :

> [**-c** [ **color**][**=** { **always** | **auto** | **never** }](https://manpages.debian.org/unstable/manpages-fr/ip.8.fr.html#c)
> 
> Configurer la couleur en sortie. Si le paramètre est omis ou si **always** est présent, la sortie en couleur est activée quel que soit l’état de stdout. Si le paramètre est **auto** , il est vérifié que stdout est un terminal avant d’activer la sortie en couleur. Si le paramètre est **never** , la sortie en couleur est désactivée. Si ce paramètre est indiqué plusieurs fois, le dernier prend la priorité. Ce drapeau est ignoré si **-json** est aussi donné.
> 
> La palette de couleurs utilisée peut être influencée par la variable d’environnement **COLORFGBG** (voir **ENVIRONNEMENT** ).

* * *

> [_COLORFGBG_](https://manpages.debian.org/unstable/manpages-fr/ip.8.fr.html#COLORFGBG)
> 
> Si cette variable est définie, sa valeur est utilisée pour détecter si le fond d’écran est sombre ou clair et utiliser des couleurs de contraste appropriées.
> 
> La variable d’environnement _COLORFGBG_ contient habituellement deux ou trois valeurs séparées par des points-virgules ; la dernière de ces valeurs est nécessaire dans chaque cas. Si cette valeur est 0-6 ou 8, choisir des couleurs adaptées à un fond foncé :
> 
> COLORFGBG=«&nbsp;;0&nbsp;» ip -c a

* * *

Je v aller tester - ce qui ne donne aucun changement \*à moins que je n’ai pas compris comment la configurer correctement !

 ![Capture d’écran du 2025-10-26 10-22-13](https://www.debian-fr.org/uploads/default/original/2X/8/8af95908bb7904fb35e2d50e9ba672477d54c647.png)

---

<div class="post-metadata">

**Author:** ![Clochette](https://www.debian-fr.org/user_avatar/www.debian-fr.org/clochette/32/8757_2.png) [@Clochette](https://www.debian-fr.org/u/Clochette)\
**Post date:** [Octobre 26, 2025, 9:52 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/21 "2025-10-26T09:52:17Z")

</div>

Petit rappel, on reste concentré sur les fils de discussion, pas de hors sujet (et on évite les sujets glissants/sensibles) … merci.

> [@PengouinPdt](#):
>
> Par contre, il semble que je n’ai pas de fichier `color.conf` !

Rhalala je pensais que la commande ip avait cette mécanique mais même pas 😕

Du coup un wrapper pour utiliser [grc](https://github.com/garabik/grc) et les fichiers à créer pour les commandes que tu souhaite wrapper avec … genre un truc comme ça à compléter et modifier selon ton besoin.

```auto
regexp=.*\b([0-9]{1,3}\.){3}[0-9]{1,3}\b.*
colours=cyan
count=once

# --- Adresses IPv6
regexp=.*[0-9a-fA-F:]{2,}\/?[0-9]*.*
colours=bright_cyan
count=once

# --- Routes par défaut
regexp=default
colours=bright_green
count=once

# --- Mot-clé via
regexp=\bvia\b
colours=bright_blue
count=once

# --- Mot-clé dev (interface)
regexp=\bdev\b
colours=bright_yellow
count=once

# --- Interface (nom du device)
regexp=\b(e[nmopslx]\w*|lo)\b
colours=magenta
count=once

```

---

<div class="post-metadata">

**Author:** ![PengouinPdt](https://www.debian-fr.org/user_avatar/www.debian-fr.org/pengouinpdt/32/3978_2.png) [@PengouinPdt](https://www.debian-fr.org/u/PengouinPdt)\
**Post date:** [Octobre 26, 2025, 10:11 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/22 "2025-10-26T10:11:03Z")

</div>

Merci pour la trouvaille.

Néanmoins, concernant les couleurs que tu indiques, les **bright\_** \* : es-tu sûr ?  
Parce que de ce que je lis concernant les couleurs :

> Colours are one of:

```auto
none, default, bold, underline, blink, reverse, concealed,
black, green, yellow, blue, magenta, cyan, white,
on_black, on_green, on_yellow, on_blue, on_magenta, on_cyan, on_white
beep

```

> `on_red` means that the background (instead of foreground) is painted with red etc…
> 
> Additional colours can be: `dark, italic, rapidblink, strikethrough` . These are supported only on some terminals, so if you want to write portable configuration files, avoid uing them (idea by James Rowe).
> 
> there can be more attributes per line (separated by space), e.g.

```auto
# this is probably a pathname
regexp=/[\w/\.]+
colours=bold blink green
count=more

```

> will display pathnames in bold blinking green

De fait je ne lis aucune mention de couleurs commençant par **blink\_** \*. Quid ?

---

<div class="post-metadata">

**Author:** ![Clochette](https://www.debian-fr.org/user_avatar/www.debian-fr.org/clochette/32/8757_2.png) [@Clochette](https://www.debian-fr.org/u/Clochette)\
**Post date:** [Octobre 26, 2025, 10:27 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/23 "2025-10-26T10:27:19Z")

</div>

> [@PengouinPdt](#):
>
> Néanmoins, concernant les couleurs que tu indiques, les **bright\_** \* : es-tu sûr ?

Non, d’ailleurs j’ai pas regardé d’exemple tu peux adapter avec les couleurs les plus appropriées.

---

<div class="post-metadata">

**Author:** ![anon36725218](https://www.debian-fr.org/letter_avatar_proxy/v4/letter/a/8e8cbc/32.png) [@anon36725218](https://www.debian-fr.org/u/anon36725218)\
**Post date:** [Janvier 4, 2026, 7:38 UTC](https://www.debian-fr.org/t/affichage-retour-commande-ipv6/91672/24 "2026-01-04T19:38:08Z")

</div>

Merci @Clochette, j’ai installé le wrapper «&nbsp;`grc`&nbsp;» ce mois dernier, décembre 😉 dans «&nbsp; **trixie** &nbsp;» ; sur le SID «&nbsp; **forky** &nbsp;» les couleurs c’est mieux sur «&nbsp;`ip -6`&nbsp;»

Sinon salut tout le monde, donc ; RienÀVoir… pour plaisanter sur les configurations perso..

Mon «&nbsp;`config.cfg`&nbsp;» de «&nbsp;[Counter-Strike](https://www.counter-strike.net/)&nbsp;» c’est celui-ci : [https://howto.zw3b.fr/pub/config\_kss-counter-strike-czero.cfg](https://howto.zw3b.fr/pub/config_kss-counter-strike-czero.cfg)

 ![counter-strike-straf-config](https://www.debian-fr.org/uploads/default/original/2X/1/18407ca2fd2037fa3af523a05112a2c4d757f1fb.jpeg)

> **Pour expliquer, la pose de mes doigts... c'est taKtile**
>
> j’ajoute (c’est moins fatiguant pour les doigts) _straf left (anulaire) - straf right (majeur) - reculer (petit doigt) - POINT (s’accroupir) - SHIFT (sauter) - CTRL (recharger ou zoomer ^^)_ ; un truc comme çà – _souris clic gauche (tirer) ; souris clic droit (avancer) - molette.._

Et, sinon :

Alors ; nous avez-vous fait de jolis «&nbsp;`color.conf`&nbsp;» pour différentes applications / systèmes ? Pouvons-nous les voir ?

Ma variable d’environnement «&nbsp;`PS1`&nbsp;» est celle-ci – pour un «&nbsp;container (ww2)&nbsp;» ; dans une "VM (host2) " ; sur une "Unité Centrale (srv-fr) " :

```auto
export PS1="\e[38;5;153m\d \t \033[38;0;32m⛔\033[00m🔜 \[\e[32;1m\]\u\e[0m@\[\e[31;1m\]srv-fr\033[38;5;32m.h2\e[38;5;172m.\h\e[38;5;153m:\[\e[34;1m\]\w\[\e[37;1m\] \e[38;5;172m# \[\e[0m\]"

```

Que je vois comme çà :

![Capture d'écran 2026-01-04 203510](https://www.debian-fr.org/uploads/default/original/2X/e/e679d3e555bd80046ba3efd88415908c564aeb85.png)

Je n’ai pas encore essayé de faire clignoter et/ou de changer la couleur les icones «&nbsp;emojis&nbsp;» selon les performances du «&nbsp;pc&nbsp;» toutes les minutes et/ou instantanément ¿comment-faire?

@+

Bonne année tout le monde !

[The Funk Chronicles: Street Soul & Hip-Hop Heat | 70s Funk Mix with Hip-Hop Vibes](https://www.youtube.com/watch?v=OoBM-SIIR7g) on channel youtube DEEP POCKET GROOVE.

* * *

Hors Sujet (punyCode) DNS PTR IDN(A) - malgré mon commentaire sur cette page :

> [@anon36725218](#):
>
> ```auto
> $ dig SOA ◕‿◕.st @dns.google +short
> ns1.ip❤10.ws. 👮.ip❤10.ws. 2025102502 300 60 420 60
> 
> ```
> 
> En tout cas, çà fait classe, moi j’aime beaucoup.

Sur les «&nbsp;`.FR`&nbsp;» ; «&nbsp;`.TV`&nbsp;» ; «&nbsp;`.EU`&nbsp;» ; «&nbsp;`.NET`&nbsp;» ; «&nbsp;`.COM`&nbsp;» ; «&nbsp;`.BLOG`&nbsp;» ; «&nbsp;`.APP`&nbsp;» ; «&nbsp;`.ST`&nbsp;» ; «&nbsp;`.WS`&nbsp;» ; «&nbsp;`.EARTH`&nbsp;» çà fonctionne – d’avoir un NS type PunyCode – en fait c’est dans le WHOIS qu’ils n’acceptent pas le PunyCode - je n’en peut plus (de moi) :

> **Résumé**
>
> La réponse du register de domain [Gandi.Net](http://Gandi.Net) (et des Autorités supérieures)
> 
> > Bonjour,  
> > Merci d’avoir patienté.
> > 
> > Il s’agit donc de limitations/restrictions spécifiques aux registres concernés, qui sont plus stricts :
> > 
> > «&nbsp;`.com / .net`&nbsp;» : voici la réponse que nous avons obtenue de la part de [Verisign](https://www.verisign.com/) :
> > 
> > > The registrant of a domain that is no longer supported by IDNA2008 should be notified that there may be unanticipated consequences for a user attempting to reach it, and such names should be replaced, held, or deleted at registry initiative.
> > 
> > «&nbsp;`.info`&nbsp;» : voici la réponse que nous avons obtenue de la part de [Identity Digital](https://identity.digital/) :
> > 
> > > The error «&nbsp;prohibited code point check failed&nbsp;» strongly suggests that the specific Unicode characters represented by the Punycode string you attempted to use for the nameserver violated the registry’s stringent rules regarding character sets.
> > > 
> > > Additionally, please be advised that the requested putative A-label is validated against normal ASCII host name rules as defined in STD3 ([RFC 1122](https://datatracker.ietf.org/doc/html/rfc1122) and [RFC 1123](https://www.rfc-editor.org/rfc/rfc1123)).
> > 
> > Malheureusement je crains donc que vous ne puissiez pas associer ces noms de domaine aux serveurs de noms mentionnés.
> > 
> > Merci de votre compréhension.
> > 
> > Cordialement,
> > 
> > Jérémie  
> > [Gandi.net](http://Gandi.net)
> 
> Et ma réponse :
> 
> > Bonjour,
> > 
> > Merci pour votre réponse.
> > 
> > Il faut vraiment que vous poussiez (cette histoire d’IDN ; d’Internationalized Domain Name in Applications), vous qui êtes «&nbsp;registart&nbsp;» ; les noms de domaine IDNA devront et doivent être acceptés. La dernière [RFC 9549: Internationalization Updates to RFC 5280](https://www.rfc-editor.org/rfc/rfc9549) qui date de mars 2024 qui est une amélioration, une mise à jour du [RFC 5280](https://datatracker.ietf.org/doc/html/rfc5280) (et qui rend obsolete la [RFC 8399](https://datatracker.ietf.org/doc/html/rfc8399)).
> > 
> > Les règles de 2008 ont changées et il faut/faudrait un jour les accepter. Je ne vous parle pas seulement des noms avec des émojis ; mes ceux avec des accents. Il y a quelques mois ; le nom de domaine [http://armées.com/](http://xn--armes-dsa.com/) ressortait son code PunyCode «&nbsp;`xn--armes-dsa.com`&nbsp;» ; et aujourd’hui on voit bien l’accent «&nbsp;le text normal&nbsp;» dans nos navigateur.
> > 
> > Il faut alerté Verisign et Identity Digital.
> > 
> > J’ai 3 noms de domaine «&nbsp;nouvelle génération&nbsp;» 😉
> > 
> > ⛔🔜.ws  
> > ip​❤10.ws
> > 
> > ◕‿◕.st
> > 
> > Bonne soirée, merci encore.
> > 
> > Cordialement,  
> > Romain.
> 
> Réponse [Gandi.Net](http://Gandi.Net)
> 
> > Bonjour,  
> > Je comprends parfaitement votre situation.  
> > Nous avons effectivement informé les registres à ce sujet, mais nous restons relativement pessimistes quant à une évolution de leur part à court terme.
> > 
> > Très bonne journée à vous.
> > 
> > Cordialement,
> > 
> > Jérémie  
> > [Gandi.net](http://Gandi.net)
> 
> Ma réponse 😉
> 
> > Bonjour,
> > 
> > C’est super, merci de les avoir informé, grandement ; Je suis conscient qu’à court terme une possible évolution serait possible.  
> > L’important est fait.
> > 
> > Merci à vous [Gandi.Net](http://Gandi.Net) et à vos équipes.
> > 
> > Cordialement,  
> > Olivier Romain Jaillet-ramey
> 
> Réponse :
> 
> > Bonjour Olivier Romain,  
> > Ravi d’avoir pu fournir l’assistance nécessaire.
> > 
> > […]
> > 
> > Cela compte énormément pour moi et nous aide à améliorer continuellement la qualité de notre service. 🌟
> > 
> > N’hésitez pas à nous recontacter si vous avez besoin d’autre chose.
> > 
> > Excellente journée à vous !
> > 
> > Cordialement,
> > 
> > Jérémie  
> > [Gandi.net](http://Gandi.net)
> 
> Nice 😃

Je lie le message à celui-ci : [Internationalized Domain Name - Comment puis-je configurer mon système Linux pour qu’il s’adapte à la norme IDNA?](https://www.debian-fr.org/t/internationalized-domain-name-comment-puis-je-configurer-mon-systeme-linux-pour-qu-il-s-adapte-a-la-norme-idna/91572)
