Bloqué sur grub rescue [résolu]

grub
boot
bios
installation
jessie
Tags: #<Tag:0x00007f0945f438a0> #<Tag:0x00007f0945f432b0> #<Tag:0x00007f0945f42e78> #<Tag:0x00007f0945f42a90> #<Tag:0x00007f0945f42680>

#1

Bonjour tout le monde,

En essayant de corriger les derniers soucis consécutifs a mon install de Jessie (librazik), j’ai changé l’ordre de boot dans le bios, et en redémarrant, je suis coincé dans grub rescue.

voici le message d’erreur :

to interrupt normal startup, press Entererror : file ‘/boot/grub/x86_64-efi/normal.mod’ not found
Entering rescue mode…
grub rescue>

infos potentiellement utiles :
J’ai un dual boot ubuntu/debian
Je découvre grub rescue , j’ai pas un gros niveau en linuxeries… ;o)

Merci de vos lumières, je crois que j’ai fait une connerie…


Problème Grub sur dual boot
#2

bon, j’ai paré a l’urgence, j’ai réussi a démarrer grâce à cette page :

J’ai fait ça :
grub rescue> set prefix=(hd0,1)/boot/grub
grub rescue> set root=(hd0,1)
grub rescue> insmod normal
grub rescue> normal

et la, ça a lancé grub.
j’ai selectionné ma debian et ça a démarré.

il reste un truc bizarroïde :
j’ai ubuntu sur ma partition sda1 et debian sur ma sda5.
Quand j’ai fait :
grub rescue> set prefix=(hd0,5)/boot/grub
grub rescue> set root=(hd0,5)
pointant donc vers la partition de debian (sda5), ça ne marchait pas, en revanche en faisant set prefix et set root sur sda1, ça marche et je peux demarrer debian dans grub.

en fouinant, je viens de trouver le fichier normal.mod sur ma partition debian dans /boot/grub/i386-pc.
est-ce qu’il aurait fallu faire : grub rescue> set prefix=(hd0,5)/boot/grub/i386-pc ?

Quelqu’un peut-il m’expliquer si c’est normal ou pas, et si non ce que je dois faire pour remédier au souci.
Merci de vos lumieres
merci d’avance
Stefan


#3

Ce n’est visiblement plus le même GRUB qui se lance.
D’après le chemin du fichier que ce GRUB recherche (x86_64-efi) il s’agit d’une variante de GRUB pour PC UEFI 64 bits installée par Ubuntu, alors que la variante installée par Debian est pour PC
BIOS (i386-pc).

Aurais-tu activé le boot UEFI ou mis le boot UEFI en priorité ?

La bizarrerie, c’est que ce GRUB EFI ne trouve pas son répertoire /boot/grub là où il le cherche. Si tu redémarres, à l’invite de grub rescue peux-tu exécuter la commande set et relever la valeur initiale des variables prefix et root ?


#4

Je ne saurais pas te dire exactement ce qui en est pour l’uefi, mais ça a été un problême pendant l’install de debian.
Je n’ai pas pu installer librazik directement, il a fallu que j’installe debian et que la modifie en librazik par la suite, j’ai été guidé pour ça par un des créateurs de librazik, via l’irc.
Je me souviens juste que secure boot est désactivé.

pour l’invite, j’ai ça :
grub rescue>set
cmdpath=(hd0,gpt2)/EFI/debian
prefix=(hd0,gpt5)/boot/grub
root=hd0,gpt5

voila
merci pour ton aide


Ecran noir lors de l'installation clé USB Debian 9
#5

Correction à mon message précédent : ce GRUB EFI a visiblement été installé par Debian et non par Ubuntu :

  • l’exécutable EFI a été lancé depuis le répertoire /EFI/debian de la partition système EFI (partition 2)
  • il recherche /boot/grub dans la partition 5 où Debian est installé.

Par contre ce doit être un reste d’une précédente installation de Debian, car il n’y a a priori pas de répertoire /boot/grub/x86_64-efi dans la partition 5 où Debian est installé.

Tu as donc eu de la chance que les fichiers du GRUB EFI d’Ubuntu soient compatibles avec ceux du GRUB EFI de Debian. Ce n’est pas toujours le cas, si les versions de GRUB sont trop différentes.

Tu peux réinstaller GRUB-EFI dans la nouvelle installation de Debian avec le paquet grub-efi-amd64 qui désinstallera grub-pc.
Ou bien tu remets l’ordre de boot comme il était avant pour que ce soit le GRUB PC BIOS installé dans le MBR du disque qui démarre en mode legacy.


#6

finalement, en remettant l’ordre de boot comme il était, ça remarche.
Par contre, si quelqu’un a la clé du mystère, je suis preneur.
Merci beaucoup


#7

Voir mon message précédent. Un GRUB peut en cacher un autre (voire deux).


#8

oups, je n’avais pas vu ton message précédent.
Du coup, maintenant que ça remarche, tu me conseille de faire quoi?
réinstaller proprement grub ou pas?
sachant qu’a terme je vais surement refaire une install clean de ubuntu

Merci en tout cas de t’être creusé les méninges pour moi


#9

Tu peux installer GRUB EFI en plus de GRUB BIOS, ainsi tu auras les deux variantes UEFI et BIOS et ça bootera dans tous les cas.

Cela forcera la désinstallation du paquet grub-pc mais son absence n’empêche pas de réinstaller GRUB BIOS manuellement car les fichiers nécessaires sont dans d’autres paquets comme grub-pc-bin (qu’il ne faut pas désinstaller si apt le propose) et grub2-common.

Si tu réinstalles Ubuntu par la suite, par défaut :

  • si tu fais l’installation avec amorçage UEFI, cela mettra le GRUB EFI d’Ubuntu en priorité dans l’ordre d’amorçage UEFI par défaut (modifiable) mais n’écrasera pas le GRUB EFI de Debian car chacun est installé dans un répertoire distinct de la partition système EFI. Cela ne touchera pas au GRUB BIOS de Debian ;
  • si tu fais l’installation avec amorçage BIOS, cela remplacera le GRUB BIOS de Debian dans le MBR du disque par celui d’Ubuntu. Cela ne touchera pas aux GRUB EFI de Debian et de l’ancienne installation d’Ubuntu.

#10

merci,
est-ce que tu penses que je pourrai re-modifier l’ordre de boot, après ça?


#11

Après quoi ?
Après l’installation de GRUB EFI par Debian ? Oui, c’est le but.
Après la réinstallation d’Ubuntu ? Oui, je suppose. Un ordre démarrera Ubuntu et l’autre Debian.


#12

avec cette combinaison c’est votre buntu qui doit être en tête de liste du menu grub ;grub est configuré par buntu et pas par debian.


#13

Merci a vous deux pour les conseils.
Désolé Pascalhambourg pour mon manque de clarté.
@anonyme2 : effectivement, c’est ubuntu qui est configuré en tête de liste de boot ( c’est pour ça que je l’ai modifié, d’ailleurs).
Je vais faire l’install de grub EFI, dès que j’aurais un peu refait des sauvegardes, comme Pascalhambourg me l’a conseillé.

merci encore
Stefan

Je passe le sujet en [résolu]