Curl php 7.3 sur Debian 10 Buster

php
libcurl
buster
curl
Tags: #<Tag:0x00007fa92cfada20> #<Tag:0x00007fa92cfad8e0> #<Tag:0x00007fa92cfad610> #<Tag:0x00007fa92cfad430>

#41

Ah ben trop tard, c’était déjà vu…


#42

Tant mieux si cela fonctionne. Mais là tu viens aussi de passer de php-fpm (un interpréteur PHP autonome et performant) à libapache2-mod-php (le module Apache pour interpréter PHP). Tu vas donc perdre en performances et peut-être aussi certains éléments de configuration.


#43

Ah mince. Du coup, je fais comment pour passer sur php-fpm ?


#44

J’ai l’impression qu ce n’est pas toi qui a installé et configuré ce serveur, non ?

Cette séquence de commandes devrait suffire :

sudo a2dismod php7.3
sudo a2enmod mpm_event
sudo apt install php-fpm
sudo apt purge libapache2-mod-php\*
sudo systemctl restart apache2

Après il faudra vérifier la configuration des hôtes virtuels apache, de PHP et des éventuels pools PHP-FPM sous /etc/php/7.3/fpm


#45

En effet. Mais je m’occupe de la maintenance. Je maitrise les bases, après j’avoue que c’est pas mon loisir préféré la conf de serveur. Je préfère coder.

Sinon dans la liste des commandes, j’ai dû rajouter :

sudo a2enmod proxy_fcgi setenvif
sudo systemctl restart apache
sudo a2enconf php7.3-fpm
sudo systemctl restart apache2

#46

Oui bien vu, j’avais oublié le fcgi :wink:
Est-ce que le module fcgid est bien installé et activé ?
Au cas où :

apt install libapache2-mod-fcgid 
a2enmod fcgid

#47

fcgid me fout le brin, l’activer me casse le serveur.

J’ai dû le désactiver.

systemctl status apache2.service
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset:
   Active: failed (Result: exit-code) since Fri 2019-11-01 06:21:07 CET; 11s ago
     Docs: https://httpd.apache.org/docs/2.4/
  Process: 1611 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILU

#48

Ah, désolé. Si ta configuration fonctionne telle quelle, je n’insiste pas :wink:
Mais ce n’est sans doute pas optimisé. La configuration doit certainement dater de plusieurs années.


#49

On a installé notre VPS en 2017.