Debug "ssh: Resource temporarily unavailable"

Tags: #<Tag:0x00007f8a4c330ff8> #<Tag:0x00007f8a4c330f08>

bonjour,

après une mise à jour de raspbian jessie vers stretch, mon raspberry semble être devenu instable.
systématiquement au bout d’une journée ou 2 je n’y ai plus accès ni en ssh ni via openvpn.
malheureusement je l’utilise comme serveur distant et il est à 1500 km. donc je ne peux pas réinstaller un système clean dans l’immédiat. je fais des hard reboot.

en ssh j’ai ce message : ssh: connect to host ***** port ***: Resource temporarily unavailable
je pense que raspbian plante de temps en temps et j’aimerais trouver l’origine du problème mais je ne sais pas comment m’y prendre.
je ne trouve rien de suspect dans syslog, mais il y a un paquet d’info !

le raspberry n’execute rien de lourd : un serveur openvpn, ssh, un client freedns, 2 ou 3 watchdogs. je l’utilise comme serveur de secours pour accéder à mon petit datacenter. mais là du coup ça perd un peu de son intérêt.

quelqu’un aurait une idée de par où commencer pour trouver l’origine du soucis ?

merci !

ton client est un windows 10 ? quand il semble crashé depuis un autre serveur Linux avec un ssh ça fonctionne pas non plus ? On dirait quand même qu’il doit gérer trop de chose et qu’il n’a plus de ressource après un moment. T’arrives a monitorer ? vite fait avec monit par exemple

mon client est ubuntu for bash for windows donc windows 10 oui, mais je pense pas que ça ait une incidence…
je testerai depuis une vm linux la prochaine fois.
je connaissais pas monit, je vais installer et configurer ça, merci !

j’ai vu un post qui traite de ce problème, il faut ouvrir le port sur windows 10 explicitement sur le firewall de win 10

si ssh crash il va te le restarter ou un autre service d’ailleurs, ca sera plus facile pour analyser sans reboot le Pi

j’ai vu un post qui traite de ce problème, il faut ouvrir le port sur windows 10 explicitement sur le firewall de win 10

moui le truc c’est que j’utilise au moins une dizaine d’autres serveurs ssh sur divers ports sans rencontrer le moindre soucis. en plus ça marche au moins quelques heures avant de “planter” et ça fait vraiment ça clairement seulement depuis la màj vers stretch.
du coup je vais plutôt explorer la piste d’un problème côté serveur avec monit.

j’ai ajouté la notif par mail via smtp relay de google vite fait et t’es prévenue par mail des qu’il pète un câble