E:dkpg a été interrompu: et comment je mets à jour alors?

Bonjour,
je suis debian débutant… merci de votre compréhension pour mon incompréhension…
je cherche à télécharger des mises à jour, mais quand j’ouvre mon gestionnaire de paquets Synaptic, j’ai l’erreur suivante: E:dkpg a été interrompu. il est nécessaire d’utiliser <<dkpg --configure -a>> pour corriger le problème.

j’ai essayé de taper dkpg --configure -a dans le terminal… ça ne ressemble pas à une commande acceptable (je ne sais pas ce qu’est une commande acceptable…)
Help! merci d’avance

Re-
je réponds moi même à ma première question: dpkg fonctionne mieux que dkpg
et voici ce que donne la commande dans le terminal…
image

là je coince… comprends pas ce que ça veut dire…
merci d’avance d’un coup de main!

1 J'aime

Je confirme : dpkg, c’est mieux ! :slightly_smiling_face:

Malheureusement, je ne pige pas la suite. Qu’est-ce qui peut bien t’arriver ?

Quelle est ta config ? uname -a ?

Salut,

Que donne en root un

apt-get check

?

merci à tous les deux
voici ce que ça donne

image

@DarkGagan : donc ça marche en fait! je n’ai pas vraiment compris, mais c’est parfait.
Merci!

1 J'aime

Normalement ça répare au mieux les dépendances cassées. Content pour toi! :wink:

C’était un problème de dépendances non-résolues, manifestement. Car les paquets dépendent les uns des autres ; ils mettent leurs fonctionnalités propres à la disposition des autres paquets, qui parfois en ont besoin pour s’installer. Or il peut arriver que l’on met à jour le paquet A et que, quelque temps plus tard, la mise à jour du paquet B cherche l’ancienne version du paquet A…

Heureusement, les outils apt proposent des solutions pour remettre sa debian d’équerre ! Ça paraît contraignant, mais en fait c’est un gage de stabilité, qui n’est pas pour rien dans l’excellente réputation de notre distribution préférée !

Par ailleurs, les commandes doivent être tapées avec exactitude ! Une commande, c’est un logiciel, qui est désigné par son nom ; et ils sont tatillons, ces logiciels, ils ne supportent pas que l’on les prenne pour un autre ! Un caractère suffit parfois à les différencier : regarde ln et ls, par exemple.

OK! merci pour ces précisions, ça pourra servir à nouveau certainement.
Premier post sur ce forum résolu en moins de 30 minutes, merci de votre accueil, je reviendrai!

1 J'aime

Non, c’était un problème d’interface chaise-clavier (PEBKAC).

  • erreur de lecture/frappe de « dpkg » devenu « dkpg », puis de « apt-get » devenu « apt -get »

  • utilisation manifeste de la commande su sans -, -l ou --login pour passer root, résultant en un environnement mal initialisé avec un $PATH incomplet.

Non, ça ne devrait pas arriver si les dépendances sont bien gérées.

salut,
tu peux préciser, s’il te plait, j’avais déjà eu des problèmes de PATH, ca pourrait venir de ça.
merci

Sans option, su ne réinitialise pas $PATH donc il manque les chemins /sbin et /usr/sbin.

2 J'aimes