Echec de mise à niveau de Jessie vers Stretch - Start and stop actions are no longer supported

mise-à-jour
synaptic
stretch
jessie
Tags: #<Tag:0x00007f0945b654b8> #<Tag:0x00007f0945b6a760> #<Tag:0x00007f0945b69450> #<Tag:0x00007f0945b6fd78>

#42

Merci, je pense que je vais devenir fou avec ce message d’Udev

root@ks29582:/# apt install linux-image-amd64/stretch
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Version choisie « 4.9+80+deb9u6 » (Debian:9.6/stable, Debian-Security:9/stable [amd64]) pour « linux-image-amd64 »
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-amd64 : Dépend: linux-image-4.9.0-8-amd64 mais ne sera pas installé
 systemd : Casse: udev (< 228-5) mais 175-7.2 devra être installé
           Recommande: libpam-systemd mais ne sera pas installé
           Recommande: dbus mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Du coup je peux même plus mettre à jour mon noyau ? lol


#43

les bidouilles dans les scripts c’est trop fort pour moi :grinning: je ne sais pas où ça va t’emmener


#44

Mais même la commande pour mettre à jour le noyau ne veut pas fonctionner :open_mouth:


#45

demande à OVH comment tu peux installer leur noyau compatible Debian Stretch


#46

Ben en fait je peux réinstaller tout mon serveur avec Debian Stretch 9.4 et le noyau à jour. Je ne peux pas mettre juste à jour le noyau depuis leur interface.

Je me demande si c’est pas mieux de faire ça car là j’ai l’impression que tout est cassé…


#47

Quel offre ?
Tu as shunté aussi le script grub spécifique pour ovh, /etc/grub.d/06_OVHkernel ?


#48

on est à Debian 9.6 https://www.debian.org/News/2018/20181110


#49

1: Kimsufi 250G de l’époque
2 :Non je n’ai pas shunté… Du coup c’est pour ça qu’il ne s’est pas mis à jour ? Il restait bloqué sur le script d’OVH au niveau du Noyau c’est ça ?


#50

Oui mais ça après je peux le mettre à jour avec un full dist-upgrade ?


#51

Finalement un gars de l’autre forum m’a trouvé un tuto pour mettre à jour le Noyau sans utiliser les paquets OVH

C’est bon j’ai mis à jour le noyau en suivant le tuto d’ovh, le serveur a bien redémarré et quand je tape uname -r il me retourne bien 4.9.142-xxxx-std-ipv6-64.

Et du coup je dois faire quoi ensuite ?


#52

JE VOUS AIME :smiley:
C’est bon !!!

J’ai fais apt-get update et j’ai refait apt --fix-broken install et tout est ok :smiley:

Les paquets se remettent à jour correctement :smiley: Merci beaucoup beaucoup beaucoup :slight_smile:


#53

comme quoi faut toujours garder à l’esprit qu’une distribution basé sur Debian qui bricole ses logiciels et Debian out of the box c’est pas idem