ERROR DRM ACPI, AFFICHAGE SACCADÉ ou TEARING intel graphics i915 (Intel Corporation HD Graphics 530) avec PC-durci nuvo 5002 (et avec un nuvo 1005)


#1

Pour le nuvo 1005 le copain est parti avec mais c’est pas plus complété, je tente de finaliser le nuvo5002 comptant produire de la vidéo dans la saison qui vient. Est innaceptable de

  • ne pas accéder au 50Hz pour l’écran comme “avant”, du coup non comptabilité avec les médias basés sur le PAL: un programme de “test” d’écran au démarrage impose ses valeurs avec plus d’autorité que les gestionnaires de fenêtres, ce qui empêche de tester d’autres résolutions.

  • ne pas pouvoir accéder à des vidéo sans tearing sur internet, sauf avec chromium (chromium, bridé en 1080pne permet pas d’accéder à une qualité suffisante pour observer la végétation, les textures…): résolu avec l’ajout de la ligne
    CLUTTER_PAINT=disable-clipped-redraws:disable-culling
    dans /etc/environment

  • pointes de consommation avec gels brefs de l’écran avec l’option “tearfree”, du coup l’affichage ne peut être fluide avec la méthode SNA.
    résolu avec l’ajout de la ligne
    CLUTTER_PAINT=disable-clipped-redraws:disable-culling
    dans /etc/environment
    Mais dans la mesure où la puissance du processeur le permet: or celle ci s’est effondrée à la mise à jour.

j’ai rétrogradé du noyau 4.9 au 4.14, ce qui supprime les ACPI et DRM error (ce qui ne change rien car la reconnaissance des paramètres de l’écran dépendent du port VGAà, mais outre le fait que ça ne change rien au fonctionnement de mon accélération matérielle (ce qui marchait marche (Vlc Mv-player, chromium fluide sans tearing et ce qui marchait pas ne marche pas: tearing dans chrome, firefox) j’ai failed to load i915/skl_dmc_ver1_27.bin (-2)
Point résolu; le paquet “misc-non-free” ne l’inclu pas, il faut le copier manuellement, mais la présence ou non de ce pilote semble pas changer grand chose (sert-il? un autre pilote prend t-il la main “par dessus”)

Pour rappel, avant un distupgrade (qui a fait la mise à jour du micro-code-intel amputant apparement la performance du processeur, chrome fonctionnait sans tearing ce qui me permettait de visualiser en qualité suffisante des paysages vu de cabines de locomotives . Depuis que chrome fait du tearing (et toutes les versions que j’avais dans le cache d’apt, alors qu’il fonctionnait avant), je ne parviens plus à accéder à ces images (pas assez de netteté en version 1080, chromium marche sans tearing mais est bridé, téléchargé (si encore c’était possible) pour regarder avec VLC n’est pas pratique pour quelques minutes de vidéos dont le total fait 15Go…

apt remove firmware-misc-nonfree
rien changé

apt-mark hold 4.19.0-0.bpo.4-amd64 (hold thunedrbir et noyau, rien à upgrader sinon)
apt-install firmware-misc-nonfree
ls /lib/firmware/i915

xt_dmc_ver1_07.bin  bxt_guc_ver8_7.bin   kbl_dmc_ver1.bin         skl_dmc_ver1_23.bin  skl_dmc_ver1.bin  skl_guc_ver4.bin    skl_guc_ver6.bin
    bxt_dmc_ver1.bin     kbl_dmc_ver1_01.bin  kbl_guc_ver9_14.bin  skl_dmc_ver1_26.bin  skl_guc_ver1.bin  skl_guc_ver6_1.bin

skl_dmc_ver1_26.bin y est mais pas skl_dmc_ver1_27.bin trouvé ainsi
curl -o /lib/firmware/i915/skl_dmc_ver1_27.bin https://raw.githubusercontent.com/wkennington/linux-firmware/master/i915/


Stretch 9.1 à 9.9 Erreur DRM ACPI systématique au démarrage
#2

Essai

# curl -o /lib/firmware/i915/skl_dmc_ver1_27.bin https://raw.githubusercontent.com/wkennington/linux-firmware/master/i915/skl_dmc_ver1_27.bin

ls /lib/firmware/i915

bxt_dmc_ver1_07.bin  bxt_guc_ver8_7.bin   kbl_dmc_ver1.bin     skl_dmc_ver1_23.bin  skl_dmc_ver1_27.bin  skl_guc_ver1.bin  skl_guc_ver6_1.bin
bxt_dmc_ver1.bin     kbl_dmc_ver1_01.bin  kbl_guc_ver9_14.bin  skl_dmc_ver1_26.bin  skl_dmc_ver1.bin     skl_guc_ver4.bin  skl_guc_ver6.bin

skl_dmc_ver1_27.bin y est


#3

dmesg -l err

[    0.792260] serial 0000:00:16.3: Couldn't register serial port 4080, irq 19, type 0, error -28

il n’y a plus d’erreur de chargement de firmware mais coté graphique rien de changé.

chez INTEL on trouve ça.

https://downloadcenter.intel.com/downloads/eula/8203/Intel-Graphics-Driver-Linux-IntelGraphics-060704-tar-gz-?httpDown=https%3A%2F%2Fdownloadmirror.intel.com%2F8203%2Feng%2Fi915Graphics.tar.gz

Detailed Description
This file contains the latest XFree86* accelerated X Windows server and required Linux* kernel modules (AGP GART and DRM) for the Intel® 82830M, 82845G, 82852GM, 82855GM, 82865G, and 82915G graphics controller-based products.

Intel does not guarantee functionality on any specific Linux distribution.

This download is valid for the product(s) listed below.
Graphics Drivers for Intel® 82830M Graphics and Memory Controller Hub (GMCH)
Graphics Drivers for Intel® 82845G Graphics Controller
Graphics Drivers for Intel® 82852/82855 Graphics Controller Family
Graphics Drivers for Intel® 82865G Graphics and Memory Controller Hub (GMCH)
Graphics Drivers for Intel® 82915G/82910GL Express Chipset Family
Graphics Drivers for Mobile Intel® 915GM/GMS, 910GML Express Chipset Family

ça n’a pas l’air simple de l’installer.

et dedans il n’y pas l’air d’avoir du “DEBIAN”
$ tar -xvf i915Graphics.tar.gz
puis aller explorer

$ ls /home/jean/INTEL-GRAPHICS-DRIVER/dripkg/kernel-modules

CVS                           novell-9-2.6.5-7.108-smp      novell-9-2.6.5-7.111-smp     redflag-Desktop4.1-2.4.26-1.EL  redhat-Desktop3-2.4.21-20.EL
novell-9-2.6.5-7.108-default  novell-9-2.6.5-7.111-default  redflag-Desktop4.1-2.4.26-1  redflag-Desktop4.1-2.4.26-1smp  redhat-Desktop3-2.4.21-20.ELsmp

Et bien voilà peut être la liste des distribution qui “marcheraient”?!
Debian on peut aller se gratter…

~$ lspci -nnk | egrep -iA3 “VGA”                             
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 530 [8086:1912] (rev 06)
       Subsystem: Intel Corporation HD Graphics 530 [8086:1912]
       Kernel driver in use: i915
       Kernel modules: i915

lshw -c video        

 *-display                  
      description: VGA compatible controller
      produit: HD Graphics 530
      fabriquant: Intel Corporation
      identifiant matériel: 2
      information bus: pci@0000:00:02.0
      version: 06                                                                                                                                                                                          
      bits: 64 bits                                                                                                                                                                                        
      horloge: 33MHz                                                                                                                                                                                       
      fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list rom                                                                                                                            
      configuration: driver=i915 latency=0                                                                                                                                                                 
      ressources: irq:132 mémoire:c0000000-c0ffffff mémoire:b0000000-bfffffff portE/S:4000(taille=64) mémoire:c0000-dffff

version du pilote qu’on trouve chez intel
gdg
Intel 830M/845G/852GM/855GM/865G/915G Driver
I386
20040604
gdg

Vieux et sans doute inadapté i386 j’ai amd64

Tout indique que le pilote Intel Tourne, mais il n’y a absolument rien de changé par rapport à quand il n’y est pas: à croire que le gestionnaire de fenêtre se sert de autre chose. Essai: changer de gestionnaire de connexion, autre chose que gdm3 et voir si ça fait écran noir: peut être qu’enfin ce pilote servira.


#4

c’était bien gdm3 le coupable. Le pilote graphique gère à la fois firefox, chrome, chromium , MV-player, VLC, dragon player, TOUT MARCHE même en lisant des vidéos bien plus grosse que l’écran
C’ÉTAIT GNOME gdm3 !!! qui faisait tourner un autre pilote (j’ai démarré sous sddm, lghtdm ne marche pas, mais déjà, il n’y a plus de saccades, ni de tearing, ni de bruit piézo électriques dans mon alim, et même pas de tearing dans le défilement des fenêtres!!!)
Correction: cette résolution apparente de problème n’est que partielle: ça le fait toujours mais moins, je retrouve le problème sur des médias plus lourds.
le véritable problème a été résolu par l’ajout de

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
dans /etc/environment
résoud le problème des saccades dans les fenêtres pleins écran, permettant du coup d’utiliser la méthode d’accélération matérielle SNA, mais la charge processeur est élevé, pour peu que ça doit du HD-1080 60HZ ou du 1440P 30HZ c’est presque à fond les 4 coeurs avec les 3 navigateurs web.

P’tin de _______ gnome… vous sabotez linux ou quoi !!! car il n’y pas que ça: gnome empêche de personnaliser son ergonomie, c’est plein d’entraves (boutons à la place de texte dans les explorateurs de fichiers, vue en icône sans possibilité de mettre vue par liste par défaut… etc)

les nombreuses déficiences d’affichage provenaient donc des mises à jour d’un composant de gnome _(ça se corrige _
CLUTTER_PAINT=disable-clipped-redraws:disable-culling
dans /etc/environment,
son “pilote” graphique en particulier (en fait c’est un choix permettant le tearing), d’où l’échec systématique des autres manip. Cependant, je ne pense pas que démarrer sous un noyau linux plus récent que le 4.19 soit possible, les noyaux plus récents ont une erreur ACPI DRM et le DRM est, sauf erreur une partie de la gestion de l’affichage.
Correction: cette erreur empêche juste au système d’avoir les information sur l’écran (peut être là la raison de l’abscence de choix des définitions), mais les noyaux plus récents tournent un peu plus lourds et du coup la puissance manque pour gérer l’affichage

L’ennui c’est que je ne dispose plus de mate (est ce possible de démarrer “mate” à partir de sdm?: oui ça marche)


#5

Bravo pour vos recherches ! et Merci.

Vous soulignez l’importance de l’adéquation du logiciel au matériel.
Autant que vous dénoncez les négligentes usines à gaz modernes ou à la mode.

Je crois qu’il reste encore le gros souci d’

Avez-vous pensé à SLiM ?

Either a display manager (SLiM, GDM, LightDM, etc.) or the startx command can be used to start MATE during system the system boot process.

C’est à assimiler à un phénomène de « Coil Whine » ?


#6

l’erreur
“ACPI Exception:
1 table load failures
ERROR EDID has major version 0, instead of 1”

Réapparait avec le noyau 4.9.0-5 qui par contre, ça ne semble pas empêcher un fonctionnement graphique correct (sous cinnadon) comme avec le 4.9.0-8 ou le 4.9.0-9 (4.19 ne fait pas cette erreur)

Je ne retrouve pas la configuration qui me permet de lire du 1440p 60Hz, ça tourne “bien” mais avec le système récent (même avec vieux noyau) la limite se tient un peu au dessus du 2K en 30hz au lieu du 4k 30Hz ou 2k 60Hz qui passaient encore dans ma configuration du début (je regardais en effet il y quelques mois en arrière, donc fin 2018, en effet, et en 60Hz 1440p cette chaine). Cette configuration devait correspondre au noyau 4.9.0-5, mais avec un serveur graphique de l’époque et les gestionnaires de fenêtres de l’époque.

j’ai remarqué aussi qu’un bruit parasite (du à un mauvais blindage ou prise de terre de l’ampli), passe dans le canal audio, seulement si une lecture de média vidéo est enclenché, (ce qui indique l’activation du processeur graphique), ça l’a toujours fait, mais seulement sur mon installation en France (à la Réunion, il n’y a pas de parasite qui passe dans le canal audio, l’activité électrique des composants matériels ne passe pas)
Ce qui est “nouveau” avec Cinnadon, c’est que cette activation est temporaire, pas permanente: le bruit s’arrête si il n’y a pas de média vidéo en lecture.

J’ai l’impression que l’accélération matérielle est gérée 2 fois, comme si il y avait une correction “interne” à certains logiciels mais pas tous, c’est en effet bizarre quand je suis avec VLC que sans activer l’option “tearfree” VLC et MV-player soient justement sans tearing(mais avec tearing si souris ou curseur affichée) et qu’avec l’option “tearfree” activée, c’est bien sur sans tearing mais saccadé (par contre, et c’est là où c’est “con” parfaitement fluide tant que la souris ou le curseur sont affichés!)

J’ai aussi remarqué que si je règle en 50Hz mon écran (sous cinnadon), il y a les saccades comme si tout était du 60Hz et que je visionnais du 50, qui bien sur ne disparaissent pas avec un média 50, car l’interface graphique tourne en 50 mais l’écran est resté à 60: quelque chose impose, quoi qu’on fasse, que l’écran reste à 60Hz, et le programme glxgears confirme que c’est en 60 en étant le seul truc affiché qui soit fluide à l’écran. Avant, ça devait être dans la chronolgie Wheezy, je pouvais choisir mon écran, c’était un “Philips” et il y avait 24,25, 50 et 60Hz, le mode 50 et 60Hz était fonctionnels, le mode 24 et 25 instable et scintillant finalement pas utilisable pour les films.
Etch, lui (en 2007 2009) était génial: quand je regardais des films, assez sensible à l’accélération des DVD, je regardais toujours les format NTSC pour avoir la bonne vitesse, en 72Hz mais sur un tube cathodique. Les linux récents ont supprimés, même sur ce tube cathodique les mutiples de 24, comme si un lobbying des homes cinéma avait fait retiré cette fonction pour garder “un avantage”, desfois c’est ce que je me dis selon la théorie du complot, des mecs dans une équipe plombent le système pour faire fuir les non-geek, et gnome fout aussi une sacré merde en “prenant la main” sur la base du système et en bridant les possibilité de personnalisation… enfin… bref, tout ça n’est pas en rapport directe avec l’erreur ACPI DRM qui curieusement, s’est installée et n’est pas résolu alors que les messages y faisant références sont récurrents un peu de partout sans réponse.


#7

j’ai adopté cinnadon, mais avec le noyau 4.19 ça tourne vraiment vraiment mieux.
LXDE est pas mal aussi.
Reste le problème de l’écran.
le « Coil Whine » dans l’alim fait penser au bruit d’un disque dur mécanique et la carte graphique “fuit” dans la prise audio de l’ampli, mais seulement en France (à la Réunion, autre installation: ça ne passe pas dans la BF, peut être un lien avec la prise de terre). C’est pas si mal pour travailler sur une configuration: écouter le bruit d’une machine informe si ça ne tourne pas rond, et le noyau 4.19 est beaucoup moins bruyant! J’ai essayé un moment le 4.9.0-6 mais il tourne comme une pattate, le 4.09-8 et 4.09.9 tournent comme du topinambour.


#8

J’ai entendu dire que le SHA256 a été cassé en écoutant l’alimentation…
au stéthoscope, je ne sais pas :smile:

Excellent ! J’entends « sauvegarde et préservation » dans ma petite tête :wink:

À chaque jour suffit sa peine.
Ça va venir.

Je suis une patate douce dès qu’il s’agit de radio ou de vraie sono :face_with_raised_eyebrow:


#9

l’autre bonne surprise que j’ai avec Cinnadon c’est que mes logiciels vidéo: Pitivi et shotcut marchent bien: Pitivi ne freeze pas une fois sur 2 et shocut s’est enfin lancé, j’ai pu l’essayé, en plus il est puissant et encode avec les choix de débits et codecs que je veux. J’ai laissé de coté pour le moment le Da Vinci Résolve, c’est trop dur à résoudre (il faut le Da Vinci Code, je crois), pour le profil flat de go-pro, le réglage contraste-couleur de shotcut suffira.
Quoique la pomme de terre, avec un écouteur piezo ça peut le faire, pour la radio (à condition que ça soit de la modulation d’amplitude).


#10

la mise à jour de sécurité du micro-code-intel a probablement amputé le processeur d’une performance qui permettait d’éviter des saccades pour une configuration où il ne suis désormais plus la cadence, pourtant la lecture d’images compressée prend peu de charge processeur (non, vérification faite, c’était avant, maintenant ça prend presque toute la puissance)
Le bruit associé au travail du processeur (ou autre circuit, l’ordinateur n’est pas bruyant en cours d’encodage tout proc à fond). Ce bruit est crée par des fréquences injectées par l’alim dans le circuit électrique lors des appels de courant de l’ordinateur, c’est pour cela que ça le fait en France mais pas à la Réunion, où dans cet autre habitation, la prise de terre est meilleure, alors qu’en France, le courant induit porte à 70 volts la tension au neutre.


#11

Pourtant le “Intel® Core™ i5-6500 CPU @ 3.20GHz” n’a pas l’hyper-threading

La mise à jour du microcode a largement amputé la performance de lecture d’une vidéo: le HD 1080 60hz demande aux 4 processeurs de tourner à fond.
La lecture avec VLC et MV-player demande pour du 1440 30 du 40%, mais presque 90 si ce format est lu par quelconque navigateurs, ce qui provoque des bruits (dans le courant électrique pollué par l’alim dans les circuit audio de l’ampli).
Je crois que la mise à jour du microde-intel, qui a désactivé l’hypertreading ou compte le faire, débouche sur un fonctionnement boiteux: la dégradation des performances est énorme et semble du (à l’oreille) à des attentes de flux de données internes.
Je me souviens que la lecture des vidéos sur youtube demandais, mais avec les navigateurs internet, une puissance négligeable: l’ordinateur restait froid, il ne chauffait (et beaucoup) que pour faire les encodages.

On se rend facilement compte de cela, vu que c’est un radiateur.

Le noyau 4.19 et le gestionnaire de fenêtre cinnamon est moins gourmand que le 4.9 et fait passer pour peu le seuil d’essouflement du processeur en dessus de la limite de quelques médias qui ne passent pas avec les version supérieures du noyau, ce qui explique l’amélioration en rétrogradant: c’est comme si cet ordinateur avait pris 10 ans de retard en performances, à ce point là ce n’est pas normal: il lisait fluide des vidéo en 4K , et là il est sur les rotule sur le format 2 fois inférieur.

Si Intel® Core™ i5-6500 CPU @ 3.20GHz n’a pas cet hyper-threading, intel-microcode version (3.20190514.1~deb9u1) est t-il tout de même la raison de cette rétrogradation des performances après la mise à jour de mai?


#12

retour au début du message pour résumer les points important de la résolution du tearing et sacades


#13

Je n’ai pas tout lu mais j’ai eu le même soucis que toi , tearing lenteur.

mon pc portable à base ne veut pas de gnome. trop poussif alors que kde aucun soucis.


#14

Je continue quelques essais, j’ai téléchargé la vidéo 1440p et 1080p de https://www.youtube.com/watch?v=_3alv4u3UPU durée 1h14’57" format 60Hz codec On2 VP9 son opus (original 4K en h.265 85Mb/s )

Original 4K h.265 85Mb/s 45Go (d’après le monsieur qui l’a envoyé)
Version 1080p 2.1Go 4.3Mb/s sur youtube, à peine accessible avec quelques sauts et 90% processeur, lu en local est rendu avec 40% puissance processeur. Avec Chomium un problème de décodage interdit d’en profiter, investigation faites, seulement avec le codec On2vp9: la vidéo a un rendu 480p par intermitence. Le seul moyen de regarder correctement la version 1080p est donc de la mettre sur le disque dur et de la lire avec VLC.

Version 1440p 5.8 Go 11.7Mb/s, demande 60% de la puissance processeur, mais est saccadée en fonction de la richesse de l’image! Mon ordinateur avec VLC peine à la lire correctement sauf les passages dans les tunnels!
C’est un débit variable. Ce débit ne varie pas selon la richesse de l’image ni selon le mouvement, mais selon… sa luminance (le débit reste quasi au maximum lorsque que le train est à l’arrêt, mais est au minimum dans les tunnels).
Ceci est peut être du à la baisse de résolution de la go-pro en basse lumière qui fournie alors une image composées de gros pixels qui représentent donc une redondance élargie à de vastes région de l’image: peut être que le débit est fonction de nombres d’éléments de l’image, même si ils sont immobiles!
Dans les tunnels: 5Mb/s environ (2.2 version 1080p), et dans le paysage, 13 Mb/s (5Mb/s version 1080p),
en 1440p au delà de 10Mb/s environ la puissance de calcul manque (elle ne manquait pas avant la mise à jour de debian 9 début mai 2019)

Les problèmes insolubles de saccades qui restent avec la bon réglage pour la vidéo (la méthode uxa) sont liés au codec On2vp9: les vidéos 60Hz passent bien si elles sont en h.264 mais passent mal en On2 VP9
Quand il s’agit de vidéos youtube au format 1080p, chromium les lit bien mieux (bien plus net) que firefox et chrome, si elles sont en h.264, ce qui est le cas avec des vidéos qui n’étaient pas des 4K mais des 1440p ou 1080p quand on les a envoyé.
Si ces vidéos sont téléchargés, elles sont pas lues de la même façon que sur le streaminh: chromium perd son défaut et la pulsation n’est pas si sensible pour les autres navigateur.

le On2 VP9 a souvent un effet détestable d’éléments d’image raffraichies à intervalles réguliers avec une pulsation de 1 à quelques herzt, ce qui est insoutenable avec de la synesthésie (perception visuelle utilisant en partie les zones du cerveau-audio)