Installation Bullseye

Ces dépôts sont correctes :

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb https://security.debian.org/debian-security bullseye-security main
deb-src https://security.debian.org/debian-security bullseye-security main

deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

Par contre celui la est inutile, il faut l’effacer :

deb http://ftp.fr.debian.org/debian bullseye main non-free

Maintenant que le sources.list est corrigé, en premier :

sudo apt update

puis ensuite mettre a jour vers debian 11 bullseye :

sudo apt full-upgrade

Avant de lancer la mise à jour de la liste des fichiers puis du système,
il faudrait d’abord désactiver tous les dépôts qui ne sont pas de debian
en lançant, avec les privilèges du compte root :

for f in /etc/apt/sources.list.d/*.list; do sudo mv $f{,.enAttente}; done

J’ai bien mis en attente les fichiers /etc/apt/sources.list.d et voici leur contenu

  • pour Teams
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] https://packages.microsoft.com/repos/ms-teams stable main 
  • pour Skype deb [arch=amd64] https://repo.skype.com/deb stable main
    J’ai corrigé le fichier /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 10.6.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200926-10:17]/ bullseye main

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb https://security.debian.org/debian-security bullseye-security main
deb-src https://security.debian.org/debian-security bullseye-security main

# bullseye-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

J’ai lancé la commande de mise à jour mais pas celle de passage vers Bullseye

joel@joel-k70ij:~$ for f in /etc/apt/sources.list.d/*.list; do sudo mv $f{,.enAttente}; done
[sudo] Mot de passe de joel : 
joel@joel-k70ij:~$ sudo apt update
E: Ligne 1 mal formée dans la liste des sources /etc/apt/sources.list (type)
N: « skype-stable.list.enAttente » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « teams.list.enAttente » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: La liste des sources ne peut être lue.
joel@joel-k70ij:~$ 

merci

pour le fichier /etc/apt/sources.list c’est peut être mieux comme ça

joel@joel-k70ij:~$ cat /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 10.6.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200926-10:17]/ bullseye main

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb https://security.debian.org/debian-security bullseye-security main
deb-src https://security.debian.org/debian-security bullseye-security main

# bullseye-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

joel@joel-k70ij:~$

A tout hasard

joel@joel-k70ij:~$ sudo dmesg |grep -i error
[sudo] Mot de passe de joel : 
[    4.857067] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[    5.543438] ACPI Error: AE_AML_BUFFER_LIMIT, Index (0x00000001B) is beyond end of object (length 0x10) (20180810/exoparg2-396)
[    5.543526] ACPI Error: Method parse/execution failed \_SB.PCI0.SBRG.EC0.STBR, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    5.543591] ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.LCDD._BCM, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    5.543655] ACPI Error: Evaluating _BCM failed (20180810/video-370)
joel@joel-k70ij:~$

Hello
quelqu’un a une idée ?
Bonne soirée

Bonjour
Je me demande ce que veut dire "Ligne 1 mal formée " et « type ». Pas facile de corriger un défaut quand il n’est pas précisé
Merci

Ça vient de la ligne 1 du fichier /etc/apt/sources.list, donne le retour de la commande head --lines=1 /etc/apt/sources.list.

voilà

joel@joel-k70ij:~$ head --lines=1 /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 10.6.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200926-10:17]/ bullseye main
joel@joel-k70ij:~$

Tu peux effacer cette ligne elle n’est d’aucune utilité, a moins que tu utilises des DVD pour installer des logiciels :

# deb cdrom:[Debian GNU/Linux 10.6.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200926-10:17]/ bullseye main

Voilà le nouveau fichier /etc/sources.list

joel@joel-k70ij:~$ sudo cat /etc/apt/sources.list
[sudo] Mot de passe de joel : 
deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb https://security.debian.org/debian-security bullseye-security main
deb-src https://security.debian.org/debian-security bullseye-security main

# bullseye-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

joel@joel-k70ij:~$ 

que faut il faire pour les fichiers du répertoire /etc/apt/sources.list.d ?

merci

Bonjour
Puisque je voulais passer à bullseye en raison des problèmes potentiels entre opencpn et buster, je me suis dit qu’il faudrait peut être désinstaller mon opencpn sous buster pour le réinstaller plus tard sous bullseye
J’ai donc tenté d’ouvrir Synaptic pour voir où en était opencpn.
Synaptic n’a pu s’ouvrir, voilà le message
E: Le type « deb » est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list
E: Impossible de lire la liste des sources.
Vous pouvez essayer de corriger le problème en ouvrant la fenêtre des dépôts.
E: _cache->open() failed, please report.

W: « skype-stable.list.enAttente » dans le répertoire « /etc/apt

Comment fait-on pour ouvrir la fenêtre des dépôts ? ça revient à ouvrir le fichier /etc/apt/sources.list ?

je ne comprends pas ce que ça veut dire

merci

Est-ce qu’une solution serait de sauvegarder ces fichiers sur une clé, puis les supprimer du répertoire /etc/apt/sources.list.d , désinstaller skype et Teams puis faire la migration vers bullseye, ensuite les remettre dans le répertoire /etc/apt/sources.list.d et réinstaller ?
Certes un peu inélégant voire brutal, mais d’une part je peux me passer de ces applications quelque temps et d’autre part je voudrais bien migrer
merci

Bonjour

Ça veut dire qu’il y a quelque chose de mal formulé
dans la première ligne du fichier /etc/apt/sources.list

Il faudrait que l’on puisse voir
le retour de la ligne de commande suivante :

hd /etc/apt/sources.list
joel@joel-k70ij:~$ hd /etc/apt/sources.list
00000000  ef bb bf 64 65 62 20 68  74 74 70 3a 2f 2f 64 65  |...deb http://de|
00000010  62 2e 64 65 62 69 61 6e  2e 6f 72 67 2f 64 65 62  |b.debian.org/deb|
00000020  69 61 6e 2f 20 62 75 6c  6c 73 65 79 65 20 6d 61  |ian/ bullseye ma|
00000030  69 6e 0a 64 65 62 2d 73  72 63 20 68 74 74 70 3a  |in.deb-src http:|
00000040  2f 2f 64 65 62 2e 64 65  62 69 61 6e 2e 6f 72 67  |//deb.debian.org|
00000050  2f 64 65 62 69 61 6e 2f  20 62 75 6c 6c 73 65 79  |/debian/ bullsey|
00000060  65 20 6d 61 69 6e 0a 0a  64 65 62 20 68 74 74 70  |e main..deb http|
00000070  73 3a 2f 2f 73 65 63 75  72 69 74 79 2e 64 65 62  |s://security.deb|
00000080  69 61 6e 2e 6f 72 67 2f  64 65 62 69 61 6e 2d 73  |ian.org/debian-s|
00000090  65 63 75 72 69 74 79 20  62 75 6c 6c 73 65 79 65  |ecurity bullseye|
000000a0  2d 73 65 63 75 72 69 74  79 20 6d 61 69 6e 0a 64  |-security main.d|
000000b0  65 62 2d 73 72 63 20 68  74 74 70 73 3a 2f 2f 73  |eb-src https://s|
000000c0  65 63 75 72 69 74 79 2e  64 65 62 69 61 6e 2e 6f  |ecurity.debian.o|
000000d0  72 67 2f 64 65 62 69 61  6e 2d 73 65 63 75 72 69  |rg/debian-securi|
000000e0  74 79 20 62 75 6c 6c 73  65 79 65 2d 73 65 63 75  |ty bullseye-secu|
000000f0  72 69 74 79 20 6d 61 69  6e 0a 0a 23 20 62 75 6c  |rity main..# bul|
00000100  6c 73 65 79 65 2d 75 70  64 61 74 65 73 2c 20 70  |lseye-updates, p|
00000110  72 65 76 69 6f 75 73 6c  79 20 6b 6e 6f 77 6e 20  |reviously known |
00000120  61 73 20 27 76 6f 6c 61  74 69 6c 65 27 0a 64 65  |as 'volatile'.de|
00000130  62 20 68 74 74 70 3a 2f  2f 64 65 62 2e 64 65 62  |b http://deb.deb|
00000140  69 61 6e 2e 6f 72 67 2f  64 65 62 69 61 6e 2f 20  |ian.org/debian/ |
00000150  62 75 6c 6c 73 65 79 65  2d 75 70 64 61 74 65 73  |bullseye-updates|
00000160  20 6d 61 69 6e 0a 64 65  62 2d 73 72 63 20 68 74  | main.deb-src ht|
00000170  74 70 3a 2f 2f 64 65 62  2e 64 65 62 69 61 6e 2e  |tp://deb.debian.|
00000180  6f 72 67 2f 64 65 62 69  61 6e 2f 20 62 75 6c 6c  |org/debian/ bull|
00000190  73 65 79 65 2d 75 70 64  61 74 65 73 20 6d 61 69  |seye-updates mai|
000001a0  6e 0a 0a                                          |n..|
000001a3
joel@joel-k70ij:~$

Bonjour

Un BOM (ef bb bf) a été inséré dans ce fichier parce qu’il a été créé ou/et édité avec un programme qui n’est pas fait pour ça.

C’est la présence de ce BOM qui provoque l’émission du message d’erreur :

E: Le type « deb » est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list

Pour créer/modifier ce fichier,
utilise plutôt cette ligne de commande
à lancer avec les privilèges du compte super utilisateur root :

apt edit-sources

Je crois bien qu’il était question de BOM dans mes démêlés avec opencpn je vais vérifier
Pour le retour de commande j’ai préféré une capture d’écran pour qu’on voie les couleurs


Bonjour

Pour supprimer le BOM qui est dans ton fichier /etc/apt/sources.list
il te faudrait lancer la ligne de commande suivante
avec les privilèges du compte root

sed -i '1s/^\xEF\xBB\xBF//' /etc/apt/sources.list

Juste après avoir lancé la ligne de commande ci-dessus,
tu pourras faire la mise à jour de la liste des paquetages et de ton système
en lançant la ligne de commandes suivante
avec les privilèges du compte root

apt update && apt upgrade
joel@joel-k70ij:~$ sudo sed -i '1s/^\xEF\xBB\xBF//' /etc/apt/sources.list
[sudo] Mot de passe de joel : 
joel@joel-k70ij:~$ cat /etc/apt/sources.list
deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb https://security.debian.org/debian-security bullseye-security main
deb-src https://security.debian.org/debian-security bullseye-security main

# bullseye-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

joel@joel-k70ij:~$