Installer la dernière version de Firefox sur Stretch ?

firefox
Tags: #<Tag:0x00007f092a604fc0>

#1

Bonjour,
Comme vous le savez Stretch est fourni avec Firefox ESR
Avant je recourais au dépôt Debian-Mozilla pour choisir ma version de Firefox, mais ce n’est plus possible.
Comment puis-je installer proprement la version actuelle (56) ?

Merci d’avance


Upgader firefox - stretch
#2

Salut,

es-tu allé voir sur le site officiel ?

Car il est disponible en 32 bits ici : https://download.mozilla.org/?product=firefox-56.0-SSL&os=linux&lang=fr
Puis en 64 bits là : https://download.mozilla.org/?product=firefox-56.0-SSL&os=linux64&lang=fr

Bonne journée


#3

Salut

https://mozilla.debian.net/

fourni firefox pour testing
Ajouter

deb http://http.debian.net/debian unstable main

Puis

$ apt-get update
$ apt-get install -t unstable firefox


Installation Debian-9.6.0-Lxde proprement
#4

Oui et la raison est donnée :

because of the requirement of rust to build them, which is not available in Jessie or Stretch

Une personne se dévouerait-elle pour avoir la dernière chaîne de compilation rustc dans stretch ? Est-ce seulement possible ?


#5

Merci à tous.

Une curiosité : quand on pioche dans unstable en installant avec un “apt-get install -t unstable nom_du_paquet”, le paquet se met à jour comme ceux de la distribution avec un classique update/upgrade, où il faut ré-exécuter la commande “apt-get install -t unstable nom_du_paquet” ?


#6

Si qq1 a une réponse à ma question juste au dessus, je suis toujours interessé :wink:
Merci !


#7

Tous les paquets installés se mettent à jour en une seule commande, c’est la force de debian et des gestionnaires de paquet.

Si tu peux utiliser le flag -t unstable, c’est que tu as ajouté les sources unstable à ton système, les règles de préférence de pinning s’appliqueront.

Et si ton paquet ne se met pas à jour alors qu’il devrait, alors en tapant la commande apt-cache policy nom_du_paquet, tu comprendras pourquoi ton paquet est mis à jour ou non, alors qu’une mise à jour est disponible.


#8

Solution testée et validée ?

Je suis preneur d’un retour d’expérience là-dessus.


#9
root@debian:/etc/apt/sources.list.d# cat mozilla-debian.list 
deb http://http.debian.net/debian unstable main
root@debian:/etc/apt/sources.list.d# apt update

Lecture des informations d'état... Fait
All packages are up to date.

Une simple simulation car j’ai déjà firefox-esr et firefox57 de mozilla en local

root@debian:/etc/apt/sources.list.d# apt-get -s install -t unstable firefox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  libevent-2.1-6
Paquets suggérés :
  fonts-stix | otf-stix mozplugger
Les NOUVEAUX paquets suivants seront installés :
  firefox libevent-2.1-6
0 mis à jour, 2 nouvellement installés, 0 à enlever et 227 non mis à jour.
Inst libevent-2.1-6 (2.1.8-stable-4 Debian:testing, Debian:unstable [amd64])
Inst firefox (56.0-2 Debian:unstable [amd64])
Conf libevent-2.1-6 (2.1.8-stable-4 Debian:testing, Debian:unstable [amd64])
Conf firefox (56.0-2 Debian:unstable [amd64])



#10

parfait, merci ploc :slight_smile:


#11

et merci grandtoubab :slight_smile:


#12

NB
Pour éviter les mises à jour automatique, j’utilise

root@debian:/etc/apt/preferences.d# cat unstable
Package: *
Pin: release a=unstable
Pin-Priority: 50
man apt preferences

dit

0 < P < 100
la version sera installée si aucune version du paquet n’est installée

c’est pourquoi j’ai l’indication

227 non mis à jour


#13

Bonjour,

Je remonte le post car sur une ‘Jessie’, la manip que tu proposes me mettrait à jour 133 paquets !!

firefox unstable.txt (80,0 Ko)

Pour quelle raison, chez toi, 2 seulement se mettent à jour ?!?


#14

As tu bien créé le fichier préférences

root@debian:/etc/apt/preferences.d# cat unstable
Package: *
Pin: release a=unstable
Pin-Priority: 50
root@debian:/etc/apt/preferences.d#


#15

oui : c’est fait


#16

man apt preferences

   0 < P < 100
       la version sera installée si aucune version du paquet n'est installée.

   P < 0
       cette priorité empêche l'installation de la version.

Pour moi quand je vois ça

96 mis à jour, 133 nouvellement installés, 43 à enlever et 1236 non mis à jour.

ton jessie n’est pas à jour de 96 paquets
il veut installer des paquets qui n’existe pas dans jessie mais qui existent dans unstable

les 1236 sont des mises à jour d’unstable qui ne seront pas appliquées

essai de descendre la priorité d’unstable

Pin-Priority: -1


#17

J’ai mis la priorité à ‘-1’. Le résultat est le même. Je ne comprends pas pour quelle raison il veut mettre ma jessie à jour avec des paquets de ‘unstable’ avec une priorité à -1. Ou alors il existe un autre paramètre à modifier ?


#18

Sur ma debian stretch je n’ai pas ce problème !!

root@debian9:~# apt-get -s install -t unstable firefox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  fontconfig-config libevent-2.1-6 libfontconfig1 libhunspell-1.6-0 libnss3
Paquets suggérés :
  fonts-stix | otf-stix fonts-lmodern mozplugger
Les NOUVEAUX paquets suivants seront installés :
  firefox libevent-2.1-6 libhunspell-1.6-0
Les paquets suivants seront mis à jour :
  fontconfig-config libfontconfig1 libnss3
3 mis à jour, 3 nouvellement installés, 0 à enlever et 1070 non mis à jour.
Inst libevent-2.1-6 (2.1.8-stable-4 Debian:unstable [i386])
Inst fontconfig-config [2.11.0-6.7] (2.12.3-0.2 Debian:unstable [all])
Inst libfontconfig1 [2.11.0-6.7+b1] (2.12.3-0.2 Debian:unstable [i386])
Inst libhunspell-1.6-0 (1.6.2-1 Debian:unstable [i386])
Inst libnss3 [2:3.26.2-1.1] (2:3.33-1 Debian:unstable [i386])
Inst firefox (56.0-2 Debian:unstable [i386])
Conf libevent-2.1-6 (2.1.8-stable-4 Debian:unstable [i386])
Conf fontconfig-config (2.12.3-0.2 Debian:unstable [all])
Conf libfontconfig1 (2.12.3-0.2 Debian:unstable [i386])
Conf libhunspell-1.6-0 (1.6.2-1 Debian:unstable [i386])
Conf libnss3 (2:3.33-1 Debian:unstable [i386])
Conf firefox (56.0-2 Debian:unstable [i386])

#19

J’en déduis donc que c’est la version Jessie qui pose problème !


#20

il faut que tu vérifies les dépots que tu utilises et toutes les préférences

cat /etc/apt/sources.list

ls -alrt  /etc/apt/sources.list.d

ls -alrt /etc/apt/preferences.d

Ceci dit on n’a meme pas besoin de dépots pour firefox. Tu télécharges la version officielle en français de Mozilla https://www.mozilla.org/en-US/firefox/beta/all/?q=French,%20Français et tu la décompresses dans don /home