MTA Zimbra : SpamAssassin | Mail DMARC (Filter) + Email Reporting

Tags: #<Tag:0x00007f63f4e9c140> #<Tag:0x00007f63f4e9c050> #<Tag:0x00007f63f4f57eb8>

Bon j’ai réussis à remettre mon système fonctionnel et avec Perl v5.36.1 à la place de la version installé par default la v5.30.0 :slight_smile:

De cette manière :

root@mail:/home/orj# wget https://www.cpan.org/src/5.0/perl-5.36.1.tar.gz
root@mail:/home/orj# tar -xzf perl-5.36.1.tar.gz
root@mail:/home/orj# cd perl-5.36.1
root@mail:/home/orj/perl-5.36.1# ./Configure -des -Dprefix=/usr
root@mail:/home/orj/perl-5.36.1# make
root@mail:/home/orj/perl-5.36.1# make test
root@mail:/home/orj/perl-5.36.1# make install

J’avais des erreurs sur AptPkg, Debconf et je n’arrivais plus à installer quoique ce soit avec les commandes « apt install » et donc je n’arrivais pas à installer Zimbra.

Le retour de la commande perl -V standard (v5.30.0)

[....]
Compiled at May 23 2023 17:17:48
  @INC:
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.30.0
    /usr/local/share/perl/5.30.0
    /usr/lib/x86_64-linux-gnu/perl5/5.30
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.30
    /usr/share/perl/5.30
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

Le retour de la commande perl -V après l’installation de Perl v5.36.1

[....]
Compiled at Jun  6 2023 00:35:21
@INC:
    /usr/lib/perl5/site_perl/5.36.1/x86_64-linux
    /usr/lib/perl5/site_perl/5.36.1
    /usr/lib/perl5/5.36.1/x86_64-linux
    /usr/lib/perl5/5.36.1

J’ai ensuite ajouté les répertoires /usr/share/perl5 et /etc/perl grâce à un export PERL5LIB.

root@mail:/home/orj# vim .bashrc
[....]
PERL5LIB="/etc/perl:/usr/share/perl5"; export PERL5LIB;

root@mail:/home/orj# source /root/.bashrc

En ajoutant /usr/lib/x86_64-linux-gnu/perl-base j’ai l’erreur suivante (à cause de « Config.pm ») :

/dev/null: Perl lib version (5.30.0) doesn't match executable '/usr/bin/perl' version (5.36.1) at /usr/lib/x86_64-linux-gnu/perl-base/Config.pm line 62.

Ce qui donne → perl -V :

[....]
Compiled at Jun  6 2023 00:35:21
  %ENV:
    PERL5LIB="/etc/perl:/usr/share/perl5"
  @INC:
    /etc/perl
    /usr/share/perl5
    /usr/lib/perl5/site_perl/5.36.1/x86_64-linux
    /usr/lib/perl5/site_perl/5.36.1
    /usr/lib/perl5/5.36.1/x86_64-linux
    /usr/lib/perl5/5.36.1

Et là j’ai donc un système « Linux mail 5.4.0-150-generic #167-Ubuntu SMP Mon May 15 17:35:05 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux » qui galope avec Perl v5.36.1.

Donc, je suis passé à l’installation de Zimbra et là plantage sur ces paquets :

  1. zimbra-perl-xml-sax-expat
  2. zimbra-perl
  3. zimbra-core-components
  4. zimbra-ldap-components
  5. zimbra-perl-xml-simple

CF :

root@mail:/home/orj/zcs-8.8.15_GA_4179.UBUNTU20_64.20211118033954# tail -100 /tmp/install.log.5pQkOdqF
Paramétrage de zimbra-httpd (2.4.57-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-perl-date-calc (6.4-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-io-compress (2.093-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-openldap-client (2.4.59-1zimbra8.8b5.20.04) ...
Paramétrage de zimbra-aspell-hi (0.02.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-ar (1.2.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-digest-hmac (1.03-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-list-moreutils (0.428-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-convert-tnef (0.18-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-opendkim (2.10.3-1zimbra8.7b5.20.04) ...
Paramétrage de zimbra-aspell-nl (0.50.2-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-config-inifiles (2.86-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-sv (0.51.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-de (20030222.1-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-dbd-sqlite (1.48-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-convert-asn1 (0.27-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-openjdk-cacerts (1.0.8-1zimbra8.7b1.20.04) ...
-bash: zmlocalconfig: command not found
Paramétrage de zimbra-apache-components (2.0.10-1zimbra8.8b1.20.04) ...
Paramétrage de zimbra-perl-net-dns (1.04-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-mime-lite (3.030-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-http-message (6.11-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-hu (0.99.4.2.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-zmq-libzmq3 (1.19-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-aspell-en (7.1.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-fr (0.50.3-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-dbd-mysql (4.050-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-perl-file-listing (6.04-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-archive-zip (1.53-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-swatchdog (3.2.4-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-pflogsumm (1.1.5-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-pt-br (20090702.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-net-http (6.09-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-aspell-es (1.11.2-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-net-dns-resolver-programmable (0.003-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-http-negotiate (6.01-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-innotop (1.9.1-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-perl-mail-spf (2.9.0-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-prepflog (0.4.1-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-http-cookies (6.01-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-aspell-zimbra (1.0.0-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-cluebringer (2.1.0.0.cf484f1b93cf9965886cc89d33bdeee9c26426cb-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-spell-components (2.0.12-1zimbra8.8b1.20.04) ...
Paramétrage de zimbra-perl-net-ldapapi (3.0.3-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-http-daemon (6.01-1zimbra8.7b2.20.04) ...
Paramétrage de zimbra-perl-net-ldap (0.65-1zimbra8.7b1.20.04) ...
Paramétrage de zimbra-perl-libwww (6.13-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-perl-mail-dkim (0.40-1zimbra8.7b3.20.04) ...
Paramétrage de zimbra-perl-mail-spamassassin (3.4.6-1zimbra8.8b4.20.04) ...
Paramétrage de zimbra-perl-xml-parser (2.44-1zimbra8.7b4.20.04) ...
Paramétrage de zimbra-perl-xml-sax-expat (0.51-1zimbra8.7b4.20.04) ...
Can't locate XML/Parser.pm in @INC (you may need to install the XML::Parser module) (@INC contains: /opt/zimbra/common/lib/perl5 /etc/perl /usr/share/perl5 /usr/lib/perl5/site_perl/5.36.1/x86_64-linux /usr/lib/perl5/site_perl/5.36.1 /usr/lib/perl5/5.36.1/x86_64-linux /usr/lib/perl5/5.36.1) at /opt/zimbra/common/lib/perl5/XML/SAX/Expat.pm line 11.
BEGIN failed--compilation aborted at /opt/zimbra/common/lib/perl5/XML/SAX/Expat.pm line 11.
Compilation failed in require at /opt/zimbra/common/lib/perl5/XML/SAX.pm line 147.
dpkg: erreur de traitement du paquet zimbra-perl-xml-sax-expat (--configure) :
 installed zimbra-perl-xml-sax-expat package post-installation script subprocess returned error exit status 2
dpkg: des problèmes de dépendances empêchent la configuration de zimbra-perl :
 zimbra-perl dépend de zimbra-perl-xml-sax-expat (>= 0.51-1zimbra8.7b4.20.04) ; cependant :
 Le paquet zimbra-perl-xml-sax-expat n'est pas encore configuré.

dpkg: erreur de traitement du paquet zimbra-perl (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de zimbra-perl-lwp-protocol-https (6.06-1zimbra8.7b4.20.04) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
Paramétrage de zimbra-spamassassin-rules (1.0.0-1zimbra8.8b6.20.04) ...
dpkg: des problèmes de dépendances empêchent la configuration de zimbra-core-components :
 zimbra-core-components dépend de zimbra-perl (>= 1.0.8-1zimbra8.7b1.20.04) ; cependant :
 Le paquet zimbra-perl n'est pas encore configuré.

dpkg: erreur de traitement du paquet zimbra-core-components (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
dpkg: des problèmes de dépendances empêchent la configuration de zimbra-ldap-components :
 zimbra-ldap-components dépend de zimbra-core-components (>= 2.0.22-1zimbra8.8b1ZAPPEND) ; cependant :
 Le paquet zimbra-core-components n'est pas encore configuré.

dpkg: erreur de traitement du paquet zimbra-ldap-components (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
dpkg: des problèmes de dépendances empêchent la configuration de zimbra-perl-xml-simple :
 zimbra-perl-xml-simple dépend de zimbra-perl-xml-sax-expat (>= 0.51-1zimbra8.7b4ZAPPEND) ; cependant :
 Le paquet zimbra-perl-xml-sax-expat n'est pas encore configuré.

dpkg: erreur de traitement du paquet zimbra-perl-xml-simple (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Paramétrage de zimbra-mta-components (1.0.19-1zimbra8.8b1.20.04) ...
Paramétrage de zimbra-perl-soap-lite (1.19-1zimbra8.7b4.20.04) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.9) ...
Traitement des actions différées (« triggers ») pour systemd (245.4-4ubuntu3.21) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour resolvconf (1.82) ...
Des erreurs ont été rencontrées pendant l'exécution :
 zimbra-perl-xml-sax-expat
 zimbra-perl
 zimbra-core-components
 zimbra-ldap-components
 zimbra-perl-xml-simple
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mais c’est déjà mieux que tout à l’heure.

Et je sais donc, que les modules Mail::DMARC et Mail::SpamAssassin::Plugin::DMARC peuvent s’installer sur cet environnement - Il ne manque plus que Zimbra :smiley: :rofl:

Si cela peut vous donner des indications.

À bientôt.

Romain

J’ai installé depuis l’utilisateur « root » le module XML::Parser et j’ai relancé l’installation → Installation complète mais…

Mais, j’ai encore une erreur à la fin de l’installation :

Socket.c: loadable library and perl binaries are mismatched (got first handshake key 0xcd00080, needed 0xe000000)

Note de Moi-même à 17h35 : Je me suis excité trop vite – Quand j’y pense, Zimbra ./install.sh ne m’a pas demandé « la vérification du nom de domaine » et de valider mon « adresse email » et toute la configuration … (attribution du mot de passe etc.)

Cela :

Installing packages
[.....]
Installing LDAP configuration database...done.
Setting defaults...     
 MX: mail.domaine.dom (10.10.0.1) 

Change domain name? [Yes]
Create domain: [mail.domaine.com] domaine.com
        MX: smtp.zw3b.eu (10.10.0.1)

        Interface: 127.0.0.1
        Interface: ::1
        Interface: 10.10.0.1
        
done. 
Checking for port conflicts
[.....]
Main menu 
 1) Common Configuration:
[.....]

CF :

tail -f /tmp/install.log.IZwajNj9
[.....]
*** Removing clientuploader extension ***
**** Fixing up the permission ****
Set capability for /opt/zimbra/common/libexec/slapd
Socket.c: loadable library and perl binaries are mismatched (got first handshake key 0xcd00080, needed 0xe000000)
Adding a symbolic link succeeded
mailboxd restart is required to enable jetty logging
**** Installation Completed. ****
**** Restart all the service as zimbra user. Run zmcontrol restart. ****

Ou :

zimbra@mail:~$ zmcontrol status
Socket.c: loadable library and perl binaries are mismatched (got first handshake key 0xcd00080, needed 0xe000000)
zimbra@mail:~$

.

zimbra@mail:~$ perl -V
Summary of my perl5 (revision 5 version 36 subversion 1) configuration:

  Platform:
    osname=linux
    osvers=5.4.0-150-generic
    archname=x86_64-linux
    uname='linux mail 5.4.0-150-generic #167-ubuntu smp mon may 15 17:35:05 utc 2023 x86_64 x86_64 x86_64 gnulinux '
    config_args='-des -Dprefix=/usr -Dotherlibdirs=/usr/share/perl5'
    hint=previous
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
  Compiler:
    cc='cc'
    ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
    optimize='-O2'
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='9.4.0'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/x86_64-linux-gnu /usr/lib /usr/lib64
    libs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.31.so
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version='2.31'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-E'
    cccdlflags='-fPIC'
    lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl):
  Compile-time options:
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Built under linux
  Compiled at Jun  6 2023 00:35:21
  %ENV:
    PERL5LIB="/opt/zimbra/common/lib/perl5/x86_64-linux:/opt/zimbra/common/lib/perl5"
    PERLLIB="/opt/zimbra/common/lib/perl5/x86_64-linux:/opt/zimbra/common/lib/perl5"
  @INC:
    /opt/zimbra/common/lib/perl5/x86_64-linux
    /opt/zimbra/common/lib/perl5
    /usr/lib/perl5/site_perl/5.36.1/x86_64-linux
    /usr/lib/perl5/site_perl/5.36.1
    /usr/lib/perl5/5.36.1/x86_64-linux
    /usr/lib/perl5/5.36.1
zimbra@mail:~$

Tiens je n’ai plus les directory /etc/perl et /usr/share/perl5 sur l’utilisateur « zimbra » - Ils ne sont pas de la variable @INC. C’est peut être cela - Je suis en train d’executer perl -MCPAN -e 'upgrade' depuis l’utilisateur « root » - Je reviens après.

:wink:

Bonne journée.

Romain

Eh bien, je vais devoir attendre 2024 pour avoir une version de Zimbra 11.0.0 GA Release :face_with_raised_eyebrow: avec Mail::DMARC fonctionnant avec Perl 5.36.X et une version LTS - d’Ubuntu (24.04).

Screenshot 2023-06-12 at 01-08-34 Download Zimbra Collaboration Network Edition

Paquet : perl-base (5.36.0-7ubuntu0.23.04.1 et autres) [security] [essential]Ubuntu – Details of package perl-base in lunar est déjà disponible en version 2023 - Ubuntu 23.04 (Homard lunaire).

Cela fait 1 an que je souhaite installer ce filtre anti-spam de bonne conformité DMARC des mails en réception.

Merci à toute leur équipe qui travaille très dur et qui nous on fait un superbe outil de gestion des emails de domaine, et des emails utilisateurs à proposer à nos clients et pour nos amis.

Bonne soirée.

Salutations,
Romain

Bonjour,

je vous ai déjà parlais de BIMI (Brand Indicators for Message Identification) en sécurité supplémentaire de DKIM/SPF sur DMARC et surtout « la personnalisation de son logo » - chose assez agréable - dirais-je :wink:

Je lie un lien vers la documentation des spécifications #BIMI.

Source : Brand Indicators for Message Identification (BIMI)

Les indicateurs de marque pour l’identification des messages (BIMI) permettent aux propriétaires de domaine de se coordonner avec les agents utilisateurs de messagerie (MUA) pour afficher des indicateurs spécifiques à la marque à côté des messages correctement authentifiés. La coordination BIMI comporte deux aspects : un mécanisme évolutif permettant aux propriétaires de domaine de publier les indicateurs souhaités et un mécanisme permettant aux agents de transfert de courrier (MTA) de vérifier l’authenticité de l’indicateur.
[…]

BIMI est conçu pour être ouvert et fonctionner à l’échelle d’Internet. BIMI est destiné à favoriser l’adoption des meilleures pratiques d’authentification des e-mails en tirant parti des politiques DMARC [RFC7489] existantes, des méthodes d’authentification de prise en charge DKIM [RFC6376] et SPF [RFC7208], et d’autres normes associées telles que ARC [RFC8617]
[…]

Par exemple, le propriétaire du domaine de « example.com » publierait la politique #BIMI dans un enregistrement TXT à « default. bimi.example.com ». De même, un destinataire de courrier souhaitant interroger la politique BIMI concernant le courrier avec un domaine d’auteur RFC5322.From de « example.com » et un sélecteur « default » (la valeur par défaut) interrogerait l’enregistrement TXT situé dans le sous-domaine de « default. bimi .exemple.com ». L’enregistrement de politique BIMI basé sur le DNS est appelé « enregistrement d’assertion BIMI » ou « enregistrement d’assertion ».
[…]

Les enregistrements d’assertion BIMI suivent la syntaxe extensible « tag-value » pour les enregistrements de clés basés sur DNS, comme défini dans DKIM [ RFC6376 ] .
[…]

Les enregistrements d’assertion sont définis avec précision…

S’il est présent, l’en-tête BIMI-Selector DEVRAIT être inclus dans la signature DKIM alignée sur DMARC utilisée pour confirmer l’authenticité du message. S’il n’est pas inclus dans la signature DKIM conforme à DMARC, l’en-tête DEVRAIT être ignoré.
[…]

Je me demandais → est-ce que cela pourrait vouloir dire :

  1. Que je peut déclarer un logo « mode default » pour « example.com »

  2. Que je peut déclarer un logo « mode default » pour « marketing.example.com »

  3. Que je peut déclarer un logo « mode personnalisé » pour « bigchef_1.marketing.example.com » (le directeur du marketing par exemple).

Merci pour vos réponses.


Est-ce qu’il y a quelque part dans le protocole, soit sur le record TXT du DNS soit dans le SVG (Meta : le nom de l’organisation, le nom du service, le nom de la personne, ses coordonnées etc) - Il faudrait penser à çà :slight_smile:


Salutations,
Romain


Je re-ajoute ces 2 liens dans ce commentaire :

Côté MUA (Mail User Agent) - Installer les vérificateurs DMARC / DKIM / SPF / BIMI sur vos serveurs receveurs d’e-mails :

:cowboy_hat_face:

Bonne journée.

J’ajoute dans ce sujet :

J’ai remarqué que plusieurs serveurs mails (principal) ont bien activés leurs signatures DKIM, configurés leur politique DMARC et les adresses IPs de leurs SPF, mais très peu ont configurés leurs enregistrements DNS DMARC pour qu’ils soient valide et que leur politique DMARC soit activée.

Je viens d’écrire un papier :

:slight_smile:

Romain

Salut, bon ce n’est ni un forum Ubuntu, ni un forum zimbra mais…

Maintenant que j’ai un environnement machine avec la dernière version de perl (v5.36.1) par dessus la version standard v5.30.0.

  1. J’aimerais savoir comment créer des packages zimbra ?

  2. Quels seraient les packages obligatoires que je dois « créer » pour avoir un zimbra qui fonctionnerait avec un autre perl (v5.36.1) que le système par défaut (Version Perl : 5.30.0-9ubuntu0.4) que je puisse installer les modules Perl Mail::DMARC et Mail::BIMI

  3. Quelle serait la procédure et dans quel ordre ?

Afin d’aider la communauté « Zimbra Collaboration Suite » et d’avoir le plus beau Zimbra OpenSource au monde sécurisé par Mail :: DMARC/BIMI :slight_smile:

:smiley:

Donc, on m’a conseillé sur le forum zimbra ici que peut-être un point de départ serait https://github.com/Zimbra/packages
Ils donnent un exemple de construction de nginx qui est incomplet.

Vous devez faire make getsrc avant make build. Si vous tapez make (pas d’arguments), cela fera exploser votre zimbra /opt/zimbra alors soyez prudent et regardez n’importe quel makefile avant de l’exécuter de cette façon.

Une Astuce serez d’utilisez d’abord https://github.com/ianw1974/zimbra-build-scripts … qui peut faire beaucoup de travail initial pour s’assurer que l’environnement de construction est configuré et pouvoir créer cette construction initiale de zimbra OSS.

Alors je n’ai pas encore essayé, je n’ai jamais créé de paquet debian/ubuntu, donc, histoire de vous tenir informé, si cela peut vous intéresser.

Salutations,
Romain.

Bonjour, j’ai ouvert un article mémo sur mon site Web pour donner les lignes de commandes que j’ai effectué pour installer Mail::DMARC et « bientôt » Mail::BIMI.

L’article ne permet pas d’avoir Mail::DMARC et Mail::BIMI sur son Zimbra, ces juste un « task force ».

Si des personnes veulent s’éssayer à tester.

Install Perl modules Mail::DMARC Mail::BIMI on Ubuntu 20.04.6 LTS

Salutations,
Romain

J’avais zappé un truc :smiley: :rofl:

Il faut que j’utilise le zm-build avant… pour construire ma version personnalisée de Zimbra, si j’ai bien suivis.

Merci à vous, merci à eux, merci.

Je vais essayer, je vous tiens au jus.

Bon on n’avance pas…

La sophistication du phishing rend l'authentification impuissante - Le Monde Informatique

Selon le fournisseur, 89% des messages suspects ne sont pas filtrés par des protocoles standards comme SPF (Sender Policy Framework, norme de vérification du nom de domaine de l’expéditeur), DKIM (DomainKeys Identified Mail, norme d’authentification du nom de domaine de l’expéditeur) ou les enregistrements DMARC (Domain-based Message Authentication, Reporting, and Conformance, standardisant l’authentification des mails par les destinataires).

:frowning:

en fait le phishing est basé sur l’ingénierie sociale.
Comme nous sommes à une époque ou les génération d’imbéciles évoqué par Einstein sont devenus la norme, le phishing a de beau jour devant lui.
l’ingénierie sociale ne peut être compensée par la technique.
C’est une question d’éducation; et là malheureusement on est loiins d’être très haut.

C’est vrai nos parents ne connaissaient ce monde informatisé.
Ils étaient sur le minitel, téléphone rose - J’ai étais, une fois, invité dans un standard de téléphone rose. Çà était marrant - Que des mecs aux standard téléphonique avec voix changée, vous imaginez… qu’est-ce qu’on rigolait, les mecs, c’était nos « pères célibataire » qu’on excitait, qu’en j’y pensE.

C’était en 1995-1998 par là…

Cà ne s’appellait « encore » pas « usurpation d’identité - pishing - hameçonnage ».

Pas bien çà, on était jeune… :rofl:

:woozy_face:

l’usurpation d’identité existe depuis l’antiquité. Se faire passer pour quelqu’un d’autre c’est très ancien :slight_smile:

Avant sur les cartes d’identité / passeport ont gardés nos lunettes de vues (c’était comme une obligation - surtout pour les supers myopes) et les photos était en couleurs.

On pouvait mieux se faire reconnaitre.

Encore aujourd’hui, je me peut pas me faire opérer de ma myopie plus de « -10 » , ni porter de lentilles.
Je suis donc obligatoirement avec une paire de lunettes sur le nez.

La nouveauté d’imposer le retrait des lunettes particulières (avec un filtre sur les verres, ou des grosses branches) sur le nez est née de la reconnaissance faciale informatisée (et en prime les portraits robots).
Les lunettes ne gênent pas la reconnaissance facile désormais.

Par exemple :

Réception de « LRE AR24 » avec L’Identité Numérique - La Poste
Accusez réception de vos Lettres Recommandées Électroniques « AR24 » en moins d’une minute avec votre Identité Numérique.

C’est presque çà, c’est « encore » une photo. Ils sont chaud c’est une agence « privée » celle-ci ? Tu voudrais ma photo :neutral_face: de l’année ou… ?

Croyez-vous qu’au « Palais de Justice » je pourrais rentrer perruqué en juge ; peut-être que çà fonctionnerai bien pour la reconnaissance faciale ?

:wink:

la pérruque c’est chez les anglo-saxon, chez nous, uniquement la robe.

Ah oui, mince, çà va moins bien fonctionner.

Bonne soirée.

Bonjour, bonsoir.

J’ai peut-être une piste → « je lie ce commentaire », il me faut des packages de version « perl » et « zimbra-perl-base » version 5.36.1 minimum pour réussir à installer Mail::DMARC me semble t’il.

GitHub - Zimbra/packages: ZCS Third Party Dependency Build System
GitHub - Zimbra/zm-build: zm-build for Zimbra Collaboration Suite, FOSS Edition

:slight_smile:

en es-tu sur? sur un serveur Debian:

root@dsrvbull01:~# perl -version

This is perl 5, version 36, subversion 0 (v5.36.0) built for x86_64-linux-gnu-thread-multi
(with 52 registered patches, see perl -V for more detail)

Copyright 1987-2022, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at https://www.perl.org/, the Perl Home Page.

root@dsrvbull01:~# apt search dmarc --names-only
En train de trier... Fait
Recherche en texte intégral... Fait
dmarc-cat/stable 0.15.0-1+b4 amd64
  decode DMARC reports

dmarcts-report-parser/stable 1.0+git20220721.51ba1de-1 all
  Perl based tool to parse DMARC reports

libmail-dmarc-perl/stable 1.20211209-4 all
  Perl implementation of DMARC

libopendmarc-dev/stable 1.4.2-2+b1 amd64
  DMARC policy library (development files)

libopendmarc2/stable 1.4.2-2+b1 amd64
  DMARC policy library

opendmarc/stable 1.4.2-2+b1 amd64
  filtrage de courriels DMARC (Domain-based Message Authentication, Reporting and Conformance)

# apt install -s libmail-dmarc-perl/stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait
Version choisie « 1.20211209-4 » (Debian:12.1/stable [all]) pour « libmail-dmarc-perl »
Les paquets supplémentaires suivants seront installés :
  libcapture-tiny-perl libclass-load-perl libclass-load-xs-perl libclass-tiny-perl libclone-choose-perl libconfig-tiny-perl libconvert-binhex-perl libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl
  libcrypt-openssl-rsa-perl libdbd-sqlite3-perl libdbix-simple-perl libdevel-globaldestruction-perl libdevel-overloadinfo-perl libdevel-partialdump-perl libdigest-bubblebabble-perl libdist-checkconflicts-perl
  libemail-abstract-perl libemail-address-xs-perl libemail-date-format-perl libemail-messageid-perl libemail-mime-contenttype-perl libemail-mime-encodings-perl libemail-mime-perl libemail-sender-perl
  libemail-simple-perl libfile-copy-recursive-perl libhash-merge-perl libimport-into-perl libio-multiplex-perl libmail-authenticationresults-perl libmail-dkim-perl libmime-tools-perl libmime-types-perl
  libmodule-pluggable-perl libmodule-runtime-conflicts-perl libmoo-perl libmoose-perl libmoox-types-mooselike-perl libnet-cidr-perl libnet-dns-perl libnet-dns-sec-perl libnet-idn-encode-perl
  libnet-imap-simple-perl libnet-ip-perl libnet-server-perl libnet-smtps-perl libobject-accessor-perl libpackage-deprecationmanager-perl libparse-recdescent-perl libpath-tiny-perl libperl4-corelibs-perl
  libregexp-common-perl libscope-guard-perl libsql-abstract-perl libtest-deep-perl libtest-file-sharedir-perl libtest-output-perl libtext-aligner-perl libtext-table-perl libtext-unidecode-perl libthrowable-perl
  libunicode-utf8-perl
Paquets suggérés :
  libmojolicious-perl libmoox-types-mooselike-numeric-perl libmoox-types-setobject-perl liblog-log4perl-perl

Non pas besoind e package zimbra pour faire du Mail::DMARC

@Zargos - désolé mais …

J’ai « expliqué » comment et pourquoi installer Mail::DMARC et Mail::BIMI dans l’OS… donc tu pourais sûrement et simplement l’installer, le configuré dans postfix etc…

Mais, j’essayé d’installer sur un Ubuntu 18.04 ou 20.04 qui sont les distributions style « Debian » compatible avec Zimbra Open Source Collaboration (donc, la version 8.6) comment-faire pour ajouter à Mail::SpamAssasin le plugin Mail::SpamAssasin::plugin::DMARC et donc au paravant installer MAIL:DMARC dans le sur programe Zimbra (qui utilise la version perl du système)

Cette version par exemple :

Release 8.8.15.GA.3869.UBUNTU18.64 UBUNTU18_64 FOSS edition, Patch 8.8.15_P41.

Zimbra Collaboration Network Edition - Secure Private Business Email &…

Ok merci, pour çà.

libmail-dmarc-perl/stable 1.20211209-4 all
  Perl implementation of DMARC

Bonne soirée.