Partager un dossier sur un réseau


#1

Bonjour,

Je cherche un moyen de partager facilement des dossiers de mon ordi avec les autres ordinateurs de mon appart.

Sur ubuntu, il y avait une option “partager ce dossier” et hop, ça apparaissait sur le réseau domestique. Mais je n’arrive pas à créer ce genre d’option sur debian.

Je n’ai pas besoin de m’embêter avec le partage vers des windows, les deux autres ordi ont Ubuntu et debian, ça devrait donc être plus simple ?

J’ai installé samba, mais pour le configurer c’est un autre problème, je me perds dans les documentations, je n’y comprend pas grand chose. Je sais à quoi je veut arriver : un clic droit sur un dossier, on le partage, un autre clic droit, on arrête de le partager :mrgreen: par contre comment arriver à ça, c’est un autre souci.

Quelqu’un peut-il me guider pas à pas, ou bien me donner le lien d’un “how to pour les vraiment nuls” ? :smiley:
Il doit y avoir un utilitaire sur ubuntu/gnome qui rend cette démarche aussi facile, mais pour l’instant je n’ai rien trouvé. En plus j’ai pas gnome :confused: ça aide pas :083


#2

À chaque fois que je veux installer un partage de dossier, avec Samba, je galère, le fichier de conf est très “sale” (c’est mon avis) et les différents soft qui devraient te faciliter la vie ne peuvent pas se sentir :wink: mais pour ce qui est du “clic-droit” pour partager, il faut installer le paquet “nautilus-share” grâce à lui tu retrouveras tes vieilles habitudes :wink:


#3

Il était déjà installé, mais du coup j’ai poussé dans cette direction-là. Grâce à ce sujet, forum.ubuntu-fr.org/viewtopic.php?id=431099 , j’ai vu que certains paquets n’étaient pas installés. Je n’ai pas installé gnome-system-tools, qui installe de tout et en particulier des trucs dont je ne veux pas, mais il me manquait python-smbc et smbclient, que j’ai donc installé. Une fois l’ordinateur redémarré, j’ai effectivement l’option qui apparait !

Sujet résolu donc. Merci beaucoup ! :023


#4

Heu en fait, presque résolu. :blush:

Quand je veux partager, voici ce qui est mis comme erreur : « net usershare » a retourné l'erreur 255 : [2011/01/17 16:59:31.890815, 0] param/loadparm.c:7588(lp_do_parameter) Ignoring unknown parameter "domain admin group" [2011/01/17 16:59:31.890958, 0] param/loadparm.c:8366(set_server_role) Server's Role (logon server) conflicts with share-level security net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Permission non accordée You do not have permission to create a usershare. Ask your administrator to grant you permissions to create a share.

Je dirais que le problème vient du fait que l’utilisateur “lylyrian” n’est pas dans le groupe ayant les droits pour partager ? Mais c’est quel groupe ?


#5

Bonjour à tous,

Cette conversation date un peu, mais j’avais le même soucis sur une installation toute fraiche de Debian Wheezy.

J’ai rajouté mon utilisateur dans le groupe sambashare e cela m’a permis de faire les partages via le simple clique sous Gnome : je ne sais pas si c’est la bonne/unique solution mais ça a fonctionné dès que je me suis déconnecté puis reconnecté sous Gnome

Si ça peut servir à d’autres :slightly_smiling:


#6

Salut,
Va voir dans /usr/share/doc/nautilus-share, il me semble que l’auteur décrit une procédure (commande à entrer dans un terminal) pour créer un smb.conf adapté.

Edit

Ca y est j’ai retrouvé, je copie/colle :

[code]nautilus-share for Debian

A quick and easy way to have it running (must be done as root):

#export USERSHARES_DIR="/var/lib/samba/usershares"
#export USERSHARES_GROUP=“sambashare”
#mkdir ${USERSHARES_DIR}
#groupadd ${USERSHARES_GROUP}
#chown root:${USERSHARES_GROUP} ${USERSHARES_DIR}
#chmod 01770 ${USERSHARES_DIR}
#mv /etc/samba/smb.conf{,.bak}
#cp /usr/share/doc/nautilus-share/examples/smb.conf /etc/samba/
#/etc/init.d/samba restart

You must add users who can share folder in the usershare group, in this example the group is “sambashare”:

#usermod -a -G sambashare your_username

– Chow Loong Jin <hyperair@gmail.com Tue, 17 Mar 2009 11:48:18 +0800[/code]


#7

En gros, RTFM quoi :mrgreen:


#8

bah, ça me parait difficile de faire plus clair !!!
Encore faut-il que cela résolve son pb ; et ça c’est pas dit :unamused:


#9

[quote=“jul”]bah, ça me parait difficile de faire plus clair !!!
[/quote]

C était mon auto critique :slightly_smiling:


#10

salut

par exempel avec adduser machin sambashare
pareil ca marche ( ne pas oublier de se déconnecter/reconnecter )