# Problème avec authentification Squid -\> impossible de se connecter

**URL:** <https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493>\
**Category:** Support Debian\
**Created:** [Décembre 7, 2020, 9:32 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493 "2020-12-07T21:32:49Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![SofianeLasri](https://www.debian-fr.org/user_avatar/www.debian-fr.org/sofianelasri/32/5589_2.png) [@SofianeLasri](https://www.debian-fr.org/u/SofianeLasri)\
**Post date:** [Décembre 7, 2020, 9:32 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493/1 "2020-12-07T21:32:49Z")

</div>

Bonjour/Bonsoir, je viens d’installer un serveur Squid sur mon serveur dédié (nan pas celui qui est chez moi pour ceux qui on vu mon précédent post), en suivant [ce tutoriel](https://linuxize.com/post/how-to-install-and-configure-squid-proxy-on-ubuntu-18-04/). Si je ne met pas d’authentification, ça marche bien. Si par contre je l’active, la fenêtre de connexion ne cesse d’apparaître et j’ai cette erreur dans les logs: TCP\_DENIED/407 4252 CONNECT [exemple.net:443](http://exemple.net:443) - HIER\_NONE  
Voici la partie de ma configuration responsable de l’authentification :

```
auth_param basic program /usr/lib/squid3/basic_ncsa_auth /etc/squid/htpasswd
auth_param basic realm proxy
acl authenticated proxy_auth REQUIRED
#
# Recommended minimum Access Permission configuration:
#
# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# Only allow cachemgr access from localhost
http_access allow localhost manager
http_access deny manager

```

Je n’ai modifié rien d’autre que http\_port monip:1234 dans le fichier de configuration.  
Quelqu’un saurait m’aider?

Merci d’avance! 😃

---

<div class="post-metadata">

**Author:** ![PascalHambourg](https://www.debian-fr.org/user_avatar/www.debian-fr.org/pascalhambourg/32/5837_2.png) [@PascalHambourg](https://www.debian-fr.org/u/PascalHambourg)\
**Post date:** [Décembre 7, 2020, 10:33 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493/2 "2020-12-07T22:33:33Z")

</div>

Où est-il question de LDAP là-dedans ?

---

<div class="post-metadata">

**Author:** ![SofianeLasri](https://www.debian-fr.org/user_avatar/www.debian-fr.org/sofianelasri/32/5589_2.png) [@SofianeLasri](https://www.debian-fr.org/u/SofianeLasri)\
**Post date:** [Décembre 8, 2020, 7:15 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493/3 "2020-12-08T07:15:28Z")

</div>

Ah mince je croyais que LDAP c’était l’authentification. 😅

---

<div class="post-metadata">

**Author:** ![SofianeLasri](https://www.debian-fr.org/user_avatar/www.debian-fr.org/sofianelasri/32/5589_2.png) [@SofianeLasri](https://www.debian-fr.org/u/SofianeLasri)\
**Post date:** [Décembre 8, 2020, 8:48 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493/4 "2020-12-08T08:48:32Z")

</div>

J’ai simplifié mon fichier config, ça ne marche toujours pas ☹

```
# acls
### local net
acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines

### safe ports
acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

#set squid port
http_port monip:3128

hierarchy_stoplist cgi-bin ?

forwarded_for delete

# authentification with username and password
auth_param basic program /usr/lib/squid3/basic_ncsa_auth /etc/squid/htpasswd
acl foo proxy_auth REQUIRED
http_access allow foo

## disable ident lookup
ident_lookup_access deny all

# last rule to block all without other valid rule
http_access deny all
```

---

<div class="post-metadata">

**Author:** ![SofianeLasri](https://www.debian-fr.org/user_avatar/www.debian-fr.org/sofianelasri/32/5589_2.png) [@SofianeLasri](https://www.debian-fr.org/u/SofianeLasri)\
**Post date:** [Décembre 8, 2020, 8:53 UTC](https://www.debian-fr.org/t/probleme-avec-authentification-squid-impossible-de-se-connecter/83493/5 "2020-12-08T08:53:26Z")

</div>

Ah j’ai trouvé, en fait il faut utiliser un nom d’utilisateur et un mot d’une longueur maximale de 8 caractères (c’est un peu débile je trouve).
