Problème lors d'un apt-get install php-zip

php
apt
Tags: #<Tag:0x00007fdf1db1ed20> #<Tag:0x00007fdf1db1ebe0>

#21

En fait, seulement les extensions php téléchargés via sury sont détectés par “Moodle”, or l’extension php-zip ne veut pas être téléchargé.


#22

A ta place je désinstallerais l’ensemble des paquets venant du dépôts sury et je repartirais qu’avec du Debian.


#23

Je confirme ce qui a été dit plus haut. J’ai installé un serveur moodle au travail, les dépôts Debian officiels sont suffisants.
Pour php-zip, si tu le vois dans le répertoire /etc/php/7.0/mods-available/, un petit phpenmod zip et c’est réglé.
La liste des paquets installés contenants ‘php’ sur mon installation:

dpkg -l | grep php
ii  libapache2-mod-php7.0         7.0.33-0+deb9u1                amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  php                           1:7.0+49                       all          server-side, HTML-embedded scripting language (default)
ii  php-cli                       1:7.0+49                       all          command-line interpreter for the PHP scripting language (default)
ii  php-common                    1:49                           all          Common files for PHP packages
ii  php-curl                      1:7.0+49                       all          CURL module for PHP [default]
ii  php-fpm                       1:7.0+49                       all          server-side, HTML-embedded scripting language (FPM-CGI binary) (default)
ii  php-gd                        1:7.0+49                       all          GD module for PHP [default]
ii  php-intl                      1:7.0+49                       all          Internationalisation module for PHP [default]
ii  php-mbstring                  1:7.0+49                       all          MBSTRING module for PHP [default]
ii  php-mysql                     1:7.0+49                       all          MySQL module for PHP [default]
ii  php-soap                      1:7.0+49                       all          SOAP module for PHP [default]
ii  php-xml                       1:7.0+49                       all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
ii  php-xmlrpc                    1:7.0+49                       all          XMLRPC-EPI module for PHP [default]
ii  php-zip                       1:7.0+49                       all          Zip module for PHP [default]
ii  php7.0                        7.0.33-0+deb9u1                all          server-side, HTML-embedded scripting language (metapackage)
ii  php7.0-cli                    7.0.33-0+deb9u1                amd64        command-line interpreter for the PHP scripting language
ii  php7.0-common                 7.0.33-0+deb9u1                amd64        documentation, examples and common module for PHP
ii  php7.0-curl                   7.0.33-0+deb9u1                amd64        CURL module for PHP
ii  php7.0-fpm                    7.0.33-0+deb9u1                amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
ii  php7.0-gd                     7.0.33-0+deb9u1                amd64        GD module for PHP
ii  php7.0-intl                   7.0.33-0+deb9u1                amd64        Internationalisation module for PHP
ii  php7.0-json                   7.0.33-0+deb9u1                amd64        JSON module for PHP
ii  php7.0-mbstring               7.0.33-0+deb9u1                amd64        MBSTRING module for PHP
ii  php7.0-mysql                  7.0.33-0+deb9u1                amd64        MySQL module for PHP
ii  php7.0-opcache                7.0.33-0+deb9u1                amd64        Zend OpCache module for PHP
ii  php7.0-readline               7.0.33-0+deb9u1                amd64        readline module for PHP
ii  php7.0-soap                   7.0.33-0+deb9u1                amd64        SOAP module for PHP
ii  php7.0-xml                    7.0.33-0+deb9u1                amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
ii  php7.0-xmlrpc                 7.0.33-0+deb9u1                amd64        XMLRPC-EPI module for PHP
ii  php7.0-zip                    7.0.33-0+deb9u1                amd64        Zip module for PHP

#24

Ah ben j’étais pas loin.