[RESOLU] Problème avec la touche AltGr


#1

Bonjour,

Je suis en train de sombrer dans la folie… :smiling_imp:

Cela fait un petit temps maintenant que j’ai remarqué avoir “perdu” mon altgr et par la même occasion les caractères @][´` {}, ce qui est assez problématique quand on doit travailler sous latex…

J’ai déjà essayé de tout et je sais que cette touche a déjà fonctionnée par la passé. J’ai googelé pendant ±4 hr et je me suis rendu compte que pas mal de gens avaient le problème mais les solutions parlaient d’un fichier XF86… que je ne retrouve pas sur ma machine.

Je travaille sous kubuntu (3.5.1) sur un intel840 et via freenx et client nx sous win…

Quel fichier log dois-je regarder, que dois-je faire ??
Merci pour votre aide

Windmill


#2

le fichier de conf de X est dispo dans /etc/X11

Il se nomme Xorg.conf sous kubuntu.

Remplacez le keymap pc104 par pc105 pour résoudre le problème!


#3

[quote=“ed”]le fichier de conf de X est dispo dans /etc/X11

Il se nomme Xorg.conf sous kubuntu.

Remplacez le keymap pc104 par pc105 pour résoudre le problème![/quote]

Ok merci concernant le clavier je dois donc bien obtenir :
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "be"
EndSection
OK, Merci beaucoup çà à l’air de marcher !!!


#4

[quote=“windmill”]Bonjour,

Je suis en train de sombrer dans la folie… :smiling_imp:

çà continue …

Windmill[/quote]

En fait, en paufinant, j’ai remarqué quelques petites choses :

Malgré que le problème semblait résolu là tantôt, çà recommance maintenant :

  • Quand je travaille sous kate ou kile, AltGr se comporte comme un ctrl “qui reste collé” jusqu’à ce que je puisse le libérer en appuyant sur ctrl
  • Quand je travaille sous Write (open office) il n’y a aucun problème !!!

Quel est donc ce fichu problème qui me pourrit la vie

Merci pour toute aide.


#5

Le layout belge, tu es sûr que c’est francophone ?
il est loin du layout français ?
ou suisse francophone ?
tu peux peut être regarder avec un layout proche, déjà, non ?

Sinon, fondamentalement, un AltGR, c’est l’équivalent d’appuyer ctrl+alt, alors peut être que kate ne retient qu’une partie du couple (le alt, par exemple, qui activerait les menus).


#6

[quote=“MattOTop”]Le layout belge, tu es sûr que c’est francophone ?
il est loin du layout français ?
ou suisse francophone ?
tu peux peut être regarder avec un layout proche, déjà, non ?

Sinon, fondamentalement, un AltGR, c’est l’équivalent d’appuyer ctrl+alt, alors peut être que kate ne retient qu’une partie du couple (le alt, par exemple, qui activerait les menus).[/quote]

J ai un peu essaye 5 cest pourquoi j ecris bizzarement- mais ca ne donne rien

voici les 2 possibilites que jai essaye mais aucune ne fonctionne quelle misere
Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "be2-latin1"
Option “RightAlt” "ModeShift"
EndSection

#Section “InputDevice”

Identifier “Generic Keyboard”

Driver “kbd”

Option “CoreKeyboard”

Option “XkbRules” “xorg”

Option “XkbModel” “pc105”

Option “XkbLayout” “be” ou fr

#EndSection


#7

ben à priori (discussion ici )
il y a ‘fr_BE@euro’ => { LAYOUT => ‘be’, XKBOPTIONS => ‘’ },
donc à priori, pour un locale belge avec le symbole euro (que tu peux reconfigurer avec ‘dpkg-reconfigure locales’), il suffit de configurer presque comme tu l’avais fait quand “ça avait l’air de marcher”:[code]Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option “XkbRules” “xorg”

Option “XkbModel” “pc105”

Option “XkbLayout” "be"
EndSection [/code]
sinon, si tu as le courage de compter tes touches :laughing: , à peine 104 ou 105…


#8

[quote=“MattOTop”]
donc à priori, pour un locale belge avec le symbole euro (que tu peux reconfigurer avec ‘dpkg-reconfigure locales’), il suffit de configurer presque comme tu l’avais fait quand “ça avait l’air de marcher”:

sinon, si tu as le courage de compter tes touches :laughing: , à peine 104 ou 105…[/quote]
Pour ce qui est de dpkg-reconfure locales (et je ne suis pas sur d’avoir compris les commentaires du lien que tu m’as fourni), j’ai essayé mais çà n’a rien donné et je ne sais malheureusement pas comment c’était avant …

Pour ce qui est des touches, çà ne donne rien que j’utilise 104 ou 105…

Une autre idée? Quel autre fichier serait susceptible de devoir être remodifié ?
Quel .log file dois je regarder pour remarquer s’il y a une erreur ?

Merci encore !

Windmill


#9

[quote=“windmill”]

autres idées
Windmill[/quote]

Finalement , j’ai réussi à trouver l’erreur et configurer la bête:

le client windows nomachine envoie de manière standard une configuration clavier de 102 touches, je n’ai pas encore réussi à modifier çà mais apparemment le problème se résoud également si on configure le xorg.conf de la manière suivante :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "xkb"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbGeometry” "pc(pc105)"
Option “XkbLayout” "be"
Option “RightAlt” "ModeShift"
EndSection

Je crois mais je vais arrêter de chercher que c’est l’option RightAlt qui fait la différence !

Voilà bonne soirée et merci pour l’aide et les idées !