Stretch 9.1 à 9.9 Erreur DRM ACPI systématique au démarrage


#1

RÉSOLU EN RÉTROGRADANT LE NOYAU de 4.9 à 4.14 (décrit sur ERROR DRM ACPI, AFFICHAGE SACCADÉ ou TEARING intel graphics i915 (Intel Corporation HD Graphics 530) avec PC-durci nuvo 5002 (et avec un nuvo 1005) sans améliorer les problèmes d’affichages)

peut être une “piste”


Detailed Description
This file contains the latest XFree86* accelerated X Windows server and required Linux* kernel modules (AGP GART and DRM) for the Intel® 82830M, 82845G, 82852GM, 82855GM, 82865G, and 82915G graphics controller-based products.

Intel does not guarantee functionality on any specific Linux distribution.

Voici le message que j’ai au démarrage, dans un ordinateur nuvo 5002 mais aussi un nuvo 1005
Cela depuis la version 9.1 sauf erreur (depuis environ 1 ans). Mon écran est mal géré (seulement 60Hz comme un écran LCD de portable), et l’accélération matérielle est mal gérée aussi (seulement par quelqes logiciels: chromium, VLC, Mv player). La qualité s’est dégradée à la dernière mise à jour (moins bonne gestion de l’affichage, tearing apparu avec chrome sur les vidéos)
J’ai tenté de démarer avec d’autre gestionnaire de connexion mais ils plantent à la gestion graphique en laissant un curseur non réactif: seul gdm3 accepte de démarrer la machine, mais gnome semble particulièrement restrictif quant à la personalisation.

[    2.812312] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.812323] EDID block is all zeroes
[    2.815918] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.815928] EDID block is all zeroes
[    2.819467] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.819473] EDID block is all zeroes
[    2.823045] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.823053] EDID block is all zeroes

[    0.019586] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[    0.019771] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[    0.019936] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[    0.021036] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)

impossible de compiler le pilote xf86-video-intel-2.99.917
(il manque toujours quelque chose
configure: error: Package requirements (xorg-server >= 1.6 xproto fontsproto pixman-1 >= 0.24 ) were not met:

No package 'xorg-server' found
No package 'fontsproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Mon installation debian n’a jamais été finalisée, mais voulant faire de la vidéo j’ai maintenant besoin de réparer quelques fonctions de base

  • ajuster le frame rate de l’écran à un des 3 standards vidéos (multiple de 24, de 25 ou de 30 images par seconde), je n’ai que 60Hz, mon écran n’a JAMAIS été recconu (alors qu’il l’était parfaitement avec des anciennes versions de debian (Jessie, et antérieures)
  • pouvoir accéder en streaming à des vidéos sans saccades (arrêts du défilement d’images, sauts) ou sans tearing (déchirement d’images car pas de syncro vertical), seul chromium accède à internet en lisant les vidéo sans streaming ni saccade mais est limité à 1080p (VLC 720p), j’ai besoin du 1440p chrome (car chromium bridé 1080p), chrome n’est plus fluide depuis le dist-upgrade de 9.1 à 9.9 (présence de tearing, avec toutes les versions de chromes précédentes aussi en test downgrade) et fire fox a toujours fait du tearing.
    Avec les anciennes versions de debian (2007 à 2014), je ne connaissait pas ces problèmes: c’était parfaitement géré en vidéo enregistré, mais n’avait pas la connexion pour le remarquer sur internet.
    TEARING RÉSOLU MAIS SUBSISTE UN PROBLÈME GÉNÉRALISÉ DE BUFFER qui ne se prduisait pas avant le dist-upgrade (donc de sauts d’images) il fallait seulement activer l’option TearFree et rien d’autre (en fait si rien d’autre précisé, la méthode (et les symptômes) sont ceux de “SNA”

Je me suis aperçu aussi que la simple existence du fichier X11/xorg.conf.d/xorg.conf.d/20-intel.conf implique le bruit associé à des problèmes de sauts d’images (buffert vidéo) avec seulemennt **
** Section "Device

** Identifier “Intel Graphics”**
** EndSection**
introduit un problème de buffer vidéo: saccades associées à un bruit dans l’alimentation de courant et activer m’option “triplebuffer” (écris de mémoire syntaxte ici douteuse) augmente ces sauts

pour faire fichier d’essai
mkdir /etc/X11/xorg.conf.d/
echo -e ‘Section “Device”\n Identifier “Intel Graphics”\n Driver “Intel”\n# Option “AccelMethod” “uxa”\n# Option “AccelMethod” “sna”\n Option “TearFree” “true”\n# Option “SwapbuffersWait” “true”\n# Option “VSync” “true”\n# Option “DRI” “2”\nEndSection’ | tee /etc/X11/xorg.conf.d/20-intel.conf

ÉCRAN seulement 50Hz (pas recconu comme externe, modèle pas reconnu…
j’ai passé une semaine à chercher partout et je me sens seul avec ce problème

  • beaucoup de gens ne remarquent même pas le décalage 60Hz 50Hz sur les média et s’en contrefichent
  • beaucoup s’accomodent du tearing ou ne savent pas ce que c’est (il faut un mot pour désigner)
    mais on en parle beaucoup plus en langage rose-beef du coup j’ai trouvé chez les mangeurs de chiens chauds.
  • rares sont ceux finalement qui travaillent en vidéo avec linux, la plupart lisent et codent, expérimentent… Après avoir bien cherché, j’apprend que les vidéastes s’embêtent pas à chercher des solution de ce coté: ils oublient tout simplement l’idée de bosser avec linux: ils n’ont pas le temps de faire de l’informatique, et sont plutôt sur Mac. C’est dommage pour Linux (il semble aussi que Da Vinci Code qui fait fureur ne sait pas lire le extfs)
    Je pense donc que ce problème que je soulève concerne beaucoup plus de machines qu’il parait.

ERROR DRM ACPI, AFFICHAGE SACCADÉ ou TEARING intel graphics i915 (Intel Corporation HD Graphics 530) avec PC-durci nuvo 5002 (et avec un nuvo 1005)
#2

le dowgrade noyau 4.19 n’affiche plus les erreurs DRM au démarage.
mais j’ai
[    3.198610] i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_27.bin (-2)
[    3.198614] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware                                                                                                  
[    3.198616] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_27.bin failed with error -2

tearing dans chrome, pas dans chromiun, pas dans les lecteurs tel MV-player


#3

Ca ne mange pas de pain de vérifier l’install de firmware-misc-nonfree (i915)

Moi je dis rien, mais j’observe tes efforts.

Ou compiler un noyau 5, pour voir ?


#4

il manque en effet le firmware désiré.

Je me méfie de la fuite en avant: mon matériel est “ancien” et semble “oublié” dans cette course en avant depuis quelques temps, je tente d’abord de revenir aux programmes de l’époque qui marchaient avec.
curl -o /lib/firmware/i915/skl_dmc_ver1_27.bin https://raw.githubusercontent.com/wkennington/linux-firmware/master/i915/skl_dmc_ver1_27.bin

je n’ai plus l’erreur au chargement sauf un truc qui ne semble pas concerner le problème graphique dmesg -l err          
[    0.792260] serial 0000:00:16.3: Couldn’t register serial port 4080, irq 19, type 0, error -28

rien de changé

essai de

#  mkdir /etc/X11/xorg.conf.d/
# echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "TearFree" "true"\nEndSection' | tee /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
 Identifier "Intel Graphics"
 Driver "Intel"
 Option "TearFree" "true"
EndSection

ÇA NE MARCHE PAS suppression du tearing, mais accrochages avec bruit dans l’alim pour tout logiciel lisant de la vidéo en plein-écran (problème de buffer vidéo associé à une pointe de consommation de courant), ce qui est flagrant, c’est le fonctionnement correct de VLC, mais seulement si le curseur ou le pointeur de la souris est visible, des que le curseur disparaît ça accroche (en mode plein écran en affichant l’image plus le curseur ça marche, donc ça pourrait le faire pour l’image seule). Quelque chose “à été mis à jour” et ne semble plus compatible avec mon matériel

apt-upgrade propose le linux-image-4.9.0-8-amd64 qui a bien fait ses preuves en error ACPI et DRM , tout comme le linux-image-4.9.0-9-amd64 (c’est bizarre d’ailleurs que ce n’est plus le inux-image-4.9.0-9-amd64 qui est proposé, et j’ai marqué mon noyau (le premier qui ne fait pas d’erreur au démarage) en hold (linux-image-4.19.0-0.bpo.4-amd64) mais apt upgrade ne semble pas en tenir compte.

pour info
liste des noyaux dedians

-rw-r--r-- 2 dak debadmin 356164776 May  8  2018 linux-image-3.16.0-6-amd64-dbg_3.16.56-1+deb8u1_amd64.deb
-rw-r--r-- 2 dak debadmin  34509484 May  8  2018 linux-image-3.16.0-6-amd64_3.16.56-1+deb8u1_amd64.deb
-rw-r--r-- 2 dak debadmin  34464912 May  8  2018 linux-image-3.16.0-6-amd64_3.16.56-1+deb8u1_i386.deb
-rw-r--r-- 2 dak debadmin 650813232 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-amd64-dbg_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin  46469070 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-amd64-unsigned_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin 199098066 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-cloud-amd64-dbg_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin  14923312 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-cloud-amd64-unsigned_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin 649628542 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-rt-amd64-dbg_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin  46492632 Mar 31 19:31 linux-image-4.19.0-0.bpo.4-rt-amd64-unsigned_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin 715884396 Mar 15 19:28 linux-image-4.19.0-4-amd64-dbg_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin  46692924 Mar 15 19:28 linux-image-4.19.0-4-amd64-unsigned_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin 220068664 Mar 15 19:28 linux-image-4.19.0-4-cloud-amd64-dbg_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin  14954584 Mar 15 19:28 linux-image-4.19.0-4-cloud-amd64-unsigned_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin 713710564 Mar 15 19:28 linux-image-4.19.0-4-rt-amd64-dbg_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin  46723072 Mar 15 19:28 linux-image-4.19.0-4-rt-amd64-unsigned_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin 715403896 May 15 00:30 linux-image-4.19.0-5-amd64-dbg_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin 715442272 May 16 12:14 linux-image-4.19.0-5-amd64-dbg_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin  46628468 May 15 00:30 linux-image-4.19.0-5-amd64-unsigned_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin  46644884 May 16 12:14 linux-image-4.19.0-5-amd64-unsigned_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin 219840696 May 15 00:30 linux-image-4.19.0-5-cloud-amd64-dbg_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin 219830768 May 16 12:14 linux-image-4.19.0-5-cloud-amd64-dbg_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin  14951364 May 15 00:30 linux-image-4.19.0-5-cloud-amd64-unsigned_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin  14951064 May 16 12:14 linux-image-4.19.0-5-cloud-amd64-unsigned_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin 713089392 May 15 00:30 linux-image-4.19.0-5-rt-amd64-dbg_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin 713082156 May 16 12:14 linux-image-4.19.0-5-rt-amd64-dbg_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin  46655972 May 15 00:30 linux-image-4.19.0-5-rt-amd64-unsigned_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin  46637744 May 16 12:14 linux-image-4.19.0-5-rt-amd64-unsigned_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin 573176278 Feb 19 23:29 linux-image-4.9.0-8-amd64-dbg_4.9.144-3.1_amd64.deb
-rw-r--r-- 2 dak debadmin  39127992 Feb 19 23:29 linux-image-4.9.0-8-amd64_4.9.144-3.1_amd64.deb
-rw-r--r-- 2 dak debadmin 572218064 Feb 19 23:29 linux-image-4.9.0-8-rt-amd64-dbg_4.9.144-3.1_amd64.deb
-rw-r--r-- 2 dak debadmin  39112138 Feb 19 23:29 linux-image-4.9.0-8-rt-amd64_4.9.144-3.1_amd64.deb
-rw-r--r-- 2 dak debadmin 573455526 Apr 14 17:28 linux-image-4.9.0-9-amd64-dbg_4.9.168-1_amd64.deb
-rw-r--r-- 2 dak debadmin  39171740 Apr 14 17:28 linux-image-4.9.0-9-amd64_4.9.168-1_amd64.deb
-rw-r--r-- 2 dak debadmin 572364812 Apr 14 17:28 linux-image-4.9.0-9-rt-amd64-dbg_4.9.168-1_amd64.deb
-rw-r--r-- 2 dak debadmin  39144432 Apr 14 17:28 linux-image-4.9.0-9-rt-amd64_4.9.168-1_amd64.deb
-rw-r--r-- 2 dak debadmin 730248932 Mar 19 05:00 linux-image-5.0.0-trunk-amd64-dbg_5.0.2-1~exp1_amd64.deb
-rw-r--r-- 2 dak debadmin  46872424 Mar 19 05:00 linux-image-5.0.0-trunk-amd64-unsigned_5.0.2-1~exp1_amd64.deb
-rw-r--r-- 2 dak debadmin 230213948 Mar 19 05:00 linux-image-5.0.0-trunk-cloud-amd64-dbg_5.0.2-1~exp1_amd64.deb
-rw-r--r-- 2 dak debadmin  15317792 Mar 19 05:00 linux-image-5.0.0-trunk-cloud-amd64-unsigned_5.0.2-1~exp1_amd64.deb
-rw-r--r-- 2 dak debadmin    474376 Mar 15 19:28 linux-image-amd64-signed-template_4.19.28-2_amd64.deb
-rw-r--r-- 2 dak debadmin    476564 Mar 31 19:31 linux-image-amd64-signed-template_4.19.28-2~bpo9+1_amd64.deb
-rw-r--r-- 2 dak debadmin    519868 May 15 00:30 linux-image-amd64-signed-template_4.19.37-2_amd64.deb
-rw-r--r-- 2 dak debadmin    519920 May 16 12:14 linux-image-amd64-signed-template_4.19.37-3_amd64.deb
-rw-r--r-- 2 dak debadmin    461624 Mar 19 05:00 linux-image-amd64-signed-template_5.0.2-1~exp1_amd64.deb

J’ai choisi
http://ftp.debian.org/debian/pool/main/l/linux/linux-image-4.19.0-0.bpo.4-amd64-dbg_4.19.28-2~bpo9+1_amd64.deb

APT-MARK HOLD ne semble pas protéger d’une mise à jour accidentelle (je désire figer thunderbird et le noyau) le noyau risque d’être mis à jour.

apt-mark hold linux-image-4.19.0-0.bpo.4-amd64

linux-image-4.19.0-0.bpo.4-amd64 était déjà marqué comme figé (« hold »).

apt upgrade

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances        
Lecture des informations d’état… Fait
Calcul de la mise à jour… Fait
Les paquets suivants ont été conservés :
 thunderbird
Les paquets suivants seront mis à jour :
 linux-image-4.9.0-8-amd64
1 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 39,1 Mo dans les archives.
Après cette opération, 143 ko d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]


#5

Attention: ça te fige linux-image-4.19.0-0.bpo.4-amd64 à la version que tu as installée (4.19.28-2~bpo9+1), mais ça n’empêche pas l’installation ou la mise à jour d’autres versions de noyau comme la 4.9.0-8 que l’upgrade te propose de faire.


#6

justement la 4.9.0-8 après la 4.9.0-9 j’en reviens: le dist-upgrade depuis la version antérieure à 4.9.08 m’a fait perdre le fonctionnement correct en lecture vidéo que je cherche depuis à refaire fonctionner comme avant.
que cela apporte t’-il de faire l’installation ou la mise à jour d’autres versions de noyau en figeant à linux-image 4.19, c’est le choix du démarage?
Mais alors si les noyaux sont mis à jour même en gardant le même nom… ça expliquerait que je ne retrouve plus le bon fonctionnement en essayant les “anciens”, ils sont “patchés”?


#7

Attention, par défaut, le systéme choisira de booter sur la version avec le plus haut numéro d’ordre, pas le dernier que tu as installé.

C’est possible que le dépot de securité en ai servi des mises à jours ajustées.


#8

finalement que le firmware soit chargé ou non ne change absolument rien à la gestion graphique, comme si c’était un autre programme du desktop qui gérait l’accélération matérielle (dans gnome?, Mate, LXde, ou gdm3 en amont), et peut être l’écran (donc l’ignoration totale d’autres modelines que je pourrais activer avec Xrand). Par contre je n’avais jamais pu démarrer un autre gestionnaire de connexion que gdm3 (écran noir), je vais donc tenter le de le refaire puisque le pilote est chargé sans erreur.

gdg
Intel 830M/845G/852GM/855GM/865G/915G Driver
I386
20040604
gdg

Le pilote qu’on trouve chez le site d’Intel est un fossile, même pas pour un amd64

Sur unbutu ils sont aussi le problème avec la mise à jour récente
https://forum.ubuntu-fr.org/viewtopic.php?id=2026018


#9

sous Cinnamon Le pilote graphique gère à la fois firefox, chrome, chromium , MV-player, VLC, dragon player, TOUT MARCHE même en lisant des vidéos bien plus grosse que l’écran

Sous MATE, non, en démarrant avec sdm cette fois (LXDE je ne sais pas encore), c’est peut être Mate qui chie.

vérifié avec

uname -a

Linux cilaos-centre-du-monde 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux

Ça fonctionne tout aussi bien sous Cinnamon
mais retour de ces erreurs

dmesg -l err

[ 0.019129] ACPI Error: [_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[ 0.019313] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[ 0.019476] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[ 0.020582] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)
[ 0.555874] serial 0000:00:16.3: Couldn’t register serial port 4080, irq 19, type 0, error -28
[ 3.130654] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.130664] EDID block is all zeroes
[ 3.137734] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.137744] EDID block is all zeroes
[ 3.141599] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.141607] EDID block is all zeroes
[ 3.145403] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.145411] EDID block is all zeroes


#10

sous Cinnamon Le pilote graphique gère à la fois firefox, chrome, chromium , MV-player, VLC, dragon player, TOUT MARCHE même en lisant des vidéos bien plus grosse que l’écran

Sous MATE, non, pareil qu’avant, en démarrant avec sdm cette fois (LXDE je ne sais pas encore), c’est peut être Mate qui chie: c’est peut être pas dans le noyau qu’il y a un pépin.

vérifié avec

uname -a

Linux cilaos-centre-du-monde 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux

Ça fonctionne tout aussi bien sous Cinnamon
mais retour de ces erreurs

dmesg -l err

[ 0.019129] ACPI Error: [_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[ 0.019313] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[ 0.019476] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[ 0.020582] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)
[ 0.555874] serial 0000:00:16.3: Couldn’t register serial port 4080, irq 19, type 0, error -28
[ 3.130654] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.130664] EDID block is all zeroes
[ 3.137734] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.137744] EDID block is all zeroes
[ 3.141599] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.141607] EDID block is all zeroes
[ 3.145403] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.145411] EDID block is all zeroes

il ya un pépin mais c’est pas la source des problèmes d’affichage semble-il


#11

"vous avez atteint le maximum de modifications, attendez 13 pour modifier"… ET BIN TANT PIS, je le colle à la suite.

sous Cinnamon Le pilote graphique gère à la fois firefox, chrome, chromium , MV-player, VLC, dragon player, TOUT MARCHE même en lisant des vidéos bien plus grosse que l’écran

Sous MATE, non, pareil qu’avant, en démarrant avec sdm cette fois (LXDE je ne sais pas encore), c’est peut être Mate qui chie: c’est peut être pas dans le noyau qu’il y a un pépin.

vérifié avec

uname -a

Linux cilaos-centre-du-monde 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux

Ça fonctionne tout aussi bien sous Cinnamon
mais retour de ces erreurs

dmesg -l err

[ 0.019129] ACPI Error: [_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[ 0.019313] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[ 0.019476] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[ 0.020582] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)
[ 0.555874] serial 0000:00:16.3: Couldn’t register serial port 4080, irq 19, type 0, error -28
[ 3.130654] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.130664] EDID block is all zeroes
[ 3.137734] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.137744] EDID block is all zeroes
[ 3.141599] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.141607] EDID block is all zeroes
[ 3.145403] [drm:drm_edid_block_valid [drm]] ERROR EDID has major version 0, instead of 1
[ 3.145411] EDID block is all zeroes

i
l ya un pépin mais c’est pas la source des problèmes d’affichage semble-il


#12

"vous avez atteint le maximum de modifications, attendez 13 pour modifier" (pour supprimer les doublons avec la corbeille… ET BIN TANT PIS, il y aura donc 3 messages presque pareils à la suite.


#13

avec le dernier noyau 4.9 09, je retrouve les sauts d’images sur VLC et MVplayer, bien que sous cineadon chrome lit les vidéo correctement.


#14

Avec le 4.19 pas de message d’erreur, et ça le fait parfois (saut d’image) mais rarement (avec mv-player), un appui sur la touche space (pause) et relancer peut le resynchroniser, sans résoudre complètement le problème avec l’option tearfree, c’est beaucoup moins flagrant qu’avec le noyau 4.9, donc ça joue également sur la performance vidéo même si ça ne semble pas “dans le principe” cela. Les navigateurs fonctionnent bien.


#15

je vais dire un lieu commun puisque tu l’as découvert :
passer au dernier noyau backports de stretch arrange parfois les choses .
mais passer du noyau 4.9.0-9 au noyau 4.19.0-0.bpo.4 (ou 5 sais plus) ,
ce n’est pas downgrader mais upgrader son noyau .


#16

le 4.19 est plus récent?!


#17

Ben oui: 4.19 > 4.9, donc oui, 4.19 est la version arrivée la dernière.
Sinon, je tourne en buster avec un noyau 5.0 compilé depuis kernel.org, je ne sais pas si il réglera les glitchs, mais en tous cas pour moi, il fonctionne nickel.