Supprimer mise en veille écrans


#1

Salut,

J’ ai un petit soucis qui est assez embêtant, lorsque je ne touche ni à la souris ni au clavier mes écrans s’ éteignent au bout de 10 minutes.
C’ est assez gênant lorsque je regarde une vidéo.
J’ ai viré gnome-screensaver et bien mis la gestion d’ énergie à jamais pour tout ce qui est extinction écrans.
J’ ai fait une recherche avec screensaver et à première vue je n’ ai plus d’ économiseur d’ écran, j’ ai tenté en paramétrant vlc pour qu’ il coupe la veille mais nada, toute les 10 minutes je dois bouger la souris pour rallumer mes écrans :confused:


#2

Salut,
j’ai un problème qui ressemble au tien …
economiseur-d-ecran-et-wm-t32044.html


#3

Merci, j’ avais pas fait attention à ton soucis,
Ce qui est bizarre c’ est que toi sous gnome ça fonctionne alors que moi non et j’ ai pourtant tout désactivé et viré les écrans de veille.
C’ est sans doute le gestionnaire d’ énergie qui déconne chez moi, je vais tenter en le réinstallant(ou en le virant si possible)


#4

Salut,

C’est un probleme de dpms http://en.wikipedia.org/wiki/VESA_Display_Power_Management_Signaling
Plusieurs solutions:

Si tu veux le desactiver temporairement, sachant que ton écran ne s’éteindra plus

xset -display :0 s off -dpms #pour le desactiver
xset -display :0 s on +dpms #pour le reactiver

Autre solution que j’utilise:
Tu modifie/crée un xorg.conf avec

Section "ServerLayout"
        Option "blank time" "180" # Temps en minutes (pas testé avec 0 mais ca dois le desactiver)
                                  # Les configs du gestionnaire d'energie sont donc prises en compte
                                  # Si tu mets 10 min dans le gestionnaire ton ecran s'eteindra au bout de
                                  # 10 min et 180 min si tu mets desactivé
EndSection

Section "Monitor"
        Option      "DPMS" "true"
EndSection

Derniere solution non testée
Dans ton xorg.conf

Section "Monitor"
        Option      "DPMS" "false"
EndSection

#5

Merci :smiley:
Je test ça avant la fin de l’ après-midi (à ma prochaine pause :smiley: )


#6

Impeccable merci :smiley:

J’ ai testé et là ça n’ a pas fonctionné donc j’ ai mis la ligne de xset dans applications au démarrage :mrgreen:


#7

Bonjour,

Sous Debian 9, pour réveiller l’écran de veille, 1 fois sur 2, ça ne marche pas, l’ordinateur est bloqué.

Je cherche donc à désactiver l’écran de veille. Dans le terminal administrateur, j’ai essayé de coller

xset -display :0 s off -dpms

mais ça me répond :

xset:  unable to open display ":0"

Si quelqu’un peut m’aider, merci d’avance.
Laurent (débutant)


#8

Bonjour Komencanto

Essaye avec :

xset -display $DISPLAY s off -dpms

#9

Merci de chercher à m’aider, MicP. J’ai donc essayé “xset -display $DISPLAY s off -dpms” mais ça donne la même réponse :

No protocol specified
xset: unable to open display “:0”

Laurent (débutant)


#10

Bonsoir

Plutôt que d’utiliser le compte administrateur,
essaye d’entrer cette ligne de commande dans une fenêtre de terminal
du compte utilisateur qui a ouvert la session graphique :
sans doute tout simplement, ton compte utilisateur.


#11

Rebonsoir, MicP,
et merci beaucoup : ça fonctionne dans le terminal utilisateur.

Je copie-colle et, même sans valider par “entrée”, aussitôt l’invite de commande se remet sur la ligne suivante, sans confirmation qu’il y a eu de l’effet, mais ça marche bien.

Donc maintenant, ça ne se met plus en veille… donc plus de problème de réveil !

Encore merci pour l’aide et la rapidité ! Cordialement, Laurent

Ajout : l’inconvénient (petit), c’est que quand on éteint l’ordinateur, il oublie et il faut refaire la manip au rallumage !