Forum debian-fr.org

Rechercher:

* Connexion   * M’enregistrer

* FAQ    * Rechercher





Poster un nouveau sujet Répondre au sujet  [ 25 messages ] 
Auteur Message
MessagePosté: 02 Aoû 2012 09:55 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Bonjour à tous,

J'ai récemment installé Exim afin de pouvoir envoyer des E-mails à partir de ma machine via des outils implémentés en PHP. Je n'ai aucun souci, tout fonctionne correctement, les mails s'envoient et les destinataires reçoivent correctement leurs mails.

En revanche, lors de la configuration d'Exim, on m'a demandé un nom de domaine local ! J'ai mis un truc au pif ne pensant pas m'en servir, et je me rends compte que toutes les 30 minutes, j'ai un échec d'envoi de mail à l'adresse root@mondomainealacon.com. Je reçois ces mails d'erreur sur l'adresse "de contact" que j'ai renseignée (enfin je crois que c'est un truc du genre)...

Vous avez une idée d'où pourrait venir le problème ?

Merci par avance


Haut
 Profil  
 
MessagePosté: 04 Aoû 2012 19:17 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 07 Fév 2008 10:31
Messages: 335
Localisation: Ile de La Réunion
salut

n'utilise pas d’extension com, org, net ou tout autres extension connues à moins d'être le propriétaire de celui-ci

utilise

Citation:
root@mondomainealacon.loc
ou
Citation:
root@mondomainealacon.ici


bref à toi de voir

a+


Haut
 Profil  
 
MessagePosté: 08 Aoû 2012 09:21 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut !

Malheureusement même en faisant cela, je reçois toujours toutes les demies-heures un mail qui me dit que l'envoi n'a pas fonctionné... Je sais pas ce qu'il veut mais j'aimerais le désactiver car ça pourrit réellement la boîte !

Le fait que j'ai mis .loc au lieu de .com ne change rien;;;

Merci quand même


Haut
 Profil  
 
MessagePosté: 08 Aoû 2012 11:03 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 13 Juil 2006 19:37
Messages: 1669
essaye en mettant le nom de ta machine, sans extension en .com, .loc ou autre


Haut
 Profil  
 
MessagePosté: 08 Aoû 2012 13:20 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Hello !

Alors c'est exactement la même chose.
Y'a pas un moyen pur et simple de désactiver ce cron ?


Haut
 Profil  
 
MessagePosté: 08 Aoû 2012 16:01 
Hors ligne
Vraiment, particulièrement bavard(e)!
Avatar de l’utilisateur

Inscription: 13 Juil 2006 19:37
Messages: 1669
S'il t’envoie des mail c'est aussi parce que c'est utile.
Sinon met ton vrai nom de domaine, tes courrier arriveront bien et tu n'auras plus le message.


Haut
 Profil  
 
MessagePosté: 08 Aoû 2012 16:14 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Oui je suis bien d'accord, si il le fait c'est qu'il y a une raison...

En fait là les mails contiennent ceci en texte :


PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/msql.so' - /usr/lib/php5/20090626+lfs/msql.so: cannot open shared object file: No such file or directory in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/msql.so' - /usr/lib/php5/20090626+lfs/msql.so: cannot open shared object file: No such file or directory in Unknown on line 0

Donc bon, pas trop utile et très spammant mais bon je vais renseigner une autre adresse et voilà. En fait je sais même pas pourquoi cette erreur est envoyée...


Haut
 Profil  
 
MessagePosté: 11 Aoû 2012 19:45 
Hors ligne
Très bavard(e)!
Avatar de l’utilisateur

Inscription: 07 Fév 2008 10:31
Messages: 335
Localisation: Ile de La Réunion
salut

ta librairie mysql pour php est elle installée ??


Haut
 Profil  
 
MessagePosté: 13 Aoû 2012 14:29 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut !

Bah je ne vois pas pourquoi elle ne le serait pas. Disons que j'ai rien fait de "particulier" mis à part les installations PHP et MySQL sur le serveur... De plus toutes les fonctions mysql_query and co fonctionnent très bien en PHP


Haut
 Profil  
 
MessagePosté: 13 Aoû 2012 16:59 
Bonjour,

La référence manquante appartient au paquet php5-mysql (§ http://packages.debian.org/squeeze/i386/php5-mysql/filelist)
Ce paquet, est-il installé ?


Haut
  
 
MessagePosté: 16 Aoû 2012 11:16 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut,

Oui il est installé, y'avait juste une mise à jour à faire...


Haut
 Profil  
 
MessagePosté: 27 Sep 2012 16:08 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
je fais un petit up car mon problème persiste...

Merci à vous !


Haut
 Profil  
 
MessagePosté: 27 Sep 2012 19:19 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Salut,
Il faut régler les deux problèmes...

Commence par mysql.so.
Il y a quoi dans le répertoire /usr/lib/php5/20090626+lfs/ ?

Et que renvoie:
Code:
apt-cache policy php5-mysql

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 28 Sep 2012 08:27 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut !

Alors dans /usr/lib/php5/20090626+lfs/ il y a :

Citation:
-rw-r--r-- 1 root root 141336 19 août 2010 suhosin.so
-rw-r--r-- 1 root root 87588 6 août 22:24 pdo.so
-rw-r--r-- 1 root root 26116 6 août 22:24 pdo_mysql.so
-rw-r--r-- 1 root root 42352 6 août 22:24 mysql.so
-rw-r--r-- 1 root root 109220 6 août 22:24 mysqli.so

La commande me renvoie :

Citation:
php5-mysql:
Installé : 5.3.3-7+squeeze14
Candidat : 5.3.3-7+squeeze14
Table de version :
*** 5.3.3-7+squeeze14 0
500 http://security.debian.org/ squeeze/updates/main i386 Packages
100 /var/lib/dpkg/status
5.3.3-7+squeeze8 0
500 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages


Merci


Haut
 Profil  
 
MessagePosté: 28 Sep 2012 09:52 
Hors ligne
Grand posteur

Inscription: 12 Fév 2010 09:01
Messages: 133
Bonjour,

Il y a 2 choses à renseigner dans Exim : Le domaine pour laquelle la machine considère les mails comme une adresse locale (destination finale) et le domaine pour compléter les adresses locales (écrans 3 et 6 de la configuration).

Par exemple tu envoies un mail à root par exemple. Il complète en root@domaine.com. Comme domaine.com et la destination finale, il regarde dans /etc/aliases pour trouver le mail de root et voir s'il le mets dans la boite local de root ou s'il le transfert à une autre adresse.

Il y a 2 tests à faire :
# mail -s 'Sujet, mail adresse' <ton mail>
texte du mail.
.
# mail -s 'Sujet, mail root' root
texte du mail.
.

Regardes : http://www.phprog.org/doku.php/exim
Ca marche pour moi pour transférer les mails de root vers mon compte gmail.


Haut
 Profil  
 
MessagePosté: 30 Sep 2012 09:11 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Salut,
Un fil avec deux discussions parallèles... C'est pas gagné!

Tu as un fichiers /etc/php5/conf.d/mysql.ini ?
Il contient quoi ?

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 04 Oct 2012 08:39 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut !

Deux discussions ? Non à l'origine c'est ce problème de spam mail qui me soûle... Je ne sais absolument pas le résoudre !

Mazarini, l'envoi de mail fonctionne j'ai une appli en PHP qui envoie des mails quand nécessaire, ça fonctionne très bien (j'ai aussi installé Mantis Tool et l'envoi de mail marche).
Ce qui me gave, c'est les mails que je reçois toutes les 30 minutes... Je vous file une capture d'écran en PJ de ce message.

Alors oui j'ai bien un fichier /etc/php5/conf.d/mysql.ini dans lequel il y a :

; configuration for php MySQL module
extension=mysql.so


Fichiers joints:
Commentaire: Capture des crons
mailCron.png
mailCron.png [ 53.96 Kio | Vu 242 fois ]
Haut
 Profil  
 
MessagePosté: 04 Oct 2012 09:21 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Salut,
Ce n'est pas un spam, c'est unr tâche cron qui se lance toutes les 30mn. Il se trouve que php rencopntre un problème, alors il t'en informe.

Essaye avec mysqli.so: (relance apache ensuite)
Code:
; configuration for php MySQL module
extension=mysqli.so


La tâche cron doit se trouver ici:
Code:
root@web:~# cat /etc/cron.d/php5
# /etc/cron.d/php5: crontab fragment for php5
#  This purges session files older than X, where X is defined in seconds
#  as the largest value of session.gc_maxlifetime from all your php.ini
#  files, or 24 minutes if not defined.  See /usr/lib/php5/maxlifetime

# Look for and purge old sessions every 30 minutes
09,39 *     * * *     root   [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete


Tu peux faire l'autruche et la commenter, mais ce n'est pas une bonne solution!

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 04 Oct 2012 11:18 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Re !

Donc j'ai bien changé le fichier, mais toujours la même erreur qui pète !

Je pense faire l'autruche du coup, tant pis si c'est pas une bonne solution...


Haut
 Profil  
 
MessagePosté: 06 Oct 2012 14:09 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Salut,
Ça a réglé le pb de mail ?

Sinon, que donne:
Citation:
# updatedb
# mlocate mysql.so

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 11 Oct 2012 07:51 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Salut !

Oui, commenter la ligne du cron a réglé le souci d'envoi de mail.

Voici ce que donnent les commandes :

Citation:
root@megadeth:~# updatedb
root@megadeth:~# mlocate mysql.so
/usr/lib/perl5/auto/DBD/mysql/mysql.so
/usr/lib/php5/20090626+lfs/mysql.so
/usr/lib/php5/20090626+lfs/pdo_mysql.so


Haut
 Profil  
 
MessagePosté: 11 Oct 2012 09:35 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Salut,
Essayer avec le chemin complet dans php.ini ?

; configuration for php MySQL module
extension=/usr/lib/php5/20090626+lfs/mysql.so

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 11 Oct 2012 10:37 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Tu veux dire ici :

Citation:
; If you wish to have an extension loaded automatically, use the following
; syntax:
;
; extension=modulename.extension
;
; For example, on Windows:
;
; extension=msql.dll
;
; ... or under UNIX:
;
extension=msql.so


Haut
 Profil  
 
MessagePosté: 11 Oct 2012 20:47 
Hors ligne
Dieu du clavier.
Avatar de l’utilisateur

Inscription: 13 Mar 2009 07:30
Messages: 12622
Localisation: Madagascar - Isalo
Pardon,
Ça se trouve maintenant ici: /etc/php5/conf.d/mysql.ini
(Ici pour Wheezy.../etc/php5/mods-available/mysql.ini)

_________________
GO Compréhensif...
SID 3.10-etc...-aptosid-amd64 && Xfce 4.10
Je fais des sites maintenant! / Service d'hébergement d'images
Visitez et Participez au wiki du forum!


Haut
 Profil  
 
MessagePosté: 12 Oct 2012 08:38 
Hors ligne
Nouvel utilisateur

Inscription: 25 Nov 2011 11:20
Messages: 76
Ok !

C'est fait , le problème est le même. Tant pis, je commente le cron et basta.

Merci quand même pour ton aide ;)


Haut
 Profil  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 25 messages ] 

Index du forum » Forums d'aide » Support Debian


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
Flux RSS Flux RSS Liste des flux Liste des flux
Powered by phpBB® Forum Software © phpBB Group
Traduction par: phpBB-fr.com
SEO
[ Time : 0.480s | 18 Queries | GZIP : Off ]