2.4 --> 2.6 = kernel panic


#1

Après avoir digéré Noël , je me suis repenché sur la compilation du noyau.
J’étais en 2.4.27 (originel sur Sarge) et j’ai tenté le 2.6.9.
J’ai dû faire une con… qq part car, après qq lignes de chargement, j’ai le noyau qui a la trouille :confused:
kernel panic - not syncing:VFS:Unable to mount root fs on unknow-block (3,6)
Ce qui est plus embêtant, c’est que l’ancien, rebaptisé .old, me joue le m^ tour. Sachant qu’à part le nom, rien n’a été changé, c’est bizarre, non ?
Est-ce que c’est réparable ou je suis bon pour tout réinstaller ?
Heureusement que je fais ts ces essais sur ma “test” et qu’il me reste la présente qui fonctionne.


#2

c’est toujours reparable, une debian…
ne jamais toucher à une install qui à bien marché et qu’on a configuré avec amour…
bon, ta version de test, elle est sur la même machine ?
sinon, as tu un livecd sous la main ?
quel boot loader utilises tu ?
peut tu donner le contenu précis de ton /boot ?
comment as tu compilé ton noyau ?


#3

[quote]bon, ta version de test, elle est sur la même machine ?[/quote] non, ce sont deux DD différents en rack mais … sur le m^ DD où j’ai ma “test”, il y a aussi d’installé Fedora 2 et Aurox 9.4

[quote]sinon, as tu un livecd sous la main ?[/quote]non

[quote]quel boot loader utilises tu ?[/quote]Grub

[quote]peut tu donner le contenu précis de ton /boot ?[/quote]non puisque je ne peux pas y aller et que je ne l’ai pas copié mais je peux donner celui de ma Debian fonctionnelle qui est le m^ pour la partie 2.4.27, je pense

[quote]comment as tu compilé ton noyau ?[/quote]méthode classique, suivie sur le tuto de Trustonme
http://www.trustonme.net/didactels/285.html#options
Merci de ton aide, une fois de plus


#4

Voilà mon /boot/ de la Debian fonctionnelle


[/url]


#5

Suite /boot/
De mémoire, une fois compilée, il y avait en plus :
initrd-2.6.9 (sans le .img)
Mais je ne suis pas sûr car j’ai ‘customisé’ le nom en ajoutant la date , ce qui donnerait initrd-2.6.9-291204
Il y avait aussi System map et vmlinuz pour le 2.6.9


#6

[quote=“Ricardo”][quote]bon, ta version de test, elle est sur la même machine ?[/quote] non, ce sont deux DD différents en rack mais … sur le m^ DD où j’ai ma “test”, il y a aussi d’installé Fedora 2 et Aurox 9.4

zut, on aurait pu editer le “menu.lst”… va falloir booter à la main… tu devrais te graver une knoppix, c’est un “swiss army knife” incomparable…

[quote=“Ricardo”][quote]quel boot loader utilises tu ?[/quote]Grub

ok, ca doit effectivement etre le cas.
en fait, ton menu.lst dans la version qui plante doit avoir oublié la ligne ‘initrd=’ .
En plus, j’ai regardé le tuto que tu as utilisé et ce n’est pas la bonne maniere de créer un noyau debian…
Donc l’idée: tu rebootes sous grub. la, tu te positionnes sur l’entree de ta 2.4.27 (ou celle du 2.6.9 pour en faire une 2.4.27, si tu n’as rien de mieux sous la main), et avec ‘e’ tu rentre dans l’edition.
La, tu retouche la séquence de boot, pour y rajouter une ligne ‘initrd=’ du même genre que celle que tu as sur ta machine de test.
une fois que ta sequence de boot te paraitra correcte, tu la boote avec ‘b’.
si ca ne marche pas, tu recommence jusqu’a trouver les bons arguments de grub.
Une fois que tu aura démarré sous nux, tu sauves ton ‘menu.lst’, et tu fais un update-grub. C’est la manière normale de mettre à jour un ‘menu.lst’ quand on installe un nouveau noyau.
Avec grub, normalement, à part la configuration initiale d’un boot windows s’il y en a besoin, tout se fait automatiquement avec update-grub.

[quote=“Ricardo”][quote]comment as tu compilé ton noyau ?[/quote]méthode classique, suivie sur le tuto de Trustonme
http://www.trustonme.net/didactels/285.html#options
Merci de ton aide, une fois de plus[/quote]
Bon, la methode decrite dans ton lien est une methode “sale” ce n’est pas comme ca qu’on produit un noyau debian. Il faut fabriquer le “kernel-image*.deb” avec make-kpkg et ensuite l’installer avec dpkg -i, et grub est automatiquement mis à jour tout seul…
un “bon” tuto pour faire un noyau debian propre, c’est la doc debian:
qref.sourceforge.net/Debian/refe … el.fr.html
le premier paragraphe te donne (en synthese, il est vrai) la maniere de faire.
Si tu as besoin d’infos plus detaillées, j’ai deja fait plusieurs post pour expliquer comment faire, mais tu peux tjs me dire si ca ne va pas.
en tout etat de cause, pourquoi as tu supprimmé l’ancienne entrée pour booter avec ton noyau qui marchait ? il ne faut jamais faire ca sans etre sur de ton nouveau noyau voyons !!!


#7

Merci, je vois ça en fin d’AM ou ce soir.
Bon app et à plus
Merci encore


#8

[quote=“Ricardo”][quote]bon, ta version de test, elle est sur la même machine ?[/quote] non, ce sont deux DD différents en rack mais … sur le m^ DD où j’ai ma “test”, il y a aussi d’installé Fedora 2 et Aurox 9.4
[/quote]
et ton grub est installé ou ? sur un disque fixe ou bien à la racine de tes amovibles ?
sinon, dsl, j’avais pas vu tes posts, mais ce que j’ai dit tient toujours.
En attendant, si tu ne te souviens plus des noms de tes fichiers, tu va etre obligé d’aller ajuster ton menu.lst avec une knoppix pour retrouver tout ca…


#9

bon sinon, j’ai retrouvé le fil ou je donnais des details sur la compil propre du noyau sous debian c’est
debian-fr.org/forum/viewtopi … =2876#2876
ou il est dit comment fabriquer un zouli paquetage kernel-image customizé avec les noms que tu veux et tout et qui s’installe proprement comme il faut avec grub… :slightly_smiling:


#10

Ça y est, je suis de retour au clavier et j’ai lu avec attention tes derniers posts. Intéressant le fil sur la compil propre du noyau.

A mon avis, si j’arrive à “régénérer” ma ‘test’ en 2.4.27, il vaut mieux que je reparte de zéro pour suivre l’install que tu préconises. Qu’en penses-tu ?

Si c’est aussi ton avis, j’aurais certainement à “faire le ménage” et il faudra que tu me dises ce que je dois supprimer et ce que je dois conserver.

Pour l’instant, je suis entrain de télécharger Knoppix version3.7-2004-12-08. Apparemment, il n’existe pas de version française et j’ai opté pour la british (beurk !)
Quand elle sera télé, je suppose que je dois la graver :wink:
et ensuite, comment je procède
:question:

PS : saloperie de Firefox qui a planté à 53 % de téléchargement :angry:
Je dis Firefox mais en fait, ça doit être Free qui a fait une coupure
Je recommence et, ça ne sera donc pas prêt avant ce soir.


#11

[quote=“Ricardo”]Ça y est, je suis de retour au clavier et j’ai lu avec attention tes derniers posts. Intéressant le fil sur la compil propre du noyau.
A mon avis, si j’arrive à “régénérer” ma ‘test’ en 2.4.27, il vaut mieux que je reparte de zéro pour suivre l’install que tu préconises. Qu’en penses-tu ?
Si c’est aussi ton avis, j’aurais certainement à “faire le ménage” et il faudra que tu me dises ce que je dois supprimer et ce que je dois conserver.[/quote]
ben, je repartirais effectivement au propre avec mon noyau 2.4.27.
dc, le clean, ca serait de:
1/ supprimer ton arborescence de compil de noyau
en gardant le .config, si tu penses qu’il est bon,
(sinon, utiliseq le /boot/config-2.4.27 que tu as et qui marche pour ton 2.4.27)
2/ supprimer le noyau 2.6 et les traces dans /boot
3/ supprimer les modules du 2.6 dans /lib/modules
4/ faire un ‘update-grub’

[quote=“Ricardo”]Pour l’instant, je suis entrain de télécharger Knoppix version3.7-2004-12-08. Apparemment, il n’existe pas de version française et j’ai opté pour la british (beurk !)
Quand elle sera télé, je suppose que je dois la graver :wink:
et ensuite, comment je procède
:question: [/quote]
wouah l’aut, jamais ? wouah :laughing:
ben tu graves et tu bootes dessus.
comme option de boot, tu choisis ‘knoppix26 lang=fr’ : knoppix est multilingue, c’est juste les options de boot qui changent entre deux version.
et pis aprés, tu va sur ton disque ki ne boote plus, tu regardes ce qu’il y a dans ton /boot, et tu modifies ton menu.lst pour retrouver ton demarrage en 2.4.27 comme c’estait avant.
Ensuite tu rebootes sur ton disque qui marche, et tu verifies la manip du ‘update-grub’, avant de te relancer dans la compil de ton noyau.
Un conseil tout de même, tu devrais, une fois que tu aura boote en 2.4.27, installer un kernel-image debian 2.6.8-1 standard, pour d’abord règler les problemes de réglages de modules liés au passage en 2.6 AVANT d’attaquer les problemes de compil de noyau

[quote=“Ricardo”]PS : saloperie de Firefox qui a planté à 53 % de téléchargement :angry:
Je dis Firefox mais en fait, ça doit être Free qui a fait une coupure
Je recommence et, ça ne sera donc pas prêt avant ce soir.[/quote]
Utilises un download manager, je sais pas, wget ou kget, c’est ahurissant à notre époque !!!


#12

Ben là, je suis bluffé grave comme dirait mon petit-fils :wink:
Sans rien faire, je peux m^ me connecter sur le net à partir de Knoppix.
J’ai vu que je pouvais aller sur ma partition “test” et donc je modifierai tt ça demain car il est 2 du mat et les yeux se brouillent.
Suite demain


#13

Reprise des opérations à 17 h.
Entré avec knoppix, allé ds /boot/ : pas de 'grub’
allé ds /mnt/hda6 (c’était mon / de ma “test”) : mount
allé ds /hda6/boot/grub/
tenté de modifier 'menu.lst’
impossible d’écrire, “lecture seulement”. :cry:
essai en ‘user’ et en 'root’
essai chmod -R 777 /…
Pas mieux : lecture seulement
:question: :question: :question:

Ps : pourtant, ds ces fichiers, le propriétaire a le droit d’écriture : bizarre !


#14

[quote=“Ricardo”]Reprise des opérations à 17 h.
Entré avec knoppix, allé ds /boot/ : pas de 'grub’
allé ds /mnt/hda6 (c’était mon / de ma “test”) : mount
allé ds /hda6/boot/grub/
tenté de modifier 'menu.lst’
impossible d’écrire, “lecture seulement”. :cry:
essai en ‘user’ et en 'root’
essai chmod -R 777 /…
Pas mieux : lecture seulement
:question: :question: :question:

Ps : pourtant, ds ces fichiers, le propriétaire a le droit d’écriture : bizarre ![/quote]
knoppix monte peut etre tes disques en readonly.
pour remonter ta partoche en “read/write”, c’est
mount /mnt/hda6 -o remount,rw

sinon, pour ce qui est du vide de /boot, c’est normal: c’est le /boot de knoppix, pas de ta debian… tu as dc bien fait d’aller le chercher ds hda6

tiens un truc à essayer, sinon, c’est de booter avec le noyau de ta knoppix directement sur ta debian:
au boot, tu peux essayer un 'knoppix root=/dev/hda6 ro single’
c’est juste pour aller modifier ton menu.lst, parcequ’il ne trouvera pas ses modules…


#15

il ne connait pas
:cry:

[quote]knoppix@ttyp1[knoppix]$ su -
root@ttyp1[~]# mount /mnt/hda6 -o remount,rw
mount: /mnt/hda6 n’est pas déjà monté ou option erronée
root@ttyp1[~]#
[/quote]

PS : j’ai trouvé le moyen :
mount -rw /mnt/hda6
et on peut écrire
autre possibilité avec ‘Gvim’, on édite, on modifie et on sauve avec
echap / : / w!
sans le ‘!’ ça ne sauve pas si c’est en read only.
J’ai modifié mon menu.lst et je ferai le test demain car il est tard :wink:


#16

il ne connait pas
:cry:

[quote]knoppix@ttyp1[knoppix]$ su -
root@ttyp1[~]# mount /mnt/hda6 -o remount,rw
mount: /mnt/hda6 n’est pas déjà monté ou option erronée
root@ttyp1[~]#
[/quote][/quote]
:slightly_smiling: c’est normal que l’option ‘remount’ ne passe pas: il faut deja que ton disque soit monté pour pouvoir le REmonter.
mais tu as deja remarqué que le -o rw fonctionnait, donc…

[quote=“Ricardo”]PS : j’ai trouvé le moyen :
mount -rw /mnt/hda6
et on peut écrire
autre possibilité avec ‘Gvim’, on édite, on modifie et on sauve avec
echap / : / w!
sans le ‘!’ ça ne sauve pas si c’est en read only.
J’ai modifié mon menu.lst et je ferai le test demain car il est tard :wink:[/quote]
ton Gvim ne râle peut etre pas avec ! si le fichier sur lequel tu sauve est en readonly, mais ca m’etonnerait qu’il effectue l’operation réellement: ca serait une sacrée faille, si un logiciel etait capable de modifier les fichiers protègés, et ca serait encore plus dangereux si il etait capable de modifier des fichiers sur une partoche en readonly…
Donc verifies que tu as bien fait tes modifs :slightly_smiling:


#17

moi bête et obéissant, je fais ce que l’on me dit, sur la m^ ligne comme indiqué ci-dessous :

[quote]knoppix monte peut etre tes disques en readonly.
pour remonter ta partoche en “read/write”, c’est
mount /mnt/hda6 -o remount,rw [/quote]

Non, j’avais auparavant chmodé en 777 mais il donnait une mise en garde supplémentaire, je pense, en rappelant que le fichier était avant en lecture seule.

[quote]Donc verifies que tu as bien fait tes modifs Smile[/quote]Oui, les mofifs sont bien réelles :
J’ai repris le menu.lst d’avant, j’ai supprimé tt ce qui avait trait à 2.6.9 ds /boot/ et j’ai renommé mon vmlinuz.old en vmlinuz-2.4.27-1-386
Mais …
Ça ne fonctionne pas
:angry:
Au départ, il m’annonce qu’il ne trouve pas le fichier vmlinuz.
Je vais y retourner et faire des copies exactes.
a+


#18

menu.lst (partie)

[quote]title Debian GNU/Linux, kernel 2.4.27-1-386
root (hd0,5)
kernel /boot/vmlinuz-2.4.27-1-386 root=/dev/hda6 ro
initrd /boot/initrd.img-2.4.27-1-386
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-1-386 (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.4.27-1-386 root=/dev/hda6 ro single
initrd /boot/initrd.img-2.4.27-1-386
savedefault
boot[/quote]
fstab

[quote]# /etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda2 /home ext3 defaults 0 2
/dev/hda3 none swap sw 0 0
/dev/hdb /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0[/quote]
/boot/

[quote]root@ttyp1[~]# ls /mnt/hda6/boot
config-2.4.27-1-386 initrd.img-2.4.27-1-386 vmlinuz-2.4.27-1-386
grub System.map-2.4.27-1-386
root@ttyp1[~]#
[/quote]
A NOTER :
le System.map-2.4.27-1-386 a été renommé comme il était avant mais, du coup, il y a un cadenas sur le fichier et il est à zero octet, alors qu’il en avait ~ 700. Je n’ai pourtant renommé qu’avec 'mv ancien_nom nouveau_nom ???
/boot/grub/

[quote]root@ttyp1[~]# ls /mnt/hda6/boot/grub
device.map #menu.lst# minix_stage1_5 stage2
e2fs_stage1_5 menu.lst reiserfs_stage1_5 xfs_stage1_5
jfs_stage1_5 menu.lst~ stage1
root@ttyp1[~]#
[/quote]


#19

il ne connait pas
:cry:

[quote]knoppix@ttyp1[knoppix]$ su -
root@ttyp1[~]# mount /mnt/hda6 -o remount,rw
mount: /mnt/hda6 n’est pas déjà monté ou option erronée
root@ttyp1[~]#
[/quote][/quote]
Autre solution : clic droit sur la partition concernée, puis action/changer le read/write, puis yes (ou ok, je ne me rappelle plus).


#20

Merci Korben, je vais essayer ça aussi.
Bonne année