2.6.14 sur une Sarge


#1

Bonjour,

Alors voilà je viens d’effectuer ma première installation de Debian Sarge (ma première Debian), avant j’étais sous Fedora Core X.
Enfait je voudrais changer de noyau (actuel : 2.6.8), j’aurais besoin d’un 2.6.14 pour supporter le wifi de mon portable acer.
Je n’ai jamais changer de noyau comme cela tout seul, ce n’est pas tant cela qui me pose problème pour le moment, mais enfaite je ne trouve pas comment obtenir un paquet du type : “kernel-source-2.6.14…deb”.
J’ai executé “apt-get install kernel-source-2.6.14” mais cela n’a rien donné, ensuite j’ai étais voir de très nombreux site internet pour me renseigner mais je n’ai pas trouvé ce genre de paquet.
Quel qu’un aurrait-il une adresse ? Ou si je ne fais pas la bonne méthode quelqu’un pourrait-il m’aider ?

Merci


#2

bonsoir,
tu trouveras ton bonheur dans la rubrique trucs et astuces: forum.debian-fr.org/viewtopic.php?t=1806
Dis c’est quoi yéhé?


#3

[quote=“wedo”]Bonjour,

obtenir un paquet du type : “kernel-source-2.6.14…deb”.
J’ai executé “apt-get install kernel-source-2.6.14” mais cela n’a rien donné,
Merci[/quote]
linux-source, et non kernel-source.
Essayes avec apt-cache search linux-source.
Sauf erreur le 14 est uniquement en testing, il te faudra les rajouter à ton sources.list


#4

[quote=“wedo”]Bonjour,

Alors voilà je viens d’effectuer ma première installation de Debian Sarge (ma première Debian), avant j’étais sous Fedora Core X.
Enfait je voudrais changer de noyau (actuel : 2.6.8), j’aurais besoin d’un 2.6.14 pour supporter le wifi de mon portable acer.
Je n’ai jamais changer de noyau comme cela tout seul, ce n’est pas tant cela qui me pose problème pour le moment, mais enfaite je ne trouve pas comment obtenir un paquet du type : “kernel-source-2.6.14…deb”.
J’ai executé “apt-get install kernel-source-2.6.14” mais cela n’a rien donné, ensuite j’ai étais voir de très nombreux site internet pour me renseigner mais je n’ai pas trouvé ce genre de paquet.
Quel qu’un aurrait-il une adresse ? Ou si je ne fais pas la bonne méthode quelqu’un pourrait-il m’aider ?

Merci[/quote]

Quel est le module de ta carte ? ipw2100 (sur portable acer) marche avec un noyau 2.6.8 chez moi.


#5

Hum, vu les modifs de la structure du kernel, notament au niveau de udev, qu’il y a eu entre le 2.6.13 et le 2.6.14, je ne recommande vraiment pas de passer une sarge en 2.6.14


#6

13 impair: version de transition.
14 pair: version “stable”.
Concrètement, chez moi, ca marche (mais c’est vrai que je suis en woody/sarge/etch/sid/experimental bien mixé :laughing: )


#7

chez moi aussi 2.6.14 en sarge, enfin avec tellement de paquets instables, que c’est un beau mixe de stable/instable. Tout ça pour dire, pas de soucis, sauf un petit pb de fonctionnement de lecteur de disquette, qui est rentré dans l’ordre.


#8

J’envisage de repasser mon poste de travail principal en Sarge (marre d’avoir de la casse après chaque upgrade :imp: ).
Et d’attendre au minimum 6 mois avant de passer en Etch, le temps que la Etch prenne de la bouteille…
Donc vous conseillez quoi pour une Sarge, 2.6.12 ou 2.6.14 ?


#9

13 impair: version de transition.
14 pair: version “stable”.
Concrètement, chez moi, ca marche (mais c’est vrai que je suis en woody/sarge/etch/sid/experimental bien mixé :laughing: )[/quote]

Les histoires de pair/impair, c’est vrai pour la version majeur, mais je n’ai rien lu de tel sur les verions mineurs. T’as vu ça où?


#10

[quote]13 impair: version de transition.
14 pair: version “stable”. [/quote]
Tu es sûr, Matt ?
Il me semblait que c’était à ce niveau :
2.4.x = version satble
2.5.x = v de transition
2.6.x= v stable


#11

[quote=“jabba”]J’envisage de repasser mon poste de travail principal en Sarge (marre d’avoir de la casse après chaque upgrade :imp: ).
Et d’attendre au minimum 6 mois avant de passer en Etch, le temps que la Etch prenne de la bouteille…
Donc vous conseillez quoi pour une Sarge, 2.6.12 ou 2.6.14 ?[/quote]

Sur 2.6.13.2 tout va bien :wink:


#12

[quote=“jabba”]J’envisage de repasser mon poste de travail principal en Sarge (marre d’avoir de la casse après chaque upgrade :imp: ).
Et d’attendre au minimum 6 mois avant de passer en Etch, le temps que la Etch prenne de la bouteille…
Donc vous conseillez quoi pour une Sarge, 2.6.12 ou 2.6.14 ?[/quote]Tu peux passer en 2.6.14 sans probleme :wink:


#13

Ok alors merci beaucoup pour vos réponses
enfaite donc j’ai rajouter un dépot Testing dans le sources.list
j’ai telecharger les sources pour un kernel 2.6.12, j’ai copier la conf, etc…
mais après lors de la compilation j’ai une foule de question sur la configuration de mon kernel (vraiement la galère), je ne sais pas trop quoi y répondre alors je ne sais trop ce que je doit faire maintenant.

Enfaite je ne suis pas sur que le problème viens de mon kernel mais lorsque j’étais sous FC4 je n’avais pas de problème pour l’installation du module AcerHK (qui permet d’activer le bouton wifi) alors que lorsque je suis aller sous la Sarge ben impossible de faire fonctionner AcerHK, j’en ai déduit que c’était peut-etre a cause de la version du kernel qui était plus ancienne. Mais j’avoue que je ne sais pas trop ou je vais.
Sinon mon portable est un Acer Aspire 3002WLMI

Yehe est un outil pour éditer des fichiers html ou php ou autre directement sur le serveur. Par exemple pour pouvoir modifier des choses plus ou moin urgente dans les sources lorsque tu n’est pas chez toi ou avec ton PC.


#14

Pour ta recompilation de noyau voir
forum.debian-fr.org/viewtopic.php?t=1806

pour les options dans le noyau voir
andesi.org/index.php?node=79#A2

Bonne recompile :slightly_smiling:


#15

merci wedo pour ta reponse. Pour toi, pour ta foule de questions:http://guide.andesi.org/html/moptions-noyau.html


#16

[quote=“ricardo”][quote]13 impair: version de transition.
14 pair: version “stable”. [/quote]
Tu es sûr, Matt ?
Il me semblait que c’était à ce niveau :
2.4.x = version satble
2.5.x = v de transition
2.6.x= v stable[/quote]
Vs avez raison: non seulement je dis une connerie, mais en plus celle là, ce n’est pas la première fois qu’on me corrige. :unamused:


#17

[quote]ce n’est pas la première fois qu’on me corrige[/quote]Je n’ai pas voulu l’écrire mais puisque tu le dis, oui, je t’avais déjà repris la-dessus.
Alors attention, c’est la dernière fois, hein ! :laughing:


#18

olala bon ben ce n’est pas fini.
Maintenant j’ai une erreur à la compilation :

drivers/char/drm/drm_memory.h:151: error: redefinition of 'drm_ioremap [...] drivers/char/drm/gamma_drv.c:56:22: error: drm_proc.h: Aucun fichier ou répertoire de ce type [...] make[4]: *** [drivers/char/drm/gamma_drv.o] Erreur 1 make[3]: *** [drivers/char/drm] Erreur 2 make[2]: *** [drivers/char] Erreur 2 make[1]: *** [drivers] Erreur 2 make: *** [stamp-build] Erreur 2


#19

[quote=“wedo”]olala bon ben ce n’est pas fini.
Maintenant j’ai une erreur à la compilation :

drivers/char/drm/drm_memory.h:151: error: redefinition of 'drm_ioremap [...] drivers/char/drm/gamma_drv.c:56:22: error: drm_proc.h: Aucun fichier ou répertoire de ce type [...] make[4]: *** [drivers/char/drm/gamma_drv.o] Erreur 1 make[3]: *** [drivers/char/drm] Erreur 2 make[2]: *** [drivers/char] Erreur 2 make[1]: *** [drivers] Erreur 2 make: *** [stamp-build] Erreur 2[/quote]
Tu le vires de ton .config et tu relances la compil:

burp:/usr/src/linux# grep DRM .config
CONFIG_DRM=y
CONFIG_DRM_TDFX=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m
# CONFIG_DRM_MGA is not set
CONFIG_DRM_SIS=m
burp:/usr/src/linux#

Mets-le en commentaire …


#20

Oai la compil à bien fonctionner.
Par contre le wifi est toujour HS…
C’est pas grave je vais continuer à chercher puis j’aurrais appris à compiler un noyau :slightly_smiling:
merci à tous