[Abandon] Installation de steam sur sid

Tags: #<Tag:0x00007fb98859bde0>

Bonjour,
Je viens d’installer hier debian sid sur mon pc de jeu, pas de gros pb de ce côté là, ça tourne. Aujourd’hui j’aimerais installer différents logiciels (steam, lutris, discord notamment) et j’ai des pb pour ces 3, mais je vais déjà poser ma question pour installer steam (ça va d’ailleurs peut être me débloquer en même temps pour lutris, parce que c’est aussi un pb de 32 bits).
Je tente de faire un

sudo apt install steam

mais ça merdouille:

nuliel@pcfixe:~$ sudo apt install steam
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libc6:i386 : Dépend: libgcc-s1:i386 mais il n'est pas installable
 libgl1-mesa-dri:i386 : Dépend: libgcc-s1:i386 (>= 7) mais il n'est pas installable
                        Dépend: libstdc++6:i386 (>= 11) mais ne sera pas installé
 libicu67:i386 : Dépend: libgcc-s1:i386 (>= 7) mais il n'est pas installable
                 Dépend: libstdc++6:i386 (>= 5.2) mais ne sera pas installé
 libllvm12:i386 : Dépend: libatomic1:i386 (>= 4.8) mais ne sera pas installé
                  Dépend: libgcc-s1:i386 (>= 4.2) mais il n'est pas installable
                  Dépend: libstdc++6:i386 (>= 11) mais ne sera pas installé
 libz3-4:i386 : Dépend: libgcc-s1:i386 (>= 7) mais il n'est pas installable
                Dépend: libstdc++6:i386 (>= 9) mais ne sera pas installé
 steam:i386 : Dépend: libgcc-s1:i386 mais il n'est pas installable ou
                       libgcc1:i386
              Dépend: libstdc++6:i386 (>= 4.8) mais ne sera pas installé
              Recommande: libasound2-plugins:i386 mais il n'est pas installable
              Recommande: libegl1:i386 mais il n'est pas installable
              Recommande: mesa-vulkan-drivers:i386 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

À noter que j’ai bien fait un sudo dpkg --add-architecture i386 et un apt update avant.
Comment faire pour résoudre ce problème? Qu’est ce que j’ai oublié? Faut il que je télécharge steam depuis le site?
Sinon mon sources.list (j’ai juste un dépôt pour vscode à côté, sinon vraiment rien d’autre)

deb [arch=amd64,i386] https://deb.debian.org/debian/ unstable main contrib non-free

Merci d’avance,
Nuliel

Parfois sous sid il faut accepter que les paquets ne soient pas installables de suite et il suffit d’attendre quelques jours.

Autre conseil, quand apt-get pose problème, j’essaie avec aptitude.

1 J'aime

Merci pour ta réponse.
Alors j’ai fait les maj à nouveau ce matin, mais rien de plus. Je pense pas qu’attendre va servir à grand chose, il faudrait surtout comprendre pourquoi la libc en 32 bits notamment ne veut pas être installé.
Sinon j’ai essayé aptitude, mais il m’a donné deux propositions qui ne permettent pas d’installer steam.
J’ai essayé avec le deb du site, c’est pareil, les libs 32 ne sont pas installées, je ne sais pas pourquoi

Finalement, j’ai essayé énormément de choses, les lib en 32 bits ne veulent définitivement pas passer, du coupj’abandonne: j’ai installé ubuntu 20.04, tant pis pour le besoin de faire les maj tous les 5 ans (enfin là 3 maintenant). Dommage parce que debian sid fonctionne parfaitement sur mon pc portable

je trouve ça étrange,
j’ai vérifié tous les paquets avec leur dépendance qu’il te manque, je les aies tous.
Moi je recommencerai depuis le début, mais avec steam seulement.

peut-être ce lien pourrait aidé
discussion du 19 août - mon installation du 2021-10-01 unstable

nul besoin de forcé l’installation et toute avec apt

j’espère que ça pourra t’aider :wink: