Alert ! UUID=xxx does not exist. Dropping to a shell

Tags: #<Tag:0x00007faa2a51aed8> #<Tag:0x00007faa2a51ae10> #<Tag:0x00007faa2a51ad20>

Bonjour,
Je viens de passer mon ordinateur portable du mode ‹ Optane without RAID › à ‹ AHCI ›, et je n’ai plus accès à Linux.
Grub s’affiche, mais ne me permet pas de démarrer Linux…
J’obtiens le message classique :
Alert ! UUID=xxx does not exist. Dropping to a shell
J’ai déjà essayé de nombreuses solutions, et j’ai vérifié que mes UUID sont bons, j’ai essayé de mettre /dev/sda6 à la place…
Que puis-je faire ?
Merci d’avance pour vos réponses.
PS: voici le rapport Boot-info si c’est utile : https://paste.ubuntu.com/p/8RvxCWrPDf/

C’est peut-être simplement que le BIOS n’a plus accès au disque non ?
Pas de disque => pas d’UUID.
Quel est l’objectif de passer de ‹ Optane without RAID › à ‹ AHCI ›, si ‹ Optane without RAID › fonctionne ?

Si si le BIOS a accès au disque.
Je suis passé en AHCI parce que j’ai un hackintosh en parallèle qui a besoin d’être en AHCI

Tu arrives donc dans un shell de dépannage. C’est déjà pas mal.
Vois-tu ta partition recherchée avec cette commande ?
lsblk -f

Dans le Shell de Busybox , la commande de lsblk n’est pas reconnue…
On parle bien du shell de initramfs, non ?

Oui oui. J’étais convaincu que lsblk était dans un shell recovery.
Alors même question, mais avec blkid (ça devrait y être).
Et profites-en en rajoutant ça:
lsmod | grep ahci

20201014_221335
Une image vaut mieux qu’un long discours…

Alors i915 / missing firmware parait assez explicite.
Essaie d’installer firmware-misc-nonfree.
En chroot ? Ou à partir d’un autre boot ? Tu dois avoir i915 sous /lib/firmware/
/lib/firmware/i915/kbl_dmc_ver1_04.bin

1 J'aime

Qu’est-ce que le mode « Optane without RAID » ?
Quels sont les supports de stockage de masse de cette machine ?
Disque dur SATA ?
SSD SATA, AHCI ou NVMe ?

Pas par défaut (mais c’est possible de l’ajouter, comme à peu près n’importe quelle commande). Si blkid n’affiche rien, on peut afficher le contenu de /proc/partitions pour voir si le noyau voit des disques partitionnables.

lspci aurait été utile aussi. Note : il existe dans le shell de GRUB mais n’affiche que les identifiants numériques, pas les noms. Ça pourrait être intéressant de comparer le résultat dans les deux modes AHCI et Optane sans RAID.

Je trouve cette liste de modules bien courte. Aurais-tu configuré /etc/initramfs-tools/initramfs.conf avec MODULES=dep ? Dans ce cas le changement de mode a peut-être changé la façon d’accéder au stockage et donc le pilote nécessaire, qui n’a pas été inclus dans l’initramfs taillé pour cette machine, et il faut revenir à un initramfs générique construit avec MODULES=most.

Aucune importance, i915 est un pilote graphique. Rien à voir avec le stockage de masse.

1 J'aime

Merci pour vos réponses. Je teste tout ça et je poste les résultats des commandes ce week-end.

i915 est certes un pilote graphique, mais n’est pas inutile pour la suite puisque réclamé par le système.
L’objectif (non détaillé) de l’écrire sous /lib/firmware/ à partir soit d’un chroot ou autre méthode était de vérifier que rien n’empêchait d’écrire sur la partition incriminée, et voir d’éventuels messages d’erreur: faire d’une pierre deux coups / un train peut en cacher un autre.
C’est souvent en croisant les manips qu’on converge tranquillement vers la réponse, lorsque le problème n’est pas trivial.

@MC2
Je propose que tu continues tranquillement ce WE avec pH.
L’important est que le noyau soit déjà accessible, puisque le shell recovery est disponible (donc sorti du grub), donc partition accessible.
C’est presque ça qui m’étonne plutôt, puisque blkid ne voit aucune de tes partitions, même pas la racine…
Je ne te cache pas que je ne suis pas convaincu que changer le BIOS après installation soit une bonne idée (pas de bons souvenirs).
Si tu n’y arrives avec pH (ou autre), et que tu tiens à AHCI au lieu de ‹ Optane without RAID ›, garde en tête que ça peut se terminer par une résinstallation nécessaire, ton autre option étant de rester en ‹ Optane without RAID ›, le temps d’analyser tout ça plus tard.
Bon courage.

Le noyau et l’initramfs sont chargés par GRUB qui passe par le BIOS pour accéder aux disques. Par contre le noyau utilise ses propres pilotes sans passer par le BIOS pour accéder aux disques.

Ca marche !
J’ai fais deux manipulations en même temps, à savoir installer le paquet firmware-misc-nonfree, et changer le fichier de configuration de initramfs de list à most, et tout roule !
Merci beaucoup pour vos réponses détaillées.

Du coup on ne sait pas laquelle des deux a corrigé le problème. Toujours faire un seul changement à la fois quand on fait du dépannage.

initramfs.conf contenait « MODULES=list » ? C’est toi qui avais défini la liste des modules à inclures dans l’initramfs ? C’est très risqué si on n’est pas très rigoureux, le moindre changement de configuration peut casser le démarrage.

Peux-tu poster cette liste de modules contenue dans le fichier /etc/initramfs-tools/modules et la sortie de la commande suivante pour comparer avec le matériel présent ?

lspci -k

J’avais suivi un tuto précédemment pour régler le problème est dans ce tuto je passais en mode list dans le fichier de config de initramfs… grosse erreur.

mc2@MERCURE:~$ cat /etc/initramfs-tools/modules
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
ahci
libahci
mc2@MERCURE:~$ 
mc2@MERCURE:~$ lspci -k
00:00.0 Host bridge: Intel Corporation Device 3e34 (rev 0b)
	Subsystem: Acer Incorporated [ALI] Device 128d
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake)
	Subsystem: Acer Incorporated [ALI] UHD Graphics 620 (Whiskey Lake)
	Kernel driver in use: i915
	Kernel modules: i915
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
	Subsystem: Acer Incorporated [ALI] Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Point-LP Thermal Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP Thermal Controller
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:14.0 USB controller: Intel Corporation Cannon Point-LP USB 3.1 xHCI Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP USB 3.1 xHCI Controller
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 RAM memory: Intel Corporation Cannon Point-LP Shared SRAM (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP Shared SRAM
00:14.3 Network controller: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] (rev 30)
	Subsystem: Intel Corporation Cannon Point-LP CNVi [Wireless-AC]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 9de8 (rev 30)
	Subsystem: Acer Incorporated [ALI] Device 128d
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:15.1 Serial bus controller [0c80]: Intel Corporation Device 9de9 (rev 30)
	Subsystem: Acer Incorporated [ALI] Device 128d
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation Cannon Point-LP MEI Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP MEI Controller
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation Cannon Point-LP SATA Controller [AHCI Mode] (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP SATA Controller [AHCI Mode]
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1c.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port (rev f0)
	Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port (rev f0)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Cannon Point-LP LPC Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP LPC Controller
00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP High Definition Audio Controller
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl
00:1f.4 SMBus: Intel Corporation Cannon Point-LP SMBus Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP SMBus Controller
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Point-LP SPI Controller (rev 30)
	Subsystem: Acer Incorporated [ALI] Cannon Point-LP SPI Controller
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
	Subsystem: Acer Incorporated [ALI] GP108M [GeForce MX150]
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
	Subsystem: Acer Incorporated [ALI] RTL8411B PCI Express Card Reader
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci
02:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
	Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
	Kernel driver in use: r8169
	Kernel modules: r8169
mc2@MERCURE:~$

Pour régler quel problème ?

Il n’est pas nécessaire de mentionner libahci puisque ahci en dépend. Par contre il manque au moins sd_mod pour les disques SATA (ahci c’est seulement pour le contrôleur SATA), le système de fichiers de la racine (ext4 ?).

Le même problème, j’avais fait beaucoup de recherches avant, pas toujours fructueuses…
Tout de façon je n’ai plus besoin de ce fichier puisque que j’utilise l’option most.

Peux-tu préciser la séquence des événements ?

  1. Tu as changé le mode SATA dans le BIOS et rien d’autre.
  2. Au redémarrage, l’initramfs ne trouvait plus la racine.
  3. Tu as changé en MODULES=list dans initramfs.conf et exécuté update-initramfs -u.

Ou bien ça s’est passé autrement ?
Quelle était la valeur de MODULES avant le changement ? most ou dep ?

Non il s’est passé beaucoup de choses… j’ai perdu grub à un moment, j’ai effectué désespérément beaucoup de manip trouvé sur internet sans pour autant toutes les comprendre (notamment passer à ‹ list ›) et enfin je me suis tourné vers un forum dans l’espoir d’une réponse.

Ton historique n’est quand-même pas clair et tu n’avais certainement pas ‹ list › dans l’ initramfs.conf lors de l’installation. Tu ne te souvenais pas avoir déjà bricolé ?
Par défault, la liste de modules est réglée à « most », et je ne pense pas que tu aurais rencontré ton problème avec most par défault.
Si tu ne bricoles plus trop (surtout ton BIOS…) , mais souhaites alléger initrd.img, tu peux régler à ‹ dep › (c’est ce que je fais systématiquement).

$ grep MODULES /etc/initramfs-tools/initramfs.conf
# MODULES: [ most | netboot | dep | list ]
MODULES=dep

# update-initramfs -u

Enfin, l’essentiel est que ça marche maintenant.