Alsa, choix de la carte par défaut

Bonjour,
Fraîchement installé Bookworm sur un iMac, je suis confronté à ce problème de configuration de carte son.
Selon /proc/asound/modules, les deux ont le même nom.
────────────────────────────────────────────────────────
1 │ 0 snd_hda_intel
2 │ 1 snd_hda_intel

Voici /proc/asound/cards
──────────────────────────────────────────────────────────
1 │ 0 [HDMI ]: HDA-Intel - HDA Intel HDMI
2 │ HDA Intel HDMI at 0xb1710000 irq 60
3 │ 1 [PCH ]: HDA-Intel - HDA Intel PCH
4 │ HDA Intel PCH at 0xb1714000 irq 61

Comment puis-je faire pour avoir PCH par défaut, en lieu et place de HDMI ?

J’ai essayé ceci dans ~/.asoundrc sans succès :

options snd_hda_intel index=2,1

Merci et bon week-end.

Christophe

Bonjour,
as-tu essayé la commande alsamixer ?

Norbert

Oui,
Pour tenter d’être plus clair, voici des captures d’écran.
aslamixer_F6
aslamixer_PCH
La colonne « Master » est ajustable par les touches du clavier mais n’a aucune influence sur la lecture en cours, quelque soit le média.
Je pense que si je peux inverser l’ordre des cartes « HDA Intel PCH » et « HDA Intel HDMI », la carte « 0 » étant la carte par défaut, ça devrait aller ?
Ou je part dans une mauvaise direction

Voilà ce que je vois dans mon fichier /proc/asound/modules

 0 snd_bcm2835
 1 vc4
 2 vc4
 3 snd_usb_audio

donc des cartes avec le même nom, tu n’es pas le seul !
et dans /proc/asound/cards

 0 [Headphones     ]: bcm2835_headpho - bcm2835 Headphones
                      bcm2835 Headphones
 1 [vc4hdmi0       ]: vc4-hdmi - vc4-hdmi-0
                      vc4-hdmi-0
 2 [vc4hdmi1       ]: vc4-hdmi - vc4-hdmi-1
                      vc4-hdmi-1
 3 [HECATE         ]: USB-Audio - HECATE
                      ARMATURE HECATE at usb-0000:01:00.0-1.4, high speed

Quand au fichier .asoundrc :

pcm.!default {
   type hw
   card HECATE     
}

ctl.!default {
   type hw
   card HECATE
}

Par similitude, j'essayerai 
pcm.!default {
   type hw
   card PCM
}

dans le .asoundrc, mais c’est vraiment empirique, comme à chaque fois d’ailleurs.

Essayé avec

pcm.!default {
   type hw
   card PCM
    }

et

ctl.!default {
   type hw
   card PCM
}

sans effets.

J’avais déjà tenté ceci

pcm.snd_hda_intel { type hw card 0}
ctl.snd_hda_intel { type hw card 0}

et

defaults.pcm.card 2
defaults.ctl.card 2

Je vais creuser les possibilités de ce fichier.

Dans les fichiers /proc/asound/cardX/pcm0p/info on retrouve les identifiants des cartes.
En cherchant dans ces fichiers, tu trouveras les numéros de carte. Il est possible que ça ne soit pas « 2 » comme tu l’indiques.
Sinon, il y a peut-être une info en fouillant dans les logs ?

Après encore bien des recherches, j’ai réussi à modifier l’ordre des cartes son.

File: /etc/modprobe.d/alsa.conf
───────┼─────────────────
   1   │ options snd_hda_intel model=auto index=1,0

Résultat :

File: /proc/asound/cards
───────┼──────────────────────────────
   1   │  0 [PCH            ]: HDA-Intel - HDA Intel PCH
   2   │                       HDA Intel PCH at 0xb1714000 irq 60
   3   │  1 [HDMI           ]: HDA-Intel - HDA Intel HDMI
   4   │                       HDA Intel HDMI at 0xb1710000 irq 61

Mais cela ne résoud pas mon problème de base, qui est que les touche multimédia du clavier ne modifie pas le volume de lecture en cours.

Merci beaucoup pour ton aide précieuse.