[alsa] Probleme avec ma carte son intégrée


#1

Bonjour,

Apres mon problème avec ma carte rezo intégrée, maintenant c’est au tour de la carte son de poser problème :smiley:

Alors :

  • alsaconf se déroule correctement il trouve ma carte son (AC97) il utilise intel8x0.

  • Je lance update-modules, puis je lance /etc/init.d/alsa start

[quote]Starting ALSA…/etc/init.d/alsa: Error: alsactl restore failed with message ‘alsactl: set_controls:986: snd_ctl_open error: Invalid argument’.
done.
[/quote]

  • lsmod | grep snd

[quote]snd_intel8x0 35988 0
snd_bt87x 14760 0
snd_ac97_codec 73284 1 snd_intel8x0
snd_pcm_oss 56680 0
snd_mixer_oss 19520 1 snd_pcm_oss
snd_pcm 100876 3 snd_intel8x0,snd_bt87x,snd_pcm_oss
snd_timer 24904 1 snd_pcm
snd_page_alloc 12944 3 snd_intel8x0,snd_bt87x,snd_pcm
gameport 5120 1 snd_intel8x0
snd_mpu401_uart 8192 1 snd_intel8x0
snd_rawmidi 26532 1 snd_mpu401_uart
snd_seq_device 9164 1 snd_rawmidi
snd 56936 10 snd_intel8x0,snd_bt87x,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 11232 2 bttv,snd[/quote]

J’ai une carte TV, c’est pourquoi c’est un peu le bordel (bt878)

  • lspci -bv (seulement la carte en question)

[quote]0000:00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 00ea (rev a1)
Subsystem: Asustek Computer, Inc.: Unknown device 812a
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 4
I/O ports at e800
I/O ports at e400
Memory at febfb000 (32-bit, non-prefetchable)
Capabilities: [44] Power Management version 2
[/quote]

  • rmmod snd_intel8x0
    J’entends un petit “pchit” dans mon casque (ca devrait etre le bon)

  • modprobe snd_intel8x0 irq=4 io=e800
    pas de soucis

  • modprobe snd_intel8x0 irq=4 io=e400 (j’ai pas trop compris cette histoire la)

[quote]alsactl: set_controls:986: snd_ctl_open error: Invalid argument
FATAL: Error running install command for snd_intel8x0
[/quote]

  • alsaconf me dit qu’il met a jour /etc/modprobe.conf

[quote]### update-modules: start processing /etc/modutils/alsa-base
above snd-pcm snd-pcm-oss
above snd-mixer snd-mixer-oss
above snd-seq snd-seq-oss

update-modules: end processing /etc/modutils/alsa-base[/quote]

ainsi que /etc/modprobe.d/sound

[quote]options snd device_mode=0660
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/lib/alsa/modprobe-post-install snd-intel8x0[/quote]

alsa-project.org/alsa-doc/do … e=intel8x0
Ici j’ai vu :

[quote]Setting up modprobe and kmod support

Before you send a mail complaining that “I don’t have /etc/modules.conf, where do I find it …” ,The /etc/conf.modules has been deprecated with a few distro’s so in your case, it may still be /etc/conf.modules. Basically they are both the same, but recent version of modutils uses /etc/modules.conf instead. Nothing to worry about as such, optionally please update to latest version of modutils. This should solve your problem.

Here’s the example for this card. Copy and paste this to the bottom of your /etc/modules.conf file.

Note to debian users: You need to save this information into a file in the /etc/modutils/ directory (Eg. /etc/modutils/alsa) and run update-modules

    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-intel8x0
# module options should go here

    # OSS/Free portion
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

[/quote]

Je rajoute ses alias dans /etc/modutils/alsa-base, je fais update-modules et si j’ai bien compris il le met dans /etc/modprobe.conf

Mais rien a y faire, toujours la meme erreur, et si je cherche des infos sur celle ci, a part un espagnol qui a le meme soucis et dont personne ne donnent de reponse
lists.debian.org/debian-user-spa … 00769.html

Rien me parait clair mais il est 5h19 donc dodo, j’espere que je ne suis pas passé a coté d’une évidence, ca m’embeterais de vous harceler pour rien :smiley:

Merci d’avance,

ghib.


#2

qques remarques:

  • il me parait bizarre que tu inseres deux fois le même module : il me semblerait plus logique d’avoir une insertion du genre modprobe snd_intel8x0 irq=4 io=e400,e800(attention, je ne suis pas sûr de la syntaxe, mais tu dois comprendre le sens ?)
  • je ne vois aucune ligne "option snd_intel8x0 " dans ce que tu cite comme élément de config. Ca veut dire que normalement, le module autodétecte lees ressources. (mais bon, si quand tu l’insère en forcant les plages io et que ca marche, c’est que l’autodetection ne fonctionne pas…)
  • as tu regardé les options spécifiques du module ? “modinfo snd_intel8x0” et joué avec (en particulier, il y a une option ac97_quirk)?
  • je crois que tu fais une confusion entre /etc/modprobe.conf et /etc/modules.conf (moi même ca m’agace un peu de ne pas comprendre précisément comment ca marche).
    /etc/modules.conf doit normalement contenir la concatenation des données de /etc/modutils, il semble concerner les kernels 2.4
    /etc/modprobe.conf doit normalement contenir la concatenation des données de /etc/modprobe.d (excepté arch) pour les kernels 2.6 (?)
    sur ma machine, c’est le dernier qui est utilisé (je ne sais pas trop si c’est le passage en 2.6, ou la version de modutils qui fait ca)
    je me suis apercu que /etc/modprobe.conf n’était pas mis à jour lors d’un ‘update-modules’, pire, je me suis retrouvé à un moment avec un fichier vide. je l’ai donc produit moi même à la mano, et ca a résolu mes problèmes (pour installer ma carte bttv, à l’époque !!!).
    vala. ++

#3

J’ai finalement installé un noyau 2.6.8-1 i386 la les pilotes nforce fonctionne sans pb. Tout fonctionne a présent.

Maintenant je vais me plonger dans l’apprentissage des bases de linux, et plus particulierement sur le noyau. Comme j’ai un AMD64 je dois suivre les spécificités de celui-ci. Alors avant de me jeter dans la gueule du loup, je vais apprendre, et j’ai du boulot. :wink:

Merci quand même.

ghib