Apach-ssl et php4


#1

Bonjour,

suite à l’instruction “apt-get install squirrelmail apache-ssl”,
apache2 et apache-ssl ont été installés (alors qu’en fait apache-ssl m’aurait suffit)

On trouve dans /etc/apache2/mods-available un fichier php4.load
qui permet de charger le module php4 d’apache :
“LoadModule php4_module /usr/lib/apache2/modules/libphp4.so”

Mais il n’y a pas d’équivalent dans /etc/apache-ssl/modules.conf
Par conséquent, php4 n’est pas chargé dans apache-ssl.

Mais question : comment charger php4 dans apache-ssl ?

Par avance merci,


#2

Curieux autant qu’étrange…

Dépend: libc6 (>= 2.3.5-1), libdb4.3 (>= 4.3.28-1), libexpat1 (>= 1.95.8), libssl0.9.8, debconf (>= 0.5) | debconf-2.0, ssl-cert (>=
        1.0-7), openssl, mime-support, apache-common (>= 1.3.34-1), apache-common (< 1.3.35), perl (>= 5.8.4-2), logrotate (>=
        3.5.4-1), libmagic1, lsb-base (>= 2.0)

Chez moi ça dépend de apache.

Quelle distrib as-tu ? Apache et Apache2 sont incompatibles. Je suppose que tu n’avais pas apache d’installé ?

Pour le reste, des spécialistes vont te répondre (reste en ligne). Je te mets une petite musique d’attente…


#3

Quelle distrib as-tu ? Apache et Apache2 sont incompatibles. Je suppose que tu n’avais pas apache d’installé ?

J’ai la distribution “stable main” (ftp.fr.debian.org/debian dans sources.list)

Je précise que lorsque j’ajoute
"LoadModule php4_module /usr/lib/apache2/modules/libphp4.so"
dans /etc/apache-ssl/modules.conf,
cela provoque une erreur au démarrage de apache-ssl.

J’ai fait un autre test en installant apache-ssl seul (ni squirrelmail ni apache2 ne sont installés). Et dans ce cas, php4 est absolument absent.
Le module libphp4.so est alors introuvable.


#4

PS. La version installée est 3.1rc3 Sarge à partir du CD founri par la 2d édition de Debian / Eyrolles par R. Hertzog


#5

En fait j’ai fini par trouver :
/usr/lib/apache/1.3/libphp4.so
n’existait pas car il fallait faire
apt-get install libapache-mod-php4
pour le créer.