Apache 2 inacessible


#1

Bonjour à tous,

Je viens d’installer un serveur web apache 2 sur ma debian sarge.
Hier j’arrivais à y acceder sans problème (enfin j’aterrissais sur la page default alors que j’ai change DocumentRoot).

Entre temps j’ai fais un apt-get update & upgrade et j’ai donc redemarre ma machine.

Maintenant il est impossible d’acceder au serveur.

D’où pensez-vous que provient le probleme ? de apache, de iptables?

Merci d’avance :wink:

romgo


#2

Salut,

  1. lit les logs : /var/log/apache2/error.log

et tu as commenter la ligne:

dans

/etc/apache2/sites-enabled/000-default ?

ensuite tu remet le documentroot à /var/www

/etc/init.d/apache2 reload


#3

Salut,

Alors quand je regarde le fichier error.log je n’ai pas d’erreur :

[quote][Sat May 06 15:52:16 2006] [notice] Graceful restart requested, doing restart
[Sat May 06 15:52:16 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-16 configured – resuming normal operations
[/quote]

Ensuite dans mon fichier /etc/apache2/sites-enabled/000-default

la ligne Redirect Match est bien commentée.

Je redemarre le serveur sans probléme.

Mon serveur a deux cartes reseaux es-ce que cela peux poser problème ?

merci

romgo


#4

Le plus simple pour le savoir serait de virer iptables, tu seras tout de suite fixé…

Ce sera assez tôt de le remettre quand ton apache sera configuré correctement. Evites de cumuler les problèmes :wink:


#5

je fais un iptables -F ?

romgo


#6

[quote] -F, --flush [chain]
Flush the selected chain (all the chains in the table if none is given). This is equivalent to deleting all the rules one by one.
[/quote]
Je suppose, oui …
Sauvegarde ta config avant …


#7

Bon j’ai fais et du coup j’ai plus d’acces ssh c’est con :confused:

tampis je le remonterai lundi, enfin le le probleme reste entier du coup


#8

Bonjour,

en fait c’etait bien mon firewall qui bloquait les connexions.

Par contre j’arrive à la racine du serveur j’ai deux dossiers diponibles à savoir :
phpmyadmin et apache2-default (ce sont des virtual host il me semble)

Le problème c’est que ces dossiers se trouvent dans /var/www
Or j’ai indique

dans mon fichier apache2.conf quelqu’un peut m’eclairer à ce sujet ?

merci d’avance

romgo :slightly_smiling:


#9

salut,
c pas le fichier apache2.conf qu’il faut modifier mais le /etc/apache2/sites-enabled/000-default

tu peux rajouter à la suite de ce fichier

<VirtualHost *> DocumentRoot /home/apache2 ServerName apache2.domaine.tld </VirtualHost>

Je t’invite à lire les docs sur apache2 :slightly_smiling:

cordialement


#10

effectivement je cherchais la doc :slightly_smiling:

Merci beaucoup :slightly_smiling: