Apt-get erreur TLS

Tags: #<Tag:0x00007fedf26e6198>

Bonjour à tous,

Je souhaiterai pouvoir installer PHP5.6 en complément de PHP7.0 sur Debian 9.

Je suis au courant des problèmes de sécurités mais mes contraintes font que je suis obligé d’être sur cette distribution.

J’ai ajouté le depot disponible sut https://deb.sury.org

J’ai cependant une erreur lors de la commande :
apt-get update

W: The repository ‘https://packages.sury.org/php stretch Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Impossible de récupérer https://packages.sury.org/php/dists/stretch/main/binary-amd64/Packages gnutls_handshake() failed:
An unexpected TLS packet was received. E: Le téléchargement de quelques fichiers d’index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Quelqu’un sait-il d’où ça peut provenir ?

Merci par avance et je peux vous fournir plus d’informations si besoin.

Je vois dans le readme du dépot qu’il y a des choses à installer et une clé à importer, tu as fait tout ça:
https://packages.sury.org/php/README.txt
?

Salut
php 5.6 est toujours dans Debian Jessie Security

https://packages.debian.org/jessie/php5

Ajouter la ligne suivante dans le /etc/apt/sources.list devrait être suffisant

deb http://security.debian.org/ jessie/updates main contrib non-free

et c’est plus un pb d’internet car le fichier se télécharge facilement

~/Téléchargements$ wget  https://packages.sury.org/php/dists/stretch/main/binary-amd64/Packages
--2018-01-18 12:10:09--  https://packages.sury.org/php/dists/stretch/main/binary-amd64/Packages
Résolution de packages.sury.org (packages.sury.org)… 217.31.192.150, 2001:1488:ac15:ff90::150
Connexion à packages.sury.org (packages.sury.org)|217.31.192.150|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 456456 (446K) [application/octet-stream]
Sauvegarde en : « Packages.1 »

Packages.1          100%[===================>] 445,76K  1,24MB/s    in 0,4s    

2018-01-18 12:10:09 (1,24 MB/s) — « Packages.1 » sauvegardé [456456/456456]

~/Téléchargements$ 

Oui Oui j’ai suivi la procédure à la lettre mais ça ne fonctionne pas.

Ca doit être effectivement un problème lié au réseau, car sur un autre serveur, la procédure fonctionne correctement.

Je vais jeter un oeil à ça merci.

les failles de sécurité de php5 sont elles corrigées sur ce dépot sury.org ??

https://www.debian.org/security/2018/dsa-4081

Je n’ai pas l’impression, d’après ce que j’ai pu voir, les packages datent du 5 janvier 2018.