Apt-get veut plus !


#1

Bonjour,

j’ai voulu installer un truc, et maintenant j’arrive plus du tout à installer via apt

voilà le message :

[quote]# apt-get install cvs-buildpackage
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
cvs-buildpackage est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
bittorrent-gui: Dépend: libwxgtk2.4-python mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
[/quote]

alors je fais comme indiquer :

[quote]# apt-get -f install
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Correction des dépendances… Fait
Les paquets supplémentaires suivants seront installés :
libwxgtk2.4-python
Paquets suggérés :
wxwin2.4-doc wxwin2.4-examples python2.3-xml
Les NOUVEAUX paquets suivants seront installés :
libwxgtk2.4-python
0 mis à jour, 1 nouvellement installés, 0 à enlever et 146 non mis à jour.
161 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/2591ko dans les archives.
Après dépaquetage, 11,5Mo d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Lecture des champs des paquets… Fait
Lecture de l’état des paquets… Fait
Récupération des rapports de bogue… Fait
(Lecture de la base de données… 156727 fichiers et répertoires déjà installés.)
Dépaquetage de libwxgtk2.4-python (à partir de …/libwxgtk2.4-python_2.4.2.6_amd64.deb) …
dpkg : erreur de traitement de /var/cache/apt/archives/libwxgtk2.4-python_2.4.2.6_amd64.deb (–unpack) :
tentative de remplacement de « /usr/bin/helpviewer », qui appartient aussi au paquet wxpython2.5.3
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/libwxgtk2.4-python_2.4.2.6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)[/quote]

voilà, j’ai trouvé d’autre topic sur le sujet, mais y avait pas de réponse, alors je me tourne chez vous.

j’espère que j’ai pas fait qqch d’irréparable, j’ai pas envie de tout réinstaller ! Pour une fois que j’arrive seule à installer linux.

merci pour vos lumières !
@+++
schlopa


#2

[quote=“schlopa”]Bonjour,

j’ai voulu installer un truc, et maintenant j’arrive plus du tout à installer via apt

voilà le message :

[quote]# apt-get install cvs-buildpackage
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
cvs-buildpackage est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
bittorrent-gui: Dépend: libwxgtk2.4-python mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
[/quote]

alors je fais comme indiquer :

[quote]# apt-get -f install
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Correction des dépendances… Fait
Les paquets supplémentaires suivants seront installés :
libwxgtk2.4-python
Paquets suggérés :
wxwin2.4-doc wxwin2.4-examples python2.3-xml
Les NOUVEAUX paquets suivants seront installés :
libwxgtk2.4-python
0 mis à jour, 1 nouvellement installés, 0 à enlever et 146 non mis à jour.
161 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/2591ko dans les archives.
Après dépaquetage, 11,5Mo d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Lecture des champs des paquets… Fait
Lecture de l’état des paquets… Fait
Récupération des rapports de bogue… Fait
(Lecture de la base de données… 156727 fichiers et répertoires déjà installés.)
Dépaquetage de libwxgtk2.4-python (à partir de …/libwxgtk2.4-python_2.4.2.6_amd64.deb) …
dpkg : erreur de traitement de /var/cache/apt/archives/libwxgtk2.4-python_2.4.2.6_amd64.deb (–unpack) :
tentative de remplacement de « /usr/bin/helpviewer », qui appartient aussi au paquet wxpython2.5.3
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/libwxgtk2.4-python_2.4.2.6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)[/quote]

voilà, j’ai trouvé d’autre topic sur le sujet, mais y avait pas de réponse, alors je me tourne chez vous.

j’espère que j’ai pas fait qqch d’irréparable, j’ai pas envie de tout réinstaller ! Pour une fois que j’arrive seule à installer linux.

merci pour vos lumières !
@+++
schlopa[/quote]

Ce probleme arrive des fois quand il existe des erreurs dans les paquages debian.

as-tu reessayé :
$ dpkg --configure -a
$ apt-get -f install

voire meme : $ apt-get install -f nomDuPaquage

en tout cas, tu n’as pas fait quelque chose d’irreparable !
avec linux, et encore plus debian, il y a toujours une solution ! :stuck_out_tongue:


#3

Généralement, pour résoudre ce problème, j’utilise une méthode assez brutale :
Je me positionne dans le répertoire /var/cache/apt/archive, puis je force l’install du paquet fautif avec un dpkg --force-install <nom du paquet .deb>
C’est pas très propre, mais ça marche.


#4

euh, y a rien qui marche dans tout ça

# dpkg --force-install <libwxgtk2.4-python_2.4.2.6_amd64.deb> bash: syntax error near unexpected token `newline'

syntax error ça veut dire quoi ?

sinon :

[code]Paramétrage de wxpython2.5.3 (2.5.3.2) …

Paramétrage de libwxgtk2.5.3-python (2.5.3.2) …

Paramétrage de bittornado-gui (0.3.10-1) …

Paramétrage de gftp-common (2.0.17+cvs20050102-3) …
Paramétrage de noteedit-data (2.7.1-2) …
Paramétrage de noteedit (2.7.1-2) …

Paramétrage de gftp-gtk (2.0.17+cvs20050102-3) …

Paramétrage de gftp-text (2.0.17+cvs20050102-3) …

Paramétrage de gftp (2.0.17+cvs20050102-3) …
Des erreurs ont été rencontrées pendant l’exécution :
bittorrent-gui
[/code]

ok je fais apt-get -f instal et il me mets comme d’habitude.

rien à changer !

que faire ?


#5

peut-être dpkg-reconfigure --all …


#6

Pour le dpkg --force-install il faut pas mettre les < et >
J’avais mis ça pour te montrer ce qu’il fallait remplacer :wink:


#7

desinstalle bitorrent gui.
puis apt-get install libwxgtk2.4-python

sinon tu as quel noyau ??
parceque chez moi la nouvel image 2.4.27 ma mis une grosse pagaille.
pour le son et pour les librairies python.


#8

c bon le prob est regle

c’est synaptic qui m’a sauvé ! j’ai cherché le package cassé et je l’ai enlever

maintenant j’ai autre chose.

depuis 2 jours, impossible de me connecter à un serveur 64 bit !

d’abord voici mon “sources.list”

[quote]deb debian-amd64.alioth.debian.org/pure64/ sid main
deb-src debian-amd64.alioth.debian.org/pure64/ sid main [/quote]

le message d’erreur :

[quote]# apt-get update
Err debian-amd64.alioth.debian.org sid/main Packages
Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Err debian-amd64.alioth.debian.org sid/main Release
Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Err debian-amd64.alioth.debian.org sid/main Sources
Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Err debian-amd64.alioth.debian.org sid/main Release
Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Impossible de récupérer debian-amd64.alioth.debian.org/p … ackages.gz Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Impossible de récupérer debian-amd64.alioth.debian.org/p … 64/Release Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Impossible de récupérer debian-amd64.alioth.debian.org/p … Sources.gz Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Impossible de récupérer debian-amd64.alioth.debian.org/p … ce/Release Erreur temporaire de résolution de « debian-amd64.alioth.debian.org »
Lecture des listes de paquets… Fait
W: Impossible de localiser la liste des paquets sources debian-amd64.alioth.debian.org sid/main Packages (/var/lib/apt/lists/debian-amd64.alioth.debian.org_pure64_dists_sid_main_binary-amd64_Packages) - stat (2 Aucun fichier ou répertoire de ce type)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Le téléchargement de quelques fichiers d’index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.[/quote]

j’ai également essayé avec :

#deb debian.inode.at/debian-amd64/pure64/(… sid main
#deb-src debian.inode.at/debian-amd64/pure64/(… sid main

#deb ftp://ftp.de.debian.org/debian-amd64/pure64/(… sid main
#deb-src ftp://ftp.de.debian.org/debian-amd64/pure64/(… sid main

#deb ftp.kaist.ac.kr/pub/debian-amd64/pure64/(… sid main
#deb-src ftp.kaist.ac.kr/pub/debian-amd64/pure64/(… sid main

c pareil

c’est pareil chez vous ? parce qu’avec mozilla c’est la même chose ( enfin j’ai essayer juste avec alioth ) il ne peut pas se connecter

merci


#9

j’ai trouvé une solution :

j’avais installé synaptic et grâce à lui, j’ai pu supprimer le logiciel

si ça peut servir à qqun…;

@++