[ ATI radeon 9700 + Xorg 6.9 ] Freeze


#1

Bonjour,

Aprés avoir désactivé le dri de la carte , je me retrouve toujours avec
une mauvaise configuration de mon ATI.

more /var/log/Xorg.0.log | grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) RADEON(0): Enabling DRM support
(WW) RADEON(0): Direct rendering disabled

more .xsessions-errors
xset: bad font path element (#68), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up…
kbuildsycoca running…
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/kde3/kcm_keyboard.so: undefine
d symbol: init_keyboard_layout
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/kde3/kcm_kdnssd.so: undefined
symbol: init_kdnssd
ALSA lib timer_hw.c:269:(snd_timer_hw_open) extended read is not supported (SNDR
V_TIMER_IOCTL_TREAD)
ALSA lib timer_hw.c:269:(snd_timer_hw_open) extended read is not supported (SNDR
V_TIMER_IOCTL_TREAD)
ALSA lib timer_hw.c:269:(snd_timer_hw_open) extended read is not supported (SNDR
V_TIMER_IOCTL_TREAD)
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0xa00022

Suite à l’accumulation de ces BadWindow errors, la machine freeze.

Voila mon Xorg.conf

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath “/usr/lib/X11/fonts/misc”
#FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath “/usr/lib/X11/fonts/Type1”
#FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section “Module”
#Load “bitmap”
#Load “dbe”
#Load “ddc”
#Load “dri”
#Load “extmod”
#Load “freetype”
#Load “glx”
#Load “int10”
#Load “record”
#Load “type1”
#Load “vbe”
#Load "dbe"
Load "extmod"
Load “glx”
#Load “record”
#Load "xtrap"
Load "freetype"
Load “type1”
#Load “drm”

EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. RV350 [Mobility Radeon 9600 M10]"
Driver “radeon”
#Option “UseFBDev” “true”

#Option          "AGPMode" "4"
    #Option          "EnablePageFlip" "on"
    #Option          "RenderAccel" "on"
    # enable (partial) PowerPlay features
    #Option          "DynamicClocks" "on"
    # use bios hot keys on thinkpad (aka fn+f7)
    #Option          "BIOSHotkeys" "on"
    # enable radeon specific xinerama
    #Option          "MergedFB" "true"
    #Option          "CRT2Position" "RightOf"
    #Option          "CRT2Hsync" "50-75"
    #Option          "CRT2VRefresh" "30-82"

EndSection

Section "Monitor"
Identifier “Generic Monitor”
#Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. RV350 [Mobility Radeon 9600 M10]"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0 # initial origin if mode is smaller than desktop
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

#Section “DRI”
#Mode 0666
#EndSection

Pourquoi le serveur X essaie t-il de detecter le second moniteur alors meme que je ne l’ai pas configuré pour?

Je ne sais pas encore très exactement la raison qui est à l’orgine du freeze.

Voyez vous le problème?

Merci :wink:


#2

Tu devrais désactiver l’option ViewPort, qui est utile en cas de dual-screen (par exemple ViewPort 1 0 sur un écran, O 1 sur l’autre).


#3
  • Tu as quelle version de Xorg ?
  • quels pilotes ATi ?
  • sur un PC fixe ?

#4

Et par ailleurs, ce que tu dis semble indiquer que ça plante lors du lancement de KDE.
Tu as essayé avec un autre window manager ?


#5

Merci pour vos réponses.
J’ai téléchargé la version des drivers ATI sur le site officiel.
Il sont initialement prévu pour Xorg 8.2 mais fonctionnent aussi pour la 6.9!


#6

Je viens de remarquer l’erreur, xfont-path :

xset: bad font path element (#6Cool, possible causes are: Directory does not exist or has wrong permissions Directory missing fonts.dir Incorrect font server address or syntax

En français, ça donnerait :
“xset: mauvais élement du chemin des caligraphies (ou lettres, ou fonts) (les causes d’erreurs possibles sont :
Repertoir inexistant ou ayant d’incorrectes permissions
Repertoir manquant fonts.dir
Adresse ou syntaxe du serveur de font incorrecte”

Vérifie si les répertoires de tes fonts (les FontPath) existent bel et bien, et que tu dispose de tout les paquets nécessaires au serveur de font (xft).