Ati rage xl 3d (accélération 3d mach64)


#1

comment se procurer le module mach64 et le compiler?
ma carte utilise le module ati par défaut donc pas d’accélération


#2

Bon j’ai vu que mach64 est fourni avec le code source du noyau 2.6.8 alors j’ai fait une recompilation (à la sauce debian) en précisant bien que je veux qu’il me compile les modules que j’ai besoin tout se passe bien. Mais lorsque je boot sur le nouveau noyau il me met un kernel panic me disant qu’il ne peut booter sur mon disque dur hdax. Je regarde les commandes de boot de mon ancien noyau et c’est identique. Je comprends pas où est l’erreur?


#3

T’as pas oublié l’option “–initrd” par hasard ?


#4

en fait j’ai compilé à l’aide de fakeroot make-kpkg … et installé avec dpkg -i kernel-image…
d’après ce que j’ai lu dans les docs tout ce qui est nécessaire est fait auto


#5

oui mais Jabba a raison: il faut faire
make-kpkg –initrd


#6

ok ben j’essai de suite


#7

Moi je n’ai pas fait d’initrd sur ma 2nde machine et mon noyau est opérationnel. (j’avais eu un msg d’avertissement un peu louche)

–initrd spécifie que c’est un noyau perso et pas officiel ?

(j’ai encore 12 questions sur les noyaux mais je crois que je n’arriverai jamais à tt comprendre… :confused: )


#8

Pose les quand meme tes questions on verra apres :slightly_smiling:


#9

Demain par mp peut-être. J’en ai marre de saouler tt le monde.

C’est bien parce que c’est toi ! :mrgreen:


#10

J’ai pas réussi à compiler avec --initrd j’ai eut des messages d’erreur. j’abandonne


#11

Copie tes messages d’erreur et colle-nous ça demain.

Tu ne dois jamais abandonner :mrgreen: les programmes sont faits pour qu’on les fasse marcher.

ps : avec un PIII 600, la compil est longue (c’est mon cas). Même si ça a l’air planté, ce n’est pas le cas…


#12

sans le --initrd j’ai eut kelke avertissement mais rien n’a empeché de compilé.
j’ai trouvé le module mach64 sur dri.freedesktop.org/snapshots/ compilé avec le common et ca à l’air de fonctionner (lecture divx et dvd plus correct) mais juste une question:
quel pilote je dois charger? pour l’instant je suis sur ati et je vois dans lsmod que mach64 est chargé alors est ce que je laisse tel quel?
j’essai de faire un glxgears mais il ne fonctionne plus a cause libXxfree86mv.so manquant donc à vrai dire je sais pas si l’accélération est fonctionnel