Avec Ma Debian... veut voir mes partitions WIN !


#1

Bonsoir,

Je peux effectuer sans soucis un :
mount -t ntfs -o ro /dev/hda1 /mnt/winxp et tout voir ! mais qu’avec root !
Donc, j’essaie de modifier /etc/fstab afin de monter mes partions WIN…
Que je fasse :
/dev/hda1 /mnt/winxp ntfs user,noauto,ro,exec,umask=0 0 0
[pas les droits pour lire /mnt/winxp]
/dev/hda1 /mnt/winxp ntfs ro,user,noauto 0 0
[ou rien comme contenu ]

Je ne sais où attribuer les droits pour un utilisateur voire le “coller” dans un groupe… par KDE pour commencer :wink:

Par avance, merci !


#2

2 solutions:
soit tu met les utilisateurs à qui tu veux donner le droit de monter les disques dans le groupe “disk”, auquel cas seul celui qui aura monté la partoche et root pourront y accéder quand c’est monté
soit tu mets la partoche en users (avec un s), et elle devient accessible à tout le monde dés qu’elle est montée.
la commande pour ajouter l’user console au group disk:
adduser console disk


#3

pour “coller” les partoches dans un groupe, il faut ajouter, dans le fstab (avec par exemple un groupe “windows” de gid:1002 et un utilisateur de uid=1000):

on peut bien sûr “jouer” sur le umask.

voili,
hatori.


#4

Bonjour et merci pour les réponses…

Mais je n’y arrive toujours pas :blush:
Il me semblait qu’il suffisait de modifier “/etc/fstab” mais les manip. n’aboutissent pas.
Maintenant même en me connectant en “root”, je ne vois rien non plus !
En ce qui concerne “adduser”, j’ai bien ajouter mon login à “disk” mais rien.

Quelle est la commande afin de lister toutes les partitions du disque ? (windows inclus :wink: )

Le fait qu’après chaque enregistrement dans la console arrive :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified
Cela a-t-il de l’importance ?

Par avance, merci.
Et bonne jounée !


#5

ça va viendre :wink:

normalement c’est le cas…

liste les partitions montées sur le système

si ils sont dans le fichier /etc/fstab…

[quote=“xtofe”]Le fait qu’après chaque enregistrement dans la console arrive :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified
Cela a-t-il de l’importance ?[/quote]
normalement, non, le montage de la table est antérieur au lancement su serveur X

d’abord une petite question: est-ce que tu as créé le dossier “winxp” dans le répertoire /mnt/ ?
si ce n’est pas le cas, ne cherche pas plus loin, ça vient de là ($ indique un shell sous Mr. Root):

Ensuite, si ça marche toujours pas, essaie de voir si ça vient de ta partoche:
-commente toutes les lignes de ton /etc/fstab relatives à tes partitions xp;
-reboot;
-essaie de “monter” tes partitions à la main:

et voit ce qu’il te dit:
-soit il y arrive et alors le problème vient probablement d’une erreur dans ton fichier /etc/fstab/ (dans ce cas joint le dans ton prochain message :wink:);
-soit il y arrive pas et dans ce cas joint sa réponse.

hatori.
PS:

la vache, plutôt matinale pour un dimanche… :smiley:


#6

la vache, plutôt matinale pour un dimanche… Very Happy
c’est plus calme :wink:

Merci d’être là un dimanche !

Alors :
Oui, le dossier est crée
Oui, mount -t ntfs /dev/hda1 /mnt/winxp cela fonctionne

Mais j’aurais souhaité créer un raccourci afin d’y accéder plus vite !

/etc/fstab/

proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda11 /home ext3 defaults 0 2
/dev/hda8 /opt ext3 defaults 0 2
/dev/hda9 /tmp ext3 defaults 0 2
/dev/hda7 /usr ext3 defaults 0 2
/dev/hda10 /var ext3 defaults 0 2
/dev/hda12 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda1 /mnt/winxp ntfs ro,user,noauto 0 0

Mais où sont mes partitions Win :open_mouth:
Car j’en ai encore une p’tite…

Voilà merci encore.
Bonne soirée,
xtofe.


#7

je n’avais pas vu que tu le précisais dans ton premier message, autant pour moi

pour pouvoir faire ça il faut que le montage automatique fonctionne…

avec cette ligne, la commande

devrait marcher, est-ce le cas?

si oui, tu n’as plus qu’à la basculer en mode automatique et lui attribuer
ton uid (>id):

tu peux affiner en créant un groupe windows ($addgroup windows)
et attribuer ta partoche à ce groupe:

sans oublier d’ajouter les utilisateurs destinés à lire la partition dans le groupe windows…
ensuite tu pourras créer des liens sur ce dossier sur ton home (>man ln pour plus de précisions).

hatori.


#8

Bonsoir,

Avec /dev/hda1 /mnt/winxp ntfs ro,user,auto,uid=1000 0 0, c’est tout bon !

Je vais tester /dev/hda1 /mnt/winxp ntfs ro,user,auto,gid=1002 0 0, pour aller plus loin… grâce à vous, merci.

Toutefois, comment afficher les autres partitions win du disque ; existe-t-il une commande ?

Merci et encore merci,
xtofe.


#9
echo pq | fdisk /dev/hda

liste les partoches de hda


#10

[quote=“xtofe”]
Je vais tester /dev/hda1 /mnt/winxp ntfs ro,user,auto,gid=1002 0 0, pour aller plus loin… grâce à vous, merci.
.[/quote]
juste une précision si tu passes par l’option groupe:
dans l’exemple “gid=1002” est un gid probable d’un nouveau groupe créé sur ton système…
il faut donc:
-que tu créés un groupe avec un nom approprié (genre “windows”):

le system te renvoie alors le gid du groupe “windows” et c’est ce gid qu’il faut mettre dans le /etc/fstab
-ensuite, les utilisateurs que tu associeras au groupe “windows” auront les droits d’accès définit dans le umask

exemple:

/dev/hda6       /mnt/windows/MA-BELLE-PARTION-WINDOWS      vfat  auto,rw,user,uid=1000,gid=1002,umask=022        0       0

la partition MA-BELLE-PARTION-WINDOWS appartient à l’utilisateur d’uid=1000 et de gid=1002 (le groupe “windows” chez wam)
et a comme droit drwxr-xr-x
un petit lien pour gérer les droits correctement:
http://lea-linux.org/admin/fstab.html

hatori.


#11

Bonjour,

J’ai bien tout noté sauf pour ça :
Win95 Ext’d (LBA)
Qui est donc ma partition dur hda2, je la monte comment ?
Cela ne fonctionnait pas avec ntfs ; j’ai voulu frimé et la mettre en auto mais :confused:

Par avance merci,
xtofe.


#12

fat


#13

Bonsoir !

mount: fs type fat not supported by kernel :open_mouth:
Je comprendrai que cela vous semble long :blush:

Merci,
xtofe.


#14

vfat :blush:


#15

Hi !

J’avais déjà essayé… et :

mount -t vfat -o ro /dev/hda2 /mnt/Data
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
(aren’t you trying to mount an extended partition,
instead of some logical partition inside?)

Bonne soirée,
xtofe.


#16

[quote=“MattOTop”] echo pq | fdisk /dev/hda
liste les partoches de hda[/quote]
peux tu me donner la sortie de la commande ?


#17

Bonjour !

Voilà :

/dev/hda1 * 1 19380 9767488+ 7 HPFS/NTFS
/dev/hda2 19381 77520 29302560 f W95 Ext’d (LBA)
/dev/hda5 19381 29533 5116671 7 HPFS/NTFS
/dev/hda6 29534 29727 97744+ 83 Linux
/dev/hda7 29728 41353 5859472+ 83 Linux
/dev/hda8 41354 43291 976720+ 83 Linux
/dev/hda9 43292 46197 1464592+ 83 Linux
/dev/hda10 46198 49103 1464592+ 83 Linux
/dev/hda11 49104 76229 13671472+ 83 Linux
/dev/hda12 76230 77520 650632+ 82 Linux swap

Merci,
xtofe.


#18

bon, c’est bien ce que je pensais :laughing: : petite explication.
hda2 n’est pas une partition lisible. Ce n’est qu’une partition primaire “extended” sur laquelle sont déclarées les partitions logiques hda5-12.
Pas la peine d’essayer de faire quoi que ce soit avec hda2, donc…
Donc, indépendament des partitions 6-12 qui doivent déja etre configurées dans fstab, les partitions windows auxquelles tu as accés sur hda sont les partitions hda1 (sans doute ton systeme) et hda5.
Elles sont toutes les deux en NTFS (dc mount -t ntfs)…


#19

Bonjour,

Merci MattOTop, encore une fois :smiley:
Bon, je vais de plus en plus faire de place pour Debian et supprimer cette partition afin de l’inclure comme une p’tite /mnt/multimedia !!!

Une belle journée à toi, MattOTop et à vous lecteurs…
Je confirme ma signature :wink:
xtofe.


#20

si ta partoche hda5 est ta partoche “données”, et si elle fait moins de 32Go, bascule la en fat32, elle servira de zone d’echange entre lin et win, la fat32 etant super bien supportée sous linux…