Avoir affichage majucule numérique Xfce Debian

Tags: #<Tag:0x00007fae4eaba190>

Bonjour

Une solution (il y en a une bien meilleure plus bas)
pour faire afficher l’état des leds CapLock et NumLock du clavier
dans un tableau de bord d’XFCE
que vous pourrez configurer avec les couleurs et le label que vous voulez.

Mais je pense qu’il y a beaucoup mieux à faire,
étant donné que cette solution lance un script toutes les demi secondes… :astonished:


Créez un fichier nommé

~/.capNumLck.genmon

dont le contenu sera :

kbdLeds=$(($(xset q | awk 'NR==2{print $NF}')*1))

# Labels affichés
capLock="C"
numLock="N"


# Couleurs
offBgColor="#000"
offFgColor="#BBB"

onBgColor="#0F0"
onFgColor="#F00"

case $kbdLeds in
    0)
       CbgCol=$offBgColor;
       CfgCol=$offFgColor;
       NbgCol=$offBgColor;
       NfgCol=$offFgColor
       ;;
    1)
       CbgCol=$onBgColor;
       CfgCol=$onFgColor;
       NbgCol=$offBgColor;
       NfgCol=$offFgColor
       ;;
    2)
       CbgCol=$offBgColor;
       CfgCol=$offFgColor;
       NbgCol=$onBgColor;
       NfgCol=$onFgColor
       ;;
    3)
       CbgCol=$onBgColor;
       CfgCol=$onFgColor;
       NbgCol=$onBgColor;
       NfgCol=$onFgColor
       ;;
esac
echo "<txt><span weight='Bold' bgcolor='$CbgCol' fgcolor='$CfgCol'>$capLock</span><span weight='Bold' bgcolor='$NbgCol' fgcolor='$NfgCol'>$numLock</span></txt>"

Faites un click-droit en haut et à droite sur le Tableau de bord
dans le menu contextuel qui s’affiche, cliquez sur Tableau de bord
et dans le sous-menu contextuel qui s’affiche, cliquez sur + Ajouter de nouveaux éléments…

Dans la liste qui va s’afficher, entrez et sélectionnez : Moniteur générique
puis cliquez sur le bouton + Ajouter puis sur le bouton X Fermer

Faites un click-droit sur le nouveau plugin qui s’est ajouté et qui affiche : (genmon)XXX
et dans le menu contextuel qui s’affiche, cliquez sur Propriétés

Dans la fenêtre Configuration qui s’affiche,
et dans la boîte de saisie située en face du label Commande
entrez le chemin absolu du fichier ~/.capNumLck.genmon
(sur ma machine, c’est : /home/michel/.capNumLck.genmon)

Décochez la case à cocher qui est à gauche du label Étiquette
et réglez la Période d’actualisation assez basse (0,50)

Sélectionnez la police de caractères et sa taille
en fonction de vos préférences (J’ai choisi : Sans 20)

Et pour finir, cliquez sur le bouton X Fermer


NumLock activé : Capture d’écran_2020-05-09_10-55-51
CapLock activé : Capture d’écran_2020-05-09_10-55-29


Sources d’inspiration :

XFCE -> xfce4-genmon-plugin

The Pango Markup Language -> The pango Class Reference

1 J'aime

Salut bonjour @josephtux ,toutes et tous :sun_with_face: :bird:

Il faudrait voir du coté du bios et de ton environnement de bureau section clavier (c’est souvent une option à la con cachée) pour la led VerrNum

Salut @MicP bonjour :slight_smile:
Bravo pour l’astuce :+1: , j’espère que tu n’y a pas passé toute ta nuit quand-même :laughing:

Merci beaucoup,
très content que tu apprécies :smiley:

L’option à la con est digne de cette qualification: elle était cochée pour Caps-Lock, alors que son intitulé me semblait indiquer le contraire. Décochée, ça marche .

(Mate, Jessie: l’option est enfouie dans le menu
Système→Propriétés du clavier→Agencements→Options de l’agencement du clavier→Utiliser les voyants du clavier…)

L’option cochée règle sur l’affichage par une LED, qui manque à mon clavier; en réalité elle mettait donc probablement une LED physique en concurrence avec l’accès pour affichage.

Bravo et grand merci Iblis.

Une autre solution beaucoup plus économique,
toujours pour XFCE :

Capture d’écran_2020-05-16_11-29-55

#!/bin/bash

# # # # # # # # # # # # # # # # # # # # # 
# Pour faire afficher sur l'écran de XFCE
#  un message de notification présentant l'état
#  des voyants du clavier "Num" et "Cap"
# 
# Installez le paquetage "xdotool"
#  en lançant la ligne de commandes suivante :
# su -c "apt install xdotool"
#
# Depuis votre compte utilisateur,
#  créez un fichier nommé :
# ~/.capsNumLock.sh
#  dans lequel vous copierez
#  l'intégralité de ce script.
#
# Rendez ce fichier script exécutable
#  en lançant la ligne de commande suivante :
# chmod u+x ~/.capsNumLock.sh
#
# Cliquez sur "Applications" -> "Paramètres" -> "Clavier" ->  Onglet "Raccourcis d'applications"
#  et cliquez sur le bouton "+ Ajouter"
#
# Entrez la ligne de commande à exécuter avec son paramètre :
# /home/michel/.capsNumLock.sh Caps_Lock 
#  et appuyez sur la touche "ver Maj"
#
# Entrez la ligne de commande à exécuter avec son paramètre :
# /home/michel/.capsNumLock.sh Num_Lock 
#  et appuyez sur la touche "ver Num"
#
# Cliquez sur le bouton "X Fermer"
# # # # # # # # # # # # # # # # # # # # # 

tempo=500   # Durée d'affichage du message (en millisecondes)
ledOn="●"
ledoff="○"
labNum="Num"
labCap="Caps"

xdotool key $1
case $(($(xset q | awk 'NR==2{print $NF}')*1)) in
    0)
       num="$ledoff"
       cap="$ledoff"
       ;;
    1)
       num="$ledoff"
       cap="$ledOn"
       ;;
    2)
       num="$ledOn"
       cap="$ledoff"
       ;;
    3)
       num="$ledOn"
       cap="$ledOn"
       ;;
esac
notify-send -t $tempo  "$num $labNum
$cap $labCap"
1 J'aime

@josephtux Cool je suis content que tu aies résolu le problème de la led :slight_smile:.
C’est vrai que c’est chiant ce genre de désagrément.Comme par exemple le VerrNum activé dans le bios et désactivé par le système au login graphique .
À un moment je pensais que ta led était grillée . Ouff de soulagement alors o/

Le premier microprocesseur intel que j’ai appris à programmer
était le 8042, celui qui est dans le clavier, directement relié à la matrice des touches du clavier.
(Actuellement c’est un Intel 8048 qui est utilisé)

L’état des leds n’a électroniquement rien à voir avec le fait que le clavier soit en majuscule ou minuscule, et c’est la même chose pour l’indicateur d’état du pavé numérique,
d’où l’inversion d’état constaté.

Oui c’est bizarre ce fonctionnement. il m’est arrivé (et encore maintenant) que le pavé numérique fonctionne alors que sa led est éteinte .Je ne sais pas si c’est en graphique ou en TTY.Du coup j’appuie sur la touche adéquat si ça fait des caractères bizarres à la place des chiffres. C’est vraiment à se prendre la tête ce truc.
Dans ma logique c’est led allumée=activé ,led éteinte=désactivé .On veut nous rendre fous je vous dis :smiley:

Le problème vient du fait qu’à l’origine (PC XT/AT), les sortie du microprocesseur du clavier
qui sont connectées à ces leds ne sont accessibles qu’en écriture.

Salut @MicP Bonjourno!! o/ :slight_smile:

Ah ok je vois le truc.Mais ne serait-ce pas possible de demander à l’OS de justement contrôler les « sorties du microprocésseur du clavier » ? Ça marche sous Windows ,alors pourquoi pas sur Debian ?.
En plus de cela ça pose des problèmes pour les « débutants » (j’en suis un aussi :smiley:) lors de la saisie de leurs mots de passe contenant des chiffres .Ça affiche des caractères spéciaux genre [4~[B[6~ ... Tu penses bien que lorsque l’utilisateur saisit son mot de passe demandé à l’aveugle (vu qu’il n’est pas affiché) et que ça lui réponds mot de passe incorrect alors qu’il est certain de l’avoir bien saisit, le gars s’arrache les cheveux :laughing:

Ça dépendra de toutes façons de l’état dans lequel chacun (BIOS, EFI, chargeur de boot)
aura décidé de laisser ces sorties.

Ok , mais avoue que c’est curieux de la part du Bios, Grub ou à l’installation de mettre par exemple VerrNum désactivé par défaut.Dans la logique il devrait être activé ,donc prêt à l’emploi .Je trouve ce blocage bizarre

Si tu utilises un portable qui n’a pas de pavé numérique,
HP Pavillon ze5516ea keypad
tu risques de trouver cette fonctionnalité beaucoup moins sympa.

La touche Shift+chiffres sur la ligne au-dessus d’azerty… ne suffit pas? Pourtant ça marche sur tout les portables non ? :open_mouth:
Pour le Fn+chiffres bleus , il me semble avoir eu des soucis effectivement.

Bonjour à tous et toutes, j’ai finalement gardé le greffon ajouté nativement par Xfce dans le panel, option trouvée sous disposition du clavier, afficher la disposition sous la forme de : système et indicateur Verr Maj activé. Le verrouillage numérique restant actif tout le temps après le premier verrouillage. Et dans le pire des cas en cas de tête en l’air la mauvaise surprise de se rendre compte que le verrouillage numérique ce n’est pas actif et que tu tapes au clavier tes mots qui suivent un nombre dans le vide. :laughing: :rofl: :roll_eyes: :thinking: :rage: :weary: Merci à tous et toutes :grin:

Bonjour

Quel est le nom de ce greffon ?

Je ne sais pas de quelle option tu parles,
je ne la vois pas :
Capture d’écran_2020-05-13_08-42-01

Clic droit sur le panel -> tableau de bord -> ajouter de nouveaux éléments -> disposition du clavier :wink:

1 J'aime

Merci,
je vois bien pour les majuscules, après avoir sélectionné système (voir ci-dessous)
Capture d’écran_2020-05-13_09-17-50
mais je n’ai pas trouvé pour NumLock

En tout cas, merci beaucoup pour le retour. :+1:

Capture d’écran_2020-05-13_09-55-55 Minuscule

Capture d’écran_2020-05-13_09-55-31Majuscule

Exactement comme moi pour le NumLock, reste à se rendre compte de l’activation ou non de NumLock pendant la saisie de nombre (et bien sûr à la fin de la saisie -> super Lol :rofl: mais bon c’est mieux que rien… :wink: