Avoir les DRM de netflix sur Opera linux

Bonjour,

Après avoir constaté que le module widewine nécessaire à l’utilisation de netflix est absent sur opera linux j’ai reporté ce problème aux equipes de Opera qui m’on suggérait d’installer chromium est d’entrer dans le terminal cette commande:

sudo ln -s /usr/lib/chromium-browser/libs/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/lib_extra/libffmpeg.so.32

qui devrait résoudre ce problème , or le terminale me renvoie un message d’erreur qui est:

ln: impossible de créer le lien symbolique '/usr/lib/x86_64-linux-gnu/opera/lib_extra/libffmpeg.so.32': Aucun fichier ou dossier de ce type

Pouvez vous m’aider à resoudre se problème et plus largement donner d’autre solutions pour l’utilisation de netlix sur opera car ce problème est le sujet de nombreuses contreverse sur le forum d’opera.

Bonjour
Je pense que les personnes qui t’ont conseillé ça se sont trompé car il est impossible de regarder Netflix sous Linux avec Chromium. Ce n’est donc pas une bonne piste pour récupérer widewine
Les seuls navigateurs (mais je me trompe peut-être) qui en sont capable c’est Firefox et Chrome.
EDIT : dans firefox tape about:plugins ça t’indiquera la localisation de widewine

2 J'aime

J’ai donc tenté d’utiliser le plugin de Widewine venant de firefox en modifiant le chemin d’accés du dossier parent d’une part mais aussi en redéfinissant le chemin d’accés de destination d’une autre part car après verifacation le dossier lib_extra n’existe pas.

sudo ln -s /home/gabriel/.mozilla/firefox/cah7yszb.default-esr/gmp-widevinecdm/4.10.2391.0 /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so

mais la commande me renvoie un autre message d’erreur qui est :

ln: impossible de créer le lien symbolique '/usr/lib/x86_64-linux-gnu/opera/libffmpeg.so': Le fichier existe

Merci d’avance pour votre aide

Alors, j’ai une question extrêmement débile, du coup, merci d’accepter toutes mes excuses.
Pourquoi tu n’utilises pas Firefox pour aller sur Netflix ?
Je ne sais pas quelle version de Debian tu utilises, mais je me sers personnellement de Firefox pour aller sur Netflix et je n’ai pas de problème particulier.

En plus, entre nous, Widevine, c’est juste pour faire chier le monde, ça n’empêche absolument pas de capturer le flux.

Et bien en effet jusqu’ici j’utilise firefox pour regarder netflix mais étant donné que toutes mes activités se tournaient autour de mon navigateur favoris je me posais cette question dans une optique de centralisation. Dans les forums d’opera beaucoup d’autre se retrouver dans la même situation et j’essayais juste d’aller chercher des solutions ailleurs pour leur exposer par la suite. Le soucis des codecs vidéo va bien plus loin que la simple utilisation de netflix pour ma part elle est defaillante dans whats app, france TV, dailymotion … Switcher entre firefox à chaque fois que j’ai besoin de ces applications pourrait paraitre la solution la plus simple mais à termes ce serait tout de même bien résoudre nativement se problème . Mais si cela pourrait dénoter d’un certain perfectionnisme.

Oui, en effet, je te proposais ça parce que c’est mon fonctionnement de fermer et lancer tout le temps le navigateur.
J’ai treize profils Firefox afin d’isoler toutes mes activités. J’utilise également Chromium avec l’option --temp-profile qui permet de ne pas stocker le profil pour les sites qui n’aiment pas Firefox, comme le site de la Poste et Doctolib.

Je ne sais pas t’aider là dessus.
J’ai trouvé ceci ça a l’air de marcher d’après les réponses qu’il y a en dessous : https://forums.opera.com/post/175864

Eh bien avant de venir ici me renseigner sur l’utilisation de widewine avec opera j’avais effectivement vu cette solution sur le forum d’opera. Mais à ce jour cette solution est obsolète au vue des commentaires plus bas. J’avais essayé de mon côté et opera ne démarrait plus. J’avais heureusement fait un instantané de mon système pour récupérer opera. De toute façon comme tu peux le lire dans le forum les dev de opera délaisse de plus en plus le support d’opera linux. J’ai beau tenter d’alerter l’équipe d’opera par mail pour l’heure faire part de ce problème très penible mais je pense qu’il va falloir attendre longtemps avant de pouvoir voir une résolution natice de ce problème.

Ben si, je le fait en ce moment avec un chromium.

C’est bien Chromium et non Chrome ?
Tu as fais des manipulations pour que ça marche ?
Sous quelle distribution ?

si ça peut aider :

dpkg -S libffmpeg.so
webcamoid-plugins:amd64: /usr/lib/x86_64-linux-gnu/avkys/submodules/VideoCapture/libffmpeg.so
atom: /usr/share/atom/libffmpeg.so
webcamoid-plugins:amd64: /usr/lib/x86_64-linux-gnu/avkys/submodules/MultiSink/libffmpeg.so
webcamoid-plugins:amd64: /usr/lib/x86_64-linux-gnu/avkys/submodules/MultiSrc/libffmpeg.so

Après 24 ans sous Debian (j’ai commencé par la Bo), je suis passé à Archlinux. En revanche effectivement, sous debian ça a l’air de coincer. Voilà la version d’archlinux que j’utilise (elle date de 2 mois en gros):

Chromium 93.0.4577.82 (Build officiel) Arch Linux (64 bits)
Révision e3a25d9b9e2d0b728e045ec87c0aa4942aa46e4e-refs/branch-heads/4577@{#1237}
Système d’exploitation Linux
JavaScript V8 9.3.345.19
Agent utilisateur Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36
Ligne de commande /usr/lib/chromium/chromium --enable-crashpad --flag-switches-begin --flag-switches-end --origin-trial-disabled-features=CaptureHandle
Chemin d’accès exécutable /usr/lib/chromium/chromium

Pas d’extensions particulières, pas de librairie libffmpeg:

~]$ locate libffmpeg
/usr/lib/libffmpegthumbnailer.so
/usr/lib/libffmpegthumbnailer.so.4
/usr/lib/libffmpegthumbnailer.so.4.15.1

[ça c’est pour l’affichage des miniatures des videos]

J’ai essayé sur ma debian et effectivement ça coince.

Bonjour

Juste pour info :

Avec Firefox 78.15.0 ESR October 5, 2021
sur debian 11 (bullseye)

Netflix fonctionnait jusque là très bien,
mais, depuis 18:00 ce mercredi 15 décembre 2021,
il m’est impossible de lancer le visionnage d’un film :

Erreur Netflix F7701:1003

J’ai tenté sans plus de succès
depuis un système Ubuntu 20.04.3 LTS (focal) nouvellement installé,
donc, avec Firefox 94.0 November 2, 2021

Je précise qu’il n’y a aucun plugins ou autres thèmes installés dans mes navigateurs Firefox
et que l’option Lire le contenu protégé par des DRM est activée.


EDIT : Problème résolu.

J’avais activé l’option : Supprimer les cookies et les données du site à la fermeture

Il fallait laisser cette option désactivé.
(J’ai transmis l’information au Centre d’aide de Netflix)

Note : M’en fou !
Je vais me créer un bon petit script pour supprimer ces cookies manuellement.

1 J'aime

:joy: on n’est jamais mieux servi que soit même :wink:

j’utilise l’addon cookie autodelete

Finalement, j’ai pu ré-activer l’option Supprimer les cookies et les données du site à la fermeture
et ça fonctionne comme avant.

Il semblerait que la désactivation de cette option n’ait été nécessaire qu’après avoir cliqué sur le bouton Accepter les nouvelles clauses.

Si je m’en souviens bien du temps où j’étais sur archlinux pamac me proposé une dependance me permettant de lire du contenu protégé à l’insatllation d’opera