Bewan usb


#1

Je viens d’installer une distribution linux debian sarge. J’ai un 2800+, a7n8x deluxe, dd 120Go maxtor…
J’ai fait une installation à partir de 3 cd debian.
Mon modem est un bewan usb st. J’ai télécharger les pilotes de celui-ci. J’ai compiler les pilotes via différents tutos dispo sur le web pour les cartes pci bewan mais qui fonctionnent avec l’usb. Mon modem est allumé, il fait le lien avec ma ligne adsl de cegetel 2Mb. J’arrive à télécharger quelques pages internet, mais je me fait déconnecté pas longtemps aprés. Mon modem perds alors le connexion. Je ne comprend pas pourquoi, j’ai pourtant chercher mais je ne trouve pas. Pourriez vous m’aider??


#2

Pour indication j’ai suivi cette page:http://www.andesi.org/index.php?node=93
avec quelques modifications nécessaires!!!
J’ai aussi pris quelques indications sur cette page:http://www.solix.info/bewan_linux.php
Ma connexion se fait alors au démarrage…
Cepandant elle ne dure pas longtemps et fonctionne quand elle veut.
Merci d’avance pour vos réponses.


#3

tu as bien une directive ‘persist’ dans ton fichier /etc/ppp/peers/dsl-provider (si c’est celui là qui est utilisé pour ta connection)?


#4

D’abord merci d’avoir répondu!!
Désolé mais je débute sous linux, je ne sais donc pas si j’utilise ce fichier.
En revanche j’ai efectivement une directive “persist” dans celui-ci.
Cependant je me demande si le probleme ne vien pas du fichier /etc/ppp/options: j’ai modifier celui-ci pour ne laisser que les lignes suivantes:
lock
ipparam ppp0
noipdefault
noauth
default-asyncmap
defaultroute
hide-password
noaccomp
noccp
nobsdcomp
nodeflate
nopcomp
novj novjccomp
lcp-echo-interval 20
lcp-echo-failure 3
sync
maxfail 0
persist
plugin /usr/lib/pppd/plugins/pppoatm.so 8.35
name nom_utilisateur@cegetel.net
user nom_utilisateur@cegetel.net

J’ai trouver cette config sur le net mais je ne connais pas la signification de la plupart des lignes (à noter que la directive “persist” est présente!!!).


#5

ben à part le fait que le /etc/ppp/options.ppp devrait être standard et que c’est /etc/ppp/peers/dsl-provider qui devrait contenir ces lignes, ca m’a l’air cohérent, tout ça (man pppd pour plus d’info).
juste, tu peux essayer d’ajuster ton mtu avecmtu=1492
( lire dslreports.com/faq/5793 )


#6

salut, j’ai le meme modem, mais suis chez tele2, en noyau 2.4 j’ai réussi à leur faire marcher, mais jamais en 2.6.

mon ppp/options

usepeerdns
lock
ipparam ppp0
noipdefault
noauth
default-asyncmap
defaultroute
hide-password
noaccomp
noccp
nobsdcomp
nodeflate
nopcomp
novj
novjccomp
lcp-echo-interval 20
lcp-echo-failure 3
mtu 1500
mru 1500
sync
maxfail 0
persist
plugin /usr/lib/pppd/2.4.2/pppoatm.so
user xxxxxxxxxxxxxx@tele2.fr

si ca peux aider.