Blocage de la souris à l'appui d'une touche


#1

Bien le bonsoir à tous !

Le titre est assez explicite je pense ^^

Lorsque j’appuie sur une touche du clavier le pointeur de la souris se bloque, ou ne bouge que par saccades (d’intervalle assez long).
J’ai cherché et regardé un peu près tous les problèmes concernant les souris sur ce forum, sans trouver de réponse. Ou alors quelques posts m’ont échappé.

C’est donc dans l’obscurité oppressante de mon désarroi que je lance un HELP à la communauté ^^

Je ne sais pas trop quelles sont les infos dont vous pourriez avoir besoin pour trouver des pistes, donc je met un peu au hasard:

Je suis sous debian etch
J’ai une souris sans fil branché sur port PS/2
Clavier filaire port PS/2.
J’ai installé xorg, kdm et kde, ainsi que imwheel.

Je vous remercie d’avance ! :slightly_smiling:


#2

Et ta couche réseau, elles est correctement configurée ? (eth0 ET lo)
J’insiste, la carte réseau ET le loopback !
Si le réseau est de travers, on peut avoir des lenteurs inexplicables dans l’interface graphique.


#3

Déjà merci de cette première réponse si rapide :slightly_smiling:
Voila ce que j’ai en tapant ifconfig:

[code]eth1 Lien encap:Ethernet HWaddr 00:60:4C:14:D7:E4
adr inet6: fe80::260:4cff:fe14:d7e4/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:65535 Metric:1
RX packets:29709 errors:0 dropped:0 overruns:0 frame:0
TX packets:27326 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:24204255 (23.0 MiB) TX bytes:3837146 (3.6 MiB)

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:239 errors:0 dropped:0 overruns:0 frame:0
TX packets:239 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:17443 (17.0 KiB) TX bytes:17443 (17.0 KiB)

ppp0 Lien encap:Protocole Point-à-Point
inet adr:82.251.43.208 P-t-P:192.168.254.254 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:28424 errors:0 dropped:0 overruns:0 frame:0
TX packets:26043 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:3
RX bytes:24133743 (23.0 MiB) TX bytes:3279547 (3.1 MiB)[/code]

Et dans le fichier /etc/network/interfaces

[code]# This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

iface dsl-provider inet ppp
provider dsl-provider
[/code]

Etant donné que je n’ai aucun message d’erreur ou quoi que ce soit d’autre, j’avoue avoir quelques difficultés à localiser la source du problème.


#4

Ta carte réseau eth1 est activée mais elle n’a pas d’adresse IP, à priori ce n’est pas grave si tu n’as pas de réseau local… Et tu as eth1 mais pas de eth0 ? Bizarre…

Sinon, essayes de taper “ping localhost”. Si ca retourne un truc du genre: "network unreachable " ou un autre message d’erreur, le problème est sûrement là, tu dois au moins avoir ton loopback activé pour que X fonctionne correctement.


#5

La requête ping sur localhost s’effectue sans problème.

[code]ounette@debian:~$ ping localhost
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.047 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.044 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=3 ttl=64 time=0.042 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=4 ttl=64 time=0.045 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=5 ttl=64 time=0.042 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=6 ttl=64 time=0.046 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=7 ttl=64 time=0.042 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=8 ttl=64 time=0.043 ms

— localhost.localdomain ping statistics —
8 packets transmitted, 8 received, 0% packet loss, time 6998ms
rtt min/avg/max/mdev = 0.042/0.043/0.047/0.008 ms[/code]

Sinon, question de débutant, tan que j’y suis ^^, ne pas avoir d’interface eth0 est-ce grave ?
eth0 ou eth1, y a t-il une différence fondamental, ou n’est-ce simplement qu’une dénomination ?


#6

[quote=“jabba”]Ta carte réseau eth1 est activée mais elle n’a pas d’adresse IP, à priori ce n’est pas grave si tu n’as pas de réseau local… Et tu as eth1 mais pas de eth0 ? Bizarre…

Sinon, essayes de taper “ping localhost”. Si ca retourne un truc du genre: "network unreachable " ou un autre message d’erreur, le problème est sûrement là, tu dois au moins avoir ton loopback activé pour que X fonctionne correctement.[/quote]
Jabba, indépendament de ta piste, l’eth1 activée sans ip doit simplement être utilisée pour le pppoe sur lequel tourne ppp0.
Par contre, le fait que ce soit eth1 peut venir de la présence d’une autre carte simplement non activée.
Pour voir les cartes physiques détectées, mais pas forcément actives (donc n’apparaissant pas dans ifconfig) ou configurées, un ‘ip link’ peut être bien pratique.

Je vous laisse.


#7

Avec
Maj/VerrNum
ça ne change rien ?


#8

Malheureusement non, cela ne donne rien.

MattOTop> Effectivement oui je possède une carte Ethernet, mais dont je ne me sert pas encore.

debian:/home/gounette# ip link 1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000 link/ether 00:0d:61:03:55:98 brd ff:ff:ff:ff:ff:ff 3: sit0: <NOARP> mtu 1480 qdisc noop link/sit 0.0.0.0 brd 0.0.0.0 4: eth1: <BROADCAST,MULTICAST,UP> mtu 65535 qdisc pfifo_fast qlen 1000 link/ether 00:60:4c:14:d7:e4 brd ff:ff:ff:ff:ff:ff 6: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP> mtu 1492 qdisc pfifo_fast qlen 3 link/ppp

En tous cas merci à tous de m’aider :slightly_smiling:

Et je m’en retourne chercher ^^

EDIT> Je viens de constater quelque chose qui, peut-être, pourrait faire avancer le schmilblick.
Normalent je suis sur un noyau 2.6.15-1-k7. Et j’ai donc ce problème de souris.
Mais, lorsque je boot sur le noyau 2.4.27 je n’ai alors pas ce problème.
Ce qui me fait penser que le problème viendrait donc de la configuration du noyau.
Non ? ^^


#9

essaie de comparer les configs des deux noyau pour ce qui concerne souris et clavier :
/boot/config-2.6.15-1-k7
et
/boot/config-2.4.27-xxx


#10

Me revoila, après une petite inspection des fichiers de config des deux noyaux.

CONFIG 2.4.27-386

[code]# Input core support

CONFIG_INPUT=m
CONFIG_INPUT_KEYBDEV=m
CONFIG_INPUT_MOUSEDEV=m
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_INPUT_JOYDEV=m
CONFIG_INPUT_EVDEV=m
CONFIG_INPUT_UINPUT=m

Mice

CONFIG_BUSMOUSE=m
CONFIG_ATIXL_BUSMOUSE=m
CONFIG_LOGIBUSMOUSE=m
CONFIG_MS_BUSMOUSE=m
CONFIG_MOUSE=m
CONFIG_PSMOUSE=y
CONFIG_82C710_MOUSE=m
CONFIG_PC110_PAD=m
CONFIG_MK712_MOUSE=m[/code]

======================

CONFIG 2.6.15-1-k7

[code]#

Userland interfaces

CONFIG_INPUT_MOUSEDEV=m
CONFIG_INPUT_MOUSEDEV_PSAUX=y
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_INPUT_JOYDEV=m
CONFIG_INPUT_TSDEV=m
CONFIG_INPUT_TSDEV_SCREEN_X=240
CONFIG_INPUT_TSDEV_SCREEN_Y=320
CONFIG_INPUT_EVDEV=m
CONFIG_INPUT_EVBUG=m

Input Device Drivers

CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
CONFIG_KEYBOARD_SUNKBD=m
CONFIG_KEYBOARD_LKKBD=m
CONFIG_KEYBOARD_XTKBD=m
CONFIG_KEYBOARD_NEWTON=m
CONFIG_INPUT_MOUSE=m
CONFIG_MOUSE_PS2=m
CONFIG_MOUSE_SERIAL=m
CONFIG_MOUSE_INPORT=m

CONFIG_MOUSE_ATIXL is not set

CONFIG_MOUSE_LOGIBM=m
CONFIG_MOUSE_PC110PAD=m
CONFIG_MOUSE_VSXXXAA=m[/code]

Il y aurait bien le CONFIG_MOUSE_PS2=m qui m’intriguerait, mais je ne sais pas trop.
Est-ce que changer une valeur (y ou m) de ce fichier suffit pour que cela soit pris en compte ?


#11

[quote=“gounette”]Il y aurait bien le CONFIG_MOUSE_PS2=m qui m’intriguerait, mais je ne sais pas trop.
Est-ce que changer une valeur (y ou m) de ce fichier suffit pour que cela soit pris en compte ?[/quote]
Non, il faut ensuite recompiler le noyau correspondant.


#12

Je te remercie :slightly_smiling:

Donc je vais tenter de recompiler mon noyau ^^

Dans /usr/src/, le lien symbolique “linux” pointe vers linux-headers-2.6.15-1-k7
Si j’ai bien tout compris se ne sont pas les sources (logique en même temps).
Il faut donc que j’installe les sources c’est bien ça ?

C’est ce que j’ai compris de ce poste de Ashgenesis: http://forum.debian-fr.org/viewtopic.php?t=1806&start=0

Une dernière question (ça m’étonnerais ^^) et j’ai finis de vous embêter ^^:

Y a t-il des articles qui expliquent bien le rôle des sources, des entêtes, et des images ? Je dois dire ne pas encore bien saisir le rôle jouer, et les interactions, entre linux-header/linux-source/linux-image.
D’ailleurs, est-ce que mes interrogations ont un sens ou je suis dans les choux ? ^^

Merci !


#13

Sauf erreur :

  • les sources sont nécessaires pour compiler le noyau
  • les entêtes sont nécessaires pour compiler les modules correspondants au noyau

Donc, dans 99% des cas, il faut les 2…


#14

Pour linux-image, c’est un nouveau noyau tout prêt que tu installes


#15

[quote=“Korben Dallas”]Sauf erreur :

  • les sources sont nécessaires pour compiler le noyau
  • les entêtes sont nécessaires pour compiler les modules correspondants au noyau

Donc, dans 99% des cas, il faut les 2…[/quote]
Erreur à partir de la deuxiême phrase:

  • les sources d’un noyau configuré ou à défaut les entêtes sont nécessaires pour compiler les modules correspondants au noyau [b]et qui ne sont pas dans les sources du noyau
  • les sources d’un noyau configuré peuvent permettre de recompiler séparément un module qui est dans l’arborescence de noyau, mais il vaut mieux recompiler tout le noyau [/b]
    gounette: dans trucs et astuces, ici même, tu trouveras plusieurs articles interessant sur la compilation du noyau, avec des réfèrences (peut être que ca va règler ton problême, mais je doute)
    Le mieux, c’est de reprendre les sources de ton noyau actuel, de les déployer, et de reutiliser sa config en modifiant juste CONFIG_INPUT_MOUSE=y CONFIG_MOUSE_PS2=y

#16

Voilà, j’ai pris des risques en postant mon message, car je n’étais pas sûr de moi, mais du coup, j’ai obtenu la réponse, finalement. :wink:


#17

Je vous remercie beaucoup !

Je n’ai pas encore résolu mon problème, mais au moins j’aurais vu comment recompiler un noyau :slightly_smiling:
Reste à trouver la bonne option ^^


#18

Voila, finalement j’aurais trouvé la cause de mon problème.
En fait, rien à voir avec la configuration du noyau !

Est-ce que je le dis ? hmm…pas taper ^^

En fait j’avais le paquet mouseemu d’installer. Il bloquait donc la souris pendant que je tapais.
Et comme il ne fonctionne que sous les noyaux >= 2.6 je n’avais donc pas le pb sur mon 2.4

Voila. ^^
Et encore fois merci de votre patience.


#19

[quote=“gounette”]En fait, rien à voir avec la configuration du noyau !

Est-ce que je le dis ? hmm…pas taper ^^[/quote]LOL, on dirait moi :stuck_out_tongue: