Bloquer l'economiseur avec xset s off


#1

bonsoir
je voudrais supprimer l’economiseur d’ecran.
j’ai installé une etch 2.6.15.
j’ai supprimé tous les xscreensaver.
j’ai modifié xorg.conf dans la section “monitor” j’ai rajouté 2 lignes
option xset s off et
option xset -dpms
j’ai rajouté les 2 meme lignes dans /etc/x11/Xsession sous “set -e"
j’ai rajouté les 2 meme lignes dans /etc/x11/Xsession.option
dans /etc/init.d j’ai crée un fichier “xset” dans lequel j’ai mis
#!/bin/sh
xset s off
dans /usr/sbin j’ai crée la meme chose
dans /usr/sbin j’ai modifié setvesablank
à un” turn blanking on" j’ai mis “off"
j’ai aussi changé le fichier winbind dans /etc/init.d .
je l’ai renomé en xxset et à l’interieur j’ai changé tous les “winbind” en
"xxset” ; sur la ligne 9 pour daemon j’ai mis /etc/init.d/xset
que j’ai fabriqué plus haut.

en fait je cherche à faire demarrer xset s off au demarrage.
dans une console ça marche mais cet ordi est pour une jeune fille qui va pas vouloir s’emmerder avec de la igne de commande.
j’ai deja cherché dans moultes forums et sites sans jamais trouver la reponse et le man il dit pas grand choses.
je sais je suis pas tres clair mais bon si quelqu’un pouvait m’aider.
merci


#2

[quote=“siaudx”]en fait je cherche à faire demarrer xset s off au demarrage.
dans une console ça marche mais cet ordi est pour une jeune fille qui va pas vouloir s’emmerder avec de la igne de commande.
[/quote]

(ré)installe xscreensaver (daemon -> se lance automatiquement) avec lequel il est possible de modifier l’option via une interface graphique (section “display power management”).

et si tu tiens absolument à ne pas installer xscreensaver, il faut voir en fonction de ton WM pour executer ton script au démarrage; exemple pour Gnome:
-> Menu Gnome -> Desktop -> Preferences -> Sessions -> Startup Programs

Pour KDE, je sais qu’il existe un équivalent et pour les autres WM (*box, …) il y a ~/.xinitrc

ça répond à ta question??


#3

ben je vais m’en contenter.
ce que je veux c’est une ligne telle que xset s off ou xset -dpms au demarrage de la machine et absolument aucune economie d’energie.l’ecran jamais eteinds 24/24.
sans xscreensaver l’ordi se mets en veille quoi qu’il arrive au bout de 20 minutes environ.
je ne trouve pas ce fichier ; j’ai aussi cherché 20 minutes en secondes dans pas mal de fichiers mais rien.
j’ai tellement modifié des fichiers pour cela que je ne me rappelle plus tous ceux que j’ai touché.il y en a 1 qui avait un 30 je lui ai mis un 30000 mais c’etait pas ça et comme je ne me rappelle plus lequel c’etait ben je laisse comme ça.


#4

j’ai trouvé
/usr/X11R6/include/X11/extensions dpms.h et dpmsstr.h
je dois pas etre bien loin.
il y a un fichier qui commande ça il est dans la machine et pas ailleurs.


#5

ne peut on pas modifier dans /usr/x11r6/bin
les fichiers ou applications xset ou xsetmode ou xsetpointer?


#6

tu peux desactiver le dpms dans xorg.conf avec option dpms off (pas xset, c’est une commande, pas un élément de config de X).
-> man xorg.conf
Il y a peut être une autre option pour l’equivalent de xset s off.
En tout cas, si tu veux faire un xset, c’est seulement une fois qu’un user est connecté (càd qu’il a les droits dessus), et donc DE L’INTERIEUR DU SERVEUR X, que tu peux modifier son fonctionnement.
Par contre, tu dois pouvoir mettre tous les xset que tu veux dans ~/.Xsession, normalement.
-> man xsession


#7

Bonsoir,
je n’ai jamais d’ecran de veille car j’ai decommenté l’option dpms dans XF86confi-4.