Boot impossible


#1

Salut à tous, je viens poster parceque j’ai un probleme de boot sous debian SID depuis aujourd’hui.
Alors j’ai fait les majs cette aprem que j’avais pas faites depuis moulte temps, et au reboot de la machine pour tester le dernier driver nvidia, impossible de booter, en effet la sequence de boot s’arrette à la fin au moment ou il load les services (alsa,inetd,portmap) etc…, je pense que c la partie juste apres qui deconne pck j’ai beau enlever et rajouter des services au demarrage avec chroot ils se loadent tous.

J’ai vu l’astuce pour les MAKEDEV, je l’ai applique mais sans succes, j’ai bien matter les fichiers logs sous un chroot mais rien d’explicité à part un probleme de chargement du module apm qui je pense n’est pas la cause du probleme (peut-etre que je me trompe) donc voila si qqn pouvait eclairer ma lanterne ce serait formidable car la je vis un calvaire sous windob, et c la corde qui m’attend d’ici la fin de la semaine ^^
Merci d’avance et bonne nuit :slightly_smiling:


#2

et ca ne passe même pas en bootant en “single” ?
bon sinon, pour éviter le chroot, tu peux booter en passant init=/bin/sh.
Tu auras déja un boot minimal.
Penser à faire un ‘sync;sync;halt’ , par contre, pour éteindre la machine (ne pas faire de shutdown quand on boote comme ça).
Ensuite, je ne sais pas ce qui te permets de dire que ce n’est pas l’apm, parceque ca sent JUSTEMENT le pb d’apm.
Par ailleurs, ca serait interressant de savoir exactement le dernier message au moment ou ça plante, aussi bien à l’ecran que dans /var/log/messages.


#3

Dans une vieille version de /var/log/messages ca donne ca à la fin

Nov 27 17:43:00 localhost kernel: ACPI: PCI interrupt 0000:01:08.0[A] -> GSI 16 (level, high) -> IRQ 16
Nov 27 17:43:00 localhost kernel: AEC6880R: IDE controller at PCI slot 0000:01:0a.0
Nov 27 17:43:00 localhost kernel: ACPI: PCI interrupt 0000:01:0a.0[A] -> GSI 18 (level, high) -> IRQ 18
Nov 27 17:43:00 localhost kernel: AEC6880R: chipset revision 7
Nov 27 17:43:00 localhost kernel: AEC6880R: 100%% native mode on irq 18
Nov 27 17:43:00 localhost kernel:     ide6: BM-DMA at 0xc000-0xc007, BIOS settings: hdm:DMA, hdn:pio
Nov 27 17:43:00 localhost kernel:     ide7: BM-DMA at 0xc008-0xc00f, BIOS settings: hdo:pio, hdp:pio
Nov 27 17:43:00 localhost kernel: hdm: Maxtor 6B200P0, ATA DISK drive
Nov 27 17:43:00 localhost kernel: ide6 at 0xb000-0xb007,0xb402 on irq 18
Nov 27 17:43:00 localhost kernel: hdm: max request size: 1024KiB
Nov 27 17:43:00 localhost kernel: hdm: 398297088 sectors (203928 MB) w/8192KiB Cache, CHS=24792/255/63, UDMA(133)
Nov 27 17:43:00 localhost kernel:  /dev/ide/host6/bus0/target0/lun0: p1
Nov 27 17:43:00 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Nov 27 17:43:44 localhost kernel: apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
Nov 27 17:43:44 localhost kernel: apm: overridden by ACPI.
....

Et dans la nouvelle version ca donne cela

Dec 13 23:53:18 localhost kernel: ACPI: PCI interrupt 0000:01:08.0[A] -> GSI 16 (level, high) -> IRQ 16
Dec 13 23:53:18 localhost kernel: AEC6880R: IDE controller at PCI slot 0000:01:0a.0
Dec 13 23:53:18 localhost kernel: ACPI: PCI interrupt 0000:01:0a.0[A] -> GSI 18 (level, high) -> IRQ 18
Dec 13 23:53:18 localhost kernel: AEC6880R: chipset revision 7
Dec 13 23:53:18 localhost kernel: AEC6880R: 100%% native mode on irq 18
Dec 13 23:53:18 localhost kernel:     ide6: BM-DMA at 0xc000-0xc007, BIOS settings: hdm:DMA, hdn:pio
Dec 13 23:53:18 localhost kernel:     ide7: BM-DMA at 0xc008-0xc00f, BIOS settings: hdo:pio, hdp:pio
Dec 13 23:53:18 localhost kernel: hdm: Maxtor 6B200P0, ATA DISK drive
Dec 13 23:53:18 localhost kernel: ide6 at 0xb000-0xb007,0xb402 on irq 18
Dec 13 23:53:18 localhost kernel: hdm: max request size: 1024KiB
Dec 13 23:53:18 localhost kernel: hdm: 398297088 sectors (203928 MB) w/8192KiB Cache, CHS=24792/255/63, UDMA(133)
Dec 13 23:53:18 localhost kernel:  /dev/ide/host6/bus0/target0/lun0: p1
Dec 13 23:53:18 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

Et donc ce qui vient juste apres la carte reseau c’est… APM

Donc apperement t’as raison c’est lui qui bloque le boot et quand je regarde dans d’autres logs j’ai ca:

Dec 13 17:17:21 localhost modprobe: FATAL: Error inserting apm (/lib/modules/2.6.8/kernel/arch/i386/kernel/apm.ko): No such device 
Dec 13 17:31:42 localhost modprobe: FATAL: Error inserting apm (/lib/modules/2.6.8/kernel/arch/i386/kernel/apm.ko): No such device 

le truc c’est que le module est bien present à cet endroit meme.
Voila je fais fouiller un peu si une solution vous avez je suis preneur :slightly_smiling:
Merci de l’aide ++


#4

Tu dis que tu as déjà essayé en desactivant /etc/init.d/apmd ?
Alors en interdisant aussi le module apm (avec un ‘alias apm off’ quelquepart dans /etc/modprobe.d) ?
Par ailleurs, ca serait peut être l’occasion d’installer un noyau plus récent et plus optimisé que le gros 2.6.8 fourni pour l’install sur n’importe quelle machine (donc trés gras et lent), non ?


#5

Je vais essayer avec l’alias.
Pour le noyau j’etais en woody au debut donc en 2.2 et j’etais passe en sid et avait recompile un kernel 2.6.8 à l’epoque, maintenant que me conseilles tu comme nouveau noyau stable et performant?


#6

Ben je suis en 2.6.11 mais ce n’est pas le dernier tu peux tres bien passer en 2.6.14 :smiley:


#7

j’ai eu des problêmes à la compil avec le 2.6.14 (sid) = à cause de yaird (dispo en sid uniquement), mais maintenant, tout fonctionne bien.
Le 2.6.12 courant en etch m’a posé moins de pb, mais me fait parfois des messages d’erreur incomprehensibles au boot en version K7, sans effet notable autrement.


#8

Bon ba j’arrive à booter en single, mais j’arrive pas à booter dans un autre mode, je sais pas si je vire bien le module apm au demarrage, je continue mes test, pour ce qui est changer de noyau je verrai plus tard car j’aimerais trouver une solution :slightly_smiling: voila ++


#9

si mon “alias apm off” ne marche pas, tu peux toujours carrément virer le .ko de /lib/modules.
Ca râle, mais ça ne gène pas.


#10

bon ben finalement j’ai recompile un new kernel, et ca boot, faut juste que je retrouves quels modules j’avais besoin pour mon matos :slightly_smiling: merci ++