Booter sur USB lorsque le BIOS ne le permet pas


#21

Ça dépend de la qualité de la clef et de la façon dont tu procèdes, visiblement il ne faut pas écrire et lire en permanence dessus…


#22

Il y a un parquage des têtes, sur une clé ? :mrgreen:


#23

Il suffit d’écouter, quand elle fait clic-clic c’est que la tête est parquée :smiley:, avantage c’est que c’est signe qu’on est fatigué également…


#24

Je n’ai pas bien approfondi ce fil mais j’ai essayé de bouter, non pas sur une clef USB mais sur un DD placé ds un boîtier externe USB et le rslt est négatif bien que mon bios soit configuré avec USB/ZIP en tête de gondole…
Ce DD est fonctionnel (une Debian sid) quand placé ds un rack et donc relié directement au PC par une nappe. J’ajoute qu’il est indépendant et fonctionne avec son propre grub.
Il me faut ajouter qq chose à ce DD pour qu’il soit reconnu ?


#25

Tu n’arrives même pas sur le grub de ton DD externe ?
J’ai un disque externe USB où j’ai installé Debian. Si je configure mon Bios pour bouter sur USB, je tombe direct sur le grub du disque…


#26

Tu n’as pas plusieurs options d’USB, du style USB/HDD ou USB/FDD ?


#27

ben non !
ben c’est ce que j’aimerais bien obtenir aussi


#28

Si, voilà les choix :
disabled
legacy floppy
LS120
ZIP
atapi MO
USB FDD
USB ZIP

–J’ai essayé avec les deux derniers mais sans rslt :cry:
–J’ai essayé avec deux DD différents (debian et mandriva), ts deux avec un grub bien fonctionnel.
Si je démarre avec un autre DD branché (rack), le choix DD en dernier et le choix USB en premier, j’arrive systématiquement sur le grub du DD en rack, donc sur nappe.
Si je démarre sans aucun DD branché (rack out), j’arrive à un
Grub Hard Disk Error.
Ptet une indication :
m^ si j’allume le DD externe USB au démarrage en m^ tps que le DD interne, il n’est pas monté automatiquement ?
Il faut que je le monte comme une clef USB ordinaire pour le voir apparaître sur mon gestionnaire de fichioers et ça ds /media/sda1
C’est donc, il me semble, qu’il n’est pas reconnu à l’allumage mais au chargement du noyau, je vois bien passer les partoches de ce DD externe ezn sda1 2 3 4 etc.
Quoi que ça paraît logique puisque je ne suis pas dessus.
Une fois de +, je m’en remets à votre sagacité. :smt006


#29

Ce qui est bizarre, c’est que quand tu enléves tous les autres disques, il trouve bien un grub, ce qui veut dire qu’il va bien jusqu’à tester ton disque USB…
Bon, sinon, tu as la possibilité de booter avec un grub sur un autre support, floppy, CD, ou clé, mais AMA, si tu as un disque interne que tu vas laisser à demeure, le plus simple si tu as un grub dessus est d’ajouter une entrée pour basculer sur le grub d’un éventuel disque externe.


#30

Non, tu as mal compris ou je me suis mal exprimé :
justement, sans aucun disque branché, je n’arrive pas au grub du DD externe, j’arrive à une erreur "grub hard disk error"
On a l’impression qu’il ignore soit le grub de ce DD externe, soit le DD lui-m^.

Oui, c’est une éventualité à laquelle j’avais pensé mais ce n’est pas ce que je cherche : emmener mon DD externe sous le bras et pouvoir le brancher sur n’importe quel PC chez mes enfants ou amis.

EDIT :
Vérification faite, le DD externe USB est bien reconnu puisque :
–allumage de la machine sans aucun DD internes branchés et sans le DD usb ext branché non plus, après le chargement de ASUS et le listing des périhériques PCI, annonce =
Disk boot failure, insert system disk and press Enter

–allumage de la machine sans DD interne branché et avec le seul DD externe USB branché, m^ affichage du listing périphs PCI et annonce =
GRUB hard disk ERROR

C’est donc qu’il est bien reconnu mais qu’il a un problème de liaison avec ce grub.

Je confirme que ce grub est fonctionnel car placé en DD interne, il démarre.
:question: :question: :question:


#31

Si grub a une erreur c’est qu’il est trouvé.


#32

Ben oui, c’est ce que j’explique ds mon msg plus haut en EDIT (croisement avec ta réponse)

EDIT encore :
bien sûr, le grub du DD ext usb est libellé comme hda et c’est ptet là l’erreur, il faudrait que je le modifie en sda :question: :question: :question:

EDIT ++ :
quand je suis sur ma Sid et que je branche ce DD ext usb à chaud, il ouvre le gestionnaire en tant que
system:/media/sda1

:question: :question: :question:


#33

voilà la partie du grub de ce DD ext usb qui semble devoir être modifiée :

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda8 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,7)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(single-user) single
# altoptions=(single-user mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

#34

Rebranches to disque dans le rack bootes dessus, et essayes avec:

# kopt=root=/dev/sda8 ro

suivi d’un update-grub mais je doute que ça suffise.


#35

non, comme tu le supposais.
Par contre, je viens de faire un fdisk sans avoir monté le DD ext usb et donc à partir de ma Sid fonctionnelle en hda.
Ce fdisk montre que le DD ext est bien reconnu et le boot est marqué sur sda9 qui correspond à une Kubuntu que j’avais installée en dernier.
Je vais aller voir sur le grub de cette kubuntu ce qu’il raconte.
Voici le fdisk :
de sda1 à sda6 = Sid /, /home/, /usr, swap, /var
sda7 et 8 = des ext2 de sauvegarde
sda9 = Kubuntu entière
sda10 = swap kubuntu

ricardo@sid-hda8:~$ sudo fdisk -l
[sudo] password for ricardo:

Disk /dev/hda: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0004e386

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         973     7815591   83  Linux
/dev/hda4            1096        4998    31350847+   f  W95 Ext'd (LBA)
/dev/hda5            1096        2311     9767457   83  Linux
/dev/hda6            4258        4925     5365678+  83  Linux
/dev/hda7            4926        4998      586341   82  Linux swap / Solaris
/dev/hda8            2312        3284     7815591   83  Linux
/dev/hda9            3285        4257     7815591   83  Linux

Partition table entries are not in disk order

Disk /dev/sda: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0b840b84

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         244     1959898+  83  Linux
/dev/sda2             245        1460     9767520   83  Linux
/dev/sda3            1461        2919    11719417+  83  Linux
/dev/sda4            2920        4998    16699567+   5  Extended
/dev/sda5            2920        3041      979933+  82  Linux swap / Solaris
/dev/sda6            3042        3527     3903763+  83  Linux
/dev/sda7            3528        3892     2931831   83  Linux
/dev/sda8            3893        4500     4883728+  83  Linux
/dev/sda9   *        4501        4973     3799341   83  Linux
/dev/sda10           4974        4998      200781   82  Linux swap / Solaris
ricardo@sid-hda8:~$ 

#36

dans le grub de ta sid active, tu ajoutes:

title Boot usb externe
map (hd0) (hd1)
map (hd1) (hd0)

Est ce que ça passe sur le grub de ton disque usb aprés ?
Est ce que tu arrives à booter ?

Si oui, dans le menu.lst, tu mets:

# kopt=root=/dev/sda8 ro

ensuite, tu fais un grub-install (hd0)
puis un update-grub.

Aprés, tu eteinds ta machine, tu enlèves le hda, puis tu rebootes.


#37

non, j’avais déjà essayé car c’est de cette façon que je boute sur le second DD interne (en rack).
quand je clique sur cette entrée, j’ai une coupure éclair mais rien .
Laisse tomber, je verrai plus tard avec le DD vierge que j’attends.
Je suppose qu’il doit falloir installer la distrib en place pour que ça boute correctement.


#38

Et sinon, as-tu essayé avec les 2 CD que j’ai indiqués ? car ce tuto à la base propose de bouter sur USB lorsque le bios ne le permet pas.
Le lien du 2e CD se trouve là : viewtopic.php?p=124175#p124175


#39

Ricardo, des news par rapport à mon tuto. Grub est vraiment un super outil.

En regardant d’un peu plus près la doc (on devrait toujours commencer par là :unamused: ), j’ai réussi à booter ma debian installée sur disque externe USB depuis n’importe lequel de mes PC (je n’y étais pas arrivé avant).

Il faut utiliser le shell de grub. Super simple. Une fois arrivé au menu de grub, appuyer sur la touche c. Tu peux le faire soit avec le grub qui est installé sur un disque interne, celui du disque externe USB ou le super grub disk permet de le faire.

Une fois sur le shell grub, il faut se “placer” sur la partition contenant le répertoire /boot du disque externe USB. On utilise pour cela la commande root.

Par exemple, si /boot se trouve sur la première partition du 2e disque identifié par grub :

Le plus dur si l’on a plusieurs disques est d’identifier le bon !
Si tu débranches tous tes disques et que tu laisses juste le disque USB avec par exemple /boot sur la première partition :

Le clavier est en qwerty => shift + 9 pour faire la parenthèse gauche, auto complétion pour compléter.
Pour vérifier que l’on est sur le bon disque, le shell grub se comporte comme une console écrire par exemple “kernel /boo” et utiliser l’auto complétion (touche tab) pour voir si grub complète par “kernel /boot” et appuyer une seconde fois sur tab pour que grub liste le contenu.

Si c’est bon, il suffit de rentrer dans le shell les lignes telles qu’elles sont écrites dans le menu.lst original.

Par exemple, pour bouter ma sid, le menu.lst contient :

[quote]title Debian GNU/Linux, kernel 2.6.23-1-686
root (hd0,1)
kernel /boot/vmlinuz-2.6.23-1-686 root=/dev/sda2 ro vga=791
initrd /boot/initrd.img-2.6.23-1-686

savedefault[/quote]

Il suffit juste de noter ce qui est en rouge et le recopier dans le shell :

[code]>kernel /boot/vmlinuz-2.6.23-1-686 root=/dev/sda2 ro vga=791

initrd /boot/initrd.img-2.6.23-1-686[/code]
et pour bouter, on marque :

Et si tout se passe bien, ça boute :smiley:

Le truc à penser avant de bouter ton disque ailleurs que chez toi, c’est d’installer plusieurs noyaux. J’ai essayé de bouter un athlon avec un noyau 686 et il n’en a pas voulu :unamused:
Penser également à adapter xorg.conf en fonction de la carte graphique utilisée…


#40

Il va falloir que je mette à jour mon tuto car si vous voulez bouter sur une live-USB, que votre BIOs ne sait pas bouter sur USB, et que vous avez grub d’installé sur le PC, plus besoin de CD, grâce au shell de grub 8)

Arrivé au menu de grub, appuyer sur la touche c.
Si vous n’avez qu’un seul disque dur, votre clé USB devrait être détectée comme un 2e disque et donc être nommée hd1 (grub nomme les disques en partant de 0).

Positionnez-vous sur la clef :

Normalement, grub vous signale que vous êtes sur une partition fat.
Et pour bouter sur la clé :

[code]>chainloader +1

boot[/code]
C’est tout !