BootSplash / Editeur VI


#1

Je viens d’installer Bootsplash et j’ai un probleme avec mon editeur VI.

Si dans mon lilo, je démarre en mode text (vga=normal) : OK
Si je démarre en mode graphique (Avec Bootsplash) : Probleme

En effet quand, je rajoute une ligne, il m’éfface la ligne suivante (Juste à l’affichage) car en effet, si je sauvegarde, quit et réouvre le fichier la ligne est présente.

Je suis sur la piste d’une histoire de FrameBuffer et autres !!! mais pas trouver de piste avec Google !!

Avez vous une idée


#2

[quote=“flo72”]Je viens d’installer Bootsplash et j’ai un probleme avec mon editeur VI.

Si dans mon lilo, je démarre en mode text (vga=normal) : OK
Si je démarre en mode graphique (Avec Bootsplash) : Probleme

En effet quand, je rajoute une ligne, il m’éfface la ligne suivante (Juste à l’affichage) car en effet, si je sauvegarde, quit et réouvre le fichier la ligne est présente.

Je suis sur la piste d’une histoire de FrameBuffer et autres !!! mais pas trouver de piste avec Google !!

Avez vous une idée[/quote]
Dans /etc/bash.bashrc, ajoutes la ligne :
alias vi=‘nano’ :slightly_smiling:


#3

Nano me fait le même probleme !!! je connais ALIAS !!!

je vais reexpliquer le probleme !!

J’ai un fichier toto :

a
b
c
d
e
f
g
h
i
j
k

je fais maintenant insertion 'i’
Je tape ‘entrée’ (return) au niveau de f

je me retrouve avec

a
b
c
d
e

f
i
j
k
"

mon ‘g’ a disparue, je sauvegarde, je quitte, je reviens !!

et la OK :
"
a
b
c
d
e

f
g
h
i
j
k
"

pas de probleme par contre cela est chiant pour editer les fichiers !!!

cela me le fait en mode graphique et pas en mode texte !!

Idée ??


#4

Un probléme de variable d’environnement peut-être? (je pense particuliérement à TERM)


#5

Je viens de m’apercevoir que lorsque je tapais dans le mode graphique de ma console, le caractere accentué a

‘à’ j’avais à la place le symbole alpha. Si je tape mon caractere alpha (à) et sauvegarde le fichier, si je l’ouvre en mode texte dans une console, j’ai bien mon à. Donc j’ai bien les bon caractere ‘fr_FR’ mais l’affichage ne prend pas la bonne police d’affichage.

Pour rappel, j’ai installé bootsplash sur debian 2.6.8.1 et je suis en console.

Une histoire de framebuffer ??


#6

dis dc, tu à compilé ton noyeau, ou installé une image ?
tu as choisi koi comme fontes “compiled in” au niveau des options du fb ?


#7

J’ai compilé mon noyeau !! par contre pour les fontes ??

— VGA text console
[] Video mode selection support
< > MDA text console (dual headed)
<
> Framebuffer console support
[ ] Select compiled-in fonts

si je mets * pour select compiled-in fonts

j’ai un menu qui apparait mais rien de cocher !!

cocher VGA 8x8 font (NEW) ???


#8

J’ai coché Select compiled-in fonts et VGA 8x16 font

mais sans changement, tjrs ‘alpha’ dans la console tty1 en mode graphique et un ‘à’ dans la console tty3 en mode texte.


#9

bon, ben mauvaise pioche…
sinon, j’ai trouvé, je crois, une piste sur
gentoo-wiki.com/HOWTO_Framebuffe … Grubsplash
en particulier dans
gentoo-wiki.com/HOWTO_Framebuffe … er_area.21

ca t’aide ?


#10

vire moi cette saloperie de frame buffer, et tout marchera bien :slightly_smiling: