Bridge pour plusieurs vm sous kvm

Tags: #<Tag:0x00007f63e3713308> #<Tag:0x00007f63e3713100>

Bonjour
Je souhaiterai avoir trois vms sur la même machine qui communique sur mon réseau locale, j’arrive a paramètre une vm mes pas plus.

Voici mon fichier /etc/network/interfaces :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*
# The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface
#allow-hotplug enp3s0
#Iface enp3s0 inet dhcp

#auto enp3s0
#iface enp3s0 inet manual


#The primary network interface and bridge
auto br0
iface br0 inet dhcp
	bridge_ports enp3s0
	bridge_stp off
	bridge_fd off
	bridge_maxwait 0 

Tout ça sous debian9
J’utilise virt-manager pour gérai les vms.

Merci de votre aide.

Bonjour

Si tu as installé le paquetage virt-manager
le pont (bridge) nommé default a sans doute déjà été créé automatiquement.

Il te suffira, si besoin, de l’activer au démarrage de la machine hôte.

Virt-manager : Édition -> Détails de la connexion -> Onglet Réseaux virtuels

J’ai juste coché la case indiquée par le curseur sur cette capture d’écran
et cliqué ensuite sur le bouton Appliquer situé en bas à droite
pour que l’interface soit automatiquement activée au démarrage de la machine hôte.

Il n’y a rien d’autre à faire,
les machines virtuelles créées avec virt-manager
pourront toutes communiquer entre elles
et vers la machine hôte en ciblant l’adresse IP 192.168.122.1
et la machine hôte pourra communiquer vers les machines virtuelles
en ciblant leur adresse IP qui sera une adresse du réseau 192.168.122.0/24

Quelle que soit la méthode d’accès au web de la machine hôte <=> WiFi ou RJ45, ou autre
les machines virtuelles auront aussi accès au web.


Le pont virbr0 (default) a automatiquement été créé
au cours de l’installation du paquetage virt-manager

Ci-dessous, le retour de la commande brctl show
une fois que le pont default a été activé :

root@debg53sw:~# brctl show
bridge name	bridge id		STP enabled	interfaces
virbr0		8000.5254004dd9a3	yes		virbr0-nic
root@debg53sw:~# 

Le fichier /etc/network/interfaces n’a pas à être modifié,
voici son contenu sur ma machine :

michel@debg53sw:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
michel@debg53sw:~$ 

et il n’y a rien non plus à ajouter dans le répertoire /etc/network/interfaces.d/

michel@debg53sw:~$ ls -l /etc/network/interfaces.d/
total 0
michel@debg53sw:~$ 

Merci pour la raiponce.

Ca marche .

Pan-dans que je tais sou la main tu ne saurais pas comment faire pour que le son d’une vm sorte dans l’hote?

Pour qu’une machine virtuelle puisse renvoyer du son à la machine hôte,
il faut que cette machine virtuelle soit équipée d’une carte son.

Dans la fenêtre concernant la machine virtuelle,
Menu Afficher -> Détails

je constate alors qu’il n’y a pas de matériel audio
alors, pour rajouter une carte son à la machine virtuelle,

Je clique sur le bouton Ajouter du matériel

puis dans la fenêtre Ajouter du matériel virtuel
je sélectionne Audio

et je clique sur le bouton Terminer

Quand la machine virtuelle va démarrer,
elle va détecter et installer et configurer la carte son
et la machine hôte diffusera le son de la machine virtelle.

Merci de ton aide
Ok met sa ne marche pas avec moi, j’ai bien installer alsa-utils.
Il faut savoir que je suis en serveur.

Tout dépends aussi de ce que ta machine virtuelle est capable de faire…

Arrête la machine virtuelle, et change le type de carte son pour le type ich6 au lieu de ac97

puis clique sur le bouton Appliquer et démarre la machine virtuelle.

J’ais fait tout les types et pas de son.
J’ais fais la même config sur l’hôte et le son sort.
J’utilise vlc en mode console pour testé.