Bureau xfce ne s'ouvre plus

Bonjour,
Suite à une mise à jour opérée de la manière suivante en root
root@pascal-laptop:/home/pascal# apt-get update
root@pascal-laptop:/home/pascal# apt-get upgrade && apt-get dist-upgrade
Au redémarrage, le bureau xfce s’ouvre mais reste vide , aucune barre de menu, aucune icone sur le bureau. Seul le pointeur de souris bouge en actionnant le touchpad ou la souris. Pour sortir de la session j’appuie sur le bouton on/off 3 secondes et le menu de déconnexion, arrêt apparaît. En me connectant sous un autre environnement (MATE) tout fonctionne normalement.
J’ai essayé les opérations suivantes en user dans un terminal console (Ctrl+Alt+F2)

pascal@pascal-laptop:~$ mv ~/.config/xfce4-session/ ~/.config/xfce4-session-bak

pascal@pascal-laptop:~$ mv ~/.config/xfce4/ ~/.config/xfce4-bak

puis en root

root@pascal-laptop:/home/pascal# service gdm3 stop

root@pascal-laptop:/home/pascal# apt-get remove --purge gdm3 gnome*

root@pascal-laptop:/home/pascal# service lightdm stop

root@pascal-laptop:/home/pascal# apt-get remove lightdm --purge

root@pascal-laptop:/home/pascal# apt-get --reinstall install xfce4 lightdm
root@pascal-laptop:/home/pascal# reboot

Après ces différentes opérations, le fichier ~/.config/xfce4 est reconstitué et devrait permettre la réouverture du bureau hors il n’en n’est rien.
Pour info tout ceci s’est passé sous Debian 10 Buster voir commande uname --all

pascal@pascal-laptop:~$ uname --all
Linux pascal-laptop 4.19.0-10-amd64 #1 SMP Debian 4.19.132-1 (2020-07-24) x86_64 GNU/Linux

Si quelqu’un a une idée, je suis preneur
Merci à tous
Pascal

Bonjour @pascal_pad

Ce serait intéressant de créer un nouvel utilisateur pour voir le comportement de la connexion à son nouveau bureau Xfce par défaut.

C’est davantage un test qu’une solution.

Je ne peux pas te dire exactement à quels groupes ce nouvel utilisateur devrait appartenir.

Bienvenue :wink:

Bonjour
Que te retourne

aptitude search ~ixfce4

Être sûr qu’il y a les paquets nécessaires

En principe oui, les paquets nécessaires sont là vu que j’ai procédé à une réinstallation de xfce4 comme indiqué dans mon premier post
root@pascal-laptop:/home/pascal# apt-get --reinstall install xfce4 lightdm
Je vais voir ce que me retourne search ~xfce4.

JE vais essayer de créer un nouvel utilisateur pour voir ce que çà donne.
Merci. Je redonnerai, bien évidement des nouvelles.
Pascal

Oui, et ?

Depuis le 17 Août je t’ai indiqué que le mélange Gdm, Lightdm est vicié et que la solution est une réinstallation propre.
https://debian-facile.org/viewtopic.php?id=28088

Bon et ? tu vas courir tous les forums ?

Merci pour vos réponses. Je ne courre pas tous les forums, seulement deux mais comme je n’avais pas eu de réponse sur le premier, je suis venu sur le second et là… Avalanche de messages sur les deux. J’ai opté pour la solution la plus simple et la plus sure, soit la réinstallation propre de debian 10 "Buster*.
Comment faire pour mettre ce post en mode « Résolu »? Je n’ai rien trouvé comme balise.
Merci et bonne journée.
Pascal

Il suffit de cocher la case carrée en bas et à droite du message que tu considères comme étant la solution.

Tu peux cocher un de tes propres messages.

Bonne journée

:+1: :wink:

N’oublie pas que pour passer en root c’est la commande: su - et non su !