Buster testing -> stable : Erreur apt-secure(8)


#1

Bonjour à toutes et tous,

J’utilise Buster depuis quelques semaines et depuis le passage de celle-ci vers stable cette nuit, un apt-get update me renvoie l’erreur suivante :

Réception de :2 http://cdn-fastly.deb.debian.org/debian buster InRelease [118 kB]
Réception de :3 http://cdn-fastly.deb.debian.org/debian buster-updates InRelease [46,8 kB]
Lecture des listes de paquets... Fait
N: Le dépôt « http://cdn-fastly.deb.debian.org/debian buster InRelease » a modifié sa valeur « Version » de «  » à « 10.0 »
E: Le dépôt « http://cdn-fastly.deb.debian.org/debian buster InRelease » a modifié sa valeur « Suite » de « testing » à « stable »
N: Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer aux pages de manuel « apt-secure(8) » pour plus de détails.
E: Le dépôt « http://cdn-fastly.deb.debian.org/debian buster-updates InRelease » a modifié sa valeur « Suite » de « testing-updates » à « stable-updates »
N: Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer aux pages de manuel « apt-secure(8) » pour plus de détails.

J’ai bien entendu fouillé un peu pour trouver la solution, mais rien n’y fait…
Je ne suis pas le seul dans ce cas d’après mes lectures, mais personne ne semble avoir trouvé la solution.

Voici mon sources.list :

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
deb http://deb.debian.org/debian/ buster-updates contrib main non-free
# deb http://deb.debian.org/debian/ buster-proposed-updates contrib main non-free
# see the sources.list(5) manual.

Merci d’avance pour votre aide :wink:


#2

Un apt-key update à été fait ?
Un clean du cache d’apt a été fait ?
Ton paquet Debian keyring est à jour ?


#3

apt-key update et net-update faits, aucun effet.
idem pour apt-get clean.
Oui, le paquet Debian keyring est bien à jour.

J’ai lu pas mal de discussions ici (et sur d’autres forums) à ce sujet et personne ne semble avoir réussi à le résoudre. Ce qui m’interpelle.
Sinon, je vais réinstaller à partir de Buster sortie hier, mais c’est dommage.


#4

Bonjour,

2019-07-07T09:09:00Z

http://cdn-fastly.deb.debian.org/debian renvoie vers http://ftp.debian.org/debian/
c’est non sécurisé.

Il est peut-être intéressant d’utiliser https://cdn-aws.deb.debian.org/debian/
comme grandtoubab mentionne l’utiliser dans ce message.

C’est utilisé pour Stretch mais c’est probablement valable pour Buster stable.
Je n’ai pas encore migré ; je n’ai donc pas vérifié.

Autrement, le manuel de apt-secure(8) est en Français, c’est une chance :wink:

édition 2019-07-07T10:04:00Z
voir ce post : Buster c'est pour le 6 juillet


#5

Merci pour vos réponses.
Mais elles sont sans effet. Il y a clairement un problème avec le passage de Buster “testing” vers “stable”.

:frowning:

EDIT : le problème est curieusement rentré tout seul dans l’ordre… :thinking: peut-être fallait-il juste attendre un peu que les dépôts soient à jour sur les serveur ou autre…


#6

Salut
la commande pose une question, as tu répondu o ?

root@debian:~# apt update
Atteint :1 http://archive.canonical.com bionic InRelease
Atteint :2 http://deb.xanmod.org releases InRelease                                                                             
Ign :3 https://dl.google.com/linux/earth/deb stable InRelease                                                                   
Atteint :4 https://dl.google.com/linux/earth/deb stable Release                                                            
Réception de :5 https://cdn-aws.deb.debian.org/debian-security jessie/updates InRelease [44,9 kB]
Atteint :6 http://repository.spotify.com stable InRelease             
Réception de :7 https://cdn-aws.deb.debian.org/debian-security stretch/updates InRelease [94,3 kB]
Réception de :8 https://cdn-aws.deb.debian.org/debian-security buster/updates InRelease [31,1 kB]
Ign :9 https://cdn-aws.deb.debian.org/debian stretch InRelease
Réception de :10 https://cdn-aws.deb.debian.org/debian buster InRelease [118 kB]
Réception de :12 https://cdn-aws.deb.debian.org/debian buster-updates InRelease [46,8 kB]
Réception de :13 https://cdn-aws.deb.debian.org/debian buster-proposed-updates InRelease [54,5 kB]
E: Le dépôt « https://cdn-aws.deb.debian.org/debian-security jessie/updates InRelease » a modifié sa valeur « Suite » de « oldstable » à « oldoldstable »
N: Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer aux pages de manuel « apt-secure(8) » pour plus de détails.
Souhaitez-vous accepter ces modifications et continuer à mettre à jour depuis ce dépôt ? [o/N] 

La commande suivante après avoir répondu o à toutes les questions lors de la première

root@debian:~# apt update
Atteint :1 http://deb.xanmod.org releases InRelease
Ign :2 https://dl.google.com/linux/earth/deb stable InRelease                                                                   
Atteint :3 http://archive.canonical.com bionic InRelease                                                                        
Atteint :4 https://dl.google.com/linux/earth/deb stable Release                                                            
Atteint :5 https://cdn-aws.deb.debian.org/debian-security jessie/updates InRelease                      
Atteint :6 https://cdn-aws.deb.debian.org/debian-security stretch/updates InRelease
Atteint :7 https://cdn-aws.deb.debian.org/debian-security buster/updates InRelease
Atteint :8 http://repository.spotify.com stable InRelease
Ign :9 https://cdn-aws.deb.debian.org/debian stretch InRelease
Atteint :10 https://cdn-aws.deb.debian.org/debian buster InRelease
Atteint :11 https://cdn-aws.deb.debian.org/debian buster-updates InRelease
Atteint :13 https://cdn-aws.deb.debian.org/debian buster-proposed-updates InRelease
Atteint :14 https://cdn-aws.deb.debian.org/debian sid InRelease
Atteint :15 https://cdn-aws.deb.debian.org/debian experimental InRelease
Atteint :16 https://cdn-aws.deb.debian.org/debian stretch Release
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.

#7

Non, je n’avais pas eu cette question.
Peut-être n’ai-je pas été assez patient (car le symptôme se retrouvait sur tous mes postes).


#8

Le bug est mentionné ici lien
ne pas hésiter à utiliser l’option --allow-releaseinfo-change avec apt


#9

Bonjour,
Debian à posté ceci sur twitter, c’est peut être ça ?

If you use apt-get to upgrade to buster, you won’t be asked about the security repository info changed from ‘testing’ to ‘stable’. Use the --allow-releaseinfo-change option, as Eriberto Mota explains here: or use apt instead

http://eriberto.pro.br/blog/2019/07/07/debian-repository-changed-its-suite-value-from-testing-to-stable/?utm_source=dlvr.it&utm_medium=twitter

utilise apt à la place d’apt-get


#10

C’est étonnant que Debian n’ait pas déclaré ‘apt-get’ obsolète, car ça fait un bout de temps que ‘apt’ l’a remplacé, non ?


#11

Is apt-get deprecated?

I didn’t find any information that says that apt-get will be discontinued. And it actually shouldn’t be. It still has a lot more functionalities to offer than apt.

For low-level operations, in scripting etc, apt-get will still be used.

Est-ce que apt-get est obsolète ?

Je n’ai trouvé aucune information qui dit qu’apt-get sera arrêté. Et ça ne devrait pas l’être. Il a encore beaucoup plus de fonctionnalités à offrir qu’apt.

Pour les opérations de bas niveau, dans les scripts, etc, apt-get sera toujours utilisé.

En premier lieu, pourquoi apt a été introduit ?

Debian, mère Linux de distributions comme Ubuntu, Linux Mint, elementary OS, etc., a un système d’empaquetage robuste et chaque composant et application est intégré dans un paquet qui est installé sur votre système. Debian utilise un ensemble d’outils appelés Advanced Packaging Tool (APT) pour gérer ce système d’empaquetage. Ne le confondez pas avec la commande apt, ce n’est pas la même chose.

Il existe divers outils qui interagissent avec APT et vous permettent d’installer, de supprimer et de gérer des paquets dans les distributions Linux basées sur Debian. apt-get est un de ces outils en ligne de commande qui est largement populaire. Un autre outil populaire est Aptitude avec des options d’interface graphique et de ligne de commande.

Si vous avez lu mon guide sur les commandes apt-get, vous avez peut-être rencontré un certain nombre de commandes similaires comme apt-cache. Et c’est là que le problème se pose.

Vous voyez, ces commandes sont de niveau beaucoup trop bas et elles ont tellement de fonctionnalités qui ne sont peut-être jamais utilisées par un utilisateur Linux moyen. D’autre part, les commandes de gestion de paquets les plus couramment utilisées sont dispersées dans apt-get et apt-cache.

Les commandes apt ont été introduites pour résoudre ce problème. apt se compose de certaines des fonctionnalités les plus utilisées d’apt-get et apt-cache en laissant de côté les fonctionnalités obscures et rarement utilisées. Il peut également gérer le fichier apt.conf.

Avec apt, vous n’avez pas à passer des commandes (ndr: à) apt-get (ndr: et) à apt-cache. apt est plus structuré et vous fournit les options nécessaires à la gestion des paquets.

Conclusion : apt=les options de commande les plus couramment utilisées dans apt-get et apt-cache.


Apt et apt-get
#12

Merci de ces explications, Rémi.