Calibrage de la batterie : empécher l'arrêt automatique sur batterie faible

Tags: #<Tag:0x00007f63e5a6d4e8> #<Tag:0x00007f63e5a76fc0>

Bonjour,
je viens d’acheter un PC portable (Del XPS 13) d’occase pas cher car la batterie est HS soit disant. Effectivement si on laisse faire l’OS elle tient 7 minutes. Mais si on refuse l’arrêt du système sur batterie faible, il tient 1h30 en lisant des vidéo NetFlix… Testé sur Windows. Bon maintenant il y a Debian. Le besoin est donc de recalibrer la batterie, et donc de la charger à fond (pas de problème) puis de la décharger à fond pour effectuer un autre cycle de charge.
Sauf qu’avec Debian 12, pas moyen de bloquer le shutdown automatique sur batterie faible. Je suis sous KDE, j’ai modifié les option dans la config mais sans succès. J’ai stoppé upower mais il s’éteint toujours (shutdown propre) sur batterie faible. Bref je ne sais pas ce qui court-circuite toutes les options et process de gestion d’énergie que j’ai désactivé. Si vous avez des idées, je prends.
Merci pour votre aide

A voir si commenter la ligne ‹ plasma-shutdown › peut faire l’affaire, juste pour un éventuel calibrage, l’état de ta batterie étant sous ta seule responsabilité.

/usr/share/dbus-1/services/org.kde.Shutdown.service

[D-BUS Service]
Name=org.kde.Shutdown
# Exec=/usr/bin/plasma-shutdown

Merci pour ta proposition @Verner mais ça n’a pas fonctionné. C’est pas KDE qui de demande l’arrêt. Avce UPower down et la ligne plasma-shutdown de commentée, j’ai quand même eu droit à un arrêt dans les règles sur batterie faible. Qu’est ce qui peut bien demander cet arrêt ? Le kernel ? Systemd ? Au delà de mon soucis de batterie, je suis intrigué…

Le BIOS ! A moins que tu confirmes vraiment un comportement différent avec un autre OS
Sinon, il va falloir éplucher un peu plus en détail, mais pas maintenant.

Alors oui je confirme que c’est bien un soucis sur l’OS. D’une part parce que le shutdown est fait proprement mais aussi parce que sur Windows, avant de le passer sous Debian, j’ai pu regarder un film Netflix pendant une heure sur batterie.

Tu peux essayer power-calibrate.
Essayer ça pour voir si influence:

# power-calibrate -R -r 20 -d 5 -s 21 -n 0 -p