Can't be load au démarrage


#1

Comme je sens beaucoup de monde en forme et en mal de BA.

J’ai des messages bizzards au démarrage, concernant le chargement du PCI:
shpchp can’t be load
missing kernel or user mode driver shpchp

pciehp can’t be load
missing kernel or user mode driver pciehp

et pour le chargement d’isapnp:

rtc can’t be load

Kezako? est-ce indispensable? :confused:


#2

Si le système marche bien, alors ce n’est pas indispensable :slightly_smiling:

Perso je pense que j’ai déjà eu ces messages au démarrage mais ça ne m’a jamais embêté plus que ça


#3

slt,

tape la commande “dmesg” et colle le resultat ici…:slightly_smiling:


#4

zeus, shpchp et pciehp, il faut juste aller les blacklister quelquepart, mais je ne sais plus ou. Bref: j’ai 2 machines sur trois environ qui ont ce warning que je méprise de ma plus grande hauteur.
Pour ta Real Time Clock (rtc), il faudrait peut être la sortie de dmesg qui la concerne, mais ça m’etonnerait que ce soit critique.
Si la machine démarre, déjà, c’est mieux que d’autres OSs.


#5

Voilà, je crois que y’as du boulot là? :laughing:
P.S.: Je sent que je vais m’y plaire chez-vous, j’espère que je vais en aider plus d’un moi aussi :wink:

zeus@kinderolympe:~$ dmesg
us registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:11.4[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.4: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#3)
uhci_hcd 0000:00:11.4: irq 11, io base 0000dc00
uhci_hcd 0000:00:11.4: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb 1-1: new full speed USB device using address 2
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 2-1: new low speed USB device using address 2
usbcore: registered new driver hiddev
usbhid: probe of 2-1:1.0 failed with error -5
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
input: Wacom Graphire on usb-0000:00:11.3-1
usbcore: registered new driver wacom
drivers/usb/input/wacom.c: v1.30:USB Wacom Graphire and Wacom Intuos tablet driver
usb 1-1.4: new full speed USB device using address 3
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
[eagle-usb] driver V2 loaded
[eagle-usb] New pre-firmware modem detected
[eagle-usb] Uploading firmware…
Linux agpgart interface v0.100 © Dave Jones
agpgart: Detected VIA KT266/KY266x/KT333 chipset
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: AGP aperture is 64M @ 0xe8000000
[eagle-usb] Binding eu_instance_t to USB 001/003
usbcore: registered new driver eagle-usb
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: acpi_pciehprm:_SB_.PCI0 evaluate BBN fail=0x5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5
usb 1-1.4: USB disconnect, address 3
[eagle-usb] Pre-firmware modem removed
shpchp: acpi_shpchprm:_SB
.PCI0 evaluate BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
usb 1-1.4: new full speed USB device using address 4
[eagle-usb] New USB ADSL device detected, waiting for DSP code…
[eagle-usb] Interface 0 accepted.
[eagle-usb] created proc entry at : /proc/driver/eagle-usb/001-004
[eagle-usb] ioctl EU_IO_OPTIONS received
[eagle-usb] ioctl EU_IO_DSP received
[eagle-usb] Loading DSP code to device…
[eagle-usb] DSP code successfully loaded to device
input: PC Speaker
inserting floppy driver for 2.6.8-2-386
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02cc960(lo)
IPv6 over IPv4 tunneling driver
[eagle-usb] Modem operational !!
[eagle-usb] Ethernet device eth0 created.
NET: Registered protocol family 17
eth0: no IPv6 routers present
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),sound/oss/via82cxxx_audio.c,via_chan_maybe_start,line=1387
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),sound/oss/via82cxxx_audio.c,via_chan_maybe_start,line=1387
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),sound/oss/via82cxxx_audio.c,via_chan_maybe_start,line=1387
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
uhci_hcd 0000:00:11.2: remove, state 1
usb usb1: USB disconnect, address 1
usb 1-1: USB disconnect, address 2
usb 1-1.4: USB disconnect, address 4
[eagle-usb] eu_irq : URB canceled by user.
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[EAGLE-USB] eu_iso_read_completion: Can’t submit urb (-19)
[eagle-usb] ADSL device removed
uhci_hcd 0000:00:11.2: USB bus 1 deregistered
uhci_hcd 0000:00:11.3: remove, state 1
usb usb2: USB disconnect, address 1
usb 2-1: USB disconnect, address 2
uhci_hcd 0000:00:11.3: USB bus 2 deregistered
uhci_hcd 0000:00:11.4: remove, state 1
usb usb3: USB disconnect, address 1
uhci_hcd 0000:00:11.4: USB bus 3 deregistered
usbcore: deregistering driver wacom
pciehp: acpi_pciehprm:_SB
.PCI0 evaluate BBN fail=0x5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5
shpchp: acpi_shpchprm:_SB
.PCI0 evaluate BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
USB Universal Host Controller Interface driver v2.2
ACPI: PCI interrupt 0000:00:11.2[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:11.2: irq 11, io base 0000d400
uhci_hcd 0000:00:11.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:11.3[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.3: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#2)
uhci_hcd 0000:00:11.3: irq 11, io base 0000d800
uhci_hcd 0000:00:11.3: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:11.4[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.4: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#3)
uhci_hcd 0000:00:11.4: irq 11, io base 0000dc00
uhci_hcd 0000:00:11.4: new USB bus registered, assigned bus number 3
usb 1-1: new full speed USB device using address 2
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 2-1: new low speed USB device using address 2
usbhid: probe of 2-1:1.0 failed with error -5
usb 1-1.4: new full speed USB device using address 3
[eagle-usb] New USB ADSL device detected, waiting for DSP code…
[eagle-usb] Interface 0 accepted.
[eagle-usb] created proc entry at : /proc/driver/eagle-usb/001-003
input: Wacom Graphire on usb-0000:00:11.3-1
usbcore: registered new driver wacom
drivers/usb/input/wacom.c: v1.30:USB Wacom Graphire and Wacom Intuos tablet driver
[eagle-usb] ioctl EU_IO_OPTIONS received
[eagle-usb] ioctl EU_IO_DSP received
[eagle-usb] Loading DSP code to device…
[eagle-usb] DSP code successfully loaded to device
uhci_hcd 0000:00:11.2: remove, state 1
usb usb1: USB disconnect, address 1
usb 1-1: USB disconnect, address 2
usb 1-1.4: USB disconnect, address 3
[eagle-usb] eu_irq : URB canceled by user.
[eagle-usb] ADSL device removed
uhci_hcd 0000:00:11.2: USB bus 1 deregistered
uhci_hcd 0000:00:11.3: remove, state 1
usb usb2: USB disconnect, address 1
usb 2-1: USB disconnect, address 2
uhci_hcd 0000:00:11.3: USB bus 2 deregistered
uhci_hcd 0000:00:11.4: remove, state 1
usb usb3: USB disconnect, address 1
uhci_hcd 0000:00:11.4: USB bus 3 deregistered
usbcore: deregistering driver wacom
pciehp: acpi_pciehprm:_SB
.PCI0 evaluate BBN fail=0x5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5
shpchp: acpi_shpchprm:_SB
.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
USB Universal Host Controller Interface driver v2.2
ACPI: PCI interrupt 0000:00:11.2[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:11.2: irq 11, io base 0000d400
uhci_hcd 0000:00:11.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:11.3[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.3: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#2)
uhci_hcd 0000:00:11.3: irq 11, io base 0000d800
uhci_hcd 0000:00:11.3: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:11.4[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.4: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#3)
uhci_hcd 0000:00:11.4: irq 11, io base 0000dc00
uhci_hcd 0000:00:11.4: new USB bus registered, assigned bus number 3
usb 1-1: new full speed USB device using address 2
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 2-1: new low speed USB device using address 2
usbhid: probe of 2-1:1.0 failed with error -5
usb 1-1.4: new full speed USB device using address 3
[eagle-usb] New USB ADSL device detected, waiting for DSP code…
[eagle-usb] Interface 0 accepted.
[eagle-usb] created proc entry at : /proc/driver/eagle-usb/001-003
input: Wacom Graphire on usb-0000:00:11.3-1
usbcore: registered new driver wacom
drivers/usb/input/wacom.c: v1.30:USB Wacom Graphire and Wacom Intuos tablet driver
[eagle-usb] ioctl EU_IO_OPTIONS received
[eagle-usb] ioctl EU_IO_DSP received
[eagle-usb] Loading DSP code to device…
[eagle-usb] DSP code successfully loaded to device
[eagle-usb] Modem operational !!
[eagle-usb] Ethernet device eth0 created.
via_audio: ignoring drain playback error -11
eth0: no IPv6 routers present
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),sound/oss/via82cxxx_audio.c,via_chan_maybe_start,line=1387
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),sound/oss/via82cxxx_audio.c,via_chan_maybe_start,line=1387
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
usb 1-1.3: new full speed USB device using address 4
Initializing USB Mass Storage driver…
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: EPSON Model: Stylus Storage Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
USB Mass Storage device found at 4
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0813
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
usb 1-1.3: USB disconnect, address 4
drivers/usb/class/usblp.c: usblp0: removed
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
via_audio: ignoring drain playback error -11
zeus@kinderolympe:~$


#6

Bon, comme première remarque: je pense que tu utilises un pilote oss pour ton audio carte mère. Il faudrait penser à utiliser le pilote alsa (meilleur son, et à mon avis moins de warnings).
Pour ce que je te dis de pciehp et shpchp, je dois dire que mes messages ne ressemblaient pas à ça, donc peut être que tu as quelque chose à ajuster, mais il faudrait chercher un peu.
Par ailleurs, je ne vois aucune réference au rtc…
Mais ndis moi, il y a quelquechose qui ne marche pas, ou c’est juste les warnings qui t’énerve ?
parceque si tu es dans le deuxiême cas, penses que le temps que tu les fasse disparaitre, d’autres seront apparus :wink: