Carte WiFi non reconnue

Tags: #<Tag:0x00007f1ef6526310>

Bonjour,

Je viens d’installer Debian dernière version en dual-boot avec windows 10 Sur mon pc portable hp. J’aimerais avoir la WiFi sous Debian, et après avoir regardé plusieurs forums, j’ai vu que les pilotes de ma carte WiFi n’étaient pas libres et qu’il fallait donc les installer. Le problème c’est que je suis débutant et malgré les sites et wiki pour effectuer cette manœuvre je n’y arrive pas. Ma carte WiFi est la suivante : Realtek semiconductor RTL8111/8168/8411.

Merci d’avance pour votre aide :o

Bonsoir Edwin1,
Je ne suis pas un génie en la matière.
Sur mon portable, après avoir installé Debian, je n’avais pas le WIFI parce que Debian n’installe pas le pilote Wifi (“iwlwifi”) pour économiser la batterie.
Tu devrais, dans un premier temps, vérifier si ce pilote est présent sur ta machine : https://wiki.debian.org/fr/iwlwifi

A+

Merci pour ta réponse ! J’essaye dès que je peux :slight_smile:

Installer LE wifi :frowning:

1 J'aime

Bonjour Edwin1,
Le probleme est-il résolu ?

As tu une connexion en te branchant avec un câble ethernet ?

Bonjour, non problème toujours pas résolu :confused:
Après des recherches plus intenses (https://wiki.debian.org/fr/WiFi) je constate que ma carte WiFi (Realtek RTL8822BE 802.11ac PCIe adapter) n’est pas dans la liste des cartes pouvant fonctionner. Ça veut dire que je ne peux pas utiliser ma carte ?
Ya-t-il des solutions pour contourner ce problème ?
Merci d’avance

J’ai bien une connection internet par câble

Edwin

Bon, on va prendre le problème par le bon bout.

Peux-tu donner le résultat (exécuté à partir d’un “su -”) de :

dmesg | grep firmware

Amicalement.

Jean-Marie

Merci de m’aider ! Alors ça donne 7 lignes :

[ 3.779200] bluetooth hci0: firmware failed to load rtl_bt/rtl8822b_config.bin (-2)

  • La deuxième est similaire mais "direct firmware load for arborescence failed with error - 2
  • La 3eme et 4eme sont respectivement pareil que 1 et 2,a part que le chemin se termine par _fw
  • la 5eme : [ 4.370362] r8169 0000:02:00.0: firmware : failed to load rtl_nic/rtl8168h-2.fw (-2)
  • La sixième sur le même modèle avec la 5 que la 3 et la 4.
  • et la 7eme: [ 4.370407] r8169 etc enol: unable to download firmware patch rtl_nic/rtl8186h-2.fw (-2)

En espérant que ça soit compréhensible ^^
Merci

Je parie que la simple installation du paquet firmware-realtek règlera tout, et non seulement ça fera marcher le wifi (si tu n’as pas installé iwlwifi et que tu as laissé le network manager se charger du boulot) et en plus tu devrais avoir du bluetooth.
J’ai gagné mon pari ?

1 J'aime

Ça a marché pour le Bluetooth effectivement, merci ! ^^ mais quand je fais “iwconfig” j’ai toujours “no wireless extensions”

On dit ce qu’on veut, ça reste un anglicisme importé, et c’est l’usage qui déterminera son genre quoi qu’en disent les dictionnaires. Et même si l’académie décidait de fixer un genre, rien à battre que ça devienne imposé à l’école, une langue ne vit que par ce que ses locuteurs décident d’en faire, ce sont eux qui décident.
Qui sait, dans 1000 ans, on dira peut être chocolatine au lieu de pain au chocolat ?

Mmmmh. Essayes maintenant le paquet firmware-misc-nonfree, juste pour voir.

Hérétique au bucher … manquerait plus que l’on nous force à utiliser Emacs :rofl:

C’est du realtek pas du ralink :wink:

Moi je proposerai surtout de voir si c’est pas plutôt que le wifi est éteint (voir le bouton ou à coup de rf_kill).

Je sais, j’ai fait installer les firmware realtek avant, mais j’ai une intuition.

Ca reste un bon truc à vérifier, oui.

Haha oui :slight_smile:piut pour firmware misc non free ça me dit

impossible d'obtenir le verrou …

etc etc
et

E: impossible de verrouiller le répertoire d'administration etc. Il est possible qu'un autre processus l'utilise

Et pour le bouton, quel bouton ??! :thinking::thinking::thinking::thinking:

Et rf_kill j’ai

commande introuvable

Voalaa merci de m’aider ^^

Comme le message le dit clairement (?), c’est parce que tu as une autre fenêtre avec une install apt (ou synaptic) en cours (ou simplement, synaptic est ouvert): termines ça pour libérer le verrou d’installation, et relance ton install.

J’ai réussi merci ! Mais ça ne change rien :confused:,
toujours rien dans iwconfig

Avec rfkill list, j’ai

0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked : no

Et firmware-misc-nonfree, tu as réussi à l’installer ? Sans résultat ?
Je m’aperçois que je t’ai dit que ta dernière commande pour l’installer avait planté parcequ’il y en avait plusieurs en même temps, mais ça peut aussi être parceque tu n’as pas utilisé sudo, ou bien que tu n’es pas passé root avec su - pour le faire, en fait.

Oui j’ai bien réussi (j’ai essayé le lendemain ça marchait ^^) et non pas de résultat :///

On va reprendre un peu plus en amont, du coup.
Dans la sortie de lspci, est ce que tu repères ta carte ?
Si oui, repères dans sa désignation une chaine de caractère significative, genre “Realtek Wifi controller” ou un autre truc, pour la retrouver et utilises le pour filtrer:
lspci -k | grep - A3 "<la chaine que tu cherches>"
Pour avoir plus d’information sur elle.